cloud_wg
LOGS
19:06:00 <roshi> #startmeeting Cloud WG
19:06:00 <zodbot> Meeting started Wed Dec  3 19:06:00 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:06:06 <roshi> #meetingname Cloud WG
19:06:06 <zodbot> The meeting name has been set to 'cloud_wg'
19:06:09 <roshi> #topic Roll Call
19:06:18 <kushal> .hellomynameis kushal
19:06:18 <roshi> who's around for some cloud goodness?
19:06:19 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:06:23 <roshi> .hello roshi
19:06:24 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:06:32 <dustymabe> .hellomynameis dustymabe
19:06:33 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:07:17 <jzb> .hellomynameis jzb
19:07:18 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:08:04 <roshi> alright, found logs
19:08:05 <roshi> :)
19:08:14 <jzb> roshi: were they hiding?
19:08:23 <roshi> #topic Prev. Meeting follow-up
19:08:35 <roshi> jzb will update fedora dockerfiles ticket (#84) in coming weeks with more plans
19:08:43 <roshi> still on point with that jzb ?
19:08:49 <jzb> roshi: yes
19:09:07 <jzb> roshi: but last week being a holiday and all I partook in being slothful and didn't do anything.
19:09:26 <roshi> no worries - it was a short week for most of us I think :)
19:09:42 <dustymabe> roshi FYI https://lists.fedoraproject.org/pipermail/cloud/2014-September/004289.html
19:10:18 <roshi> thanks dustymabe
19:10:21 <kushal> dustymabe, Thank you :)
19:10:36 <roshi> #topic Docker image page text (#85)
19:10:43 <roshi> #link https://fedorahosted.org/cloud/ticket/85
19:11:27 <jzb> argh. That's me. I will finish today.
19:11:37 <roshi> sounds good
19:11:43 * scollier here
19:11:49 <roshi> welcome scollier :)
19:12:40 <roshi> #action jzb to get a draft together for the copy on the docker page
19:13:03 <roshi> #action others to contribute to the draft once it's done
19:13:07 <roshi> anything else for this?
19:13:25 <jzb> I'll put new text in the ticket + forward to list
19:13:32 <jzb> so if anyone has comments, put 'em there.
19:13:33 <roshi> sounds good
19:13:36 <jzb> please
19:13:38 <jzb> :-)
19:13:55 <roshi> #topic Publicize fedora-dockerfiles (#84)
19:13:57 <roshi> #link https://fedorahosted.org/cloud/ticket/84
19:14:04 <roshi> you again jzb :)
19:14:42 <jzb> roshi: didn't we just do this ticket?
19:14:53 <jzb> I feel a little Deja-Vu
19:14:53 <kushal> Even I am supposed to do few more new blog posts on this, but this is a long running process.
19:15:06 <roshi> last was docker download page, this is dockerfiles
19:15:19 <roshi> yeah - it's not constrained to release time
19:15:20 <jzb> roshi: scroll up ;-)
19:15:36 <roshi> less of a priority
19:15:41 <roshi> oh, prev followup
19:15:41 <jzb> roshi: 19:08 < roshi> jzb will update fedora dockerfiles ticket (#84) in coming weeks with more plans
19:15:43 <roshi> haha
19:16:02 <roshi> yeah, having them split out like that in the minutes makes me do things twice some times :)
19:16:05 <roshi> sorry
19:16:06 <roshi> moving on
19:16:40 <roshi> #topic Upload Criteria (#80)
19:16:45 <roshi> #link https://fedorahosted.org/cloud/ticket/80
19:17:32 <roshi> I still have to put this on the final release criteria
19:17:40 <roshi> but we're on track to not violate it :)
19:18:16 <roshi> sorry, been focusing on testing and other QA stuff atm
19:18:23 <roshi> and it's going to be a long night it looks like
19:18:24 <jzb> roshi: I think we're all in favor now - we can probably close it once you add to the criteria
19:18:30 <roshi> yeah
19:18:35 <roshi> that's what it's waiting on :-/
19:18:42 <roshi> once I get it in there I'll close the ticket
19:18:58 <jzb> roshi: hang in there - we're in the home stretch!
19:19:06 <jzb> roshi: you'll be able to sleep soon
19:19:12 <roshi> #action roshi to update the criteria and close the ticket (#80)
19:19:18 <roshi> lies :p
19:19:35 <roshi> I checked my alcohol store, should be good to go :p
19:19:51 <roshi> #topic OpenshiftCommons (#83)
19:19:54 <roshi> #link https://fedorahosted.org/cloud/ticket/83
19:20:02 <roshi> can I get a tl;dr on this?
19:20:39 <dustymabe> I wasn't here for last meeting but from what I remember people were waiting to hear back from someone?
19:20:42 <roshi> never looked into it really...
19:20:43 <kushal> No updates on this yet.
19:20:46 <dustymabe> pyhtondj or something like that
19:20:51 <jzb> dustymabe: the board or the upstream, one.
19:21:01 <kushal> jzb, both :)
19:21:38 <jzb> kushal: or that
19:22:21 <dustymabe> who were the people that send pythondj a note and are waiting to hear back?
19:22:25 <dustymabe> I think number80
19:23:16 <jzb> dustymabe: I sent her a note but it was more from the Project Atomic side.
19:24:09 <kushal> dustymabe, even I sent one.
19:24:47 <jzb> hey
19:24:51 <jzb> here's a thought
19:24:56 * jzb goes to look in #openshift
19:25:10 <jzb> dang
19:25:12 <jzb> no such luck
19:25:41 <jzb> Email it is.
19:25:50 <dustymabe> yeah I donI would volunteer to head up the effort if I had spare cycles.
19:25:57 <dustymabe> I don't really know what it is right now
19:26:01 <jzb> dustymabe: it's not urgent anyway
19:26:08 <dustymabe> I would volunteer to head up the effort if I had spare cycles.
19:26:52 <roshi> doesn't look like much for us to do with this ticket until we hear back
19:27:04 <roshi> #topic Open Floor
19:27:12 <roshi> anyone have anything for open floor?
19:27:54 <dustymabe> roshi: not right now. still working with DO. I am going to get our RC4 into their infra next and start working with that.
19:28:00 <roshi> nice
19:28:04 <kushal> We have a review request up for rocket.
19:28:13 <roshi> that's what I was going to bring up
19:28:18 <jzb> kushal: link, pls?
19:28:19 <roshi> what's the plan with rocket?
19:28:34 <kushal> #link https://bugzilla.redhat.com/show_bug.cgi?id=1169966
19:28:40 <jzb> roshi: we should plan on including it for F22, I think.
19:28:46 <jzb> clearly it's too late for Fedora 21
19:28:46 <kushal> roshi, First we should provide a package
19:28:49 <roshi> will it be ready by then?
19:29:00 <jzb> roshi: define "ready" ;-)
19:29:11 <kushal> roshi, it is usable now
19:29:13 <jzb> roshi: this is Fedora after all. "First" is part of our charter.
19:29:32 <scollier> do we need a fedora-rocketfiles repo?  for the manifest.json files?
19:29:42 <roshi> lol
19:29:45 <roshi> a fair point
19:30:22 <kushal> What I understood, the developers should think clearly before writing an app for containers
19:30:31 <scollier> you can build rocket images off of the fedora containers.  and we have a large repo.
19:31:07 <scollier> having said that, not 100% sure of the portability and level of effort required.
19:31:13 <jzb> scollier: do you "lose" anything with Docker containers and rkt?
19:31:32 <kushal> scollier, you can do that from a running containers
19:31:40 <scollier> jzb, i'm experimenting now.. i can't really comment ATM.
19:31:43 <scollier> kushal, you run the container, and then docker export that container.
19:31:54 <scollier> that gets exported to a "rootfs"
19:32:00 <kushal> yes
19:32:21 <scollier> which, is added to the manifest.json file, and gets re-wrapped into a rocket .aci file.
19:32:21 <scollier> which can then be, in theory, run.
19:33:22 <kushal> I will try that tomorrow
19:33:48 <scollier> i think it's worth looking into.  and if there are no objections, we can create a fedora-rocketfiles (or w/e) repo, and start sharing.
19:34:02 <roshi> sounds good to me
19:34:15 <roshi> will atomic be able to run rocket containers?
19:34:31 <jzb> scollier: no objections here
19:34:44 <scollier> roshi, provided the package listed above is in the tree, and the rkt bin is there, yes.
19:34:51 <roshi> cool
19:34:55 <jzb> roshi: we haven't officially discussed this but once we've packaged it, I would like to include rkt in Atomic yeah
19:35:06 * roshi couldn't really tell how much different it was and whatnot
19:35:14 <roshi> since I'm just starting to learn/get used to docker
19:35:18 <jzb> though... here's a can o' worms
19:35:21 <dustymabe> jzb: we would ship docker and rocket in the same tree?
19:35:31 <jzb> should we worry about plain lxc containers?
19:35:50 <scollier> dustymabe, i'd say, why not?
19:35:55 <jzb> dustymabe: I think so? I don't think rkt will take up too much space, and I don't think they conflict
19:36:01 <dustymabe> we need to make our naming more generic then
19:36:07 <dustymabe> docker-host is not going to fly
19:36:13 <scollier> ^ true.
19:36:14 <jzb> dustymabe: yeah, container-host
19:36:27 <jzb> or "super-awesome-host"
19:36:31 <roshi> or just call it "transit"
19:36:35 <roshi> or "ship"
19:37:42 <roshi> continue on with the shipping container idea
19:37:46 * roshi doesn't know
19:37:57 <scollier> https://github.com/fedora-cloud/Fedora-Rocketfiles
19:37:57 <kushal> :)
19:38:20 <roshi> that was quick :)
19:39:06 <roshi> well, seems we're all on the same page
19:39:10 <roshi> anything else?
19:39:12 <jzb> scollier: could you add me to that repo?
19:39:16 <jzb> or am I already
19:39:17 <jzb> ?
19:39:27 <jzb> scollier: I'm jzb on GitHub, btw.
19:40:03 <scollier> jzb, you are already in that organization.
19:40:51 <jzb> woohoo
19:41:58 <dustymabe> scollier: is there a list of people who are?
19:42:05 <dustymabe> should we make all of the WG be members?
19:42:09 <roshi> click the org name
19:42:19 <scollier> dustymabe, https://github.com/fedora-cloud
19:42:23 <scollier> should show a list there.
19:42:35 <roshi> it does
19:42:39 <dustymabe> ahh. got it
19:42:40 <scollier> dustymabe, but you don't have to be a member to fork and submit a PR
19:42:47 <roshi> yeah
19:42:53 <scollier> dustymabe, the "members" are admins of sorts.
19:42:56 <dustymabe> scollier: yep. as I have learned :)
19:43:10 <roshi> I don't see a ton of point in adding us all (even though I'd like the little badge thing under my profile :P)
19:43:38 <scollier> roshi, i agree
19:45:53 <roshi> well, anything else to discuss? or can we call it?
19:47:02 <jzb> roshi: call it
19:47:02 * roshi gets the fuse out...
19:47:08 * roshi sets fuse
19:47:10 <jzb> oh wait
19:47:10 <roshi> 3...
19:47:18 <jzb> quick note - go look at the final release announcement on the wiki
19:47:26 <roshi> !!DETONATION ABORTED!!
19:47:38 <jzb> should be good, but if there are any comments, changes, the readiness meeting is tomorrow
19:47:42 <jzb> that's all
19:47:45 <roshi> sweet
19:47:47 <jzb> please recommence detonation
19:47:58 <roshi> !! RECOMMENCING !!
19:48:01 <roshi> 2...
19:48:14 <roshi> 1...
19:48:28 <roshi> thanks for coming folks!
19:48:31 <roshi> #endmeeting