fedora-meeting-1
LOGS
16:01:06 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-11-04)
16:01:06 <zodbot> Meeting started Tue Nov  4 16:01:06 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:06 <sgallagh> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
16:01:06 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
16:01:06 <sgallagh> #topic roll call
16:01:14 <nirik> .hello kevin
16:01:15 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
16:01:18 <stefw> .hello stefw
16:01:18 <sgallagh> .hello sgallagh
16:01:21 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
16:01:22 <mitr> Hello
16:01:24 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:01:40 <junland> .hello junland
16:01:41 <zodbot> junland: junland 'John Unland' <opensourcejohn2112@gmail.com>
16:01:43 <simo> .hello
16:01:44 <zodbot> simo: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
16:01:44 <danofsatx> .hello dmossor
16:01:46 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
16:01:47 <simo> .hello simo
16:01:52 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
16:03:14 * sgallagh waits a couple more minutes
16:03:32 <danofsatx> heh....I just noticed that #halp is a useful command...
16:04:41 <adamw> .hello adamwill
16:04:42 <zodbot> adamw: adamwill 'Adam Williamson' <adamw+fedora@happyassassin.net>
16:04:49 <sgallagh> #topic Agenda
16:04:50 <sgallagh> #info Agenda Item: Test Day Planning
16:05:01 <sgallagh> We only have one item currently on the agenda.
16:05:20 <sgallagh> Do we have other topics to discuss today?
16:05:28 <junland> Nope.
16:05:56 <danofsatx> #link https://fedoraproject.org/wiki/Test_Day:2014-11-07_Server
16:06:02 <sgallagh> #topic Test Day Planning
16:06:02 <sgallagh> #link https://fedoraproject.org/wiki/Test_Day:2014-11-07_Server
16:06:34 <danofsatx> oops...sorry sgallagh, didn't mean to step on your toes. I thought the topic had already been issued....
16:06:41 <sgallagh> So junland put together a framework for Friday's Test Day
16:06:56 <sgallagh> danofsatx: no worries; you're not chaired so zodbot ignored you :)
16:07:06 <danofsatx> ah, k ;)
16:07:32 <sgallagh> I took a look at it and cleaned up a couple minor presentation things
16:07:43 <junland> Thank you.
16:07:46 <sgallagh> But on the whole, I think it's probably a reasonable place to have people start.
16:07:47 <danofsatx> so did I
16:08:01 <junland> I encourage everyone to look over the wiki and change any mistakes / typos.
16:08:14 <nirik> might point the test image to beta? or the tc1 final?
16:08:18 * junland first time doing a Testday Template
16:08:27 <danofsatx> Should we mention adamw's fancy relval tools on the test day page?
16:08:30 <nirik> but otherwise looks great. ;)
16:08:31 <sgallagh> nirik: Yeah, I was going to do that today, once the TC1 is finalized
16:08:53 <sgallagh> danofsatx: I'm not sure if relval works on Test Day pages.
16:08:54 <sgallagh> adamw: ?
16:08:58 <adamw> relval doesn't do much/anything with test days yet.
16:09:08 <danofsatx> oh yeah, right....missed that.
16:09:13 <sgallagh> np
16:09:13 <adamw> (the result parsing code would probably work, but there's no relval tui hookup for it.)
16:09:23 <danofsatx> relval /= test day, relval = release validation
16:09:25 <junland> We will be using Beta TC4 .iso?
16:09:39 <adamw> RC4, not TC4
16:09:50 <sgallagh> junland: No, we'll be either using the official beta release or the TC1 release coming out today.
16:10:05 <junland> Okay don't know if the link to the .iso was right or not...
16:10:43 <junland> It's linked to TC4
16:10:44 <sgallagh> junland: It's not, but we'll get that cleared up before Friday
16:10:51 <junland> Okie dokie.
16:10:59 <sgallagh> As I said above, we'll probably want to use the most recent official compose
16:11:05 <junland> Right.
16:11:18 <sgallagh> As of right now, I don't foresee any need to do a custom compose for the Test Day
16:11:38 <junland> Custom compose being?
16:12:00 <sgallagh> junland: Some Test Days produce a special Live image with updated packages
16:12:09 <sgallagh> It's unlikely that we will need that
16:12:12 <junland> Ah.
16:12:22 <junland> Got it.
16:12:55 <danofsatx> 'specially since Server doesn't have a Live image ;)
16:13:02 <sgallagh> #info Anyone in the Server SIG/WG that will be available on Friday to mentor testers, please add your names to the "Who's available" section
16:13:07 <adamw> TC1 should be opening up soon, of course we don't know yet if it has any showstopper issues, so we should check that
16:13:23 <adamw> danofsatx: in theory we could do special composes of any image for a test day, it just usually turns out to be a live that makes sense
16:13:25 * danofsatx is waiting with baited breath
16:13:28 * junland nods
16:13:57 <sgallagh> #info tentative plan is to point at the F21 Final TC1 image unless it has major showstopper issues; in which case, we will point at the Beta release.
16:15:29 <sgallagh> stefw: are you aware of anything Cockpit-related that we didn't test during Beta validation that you'd like people to play around with?
16:15:58 <stefw> sgallagh, use of various browsers like internet explorer
16:16:33 <sgallagh> stefw: OK, could you (maybe with junland's help) set up a couple test cases?
16:16:42 <sgallagh> I'd also like to see people play with the Docker support
16:16:43 <stefw> sure
16:16:53 <junland> Sure, for cockpit?
16:17:27 <sgallagh> With Cockpit specifically, but it probably wouldn't hurt to also have a free-form test of docker in general
16:17:44 <junland> Okay, will do.
16:18:00 <sgallagh> #action stefw and junland to put together Cockpit tests such as browser support
16:18:42 <sgallagh> #action junland to add Docker free-form testing as a suggested case for the Test Day
16:19:05 <danofsatx> accepted reference for Docker packages available?
16:19:21 <sgallagh> danofsatx: This sentence no verb.
16:19:43 <danofsatx> is there an accepted reference for Docker packages available?
16:19:47 <junland> I prolly will need some guideance on Docker, I haven't played around with it.
16:19:50 <danofsatx> sgallagh: better?
16:19:58 <sgallagh> danofsatx: Thanks, I wasn't sure what you were asking
16:20:37 <sgallagh> https://docs.docker.com/userguide/ is probably a good start
16:20:45 <junland> Got it.
16:21:33 <sgallagh> OK, anything else we want to highlight this time around?
16:22:35 <junland> Nope, just that everyone looks over the wiki when they have the time...
16:22:40 <simo> sgallagh: is there any known issue we should point out to tester to avoid having them waste a lot of time ?
16:23:17 <sgallagh> simo: I'm not aware of any that aren't listed at https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CB4QFjAA&url=http%3A%2F%2Ffedoraproject.org%2Fwiki%2FCommon_F21_bugs&ei=XP1YVNifBo2cygSXvoGACA&usg=AFQjCNHkGhVkXtUZklaQC5p_9OJWDwvOfQ&bvm=bv.78677474,d.cGE
16:23:22 <sgallagh> Gah, bad past
16:23:30 <sgallagh> http://fedoraproject.org/wiki/Common_F21_bugs
16:23:51 <sgallagh> (my super-secret mnemonic technique: revealed!)
16:24:45 <nirik> heh
16:24:49 <sgallagh> If we discover any, we should add them to the wiki
16:24:54 <sgallagh> (either one)
16:25:07 <simo> ok
16:25:16 <simo> I just thought it was worth making sure
16:25:46 <sgallagh> simo: Should we make it a goal to get sufficient karma testing on FreeIPA 4.1 on Friday?
16:26:12 <simo> out of the testing, or before the testing ?
16:26:17 <simo> out of the testing it would be nice
16:26:23 <sgallagh> out of the testing
16:26:50 <sgallagh> Would you mind sending out a freeipa-interest or -users notice about the testing so we can hopefully grab some of that crowd?
16:26:54 <sgallagh> simo: ^^
16:27:26 <simo> I will send it to freeipa-users
16:27:30 <sgallagh> Thank you
16:27:49 <sgallagh> #action simo to ask for test volunteers on the FreeIPA users mailing list.
16:28:47 <sgallagh> OK, I don't think I have anything else on this topic.
16:29:05 <sgallagh> junland: This is kind of your baby: do you have anything further to add?
16:29:42 <junland> Yes, it is. No not really. Just if you have any "free time" please feel free to look over the wiki.
16:29:43 <nirik> thanks junland for organizing things. :)
16:29:52 <danofsatx> firewall-cmd --zone=FusionGateway --list-all -> http://ur1.ca/iovkf
16:29:55 <junland> No problem.
16:29:56 <sgallagh> Yes, many thanks junland
16:29:58 <junland> :)
16:30:03 <sgallagh> danofsatx: Wrong channel
16:30:16 <sgallagh> #topic Open Floor
16:30:22 <danofsatx> whoops :o
16:30:36 <sgallagh> #info Fedora 21 Server Beta has been released!
16:31:08 <sgallagh> We're in the final stretch now.
16:32:00 <adamw> we probably should revisit final criteria and test cases.
16:32:02 <sgallagh> Also: F21 Final TC1 is out
16:32:06 <sgallagh> #link http://dl.fedoraproject.org/pub/alt/stage/21_TC1/
16:32:18 <sgallagh> adamw: OK
16:32:22 <danofsatx> woot!
16:32:29 <junland> Yay!
16:32:30 <sgallagh> #topic Final Release Criteria
16:32:40 <sgallagh> adamw: Take it away
16:32:40 <adamw> there's a mail from me in the server@ archives dated 2014-09-29 with the subject "Proposed Server release criteria for F21 Beta and Final"
16:32:48 <adamw> it contains some Final suggestions with a lot of hand-waving and ????
16:34:23 <adamw> we can add the fairly cover-all criterion for 'release-blocking roles in general', fine, but it would be good to nail down precisely what we require from Cockpit, and from the directory server role specifically (since we're carrying its requirements in the general criteria for 21)
16:34:26 <sgallagh> adamw: For the sake of level-setting, what is the general difference between Beta and Final criteria?
16:34:30 <sgallagh> (For Fedora as a whole)
16:34:49 <adamw> as with alpha/beta we're not quite as sharp on that as we should be :/
16:35:07 <adamw> it's sort of supposed to be 'polish' between beta and final, but that's vague and not really adhered to
16:35:36 <sgallagh> In the case of the release-blocking roles, I think the Beta criteria are pretty strong. We have to be able to stand up a domain controller and be able to connect clients to it.
16:35:50 <adamw> my very vague rule of thumb is that things should be more or less *in place* at beta but we can tolerate more conditional brokenness than at final, more things that need workarounds and whatever
16:35:54 <sgallagh> We might want to add "decommission it" to the list, but that's not necessarily blocking
16:36:14 <sgallagh> adamw: That was kind of my understanding as well.
16:36:33 <adamw> this may be the point where someone says 'it shouldn't crash!' or something, but i'm getting to be less of a fan of criteria like that, they tend to be hostages to fortunme
16:37:17 <danofsatx> yeah, decommissioning broken deployments would a good feature ;)
16:37:17 <sgallagh> How about making that official: "Final Criteria are equivalent to Beta criteria, but workarounds are not permitted for common (judgement call) situations"
16:37:24 <adamw> the thing i'll note the current criteria don't really cover is that they don't require the server to *do* a lot, though we might consider that sort of implicitly covered upstream
16:37:48 <adamw> meh, i don't like that on a product-specific basis, it feels more of a high level thing to work out on a criteria-wide basis
16:38:06 <sgallagh> adamw: It's both implicitly covered there and also more specifically in the Test Day we're running
16:38:08 <adamw> the criteria 'documentation' stuff hasn't been updated for a while, i could stand to take a pass at it based on our current operating conventions
16:38:17 <danofsatx> current criteria requires that it installs, can install packages, can be managed by cockpit, and can stand up a FreeIPA domain. That's a lot.
16:39:21 <adamw> ok, so i get the feeling currently we don't want to add requirements for domain controller for final, that's fine
16:39:28 <adamw> any thoughts on cockpit?
16:39:33 <sgallagh> Not this time around on the DC
16:39:45 <sgallagh> I think that we will probably strengthen the requirements in F22
16:39:55 <sgallagh> stefw: your turn :)
16:40:13 <stefw> no, i don't think we want to add any more requirements
16:40:36 <stefw> it's unlikely we'll do anything but very serious bug fixes in F21
16:40:46 <danofsatx> well, the intent is to test rolekit, not FreeIPA. To get a better test coverage, we need more roles to deploy, like database, web, dhcp, yadda, yadda......
16:40:53 <sgallagh> stefw: We don't have to add requirements that aren't already met
16:41:24 <sgallagh> danofsatx: Yeah, I've got a start on the database role in my local checkout, but it's *definitely* not ready.
16:41:31 <adamw> danofsatx: as i understand it, we do want the fedora primary/release-blocking roles to have specific quality requirements/testing
16:41:59 <danofsatx> agreed.
16:42:01 <sgallagh> stefw: What we're looking for is, beyond Beta, is there anything that we want to be certain works.
16:42:02 <adamw> danofsatx: this is why i keep harping on the requirement to set up some kind of infrastructure for that, i.e. a place for roles to be defined and their requirements laid out
16:42:17 <sgallagh> One could argue that "Cockpit must be usable with the following browsers..." is a valid example
16:42:23 <sgallagh> And one that you're already looking into
16:42:24 <danofsatx> preaching to the choir, adamw ;)
16:42:36 <adamw> the beta requirements for cockpit are:
16:42:37 <adamw> View the system's logs
16:42:37 <adamw> View the system's running services
16:42:37 <adamw> Enrol the system to a FreeIPA or Active Directory domain
16:42:44 <stefw> sgallagh, i tihnk the current set of requirements, startup, login, ...
16:42:45 <stefw> yes those
16:42:46 <stefw> are enough
16:42:58 <stefw> any further bug discovery we do during the test day will help for future Fedora releases
16:44:55 <sgallagh> adamw: I suppose I'd add a couple specific Domain Controller criteria, actually
16:45:32 <sgallagh> I'd say that we probably want to confirm that kinit, ssh-via-GSSAPI and DNS lookups against the DC work
16:45:42 <danofsatx> like bind not crashing when you add a client? ;)
16:45:46 <adamw> are these things that are appropriately final requirements or stuff we overlooked for alpha/beta?
16:45:54 <sgallagh> danofsatx: Exactly like that :)
16:46:06 <adamw> well, that was accepted as a violation of the existing criteria easily enough, iirc.
16:46:15 <danofsatx> yeah, you couldn't add clients.
16:46:53 <sgallagh> adamw: Well, the kinit and ssh-via-GSSAPI should probably be Beta going forward, now that you mention it.
16:47:08 <sgallagh> (Retroactively, I'll mention that I *did* test this anyway and it worked)
16:47:49 <sgallagh> As for DNS, I'd say that it's a spectrum: host lookups should be Beta, SRV lookups Final, perhaps.
16:48:11 <sgallagh> (And then there's SSHFS...)
16:48:29 <sgallagh> I'm not going to put DNSSEC on the list this time either
16:50:10 <sgallagh> I'd also say that kerberos auth is mandatory for Beta, but auth via LDAP could be argued as Beta or Final.
16:51:07 <adamw> sgallagh: can you send a mail with a plan / rough draft and we can work together to polish it into proposed criteria?
16:51:08 <sgallagh> adamw: Is this good enough to work with?
16:51:29 <sgallagh> #action sgallagh to send a mail with a plan / rough draft and work together with adamw to polish it into proposed criteria?
16:51:37 <sgallagh> #undo
16:51:37 <zodbot> Removing item from minutes: ACTION by sgallagh at 16:51:29 : sgallagh to send a mail with a plan / rough draft and work together with adamw to polish it into proposed criteria?
16:51:39 <sgallagh> #action sgallagh to send a mail with a plan / rough draft and work together with adamw to polish it into proposed criteria.
16:51:52 <sgallagh> So: "yes"
16:52:23 <sgallagh> adamw: Anything further on the criteria for today?
16:52:34 <sgallagh> Maybe send an email to the mailing list asking for other suggestions as well
16:54:10 <sgallagh> I'll assume that to be a no, then
16:54:18 <sgallagh> #topic Open Floor Redux
16:54:24 <sgallagh> Any more Open Floor items?
16:54:46 * simo goes blank
16:55:11 * junland has nothing
16:55:36 <sgallagh> Oh, I have one thing
16:55:57 <sgallagh> I'll be in transit to Usenix LISA next week and can't run the meeting.
16:55:58 * junland has to go. Will be on a little later.
16:56:05 <sgallagh> Can I have a volunteer to run zodbot?
16:56:25 * danofsatx votes for adamw - he has nothing else to do
16:56:25 <nirik> I guess I could... or we could skip?
16:56:47 <sgallagh> .fire danofsatx
16:56:47 <zodbot> adamw fires danofsatx
16:57:06 <sgallagh> nirik: I'd prefer not to slip just because I'm not around.
16:57:15 <sgallagh> s/slip/skip/
16:57:22 <sgallagh> (Man, I have *that* on the brain, I guess)
16:57:25 <adamw> heh
16:57:38 <adamw> i could do it if no-one else will, but i'm usually still catching up at this time in the morning
16:58:06 <sgallagh> #action nirik to chair next week's meeting in sgallagh's absence
16:58:21 <sgallagh> adamw: Thanks for the offer; I'm sure nirik will use you as a backup if needed
16:58:23 <danofsatx> adamw: s/catching/waking
16:58:54 <sgallagh> OK, I'm closing the meeting now. Thanks for coming, everyone
16:59:01 <adamw> oh, missed nirik volunteering. yay.
16:59:09 <adamw> danofsatx: aw, now that was mean. accurate, but mean.
16:59:14 <sgallagh> #endmeeting