fedora-meeting-1
LOGS
14:59:45 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-09-30)
14:59:46 <zodbot> Meeting started Tue Sep 30 14:59:45 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:46 <sgallagh> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
14:59:46 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
14:59:46 <sgallagh> #topic roll call
14:59:55 * nirik waves.
15:00:10 * stefw is sorta here ... finishing up another discussion
15:00:54 <mitr> Hello
15:01:58 <adamw> ahoy
15:02:12 <simo> yoha
15:03:09 <sgallagh> #topic Agenda
15:03:09 <sgallagh> #info Agenda Item: Fedora 21 Release Criteria
15:03:21 <sgallagh> Any other agenda topics for this week?
15:04:28 * sgallagh takes that as a "no"
15:04:36 <sgallagh> #topic Fedora 21 Release Criteria
15:04:57 <sgallagh> Has everyone had a chance to look at Adam's proposed criteria?
15:05:17 <nirik> yep
15:05:50 <sgallagh> I think the Beta criteria around logging and firewall is fine.
15:06:25 * tuanta is here
15:06:29 <nirik> yeah. me too.
15:06:35 <sgallagh> The Roles we probably want to clarify somewhat (especially given that we aren't going to have 100% coverage of the Role Spec this time around; support for reconfiguring a role is not going to be ready)
15:06:55 <sgallagh> s/reconfiguring/redeploying/
15:06:58 <nirik> for cockpit we could add some generic stuff? must be installed, must start, must be reachable, must be able to login?
15:07:07 <adamw> i think i left reconfiguration out for alpha, but yeah, we can clarify the final state
15:07:16 <sgallagh> nirik: Yeah
15:07:20 <mitr> … and for connecting to localhost, each of the major tabs should not be obiviously broken?
15:07:21 <adamw> nirik: the first three are in alpha i believe
15:07:27 <nirik> ok.
15:07:56 <sgallagh> I'd like to say that certain critical functionality should be ready for Beta
15:08:11 <sgallagh> stefw: For example, I'd like it to be a blocker if domain-joining isn't working
15:08:28 <sgallagh> There's a couple bugs around that right now (some comps-related, some realmd)
15:08:38 <stefw> sgallagh, yes i have a fix upstream
15:08:42 <stefw> will release a new realmd
15:08:42 <sgallagh> Great
15:08:55 <adamw> sgallagh: as in, client enrolment?
15:09:03 <sgallagh> But I think that's a reasonable thing to list as a blocker for future Beta criteria too
15:09:24 <sgallagh> adamw: Right, being able to join a machine, through Cockpit, into a FreeIPA or Active Directory domain
15:09:34 <adamw> sgallagh: so the problem with that is it's fine to start writing Role requirements into the Fedora criteria when we have one role
15:09:44 <adamw> when we have sixteen it's going to start looking a little unwieldy
15:10:00 <sgallagh> adamw: This isn't a role requirement (I'm confused)
15:10:14 <adamw> sgallagh: ohhh, i see
15:10:23 <adamw> you mean enrolling the system as a client to some *other* freeipa domain
15:10:24 <adamw> gotcha
15:10:26 <sgallagh> Yes
15:10:43 <adamw> then i'd be +1 sure, but let me see if it's already covered
15:11:32 <sgallagh> Technically, that is probably two criteria: 1) Joining to FreeIPA must be possible; 2) Joining to AD must be possible.
15:11:57 <sgallagh> stefw: Would you like to describe any other functionality of Cockpit that you think is critical?
15:12:34 <sgallagh> Perhaps anything related to the logging, storage or network configuration functionality
15:12:43 <adamw> oh that's right. we already put this in for Alpha
15:12:44 <adamw> "It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install, and the system must respect the identity, authentication and access control configuration provided by the domain. "
15:12:54 <adamw> then we promptly had to wave our hands at it because install-time AD join was busted.
15:13:06 <stefw> sgallagh, can i ask mvollmer and the guys about that?
15:13:24 <stefw> i think being able to log into cockpit should be mentioned explicitly
15:13:27 <sgallagh> Of course.
15:13:39 <sgallagh> stefw: That's an Alpha criterion already, I think
15:13:52 <sgallagh> What about Cockpit+Docker?
15:14:16 <sgallagh> I think it's reasonable to assert that Cockpit being able to retrieve and start docker images from the Docker repository is a sensible blocker.
15:14:45 <adamw> beta or final?
15:15:10 <adamw> and remember, i'm gonna need you to say the same thing at a go/no-go meeting when everyone's saying 'ehhh, can't we just ship it already?' :)
15:15:11 <sgallagh> adamw: At a high-level, how do we differentiate the two?
15:15:24 <sgallagh> My understanding was that everything must be functionally complete at Beta
15:15:37 <adamw> it is a bit tricky
15:15:56 <adamw> i tend to try and do it along the lines of code-complete vs. polished
15:16:19 <adamw> stuff has to *basically* work at beta but there's some wiggle room for cases where you need to workaround or some particular configuration is busted
15:16:20 <sgallagh> I could be fine with that being a Final criterion, I suppose.
15:16:51 <sgallagh> adamw: BTW, we have to leave Roles off of the Cockpit criteria for F21, as they aren't implemented there.
15:16:55 <adamw> theoretically speaking something like 'cockpit must do what it's designed to do' would look more like either it should block beta or not block at all, but you know, it's not an especially well-defined thing, i'd be lying if i said it was.
15:16:57 <adamw> sgallagh: rgr
15:19:08 <adamw> so this is good stuff - did anyone have thoughts on the idea of having role requirements defined outside of the criteria and owned more by server WG / role proposers?
15:19:13 <sgallagh> Cockpit is moving to a modular design. Could we say that any module that will ship with Fedora N must be present and feature-complete by Beta (or else disabled/deferred to Fedora N+1)?
15:19:33 <stefw> i'm not sure the modular component stuff will land for f21
15:19:41 <stefw> or that we should describe it in the criteria
15:19:44 <sgallagh> ok
15:19:58 <adamw> i think that could be a hostage to fortune, as there are likely going to be modules that when it comes to it we say 'ehh, we can just fix it for final'. but if we're willing to stick to it...
15:20:18 <sgallagh> adamw: Yeah, I think it makes sense for the Role designers to write up their own criteria for whether they function (and ideally have it vetted by Fedora QA to make sure it's sensible)
15:21:09 <sgallagh> Obviously, we didn't do that yet for F21 and Domain Controller.
15:21:36 <adamw> the release criteria would then have something more or less like the FESCo blanket criterion
15:21:44 <sgallagh> In this particular special case, we basically have an entire division at Red Hat doing it. So I'm not terribly worried
15:21:58 <adamw> and server WG would be able to consider whether to keep the role and block the release, or demote the role somehow
15:22:31 <adamw> i'm fine with taking f21 as a special case in that it's our very first role ever and therefore basically a test of the whole thing, it's just For The Future that we'd need to look at a different design
15:22:40 <sgallagh> Well, we're going to be breaking out the role definitions in rolekit so that we can have subpackages provide the roles.
15:22:44 <adamw> but still, i started running out of steam writing Final requirements for IPA
15:22:58 <sgallagh> So demoting it would be a matter of not shipping it as part of the Server definition and/or on the DVD
15:23:40 <sgallagh> adamw: Perhaps we could ask simo nicely if he could ask the Red Hat FreeIPA folks to publish some subset of their test plan for us?
15:25:41 <sgallagh> adamw: What else do we want to discuss here? I think it's in reasonably good shape.
15:26:08 <sgallagh> #action stefw to discuss with the Cockpit upstream what Beta Criteria they should have
15:26:12 <sgallagh> (forgot to note that)
15:26:16 <stefw> roger
15:26:21 <sgallagh> Thanks
15:28:10 <adamw> yeah, i think i can pull something together for final from this, thanks
15:28:17 <adamw> we also need test cases but it should only be a couple
15:28:26 <adamw> we already have a whole bunch of ipa test cases, which is handy
15:30:06 * sgallagh nods
15:30:30 <sgallagh> adamw: Once again, thank you for putting this together. Your efforts are appreciated.
15:31:39 <sgallagh> #info adamw's proposed criteria were largely accepted, with some pending additions to Cockpit and the Domain Controller role forthcoming.
15:31:50 <sgallagh> #topic Open Floor
15:31:55 <sgallagh> Anything for Open Floor today?
15:33:21 * sgallagh sets the countdown at 60s
15:34:21 <sgallagh> #endmeeting