fedora-meeting-1
LOGS
15:00:56 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-09-09)
15:00:56 <zodbot> Meeting started Tue Sep  9 15:00:56 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:56 <sgallagh> #topic roll call
15:00:56 <sgallagh> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
15:00:56 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:01:05 * nirik waves.
15:01:11 * stefw is here
15:02:05 * pbrobinson is here as an ARM person
15:02:28 <twoerner> hi
15:02:29 <sgallagh> Thanks pbrobinson
15:03:24 * sgallagh waits a few more minutes.
15:03:42 <mitr> Hello, sorry I'm late
15:04:00 <sgallagh> mizmo_: You around? I'm going to want your opinion on the second topic :)
15:04:11 <sgallagh> OK, let's go over the agenda
15:04:17 <sgallagh> #topic Agenda
15:04:17 <sgallagh> #info Agenda Topic: ARMv7 Support
15:04:17 <sgallagh> #info Agenda Topic: Fedora 21 Alpha Announcement and Download Page
15:04:34 <sgallagh> Any other agenda topics to cover?
15:04:49 <adamw> sorry, /me around
15:05:41 <twoerner> sgallagh: maybe the remaining steps needed for rolekit
15:06:21 <sgallagh> You're probably right, but unfortunately I have another meeting in a half-hour and we probably won't get to that here (while I'm around)
15:06:32 <twoerner> sgallagh: ok
15:06:44 <sgallagh> Can you send your questions to the mailing list for now?
15:07:07 <twoerner> it is mostly the TODO list we have in the repo
15:07:16 <sgallagh> #info twoerner wishes to discuss rolekit remaining tasks, but we probably don't have enough time with the relevant people at this meeting.
15:07:20 <twoerner> docs, translations
15:07:30 <adamw> get people up to speed on the netinst situation maybe?
15:07:51 <sgallagh> #info Agenda Topic: Netinst media update
15:07:52 <sgallagh> Good point.
15:08:03 <sgallagh> ok, let's get started.
15:08:09 <sgallagh> #topic ARMv7 Support
15:08:48 <sgallagh> According to our technical specification, we've committed to supporting Fedora Server on those ARM platforms that can use Anaconda to install
15:08:59 <sgallagh> (As opposed to those that can only use premade disk images)
15:09:03 <sgallagh> #link https://fedoraproject.org/wiki/Server/Technical_Specification
15:09:11 <mizmo_> sgallagh, im here sorry
15:09:24 <sgallagh> no problem
15:09:52 <sgallagh> The release engineering folks have been generating install trees for these platforms, but I don't think any verification of any kind has happened yet.
15:10:11 <sgallagh> pbrobinson: Can you point us in the right direction for how to test these ARM trees?
15:10:32 <sgallagh> Either available hardware, instructions on using an emulator or <other>?
15:10:39 <pbrobinson> sgallagh: in terms of netboot and install it's mostly the same as per x86
15:10:39 * nirik could try and find time to test. I have a beagle bone black here and can also test on highbank.
15:11:07 <sgallagh> It's dangerously late in the Alpha cycle for us to be just starting this, unfortunately.
15:11:10 <pwhalen> sgallagh, i have been testing network installs on a couple of hw targets, wandboard, cubietruck and highbank
15:11:19 <pbrobinson> you just need to setup uboot properly, let me see if I can find those instructions
15:11:21 <sgallagh> I'd like us to figure out if we're workable or completely broken and should defer support
15:11:59 <sgallagh> #info We need to be able to test ARMv7 hardware to make certain it's not completely broken
15:12:03 <pbrobinson> pwhalen is the best to answer that, but the pxe based installs are generally working for F-21 on ARM so I think we're in reasonable shape
15:12:04 <pwhalen> not broken on arm, quite usable
15:12:09 <sgallagh> #info nirik has some available hardware
15:12:12 <pwhalen> also possible in qemu
15:12:21 <sgallagh> $info pwhalen has been testing network installs on a couple of hw targets, wandboard, cubietruck and highbank
15:12:32 <sgallagh> #info pwhalen reports that ARM is quite usable
15:12:36 <sgallagh> (this is good to hear!)
15:13:10 <sgallagh> #info PXE-based installs are working for general F-21 on ARM, so Fedora Server should be in reasonable shape
15:13:54 <sgallagh> We really should make sure that the Fedora Server Alpha TCs in particular are at least smoke-tested on real hardware if possible.
15:14:18 <sgallagh> Is there someone with more available time than I have willing to attempt this?
15:14:37 <pwhalen> sgallagh, for sure. i've been testing each TC, both server and workstation
15:14:38 <sgallagh> #info pwhalen has been testing network installs on a couple of hw targets, wandboard, cubietruck and highbank
15:14:58 <sgallagh> OK, great. Then we're in better shape than I thought
15:15:00 <pbrobinson> sgallagh: I can help with that, I'm testing various devices anyway so whether it's server or other makes little difference to me
15:15:15 <sgallagh> #info pwhalen confirms that he's been testing each TC on ARM. We're in good shape.
15:15:32 <sgallagh> #action pbrobinson will also help test various devices on Fedora Server
15:15:49 <sgallagh> pbrobinson, pwhalen: Any major "gotchas" we should be aware of right now?
15:15:58 <sgallagh> Anything likely to be a blocking issue?
15:16:04 <pwhalen> nothing arm specific
15:16:11 <pbrobinson> agree with pwhalen
15:16:32 <sgallagh> #info No known ARM-specific blocking issues at this time
15:16:41 <sgallagh> OK, anything else to add, then?
15:16:52 <sgallagh> (This is better news than I expected today)
15:17:05 <simo> meh sorry, I'm late :/
15:17:38 <sgallagh> OK, I'll move on to the next topic.
15:17:45 <sgallagh> #topic Fedora 21 Alpha Announcement and Download Page
15:17:45 <sgallagh> #link https://fedoraproject.org/wiki/F21_Alpha_release_announcement
15:17:45 <sgallagh> #link http://stg.fedoraproject.org/en/get-prerelease#server
15:18:13 <sgallagh> The Websites and Marketing teams have asked us to review the content of both of these pages for the upcoming Alpha release
15:19:02 <sgallagh> I think we want to add a mention of Cockpit to the Alpha release announcement page
15:20:20 <sgallagh> Suggestions for phrasing?
15:20:33 <sgallagh> stefw, mizmo_: I'm counting on you two here :)
15:20:50 <adamw> do we actually have the role deployment mechanism and role working yet?
15:20:55 <mizmo_> sgallagh, im a bit behind - i didnt know cockpit was going to be available in f21
15:21:01 <adamw> this is specifically the *Alpha* announcement, so it shouldn't talk about those if they're not working in alpha
15:21:09 <simo> sgallagh: where do you want to mention it ?
15:21:29 <mizmo_> simo, it'd be under this header https://fedoraproject.org/wiki/F21_Alpha_release_announcement#Fedora_21_Server
15:21:40 <sgallagh> adamw: Yes, the Domain Controller role can be deployed.
15:21:45 <tuanta> sorry, I am late
15:21:57 <sgallagh> (Not really managed, but deployment and decommission is pretty much working)
15:21:58 <tuanta> .hellomynameis tuanta
15:21:59 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:22:25 <simo> mizmo_: yep, but I was wondering whether sgallagh wanted to mention it in the main paragraph or in the Domian Controller one or have a separate paragraph
15:22:32 <simo> should we mention rolekit by name ?
15:22:57 <simo> .hellomynameis simo
15:22:58 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
15:22:59 <adamw> sgallagh: huh, nice. clearly i've not been keeping up :)
15:23:00 <mizmo_> id call it out under its own paragraph if we were gonna add it
15:23:33 <simo> I was thinking we want a paragraph that explains rolekit+cockpit as foundational tools
15:23:45 <simo> and then one for explicit roles, if that is permissible
15:23:52 <sgallagh> simo: Would you be willing to put something together and send it to the mailing list for edits?
15:24:12 <simo> if you like broken english, sure :)
15:24:36 <tuanta> :)
15:24:39 <sgallagh> I'm sure the native speakers can clean up the grammar
15:25:13 <sgallagh> #info We want to add mention of both Cockpit and rolekit as foundational tools of the Fedora Server on the Alpha announcement
15:25:25 <stefw> sgallagh, i can come up with some text for that
15:25:43 <sgallagh> #action simo and stefw to take a first crack at the text and send to the mailing list for tweaking.
15:25:47 <sgallagh> (Fair?)
15:25:55 <simo> workforme
15:25:55 <stefw> must switch out my coding grammar module and put in lingual grammar module
15:26:23 <simo> wait, there is a difference ? oh boy ... that's why ... :)
15:26:23 <sgallagh> Anyone have any concerns about the Download page?
15:26:34 <simo> sgallagh: it looks good to me
15:27:06 <adamw> ack
15:27:30 <sgallagh> ack from me as well
15:27:42 * nirik 's laptop freaked out... reading/catching up.
15:27:47 <sgallagh> (though that's probably a conflict of interest, as I've been back-and-forth on it with robyduck)
15:28:20 * simo slaps a "good job" sticker on sgallagh's back and calls it done :)
15:28:45 <sgallagh> Anyone mind if I slap the #agreed label on this, then?
15:28:55 <mizmo_> +1
15:29:26 <sgallagh> #agreed Content of the Fedora Server download page looks good and is approved by the Server WG
15:29:39 <sgallagh> OK, we have one more topic and I have to run to another meeting.
15:29:52 <sgallagh> #topic Netinst media update
15:30:14 <sgallagh> Would someone mind volunteering as secretary for the remainder?
15:30:19 <sgallagh> adamw: Maybe you?
15:30:44 <adamw> er, possibly, what am I supposed to be doing?
15:31:16 <sgallagh> Just #info and move on to Open Floor after this topic, then #endmeeting
15:31:31 <sgallagh> I'll handle sending out the minutes later
15:32:00 <adamw> oh, you're out, then. sorry, multitasking
15:32:14 <adamw> sure, whatever, maybe just chair a few of us and we can co-op it?
15:32:49 <adamw> so on this topic, the bug report to watch is https://bugzilla.redhat.com/show_bug.cgi?id=1134524
15:32:50 <sgallagh> adamw: You are already chaired
15:32:52 <adamw> yay me
15:33:31 <adamw> the back story: network install images haven't ever worked quite right for F21 Alpha yet, and last week we sort of realized we hadn't come to a clear agreement on how they were *going* to work
15:33:44 <mizmo_> oh this one :(
15:33:53 <adamw> this has been thrashed out between releng and jreznik and the WGs and anaconda in the last few days, and we have a rough consensus at this point, I believe
15:34:33 <adamw> which is that network install images will indeed be product-ized, they will use product-ized install trees for their default 'main' repo, and releng will handle the necessary mirroring / MM redirecting to make that work
15:35:31 <adamw> i think our action items here are mostly 'monitor and test', but I believe there's going to be a need to create fedora-(product).repo files for yum and somehow include them in installer image generation; those repos probably only need to be used by anaconda, not by installed systems
15:35:33 <simo> adamw: do you have a oneliner that tells what's the issue ?
15:35:48 <adamw> simo: come on, you know me. one liner?
15:36:09 <simo> I know, it was a test!
15:37:02 <adamw> simo: er, more or less, if you want network install images to have a product-specific set of available packages / package groups, with our current tech, they need to be using a product-ized package repo - we can't make it so all products use the same repo but present different lists of available packages/groups
15:37:25 <simo> oh, odd
15:37:50 <mitr> adamw: The .repo files referred to in comment#18 already exist, or will be created by someone other than us?  Or do we need to take action?
15:37:55 <adamw> so we had those trees all along (they're what the Product DVDs are built from) but what we didn't have is the bits to make anaconda find the product-ized tree for the product being installed and use it as the default repo when booting that product's netinst
15:38:05 <simo> I do not like the precedent of having multiple repos, but if we can keep them strictly for anacond and generated automatically from the common repo I guess it will work
15:38:38 <adamw> mitr: i believe someone's going to need to create them, i don't believe that's been assigned yet. but that's just me working out the process, best to get dgilmore and/or anaconda to confirm. i plan to talk to dgilmore a bit more about the todo items today
15:39:07 <adamw> simo: so the alternative would be for someone to implement product-ized comps, basically
15:39:15 <adamw> so a single repo could have multiple per-product comps data
15:39:55 <simo> adamw: I thought that was the plan since we started all these products stuff to be hoinest
15:40:02 <adamw> that would allow us to use one shared repo (but then we'd still need a way for the installer to pick the right comps data, of course)...i'm guessing the assumption of 'one set of comps data per repo' is a pretty deep one in yum, dnf, anaconda etc etc and might be hard to change
15:40:07 <simo> I am quite surprised we find this technical bump so late in the process
15:40:14 <adamw> simo: yeah, that was the kind of confusion we had to sort out this week
15:40:25 <adamw> simo: well, i think some people knew about it all along and assumed everyone else did, but they didn't :)
15:40:42 <simo> never trust domain experts :)
15:41:52 * nirik nods
15:41:53 <adamw> creating the per-product repo definitions shouldn't really be too big of a deal, i think, the way we have repos set up they probably will very rarely need to be changed and we can probably do it automatically from the 'master' repo in some way or other (i have to read the fedora-repos spec). the mirrormanager stuff is probably the tricky bit, but we have releng for that. ;)
15:42:27 <simo> ok
15:42:36 <adamw> nirik: did I mess anything up there that you see?
15:42:40 <simo> is this going to be a short term or long term solution ?
15:42:59 <simo> ie are we doing a hack to get F21 out, or are we going to settle on this delivery method ?
15:43:01 <nirik> not off hand. I've not been following it super closely tho
15:43:10 <mizmo_> yehi missed that, whats the short term fix
15:43:21 <simo> mizmo_: create one repo per product
15:43:27 <simo> at least for install
15:43:27 <adamw> #info see https://bugzilla.redhat.com/show_bug.cgi?id=1134524 for details on what's needed to make per-Product network install images work. our involvement is likely to be limited to monitoring and testing
15:43:48 <adamw> simo: well, dgilmore would be the expert, but my take would be that it's not exactly a short term bodge
15:43:48 <simo> adamw seem confident we do not need to install per-product repos  in the installed image
15:43:58 <mizmo_> ah okay
15:44:24 <simo> adamw: I'd really like to understand what is the long term plan and what would be the ideal solution and whether we can reach it or not
15:44:55 <simo> however as long as all the WGs and Fesco and releng are ok with this plan for f21 I guess we'll be fine ?
15:45:01 <adamw> simo: well, i mean, it's kind of a big question. there's all sorts of stuff about how we do repositories and package management and image generation bundled up here.
15:45:14 <simo> what kind of input is <who?> seeking from us ?
15:45:19 <adamw> i'd say that as long as we're on our current generation of repository and installer creation tooling, we're going to need something along these lines.
15:46:09 <adamw> simo: so two things: one, if people look at the details on the bug and think they look incredibly awful or will not implement what we want or they have a genius idea for doing it better, that'd be useful input
15:46:29 <adamw> two, testing - once we actually implement the bits we think should get netinst working OOTB, we need folks to check that, of course
15:46:57 <mitr> adamw: My only possible concern is storage space, but if releng/infra is OK with the plan I have nothing to add.
15:47:06 <adamw> as I understand it, it'll also need testing to confirm that it continues to work at each milestone release and each TC1 point (because we have to roll over the mirrormanager redirects at  those points, boring technical details in bug)
15:47:08 <simo> adamw: ok for testing when will netinst images available ?
15:47:27 <simo> adamw: should we add an action item for one of us to trest them as soon as they are released ?
15:47:38 <adamw> simo: i think it's slightly too early to answer that, needs releng to assess the difficulty of mirrormanager changes i think
15:47:58 <simo> adamw: well then it seem we do not have much to go on
15:48:03 <adamw> adding the new repos would be a trivial hour or two, and making sure anaconda looks for the right repo files is also pretty trivial, it's the MM bit that's the most complex i think.
15:48:19 <adamw> i'm figuring we want this fixed before Alpha goes out
15:48:32 <adamw> the bug is marked as a release blocker, which per process means we can't do an RC without fixing it
15:48:34 <simo> from my pov I do not have enough knowledeg to judge their proposed soluition, and the only danger I see is in having divergent package sets in different product repos, which we swore never to do)
15:48:55 <adamw> so, if you see an RC1, that means we fixed it or gave up :P it may come in TC7 or TC8 or what the heck ever, too many variables
15:49:04 <simo> if these are non-issues, I guess we need to wait and see how the netinst behaves once releng is done
15:49:16 <nirik> well, they are all made from the same collection of packages.
15:49:20 <adamw> simo: the diverged repos are just the product-specific installer trees, which we already have and need to build the diverged installer images
15:49:41 <simo> adamw: diverged installer trees is fine
15:50:34 <adamw> so when we say 'repo' here we're just talking about the main 'fedora' repo for the network install. the installed system can use the non-productized, generic release repo, and as I read the old discussions that's what everyone agreed all the products would do.
15:51:00 <adamw> it would probably be a really bad idea for the installed system to use the product-ized repo as its 'fedora' repo because it would mean you couldn't install anything that wasn't on the DVD, more or less. anyhow.
15:51:08 <nirik> right
15:52:04 <adamw> anyway, once we actually put the bits together i'll make sure it's mentioned in the relevant TC/RC announcement
15:54:41 <simo> adamw: ok
15:54:43 <simo> sounds good
15:54:49 <adamw> #info adamw will communicate once we have a TC/RC where the new netinst bits should be in place and folks can test/examine the mechanism
15:54:55 <simo> do we need any vote/blessing on something ?
15:55:21 <adamw> I don't think so, the plan was pretty much agreed between dgilmore/jreznik/sgallagh/kalev/bcl , this was mostly just bringing people up to speed
15:55:41 <adamw> i can provide more technical details on exactly what the problem is and the design of the new approach is to anyone who's interested, just didn't want to clog up the meeting
15:55:44 <adamw> so, moving on:
15:55:46 <adamw> #topic Open floor
15:55:53 <adamw> any other business?
15:56:26 <simo> I am not sure I should bring this up
15:56:42 <simo> but should we discuss the latest proposal from systemd/Lennart "cabal" ?
15:56:50 <adamw> what proposal is that?
15:56:52 <simo> I guess this is more for the base wg
15:57:11 <simo> and I do not want to discuss the details now only know if it is something in topic for our wg
15:57:23 <simo> adamw: let me find the link
15:58:23 <simo> adamw: http://0pointer.net/blog/revisiting-how-we-put-together-linux-systems.html
15:58:29 * nirik thinks it's interesting, but might not get the adoption they really want.
15:58:44 <simo> a very controversial proposal (more controversial than systemd imho :)
15:58:48 <nirik> and there's tons of details missing. ;)
15:59:03 <nirik> and btrfs isn't able to do what they want (yet)
15:59:10 <simo> nirik: I think it is interesting too, just quite off still
15:59:42 <simo> nirik: btrfs is not stable yet either, even if it were able to do what they want (and I question the need to do some of it in a FS specific way)
15:59:50 <simo> but again I do not want to discuss the proposal itself
16:00:01 <mitr> simo: Structurally I think this would be for Base, and we can talk to Base (both individually as and as a Server WG)
16:00:02 <simo> just whether it is something we should even discuss in this wg
16:00:31 <mitr> I haven’t had a chance to read through it yet I’m afraid.
16:00:42 <simo> it *is* going to affect everything if adopted, in quite some radical ways
16:00:55 <simo> but whether we should dicsuss it here is a different matter
16:01:39 <nirik> not sure. I would say probibly a wider discussion would need to happen first...
16:01:42 <adamw> oh, right, the btrfs design
16:01:55 <adamw> seems a bit early
16:01:55 <nirik> and then if we want to move forward with it, more discussion on how it would affect server.
16:02:29 <mitr> simo: I’d say that we should discuss here to the extent it affects/interferes with server-specific concepts.
16:04:28 <adamw> #info we note the sixteen-wheel truck on the horizon labelled Lennart's Latest Bright Idea - http://0pointer.net/blog/revisiting-how-we-put-together-linux-systems.html
16:04:45 <simo> mitr: I tend to agree
16:04:55 <mitr> simo: I’m generally worried that there will be no perfect venue to discuss this.
16:05:00 <simo> ok let's postpone until after F21 is out ? makes sense ?
16:05:22 <simo> mitr: I think it may be worth just to provide feedback about our concerns and requirements
16:05:37 <adamw> mitr: we can delegate someone from server WG to talk to base and lennart and see whether this is something lennart really wants fedora to take up and something base is interested in actually taking up, whether the time for that is now i don't know
16:06:10 <simo> mitr: for srv for example I have some huge reservation about the idea that 2 different versions of glibc or other other core libraries could be running at the same time
16:06:16 <mitr> I haven’t read that yet so my opinion on the process really doesn’t count.
16:06:18 <simo> but we'll discuss that another time
16:09:06 <adamw> ok, we're over our hour
16:09:14 <adamw> anything else to discuss or should we wind up now?
16:11:32 <simo> wind up
16:12:04 <simo> stefw: do you want to write the whole paragraph about rolekit/cockpit or just a phrase/2 about copckpit
16:12:05 <simo> ?
16:13:09 <adamw> ok, i don't recall if there's any special tear-down for this meeting so i'll go ahead and endmeeting in a minute unless anyone tells me otherwise
16:13:22 <stefw> simo, i can just write the cockpit part
16:15:21 <simo> adamw: #enmdmeeting
16:15:27 <adamw> doing it
16:15:29 <adamw> #endmeeting