releng
MINUTES

#fedora-meeting-1: RELENG (2014-09-08)

Meeting started by dgilmore at 15:41:03 UTC (full logs).

Meeting summary

  1. init process (dgilmore, 15:42:52)
  2. #1107 auto-cleanup rawhide trees (dgilmore, 15:44:11)
    1. https://fedorahosted.org/rel-eng/ticket/1107 (dgilmore, 15:44:20)
    2. < dgilmore> this needs a script written that will keep the last 14 trees (tyll, 15:44:56)
    3. < dgilmore> we could run it via cron or buildbranched/buildrawhide (tyll, 15:45:32)
    4. < dgilmore> though updates trees need cleaned up also as bodhi just leaves them there (tyll, 15:45:48)
    5. affected paths /mnt/koji/mash and /mnt/koji/mash/updates (tyll, 15:48:13)
    6. ACTION: masta I'll take the cleanup task. (tyll, 15:51:04)

  3. #1501 repomd.xml signing in bodhi (dgilmore, 15:51:08)
    1. < dgilmore> I would be more willing to revisit with concrete proposal (tyll, 15:54:14)
    2. dgilmore> tyll: autosigner box is sperate with more limited access than the releng boxes (tyll, 15:54:23)
    3. releng04 and relepel01 used to prepare updates (tyll, 15:56:27)
    4. ACTION: someone come up witha concrete implementation plan and we can revisit (dgilmore, 16:00:15)

  4. #5931 [Proposal] Move new branch and unretire requests to pkgdb2 (dgilmore, 16:00:23)
    1. https://fedorahosted.org/rel-eng/ticket/5931 (dgilmore, 16:00:31)
    2. http://paste.fedoraproject.org/131843/41019240 (tyll, 16:07:43)
    3. < pingou> - Do we really want to populate the branch when we create them? (tyll, 16:14:05)
    4. < pingou> the second question I have is: for new *fedora* branch, what do we need to check beside that the requester is a packager? (tyll, 16:14:40)
    5. < pingou> we "just" need to define what we want to fully automate and what we still want to check "manually" (tyll, 16:14:59)
    6. < pingou> I've started working on a pkgdb-admin CLI part of pkgdb-cli https://git.fedorahosted.org/cgit/packagedb-cli.git/tree/pkgdb2client/admin.py?h=pkgdb_admin (tyll, 16:15:26)
    7. for new branches, check whether the person is a packager and has commit ACLs for at least on Fedora branch (tyll, 16:16:16)

  5. #5967 Enable source repo generation (dgilmore, 16:16:18)
    1. https://fedorahosted.org/rel-eng/ticket/5967 (dgilmore, 16:16:26)
    2. < dgilmore> this comes at a massive cost (tyll, 16:17:29)
    3. < dgilmore> it will be next to impoosible to turn off if we enable it (tyll, 16:19:10)
    4. ACTION: dgilmore ask for some more info in the ticket (tyll, 16:20:10)
    5. < dgilmore> I really do not understand what the perceived gain is either (tyll, 16:20:27)
    6. < nirik> in any case I wouldn't want to do it in freeze. (tyll, 16:20:36)

  6. #5959 Enable keep-alive connections for koji (primary and secondaries) (dgilmore, 16:23:34)
    1. https://fedorahosted.org/rel-eng/ticket/5959 (dgilmore, 16:23:40)
    2. ACTION: pbrobinson to enable and do testing to make sure nothing breaks (dgilmore, 16:29:15)


Meeting ended at 16:33:10 UTC (full logs).

Action items

  1. masta I'll take the cleanup task.
  2. someone come up witha concrete implementation plan and we can revisit
  3. dgilmore ask for some more info in the ticket
  4. pbrobinson to enable and do testing to make sure nothing breaks


Action items, by person

  1. dgilmore
    1. dgilmore ask for some more info in the ticket
  2. masta
    1. masta I'll take the cleanup task.
  3. pbrobinson
    1. pbrobinson to enable and do testing to make sure nothing breaks


People present (lines said)

  1. dgilmore (79)
  2. tyll (44)
  3. pingou (24)
  4. nirik (22)
  5. masta (8)
  6. bochecha (6)
  7. zodbot (4)
  8. pbrobinson (2)
  9. sharkcz (2)


Generated by MeetBot 0.1.4.