fpc
LOGS
16:02:40 <geppetto> #startmeeting fpc
16:02:40 <zodbot> Meeting started Thu Sep  4 16:02:40 2014 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:40 <geppetto> #meetingname fpc
16:02:40 <zodbot> The meeting name has been set to 'fpc'
16:02:40 <geppetto> #topic Roll Call
16:02:51 * Rathann here
16:02:55 <geppetto> abadger1999 tibbs|w limburgher SmootherFr0gZ RemiFedora racor spot: FPC ping
16:03:00 <geppetto> #chair Rathann
16:03:00 <zodbot> Current chairs: Rathann geppetto
16:03:11 * RemiFedora here
16:03:38 <geppetto> #chair RemiFedora
16:03:38 <zodbot> Current chairs: Rathann RemiFedora geppetto
16:06:57 <geppetto> abadger1999 tibbs|w limburgher SmootherFr0gZ racor spot: FPC ping
16:07:21 <RemiFedora> + racor ;)
16:07:32 <geppetto> yeh, just waiting for him to respond
16:07:33 * jsmith is lurking
16:10:47 * racor is here
16:10:56 <geppetto> #chair racor
16:10:56 <zodbot> Current chairs: Rathann RemiFedora geppetto racor
16:11:14 <geppetto> tibbs: FPC ping?
16:22:41 <geppetto> well, this is going bad again
16:22:53 <geppetto> #topic Open Floor
16:23:19 <geppetto> I emailed spot last week about how to get some more people on the FPC … but didn't get a responce
16:23:48 <geppetto> I'll ping him again now
16:23:56 <geppetto> Anybody want to bring anything else up?
16:25:04 <Rathann> oh
16:25:27 <Rathann> why did you ask only spot?
16:26:00 <geppetto> just he's the one who always did it before, AFAIK
16:26:05 <geppetto> who else should I ask?
16:27:34 <Rathann> any one of us can send an announcement asking for volunteers
16:27:40 <racor> In the past, we've first asked FPC for candidate proposal
16:28:18 <Rathann> during FLOCK in Prague, I met at least one person who was interested in joining
16:28:21 <racor> later we've asked for volunteers in the public
16:28:40 <Rathann> I told him to watch out for a public call
16:28:42 <racor> and when we had enough candidates, we've voted
16:28:53 <geppetto> ok, that seems fine to me … if anyone has any candidates … might as well send everyone an email off list about them
16:29:09 <geppetto> I'd guess we'd want at least 2 new people
16:29:21 <Rathann> right
16:30:03 <racor> Q: What is the situation with spot rsp abadger1999? Have they quit FPC? Are they too busy?
16:30:46 <geppetto> AFAIK spot is just busy … isn't chairman anymore, but isn't sure how much time he'll have for FPC in the future
16:31:16 <geppetto> abadger1999 has a new job, so at least in the short term won't be here every week
16:31:37 <geppetto> hopefully after a few weeks at the new job he'll be able to make it as a member every week
16:31:49 <tibbs> Sorry, folks; I have a cold and am drug-addled.  Just got to a computer.
16:31:57 <geppetto> #chair tibbs
16:31:57 <zodbot> Current chairs: Rathann RemiFedora geppetto racor tibbs
16:32:10 <geppetto> We have quorum :-o
16:32:35 <mbooth> I have a quick question, doe being a FPC member preclude one from proposed packaging guideline changes and what not?
16:32:46 <mbooth> s/doe/does/
16:32:58 <tibbs> Not at all.
16:33:00 <geppetto> mbooth: no, quite the opposite
16:33:06 <Rathann> mbooth: if you mean "from proposing"? then no, it doesn't
16:33:14 <tibbs> In the olden days that's how it worked.
16:33:20 <mbooth> I see
16:33:40 <tibbs> But things mainly moved off to things that were so domain-specific that most of us aren't qualified to write the guidelines.
16:33:42 <racor> in the current days with are overwhelm with a pile having piled up ;)
16:33:53 * mbooth considers volunteering
16:33:55 <geppetto> #action racor Rathann to email FPC members with a candidate each.
16:34:00 <geppetto> #topic #447     Bundling exception for axmail
16:35:37 <geppetto> I'm guessing this is a fork … although it would have been nice if they'd done the bundling questions
16:37:30 <tibbs> geppetto: I agree.
16:38:46 <RemiFedora> yes seems a fork
16:39:09 <tibbs> I mean, could be dicks and say "you didn't answer all the stuff" but approving this seems pretty obvious.
16:39:24 <geppetto> Ok
16:39:25 <geppetto> +1
16:39:30 <Rathann> fork +1
16:40:14 <tibbs> +1
16:40:16 <RemiFedora> +1
16:40:51 <racor> +1
16:41:09 <geppetto> #info Passed:  #447     Bundling exception for axmail (+1:5, 0:0, -1:0) (Considered a fork)
16:41:27 <geppetto> #topic #448     Copylib exception for fastlz
16:41:32 <geppetto> https://fedorahosted.org/fpc/ticket/448
16:42:09 <RemiFedora> just something I have detect recently...
16:42:38 <geppetto> yeh, it might be nice if you could package it into a library so a bunch of things could use it
16:42:46 <geppetto> but I'd also like a ferrari :)
16:42:56 <RemiFedora> ask 2, I want one :
16:42:56 <geppetto> or a unicorn, so...
16:43:00 <geppetto> +1
16:44:26 <tibbs> Interesting; fastlz has command line utilities, too.
16:44:37 <Rathann> ask php-pecl-memcached if they want to maintain the fork as a library?
16:44:53 <Rathann> who else is bundling fastlz?
16:44:54 <geppetto> it can't hurt
16:45:15 <RemiFedora> for now, only pel/memcached, but I havent search in "all" fedora sources
16:45:26 * geppetto nods
16:45:39 <geppetto> but you have one more
16:45:40 <RemiFedora> but I see it in pecl/yac (not yet submitted)
16:45:51 <RemiFedora> and in another (not yet submitted)
16:46:06 <tibbs> There really isn't much code here.  It's not all that different from encryption code which we already permit.
16:46:09 <geppetto> Do you want to submit either of them soon?
16:46:31 <tibbs> The real concern is what happens if some security issue is found, same as any other bundling.
16:46:33 <geppetto> tibbs: AFAIK we don't allow encyrption code … just sha1/md5
16:47:01 <tibbs> That's pretty much what I was trying to say.
16:47:05 <RemiFedora> Yes I'd like ti be able to submit, at least yac
16:47:43 <RemiFedora> tibbs, of course, this need to be tracked, using an bundled(fastlz) or something
16:47:58 <geppetto> seems like we should allow it in the short term at least then … although if we can get the memcache people to make a library out of it, then we'd want everyone to use it
16:48:27 <Rathann> +1 to that :)
16:49:37 <geppetto> tibbs RemiFedora racor: vote?
16:50:01 <RemiFedora> libmemcached already provides an util lib, with some "hash" algo (usually bundled in some other project)
16:50:14 <RemiFedora> hashkit_jenkins p.e.
16:50:16 <Rathann> well I'm not voting for making it a copylib exception
16:50:27 <geppetto> #action RemiFedora Speak to php-pecl-memcached maintainer/upstream about them creating a library for fastlz.
16:50:46 <Rathann> just +1 for this particular exception as upstream seems dead
16:51:00 <racor> why not turn the "old" upstream into a package?
16:51:13 <geppetto> Rathann: You want to vote again for the next package RemiFedora wants to submit?
16:51:34 <geppetto> racor: Idealy someone would do that … hopefully memcache people will
16:51:43 <Rathann> racor: presumably because the current users of that code have patched it? I haven't checked
16:52:01 <RemiFedora> no, code if the same than the very old upstream one
16:52:29 <racor> then it should not be much of effort to package it :)
16:52:30 <Rathann> well if it's not patched then unbundle and package separately, obviously
16:52:47 <RemiFedora> I don't want to be upstream for this ;)
16:54:12 <Rathann> then have someone else package fastlz for you ;)
16:55:36 <racor> or question the role of this code.
16:56:08 <geppetto> question it's role?
16:56:20 <geppetto> You mean how useful it is over everyone moving to zlib?
16:57:28 <racor> geppetto: There must be reasons this code didn't gain more popularity.
16:57:58 <geppetto> racor: in older times people cared a lot more about size result than compress/decompress time … hence gzip => bzip2
16:58:31 <geppetto> racor: Now some people care a lot about CPU, because storage/network is "cheaper"
16:59:19 <racor> geppetto: True, but people also care about reliability and security
17:00:22 <geppetto> true
17:00:32 <racor> geppetto: One lesson learnd from xz, lzma was, don't trust compression algorithms unless extensively tested.
17:01:12 <geppetto> Well … this is already being used in memcached
17:01:33 <racor> geppetto: Sorry, I am not familiar with it ;)
17:01:40 <geppetto> That doesn't mean it's secure/great/whatever … but in many ways that's better than if they'd made a library and nobody was using it
17:04:03 <geppetto> Does anyone else want to vote on letting RemiFedora bundle it for pecl/yac?
17:04:30 * RemiFedora searching for summershum instance....
17:06:33 <geppetto> #info Needs votes:  #448     Bundling of fastlz for pecl/yac (+1:3, 0:0, -1:0) (everyone would be happier if it was a lib.)
17:06:42 <geppetto> #topic #450     Temporary jsquery packing exception for kimchi
17:06:47 <geppetto> https://fedorahosted.org/fpc/ticket/450
17:07:22 <geppetto> this feels like a -1, go help them get it into Fedora
17:08:38 <RemiFedora> +1 as we already tons of jquery bundled in every webapp, and jquery is just something with no stable API, nearly impossible to unbundle
17:09:37 <geppetto> ahh, you think the effort to get it into Fedora is doomed then … or will just take a really long time?
17:10:01 <RemiFedora> dommed
17:10:06 <geppetto> fair enough
17:10:07 <RemiFedora> doomed
17:10:09 <geppetto> +1
17:10:57 <tibbs> I feel dumb, but are jsquery and jquery different things?
17:11:18 <geppetto> java = j, javascript = js … AIUI
17:11:26 <Rathann> actually it seems to bundle a lot more than jquery
17:12:40 <tibbs> At least jsquery seems to be some kind of jquery replacement, so not the same thing at all.
17:15:09 <Rathann> tibbs: kimchi bundles jquery
17:15:13 <geppetto> yeh, I'm completely wrong … both JavaScript … no idea about anything
17:15:27 <Rathann> and jquery-ui
17:15:30 <geppetto> Rathann: Why do they say jsquery then?
17:15:38 <Rathann> probably a typo
17:17:23 <geppetto> I just pinged brent, so I'll give him a couple of minutes
17:19:44 <Rathann> RemiFedora: I'm still hopeful that with enough pressure from distros, upstream can be convinced to at least make regular releases and keep stable API between minor updates
17:22:23 <RemiFedora> Rathann, I hope you will never know about Bower and Grunt...
17:22:39 <Rathann> anyway, I'm +1 to temporary jquery bundling exception for kimchi
17:23:00 <geppetto> tibbs racor: vote for tmp. bundling exception?
17:23:32 <racor> +1, I don't think can change this unfortunate mess.
17:24:03 <tibbs> +1
17:24:43 <geppetto> #info Passed: #450     Temporary jsquery packing exception for kimchi (+1:5, 0:0, -1:0)
17:25:04 <geppetto> #topic #454 	Bundling exception for php-phpoffice-phpexcel
17:25:09 <geppetto> https://fedorahosted.org/fpc/ticket/454
17:26:50 <RemiFedora> I think is a fork of a mostly dead project
17:27:04 <geppetto> maybe
17:28:00 <geppetto> I feel like they could have integrated it better so they could merge with upstream better
17:28:10 * Rathann too
17:28:48 <geppetto> I'm also not impressed that the last upstream release of 2 years ago contains bugfixes that they haven't ported to their fork yet
17:29:59 <geppetto> RemiFedora: we don't ship pear OLE, right?
17:30:20 * RemiFedora checks
17:30:39 <RemiFedora> http://rpms.famillecollet.com/rpmphp/zoom.php?rpm=php-pear-OLE
17:30:43 <racor> Sorry folks, it's 30 mins past the hour, I have got to quit now. Dinner's waiting ;)
17:30:54 <racor> bye
17:30:55 * geppetto nods
17:31:22 <geppetto> RemiFedora: so we do … I'm less tempted to just give them a +1 then
17:32:20 <Rathann> yeah, I have to leave as well, -1 as is for now
17:32:36 <RemiFedora> we can probably to see if excel upstream answer to last comment, about OLE being available via composer
17:32:44 <Rathann> agreed
17:32:50 <Rathann> sorry and bye
17:32:52 * geppetto nods … I'll add a comment to the ticket, see if they can give us some more info. about why they can't fix stuff
17:34:04 <geppetto> #info Needs more info: #454     Bundling exception for php-phpoffice-phpexcel (leaning towards -1s)
17:34:13 <geppetto> #topic Open Floor
17:34:46 <geppetto> Ok, anyone want to bring something up … if not I'll close in 5 minutes
17:34:50 <RemiFedora> I propose we close ticket 399
17:35:15 <RemiFedora> with something like "this can't be in the normal Fedora guidelines"
17:36:08 <geppetto> Why not just vote -1 in ticket?
17:36:26 <geppetto> Maybe a comment explaining why?
17:36:34 <geppetto> I apparently voted +1
17:36:45 <geppetto> …but I don't remember anything about it atm.
17:40:16 <RemiFedora> soory I mean 339... of course... the SCL one
17:41:48 <geppetto> ahh
17:42:02 <RemiFedora> (and for 399, a very old one, I vote +1, so we have +5 and we can close it as approved)
17:42:19 * geppetto nods
17:42:44 <geppetto> I'm not sure what to do about 339 … feels like we should at least have quorum before we give up on it
17:47:30 <geppetto> #endmeeting