fpc
LOGS
16:01:02 <spot> #startmeeting Fedora Packaging Committee
16:01:02 <zodbot> Meeting started Thu Jul 10 16:01:02 2014 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:07 <spot> #meetingname fpc
16:01:07 <zodbot> The meeting name has been set to 'fpc'
16:01:16 <spot> #topic Roll Call
16:01:19 <abadger1999> Greetings.
16:01:21 * geppetto is here
16:01:35 <spot> #chair abadger1999 geppetto
16:01:35 <zodbot> Current chairs: abadger1999 geppetto spot
16:02:09 * racor is here
16:02:15 <spot> #chair racor
16:02:15 <zodbot> Current chairs: abadger1999 geppetto racor spot
16:02:15 * RemiFedora is here
16:02:19 <spot> #chair RemiFedora
16:02:19 <zodbot> Current chairs: RemiFedora abadger1999 geppetto racor spot
16:03:31 <spot> tibbs_, SmootherFrOgZ: ping
16:04:34 <geppetto> spot: as an addition to the agenda (not sure if you want it at the beginning or end), lennart wants us to look at #191 again.
16:04:34 * SmootherFrOgZ is around
16:04:37 * spot is eating a few bites while waiting for any late comers
16:05:22 <spot> #chair SmootherFrOgZ
16:05:22 <zodbot> Current chairs: RemiFedora SmootherFrOgZ abadger1999 geppetto racor spot
16:05:31 * geppetto only has gummy cola bottles … and not sure this counts as "lunch"
16:05:43 * sgallagh lurks for the discussion of the per-product config draft
16:05:44 * abadger1999 finds he needs to reboot after the meeting... keep running out of process  space and crashing chrome
16:06:09 <spot> abadger1999: i think you can increase your ulimit and resolve that without a reboot
16:06:40 <abadger1999> spot: Yeah, zsh has forgotten how to ulimit for some reason.
16:06:55 <abadger1999> unable to load liblimit or something
16:07:26 <abadger1999> It's been a few months so it's probably time anyway
16:07:42 <spot> okay, i won't starve to death now. :)
16:07:58 <spot> #topic Software Collections in Fedora - https://fedorahosted.org/fpc/ticket/339
16:08:37 * spot is honestly not sure what's going on here, just a lot of unhappy people.
16:08:53 <geppetto> that about sums it up
16:08:56 <abadger1999> yeah, I'm trying to plow ahead but everyone is getting unhappier and unhappier.
16:09:00 <tibbs|w> I found that everything I want to say is non-productive.
16:09:05 <abadger1999> and htat makes the going slowre and slower.
16:09:43 <abadger1999> tibbs|w: I'm trying not to get to that point but if you read the tickets... I guess you can see that's getting harder and harder for me too :-(
16:09:50 <tibbs|w> Indeed.
16:10:03 <abadger1999> So productive questeions and notes
16:10:20 <abadger1999> spot did you get a hold of licquia about adding fedora to LANANA?
16:10:24 <Rathann> hi, sorry for being late
16:10:32 <spot> abadger1999: not yet, will try right now
16:10:35 <abadger1999> Cool.
16:11:06 <spot> #chair Rathann
16:11:06 <zodbot> Current chairs: Rathann RemiFedora SmootherFrOgZ abadger1999 geppetto racor spot
16:11:18 <abadger1999> On the naming front, I've got a proposal for SCLs that depend on multiple other SCLs
16:11:48 <spot> maybe we could prefix them with "WTF" (obviously not serious)
16:12:52 <spot> abadger1999: is the proposal something we can consider for a vote today or something that needs the SCL people to review first?
16:12:52 <abadger1999> Allow the first SCL for a package-version to use fdr-$scl$version.  If there are other SCLs of that package-version with different deps, they MUST include the other SCLs in their name.
16:13:36 <abadger1999> spot: Well... I think the communication with the SCL team is so spotty that we should approve things and then let them come up with counter proposals if they don't like it.
16:13:41 <abadger1999> Otherwise we'll never get anywhere.
16:13:47 <spot> i'm sorry. that's the sound of my brain bleeding out a little bit.
16:14:01 <abadger1999> Pros and cons of this proposal:
16:15:02 <abadger1999> Con: end users will have to deal with figuring out what hte difference is between fdr-rails3.2 and fdr-rails3.2-scl-ruby1.9.3-v8_3.21.
16:15:36 <abadger1999> Pro: For the common(er) case of only a single SCL at a particular version, we won't have to deal with the huge names at all.
16:15:50 <spot> s/end users/install tools
16:16:19 * spot doesn't even want to think too hard about those horrific n-v-r values
16:17:09 <tibbs|w> The problem is that we're trying to cram far more information into the package name than is reasonable to put there.
16:17:18 * RemiFedora nods
16:17:23 <tibbs|w> If things were in separate repos, this wouldn't be an issue.
16:17:24 <spot> Then again, SCLs are giant hacks anyways, so hey, why not add more hacks.
16:17:38 <abadger1999> tibbs|w: Yeah.
16:18:18 <abadger1999> tibbs|w: I've come to the conclusion that rpm wasn't made for this -- solving the base problem is better done with a package management tool that has builtin and across the board support for namespacing.
16:18:30 <tibbs|w> I'm not sure everyone sees this as a pile of giant hacks, which is part of the disconnect.
16:18:42 <abadger1999> but if SCLs are to go in, we have to work with what the tool can do rather than what we want it to do :-(
16:18:55 <spot> tibbs|w: i think they might see this as a pile of "clever" hacks.
16:18:58 <abadger1999> tibbs|w: Yep, I definitely see that disconnect as well.
16:19:55 <tibbs|w> The sad thing is that we conveniently have this new yum replacement thing, and it and SCLs came about at the same time, and somehow they didn't talk to each other.
16:20:18 <geppetto> SCLs were before dnf
16:20:27 <spot> I'm sure it will handle SCLs perfectly. *cough*
16:20:42 <geppetto> And I'm not sure what the yum/dnf layer can do to help SCLs
16:21:31 <abadger1999> <nod> I think it has to be at the rpm layer.  the dep solver doesn't add metadata to packages, it works with the metadata that rpm provides it with.
16:21:37 <spot> anyways, lets try to vote on this micropart.
16:21:38 <tibbs|w> Well from my perspective SCLs came about around the same time, but I understand that they came from within Red Hat and I have no way to know how long it was grinding around in there.
16:21:45 <spot> tibbs|w: too long.
16:21:49 <geppetto> In some ways I think ostree/docker are going to solve the SCL problem, but who knows.
16:22:11 <spot> Proposal: Allow the first SCL for a package-version to use fdr-$scl$version.  If there are other SCLs of that package-version with different deps, they MUST include the other SCLs in their name.
16:22:26 <geppetto> +1, how bad can it be
16:22:34 <RemiFedora> sems reasonable
16:22:46 <abadger1999> Reluctant +1... its the best of all the bad solutions I could come up with.
16:22:48 <tibbs|w> +1, it could be bad but it's all bad already.
16:23:03 <spot> +1, and i look forward to the first 100+ character package name as a result.
16:23:09 <RemiFedora> and just hope anyone will want to provides 2 scl of same version
16:23:12 <RemiFedora> +1
16:23:22 <tibbs|w> I wonder what the package name limit is....
16:23:35 <abadger1999> tibbs|w: You think as I do. :-)
16:23:35 <geppetto> I wouldn't be shcoked if it was low
16:24:03 * spot is not opening the rpm source to find out
16:24:05 <geppetto> But I vaguely recall Panu saying they'd dropped the limit and it was now just limited by header size.
16:24:25 <Rathann> +1
16:24:28 <spot> okay, i count +6.
16:24:33 <Rathann> reluctantly
16:24:39 <geppetto> so assuming rhel-6+ (or maybe rhel-7+) … I think it's like 100k+ :-o
16:24:40 <spot> SmootherFrOgZ, racor, want to go on the record here?
16:25:00 <SmootherFrOgZ> +1 from me
16:25:39 <spot> #action abadger1999's naming proposal for SCLs that depend on other SCLs approved (+1:7, 0:0, -1:0)
16:25:53 <spot> Any other SCL items we can tackle today?
16:26:30 <abadger1999> We also have: https://fedorahosted.org/fpc/ticket/444
16:26:36 <abadger1999> It's at +5 so it's officially passed.
16:26:56 <abadger1999> But since it's a recommendation to releng, it's probably good information for them to know what all of FPC thought.
16:27:09 <tibbs|w> Do we want to talk about the disconnect?  Because it seems the SCL folks are really unhappy that we don't want SCL macros complicating normal packages.
16:27:24 <abadger1999> So SmootherFrOgZ, RemiFedora: that just means, votes from you two.
16:27:33 <racor> spot: I've decided to abstain from voting on SCLs
16:27:46 <geppetto> tibbs|w: I'd thought about replying to the big comment from vit
16:27:47 <abadger1999> tibbs|w: We can... what do we want to say, though?
16:27:55 <spot> racor: okay, we'll count you as a +0 on all of the related votes then.
16:28:15 <RemiFedora> about package vs branch, I'm +0, both can work
16:28:15 <geppetto> But our reasoning was in the logs … and I'm busy, so didn't do anything, yet.
16:28:29 <tibbs|w> I was taking the same attitude as racor but I decided that I could at least try to help make things less distasteful when possible.
16:28:30 <abadger1999> Just that we want to officially state that SCLs are ugly hacks and that's what's informing our decisions to keep them separate from mainstream packaging?
16:29:05 <RemiFedora> about droping SCL from mainstream package, I'm -1
16:29:06 <geppetto> abadger1999: yeh, might want to reword that though … unless you want the comments to go a particular place :-o
16:29:12 <RemiFedora> this break all SCL magic
16:29:29 <tibbs|w> One person's magic...
16:29:35 <geppetto> RemiFedora: what do you mean?
16:29:39 <tibbs|w> is another person's... something horrible.
16:30:09 <RemiFedora> if you forbid SCL macro in mainstream, you cannot cherry-pick change in SCL package from main one
16:30:16 <abadger1999> geppetto: the magicness of one spec file that can be built into any number of different packages depending on what packages are in the buildroot.
16:30:17 <RemiFedora> so you "really" have to maintain 2 spec
16:30:26 <geppetto> abadger1999: yeh, but it doesn't break that
16:30:32 <tibbs|w> Which is nothing but a positive in my opinion.
16:31:33 <abadger1999> geppetto: Doesn't it break that if we're saying that mainstream packages cannot contain SCL macros? (Note -- I'm pretty sure remi is talking about the other SCL decision from last week here)
16:31:41 <geppetto> RemiFedora: the problem I see is that you'll have a lot of false confidence … when people are doing changes to the normal package (with a _much_ scarier specfile) they won't also be rebuilding 666 SCLs from it.
16:31:47 <racor> tibbs|w: IMO scls are failing and overly complex approach, but I do not want to stand in the way of its promotors.
16:31:58 * spot doesn't care if non-SCL packages have SCL macros as long as they're not enabled in builds.
16:32:00 <geppetto> RemiFedora: And that almost never happens now (changes to specfile that are untested).
16:32:17 <abadger1999> https://fedorahosted.org/fpc/ticket/339#comment:51  https://fedoraproject.org/wiki/User:Toshio/SCL_Macros_Change
16:32:25 <spot> rough equivalency to conditionalization for non-Fedora/EPEL targets in spec files
16:32:40 <geppetto> abadger1999: The SCL branch can still do that
16:32:43 <spot> don't forbid them, sure don't require them.
16:33:03 <geppetto> abadger1999: where branch == a git branch, or another git repo. … but you know what I mean.
16:33:11 <RemiFedora> should stay a packager choice / freedom
16:33:16 <abadger1999> geppetto: correct.  I think that Remi is registering a vote for both the branch-vs-repo and the scl-macro-separation.
16:33:37 <geppetto> spot: It's similar … but a _huge_ amount more changes, and much more testing required, and not done.
16:33:48 <geppetto> abadger1999: yeh
16:34:31 <spot> geppetto: sure, but if they're not enabled, it _should_ not matter. if i conditionalized a massive amount of hooks for opensuse or RHEL 3 in my spec, it would still pass review.
16:34:48 <spot> might scare off reviewers, but that's the _packager_'s problem.
16:35:14 <abadger1999> spot: And also comaintainers... and provenpackagers who have to fix something in a lot of packages.
16:35:19 <geppetto> I wouldn't mind betting on how many reviewers would just fail you for that
16:35:34 <RemiFedora> don't forget the rule "The spec file for the package MUST be legible."
16:35:37 <abadger1999> spot: and it could also arguably fail the legibility guideline.
16:35:48 <geppetto> if you had suse stuff on the same order as what SCLs require.
16:35:58 <RemiFedora> I remember having to refuse to review  some non-legible specfile
16:36:29 <tibbs|w> But you know it's going to come down to a group of people simply accepting each others packages without really caring about such trivialities as how crappy the packages look.
16:36:37 * spot is going to abstain from claiming that SCL macros make a package illegible. :D
16:36:41 <tibbs|w> I gave up that fight long ago.
16:36:42 <abadger1999> I know we used to have a rule not to include things like conditionals for opensuse but we either discarded that or it was a fedora.us rule that didn't get turned into a written rule in fedora extras.
16:36:59 <spot> abadger1999: the latter.
16:37:13 <abadger1999> anyhow...
16:37:48 <spot> the fact remains that there are a group of packagers who feel that spec files with SCL macros conditionalized off are legible
16:37:58 <abadger1999> #info Recommend to releng to use separate git repos PASSED: (+1:5, 0:3, -1:0) SmootherFrOgZ did not vote.
16:38:15 <spot> assuming that same group is willing to review those packages... do we care?
16:38:47 <abadger1999> #info https://fedoraproject.org/wiki/User:Toshio/SCL_Macros_Change Remi added a -1 vote.  (+1:5, 0:0, -1:1); guideline still passed.
16:39:06 <abadger1999> #action spot contacting licquia about getting fedora registered with LANANA
16:39:21 <spot> i guess we do. put me down as a -1 on that one as well.
16:39:43 <abadger1999> #info https://fedoraproject.org/wiki/User:Toshio/SCL_Macros_Change Remi and spot added a -1 vote.  (+1:5, 0:0, -1:2); guideline still passed.
16:40:01 <spot> not because i don't support separation (i do), but I have no issue with the macros being present but disabled in non-SCL packages.
16:40:10 <abadger1999> spot: Yeah we care -- because it affects more than just the packagers who care about SCLs.
16:40:31 * spot has seen worse than the SCL macros in Fedora
16:40:31 <abadger1999> It affects other people who want to work on putting that upstream software in Fedora.
16:40:50 <abadger1999> Because it affects the spec file for everyone unless we make it so that there's separation.
16:41:15 <abadger1999> anyhow..
16:41:34 <abadger1999> tibbs|w: Is there something concrete we can do about the disconnect or should we move on?
16:41:57 <spot> i think we've beaten this poor, deformed, and dead horse enough for today. it looks like this issue will have to be moderated by a third-party to proceed any further.
16:42:04 <tibbs|w> I I don't really think so.  It seems we're not unanimous, but I'm not sure anyone is going to change.
16:42:54 <geppetto> Well if you are split, then I guess it should be allowed
16:43:02 <geppetto> s/you/we/
16:43:14 <spot> I see no update on ticket 382, so we'll just table it... again.
16:43:32 <spot> #action Tabling 382 (Go Packaging Guidelines)
16:43:50 <geppetto> Because as much as I hate it, it is just a bunch of macros in a specfile … that should be noops.
16:44:53 <spot> geppetto: are you changing your vote? if not, lets move on.
16:46:13 <geppetto> yeh, let's move on
16:46:26 <spot> #topic AppData - https://fedorahosted.org/fpc/ticket/414
16:46:42 <spot> Most of the Fedora licenses are now in the draft for the next SPDX
16:46:50 <spot> SPDX is... kindof a train wreck though.
16:47:09 * spot was going to present on SPDX/Fedora at Flock, but no one wanted to hear it.
16:47:46 <spot> The ideal solution here would be if the verify tool didn't care about the license field validity
16:48:06 <spot> (possibly with an optional flag to ignore license checking)
16:48:17 <abadger1999> <nod>
16:48:34 <spot> barring that, we could not fail the build if it didn't verify, which defeats the point of verifying at all
16:49:11 <spot> i propose we ask richard to add a mode that verifies everything except license
16:49:22 <spot> and if he declines, we know what our options are
16:49:25 <abadger1999> +1
16:49:41 <geppetto> sounds good
16:50:09 <tibbs|w> +1
16:50:43 <RemiFedora> IIRC, appdata-validate already have a "strict" mode, so perhaps no need for a new option
16:50:49 <racor> -1
16:51:29 * spot is +1 on this proposal
16:51:33 <geppetto> racor: what do you want to do instead?
16:51:49 <SmootherFrOgZ> +1
16:52:15 <tibbs|w> I really wish I understood why these files have to carry any kind of license at all.
16:52:49 * spot sees +5 (counting geppetto's "sounds good" as a +1)
16:53:27 <RemiFedora> tibbs|w: me too
16:53:40 <spot> racor: i'd like to document your dissent, is it specific to this request or is it just "appdata is not okay" in general.
16:54:56 <racor> AppData as an optional feature for those packages who support it (In my understanding == Gnome-only) would be OK to me.
16:55:58 <Rathann> racor: it's not GNOME-only
16:56:00 <kalev> racor: KDE's Apper is also going to use appdata.
16:56:16 <racor> Making it mandatory would only be feasible if they can be automatically generated as fallback, but is the stuff which drives away people from Fedora otherwise (workload, overhead, bureaucracy)
16:56:35 <tibbs|w> That was pretty much my position as well.
16:57:15 <racor> kalev: OK, then it's KDE+Gnome - all the rest of the world == lacks generality => Not a wise idea, to mandate
16:57:16 <RemiFedora> doing a lot of support, about installing software, is always end with "open a terminal..."
16:57:58 <RemiFedora> I think we're going in a very strange direction...  with relying on appdata
16:58:15 <spot> okay, so generally opposed to appdata. noted.
16:58:23 <Rathann> it's a kind of chicken and egg problem - lack of appdata hinders its adoption
16:58:24 * abadger1999 notes he talked to nirik and rdieter... nirik was supportive of AppData (upstream xfce seemed receptive) rdieter was not supportive of a MUST (but okay with SHOULD)
16:58:42 <spot> #action request validate option without license check (+1:5, 0:0, -1:0)
16:59:19 <spot> #topic %py3dir not removed by rpmbuild --clean - https://fedorahosted.org/fpc/ticket/435
16:59:24 <Rathann> spot: racor voted -1
16:59:33 <spot> sorry, i noted that properly in the ticket
16:59:37 <spot> #action request validate option without license check (+1:5, 0:0, -1:1)
16:59:37 <racor> Rathann: Do I need to pronounce the common accusations against RH, Fedora and Gnome, probably everybody outside of RH has heard many times?
16:59:38 <Rathann> ok
17:01:09 * spot is looking to see who actually maintains python3 these days
17:02:26 <Rathann> spot: I'm +1 to current https://fedoraproject.org/wiki/User:Rhughes/DraftAppDataGuidelines wording, with the license validation exception as noted by spot
17:02:33 <abadger1999> bkabrda and the python-team
17:04:12 <spot> Is there a macro for "the working topdir of the build" ?
17:04:30 <spot> because then %py3dir could use that to set its custom py3 dir below it
17:04:40 * spot doesn't think there is though
17:05:07 <abadger1999> Yeah, I think there is.  But it has issues too.
17:05:30 <abadger1999> https://bugzilla.redhat.com/show_bug.cgi?id=563622#c10
17:05:54 <abadger1999> (that's not about the presence or absence of a macro -- it's the potential problem)
17:07:06 <spot> hm. it seems odd that a test suite would fail on the existence of an extra directory
17:07:36 <spot> i mean, if we named it "src" or something, maybe
17:07:45 <spot> but with the namespacing...
17:07:50 <abadger1999> spot: it's test discovery.
17:07:58 <abadger1999> So it does (pseudo code)
17:08:06 <Rathann> I've just added my suggestion to that bug
17:08:07 <Rathann> https://bugzilla.redhat.com/show_bug.cgi?id=563622#c11
17:08:10 <spot> abadger1999: it just blindly iterates through every directory below the top-level looking for tests?
17:08:12 <abadger1999> find . -name 'text_*.py' -exec testsuiterunner
17:08:48 <abadger1999> spot: pretty much -- there might be a way to clue it in that somethings really are off limites... I could look at the code.
17:09:02 <RemiFedora> Rathann: this is the solution I use for php extension (duplicate to source tree)
17:09:13 <abadger1999> but there's multiple test runners that have discovery.
17:09:20 <abadger1999> So it would be checking the code for all of them.
17:09:25 <hughsie> spot, i'm happy to make validate-relax not check the licence values at all; i'll get to making the changes tmw
17:09:35 <spot> yeah. a common toplevel empty dir would also resolve this
17:09:39 <spot> hughsie: cool, thanks.
17:10:41 <abadger1999> <nod> that works... of course then things get even more different between pure-python2/python3 packages and mixed python2+python3 packages.
17:11:30 <spot> yeah.
17:11:33 * spot was trying to avoid that
17:11:40 * spot almost doesn't care about --clean. :)
17:12:47 <abadger1999> <nod>
17:13:02 <abadger1999> The %doc is more of a problem.
17:14:12 <abadger1999> I'm not necessarily against that... Just pointing it out as a con.
17:15:12 * spot would defer to the python3 maintainer on how they wanted to solve this
17:15:17 <spot> (if at all)
17:15:38 <spot> abadger1999: LANANA just updated, "fedora" is a valid name now.
17:15:48 <Rathann> I'd actually drop py3dir as a non-generic thing and recommend doing what I just suggested
17:16:08 <abadger1999> Maybe we should table -- there are a couple tickets we need to do for Fedora 21 Changes.
17:16:28 * spot agrees, lets table until we hear from bkabrda
17:16:38 <spot> if someone wanted to email him directly, that would be useful.
17:17:08 <spot> #topic tmpfiles.d - https://fedorahosted.org/fpc/ticket/439
17:17:09 <abadger1999> Rathann: It does seem to handle all the cases... it's just how it interacts with packages which only build a single  python$MAJOR target.
17:17:32 <spot> New draft: https://fedoraproject.org/wiki/User:Toshio/Tmpfiles.d_%28draft%29#Example_spec_file
17:18:18 <abadger1999> Diff: https://fedoraproject.org/w/index.php?title=User%3AToshio%2FTmpfiles.d_%28draft%29&diff=381824&oldid=381816
17:19:01 <spot> Seems sensible to me. +1
17:20:21 <abadger1999> +1
17:20:24 <geppetto> +1
17:20:31 <Rathann> +1
17:20:31 <SmootherFrOgZ> +1
17:20:38 <abadger1999> Oh -- the one question is whether we want to simplify that one portion.  But I guess not  ;-)
17:21:21 <RemiFedora> +1
17:21:30 * spot looks at tibbs|w & racor (if still with us) for votes
17:21:35 <tibbs|w> +1
17:22:17 <spot> #action Draft approved (+1:7, 0:0, -1:0)
17:22:55 <spot> #topic https://fedorahosted.org/fpc/ticket/191 - Recommend Restart=on-failure or on-abnormal
17:23:32 <tibbs|w> Wow, how old is that one?
17:23:34 * spot really doesn't agree with lennart on the logic of "this can't be the default, because these corner cases would not operate properly", thats why corner cases need special settings.
17:23:57 <geppetto> tibbs|w: been reopened
17:24:00 <spot> that said, i have no spirit to go toe to toe with lennart on something of relative unimportance.
17:24:15 <racor> spot: I was reading ... +1
17:24:19 <geppetto> spot: yeh, I don't see why he can't have a different default depending on if it's a one-shot or long running service.
17:24:27 <spot> Proposal: Add lennart's suggested text (comment 22)
17:25:01 <tibbs|w> +1 to the basic concept.
17:25:29 <racor> anyway, it's 19:25 local time, I have to quit.
17:25:30 <spot> +1 to proposal
17:25:35 <spot> racor: thanks for staying so late
17:25:49 <tibbs|w> I think the text is OK so +1 to the whole thing.
17:25:54 <geppetto> I don't see any SHOULD or MUST bits … so it's just systemd documentation?
17:26:01 <spot> geppetto: correct.
17:26:09 <geppetto> I guess I'm +1 then
17:26:18 <Rathann> +1
17:26:24 <SmootherFrOgZ> +1 on recommendation
17:26:26 <abadger1999> +1
17:27:36 <RemiFedora> +1
17:27:54 <spot> #action additional recommendation text around restart values approved (+1:7, 0:0, -1:0)
17:28:09 <spot> I don't see any other items on the official agenda email...
17:28:49 <spot> abadger1999: is there something else blocking a feature we need to address today?
17:28:55 <abadger1999> yeah
17:29:10 <abadger1999> https://fedorahosted.org/fpc/ticket/445
17:29:21 <abadger1999> #topic #445 New Java Packaging Guidelines
17:29:35 <abadger1999> https://fedoraproject.org/w/index.php?title=User%3ASochotni%2FJavaPackagingDraftUpdate&diff=373161&oldid=372467
17:29:43 <abadger1999> This is an update that makes javadocs optional.
17:30:08 <tibbs|w> If that's really it, +1.  Honestly I'd just do it.
17:30:14 * spot is fine with leaving javadoc creation at the packager's discretion
17:30:17 <abadger1999> +1
17:30:19 <spot> +1
17:30:24 <geppetto> sure +1
17:31:01 <Rathann> +1
17:31:14 <RemiFedora> +1
17:31:52 <abadger1999> #action Make javadocs optional approved: (+1:6, 0:0, -1:0)
17:31:58 <abadger1999> #topic #446 Per-product Configuration Draft
17:32:05 <abadger1999> https://fedorahosted.org/fpc/ticket/446
17:32:12 <abadger1999> sgallagh: You're up.
17:32:39 <tibbs|w> Made him wait 90 minutes....
17:32:47 <abadger1999> Yeah :-(
17:33:29 <abadger1999> So geppetto and I have both looked at this.  It doesn't seem totally insane and there is a need for this in a multiple-products world.
17:33:56 <abadger1999> but there's a lot of rules to read to figure out what's happening.
17:34:03 <tibbs|w> " Any package that requires a configuration that differs between Products must obtain permission from that Product's Working Group before packaging it. "
17:34:29 <tibbs|w> Would they have to talk to multiple groups?  Otherwise, which one group would they talk to?
17:34:36 <spot> this level of additional bureaucracy makes my eyes hurt.
17:34:41 <spot> in _every_ package
17:34:55 * sgallagh appears
17:35:16 <tibbs|w> I don't see this as applying to very many packages, honestly.
17:35:17 <sgallagh> spot: Shouldn't be every package
17:35:23 <abadger1999> spot: Only in packages that have different config per-product.
17:35:28 <sgallagh> That line is specifically there to LIMIT it to very few package.
17:35:41 <spot> Do we know what packages this will apply to in f21?
17:35:45 <sgallagh> In other words, you have to have a damn good reason why that Product needs a different default
17:35:47 <geppetto> Yeh, my assumption was that while firewalld is probably a great example … a bunch of things wuld ship the same config. everywhere
17:35:57 <sgallagh> spot: The only one I'm *certain* about is firewalld
17:36:29 <sgallagh> I suspect that Workstation may also want one for PolicyKit
17:36:39 <spot> okay. i misread that part. apologies.
17:36:52 * Rathann has to drop off, sorry
17:37:05 <sgallagh> And jwb mentioned perhaps httpd being different (with WS getting something more attuned to developers and Server/default for deployment)
17:37:40 <spot> worth noting that under this scheme, the default pull on a matching provides will be the shortest one at the beginning of an alpha sort (i think)
17:37:48 <spot> which would be the "config-server"
17:38:12 <sgallagh> spot: Actually "fewest additional deps" would win
17:38:33 <spot> sgallagh: is that behavior identical in yum and doesnotfinish?
17:38:37 <sgallagh> So config-standard will most likely win that, once we've got the deps added to fedora-release-$PRODUCT properly
17:39:03 <sgallagh> spot: That was what I heard from akuzompl, yes
17:39:08 <spot> okay
17:39:38 * sgallagh also notes that this is a stop-gap measure until we have advanced deps in RPM/DNF
17:39:44 <spot> then i guess, +1
17:41:07 <geppetto> If you can convince spot … +1 ;)
17:41:29 <spot> its ugly, but if i'm honest, i'd probably solve it the same way.
17:41:46 <abadger1999> +1
17:41:55 <RemiFedora> I think a line telling "main package must requires foo-config" is missing...
17:42:06 <RemiFedora> (but is in the example)
17:42:08 <RemiFedora> else +1
17:42:26 <sgallagh> RemiFedora: You're correct. I'll add that
17:42:39 <sgallagh> Thanks
17:43:00 <SmootherFrOgZ> +1 as well
17:44:53 <spot> i count +5
17:45:14 <spot> #action Per-product config draft approved (+1:5, 0:0, -1:0)
17:46:53 <spot> any other items for features?
17:47:19 <abadger1999> Not that I know of.
17:47:31 <sgallagh> Thanks, folks.
17:47:34 <spot> #topic New FPC chair
17:47:37 <abadger1999> There's a few followups that weren't put into this week's agenda if we want to get to them.
17:47:46 <spot> as you've surely noticed, my attendance has been poor at best.
17:47:48 <abadger1999> Hmm... this might be more important.
17:48:36 <spot> My new job doesn't leave me a ton of time for Fedora packaging, and honestly, my heart is less and less in it these days with things like SCLs at the forefront.
17:49:06 * spot isn't leaving Fedora, but I'd like to give the "fpc chair" role to someone else on the committee
17:49:44 <spot> and we'll see if i manage to attend enough as a normal member to merit that seat
17:49:56 <spot> anyone want that role? :)
17:50:32 <geppetto> I guess everyone but abadger1999 takes a step back?
17:50:47 * spot is intentionally not forcing the role on anyone.
17:50:59 <RemiFedora> spot: you have raise the level very high for this chair with your work during years ;)
17:51:24 <spot> this task is pretty much thankless to most of Fedora, we just get seen as the people who won't let them do what they want however they want
17:51:31 <spot> but i do think we serve an important role
17:51:46 <abadger1999> So... I can take the role of chair for a month or maybe two.
17:52:07 <abadger1999> but the thanklessness of the SCL work has sapped my will to live as well.
17:52:33 <abadger1999> I'm not sure I want to continue on the committee, much less as chair once we finally get that off our plates.
17:53:19 <abadger1999> A second note would be that spot and I worked together to take care of all the work of writing up guidelines, finalizing drafts that came in incomplete or too poor, sending out announcements, etc...
17:53:47 <abadger1999> I know that one person won't be able to take up all the work that both of us were doing.
17:54:10 <spot> well, we dont have to decide it right now
17:54:19 <spot> just wanted to throw it out there. think about it. :)
17:54:22 <abadger1999> <nod>
17:54:32 <spot> #topic Open Floor
17:54:59 <abadger1999> Question for SmootherFrOgZ or geppetto... do you know what needs to happen to a ticket to tag it for the agenda?
17:55:18 <abadger1999> There's some tickets that seem to slip through the cracks and others that I want to tag back onto the meeting agenda.
17:55:23 <abadger1999> but I'm not sure how/why.
17:55:40 <geppetto> abadger1999: we don't have a great process for getting old tickets back on the agenda
17:56:09 <geppetto> abadger1999: if there are open questions, I leave them on … when I think they are done I drop them, and I add the new ones.
17:56:30 <abadger1999> k
17:56:45 <abadger1999> So I guess just continue to mention them as replies to the meeting agenda email for now?
17:56:51 <SmootherFrOgZ> iirc we a a flag for that
17:56:54 <SmootherFrOgZ> I need to check
17:57:06 <spot> there is some sort of "meeting" state
17:57:07 <SmootherFrOgZ> have*
17:57:16 <SmootherFrOgZ> spot: +1
17:57:22 <abadger1999> SmootherFrOgZ: cool.  If there is we just need to document it and then start using it.
17:57:50 <SmootherFrOgZ> yeah, I'll send out an email with the details and eventually put it on the fpc's wiki
17:58:10 <geppetto> yeh, I'm mostly happy to do anything extra … as long as it doesn't involve opening every ticket or something
17:58:28 <abadger1999> SmootherFrOgZ: thanks
18:02:33 <abadger1999> That's all I have.
18:03:19 <spot> okay, i think we're done for today
18:03:21 <spot> thanks everyone
18:03:24 <spot> #endmeeting