fedora-meeting-1
LOGS
15:10:27 <mitr> #startmeeting Server Working Group Weekly Meeting (2014-07-08)
15:10:27 <zodbot> Meeting started Tue Jul  8 15:10:27 2014 UTC.  The chair is mitr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:10:32 <mitr> #chair sgallagh mizmo nirik davidstrauss stefw adamw simo tuanta mitr
15:10:32 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:10:38 <mitr> #topic roll call
15:10:41 <mitr> Hello
15:10:54 <tuanta> .hellomynameis tuanta
15:10:56 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
15:10:57 * nirik is here, but as usual trying to get stuff started for the day.
15:12:27 <mitr> With adamw and davidstrauss that would seem to be a quorum?
15:12:45 <mitr> #topic Release Media Status and Tasks
15:13:21 <mitr> For my part, fedora-install-server.ks, still fighting the tools
15:13:32 <adamw> .hellomynameis adamwill
15:13:33 <zodbot> adamw: adamwill 'Adam Williamson' <adamw+fedora@happyassassin.net>
15:13:52 <mitr> systemd replacing /etc/resolv.conf with a symlink has broken things left and right (lorax, anaconda post-install, and post-install system)
15:14:31 * danofsatx-work is listening
15:14:32 <mitr> Except for that (i.e. except that anaconda crashes), the kickstart does produce a “working” netinstall image, but that’s really low bar
15:14:51 <nirik> hey, it's pre alpha.
15:15:00 <nirik> :) and thanks for working on it mitr
15:15:00 <mitr> The DVD image doesn’t even boot at this point, I”m looking at that right now.
15:15:25 <mitr> Then, the kickstart can still do with more cleanups (carries all of kde-l10n at this point).
15:16:07 <mitr> AFAIK, we also don't have comps covered (e.g. even though cockpit will be on the DVD it won’t be installed by default)
15:16:24 <mitr> And I don’t know about the fedora-release-$product packages, haven’t been following that conversation in sufficient detail.
15:16:27 * stefw apologizes for tardiness
15:16:28 <mitr> (EOF)
15:17:00 <mitr> nirik: Do you want the work in progress committed now, or after it is in a better shape?
15:17:08 <nirik> I think dgilmore and sgallagh were taalking about the release stuff... but I didn't follow it closely either
15:17:09 <adamw> early and often
15:17:15 <nirik> yeah, go ahead I'd say.
15:17:37 <mitr> OK, pushed.
15:19:21 <nirik> nothing will use it until we point something to use it anyhow.
15:21:17 <davidstrauss> .hellomynameis davidstrauss
15:21:18 <zodbot> davidstrauss: davidstrauss 'David Strauss' <david@davidstrauss.net>
15:21:31 <adamw> so in case anyone missed it on the list, i did a bunch of work on release validation yesterday
15:21:43 <adamw> see https://lists.fedoraproject.org/pipermail/server/2014-July/001361.html
15:21:53 <adamw> it could certainly  benefit from other people taking a look at it
15:23:47 <mitr> The top-level draft criteria they seemed fine to me (though based only on a very cursory read)
15:24:01 <adamw> it would be nice if people could maybe, you know, look at it a bit more than "cursory"
15:24:08 <adamw> since it'll be what decides if we release the product or not...:P
15:24:28 <adamw> those paying close attention may note i fudged the server role issue for alpha; as written it doesn't actually require any server role functionality at all
15:24:57 <adamw> it does encode the firewall configuration and cockpit requirements, though.
15:25:20 <nirik> cool. Thanks for all that work adamw
15:25:29 <adamw> which kind of implicitly requires whatever comps stuff is necessary to give us a forked core install
15:25:52 <adamw> and, of course, requires that the product sort of, you know, exist. :P
15:27:58 <nirik> yeah.
15:29:10 <mitr> So can we collect a list of required/missing deliverables?
15:29:24 <mitr> 1.Finished kickstart
15:29:38 <mitr> 2. Comps updated to include Server packages, some by default
15:30:02 <mitr> 3. rolekit and plugins (not blocking image creation)
15:30:30 <nirik> the stuff for the 2 roles would be in comps?
15:30:55 <nirik> 4. fedora-release-server (or whatever it ends up being)
15:31:07 <mitr> (incl. systemd presets and other things where the configuration differs from other products)
15:31:56 <mitr> nirik: ATM comps has two relevant "environments", web-server and infrastructure-server.  Might make sense to merge them?  I don’t know; and the roles should definitely be seletable in there as groups.
15:32:26 * nirik nods.
15:32:46 <nirik> I guess I'd leave those other ones alone for now... and make new ones for the 2 roles.
15:33:17 <mitr> This is blocked by rolekit anyway, at least for today/this week I guess
15:34:36 <nirik> yeah
15:38:12 <mitr> So… I'm working on 1; sgallagh promised to take a look at 2; twoerner is hacking on 3; do we have anyone owning 4?
15:39:11 <adamw> beta and final release validation work still needs to be done, btw, i suppose i'll wind up doing that too.
15:39:17 <nirik> I think dgilmore/releng wanted to own those
15:40:38 <mitr> adamw: I think I could help with some of the testing if it doesn’t require too much specialized tool knowledge
15:40:53 <mitr> #info Outstanding tasks
15:41:02 <mitr> #info Finish kickstart: mitr
15:41:20 <adamw> mitr: it's the test process design that i'm getting very little help with :/ testing itself i think (or at least i hope) more people will help out on...
15:41:40 <mitr> #info Comps updated to include Server packages, selectable roles: sgallagh?
15:41:55 <mitr> #info rolekit and plugins: twoerner and others
15:42:06 * sgallagh is here now.
15:42:07 <nirik> some of the testing design we may only see needs adjustment when we start using it.
15:42:10 <mitr> #info fedora-release-server: dgilmore/releng
15:42:16 <nirik> (but of course it would be nice not to change things in the middle)
15:42:18 <sgallagh> Sorry, appointment ran very long
15:42:42 <adamw> nirik: yeah, that usually happens.
15:44:13 <mitr> sgallagh: http://meetbot.fedoraproject.org/fedora-meeting-1/2014-07-08/fedora-meeting-1.2014-07-08-15.10.log.txt
15:44:58 <sgallagh> mitr: Thank you
15:47:01 <sgallagh> #action sgallagh to sort out comps changes
15:48:02 <sgallagh> mitr: I think we want to be working with Infrastructure Server
15:48:35 <mitr> sgallagh: oh of course
15:49:25 <sgallagh> What I mean is for right now I'm going to focus on comps changes to Infra Server
15:49:52 <mitr> What I mean is that I should have noticed the direct applicability to our target audience :)
15:50:39 <sgallagh> I think we're in violent agreement and should move on :)
15:52:30 <adamw> NO, I AGREE MORE!!!!
15:52:57 <sgallagh> I still need to work out with dgilmore the creation of the release packages
15:53:13 <sgallagh> Even if we just create some placeholder ones we can start using in Requires:
15:54:04 <stefw> that seems the concrete step towards meeting the change freeze deadline
15:54:22 * sgallagh nods
15:54:35 * adamw really needs to catch up with that discussion
15:56:27 <sgallagh> I'll prep a straw-man patch immediately after the meeting
15:59:45 <sgallagh> #action sgallagh to provide a holdover fedora-release-$PRODUCT patch
16:02:08 <sgallagh> nirik: Are you aware of other issues that we need to solve for the Alpha?
16:02:40 <nirik> I think those are the biggies... we need to be able to compose something we can test. ;)
16:03:14 <sgallagh> OK, so I've got most of those on my plate... that's going to be a bit heavy.
16:03:29 <sgallagh> (Thanks mitr for jumping on the kickstart/compose tests)
16:04:22 <sgallagh> I can't think of anything obvious I can hand off though.
16:04:38 <sgallagh> OK, anything further on this topic, or shall we move on?
16:05:43 <sgallagh> OK, we didn't have anything else on the agenda as far as I am aware
16:05:47 <sgallagh> #topic Open Floor
16:06:01 <sgallagh> Anything for Open Floor?
16:07:02 <adamw> nope.
16:07:02 <danofsatx-work> CentOS 7 was release yesterday...have we had any interaction with their SIG lately?
16:07:30 * danofsatx-work is installing right now to play with it
16:07:30 <sgallagh> danofsatx-work: Not recently, now.
16:07:34 <sgallagh> s/now/no/
16:09:40 <danofsatx-work> ok, just thought I would ask - we're all a bit busy at the moment ;)
16:09:44 <sgallagh> No kidding.
16:09:55 <sgallagh> Ok, I'm going to call the meeting to an end and get to work on those patches.
16:10:04 <sgallagh> Thanks (and sorry I was so late!)
16:10:40 <sgallagh> #endmeeting