fedora-meeting-1
LOGS
14:58:46 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2014-05-06)
14:58:46 <zodbot> Meeting started Tue May  6 14:58:46 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:58:49 <sgallagh> #chair sgallagh mizmo nirik davidstrauss Evolution adamw simo tuanta mitr
14:58:49 <zodbot> Current chairs: Evolution adamw davidstrauss mitr mizmo nirik sgallagh simo tuanta
14:58:55 <adamw> ahoyhoy
14:58:56 <sgallagh> #undo
14:59:01 <sgallagh> #chair sgallagh mizmo nirik davidstrauss adamw simo tuanta mitr
14:59:01 <zodbot> Current chairs: Evolution adamw davidstrauss mitr mizmo nirik sgallagh simo tuanta
14:59:09 <sgallagh> #topic roll call
14:59:23 <sgallagh> Who is around today?
14:59:42 <davidstrauss> I am
14:59:44 <danofsatx-work> here
14:59:59 * mizmo_afk here
15:00:02 * tuanta is here
15:00:03 <simo> simo: here
15:00:13 <sgallagh> nirik is on a well-deserved vacation, IIRC
15:00:40 <mitr> Hello
15:01:12 * masta lurks
15:01:27 <sgallagh> Ok, so let's proceed
15:01:32 <sgallagh> #topic agenda
15:01:39 <sgallagh> #info Agenda Item: New WG Members
15:01:42 <sgallagh> #info Agenda Item: Server Role API Discussion
15:01:53 <sgallagh> Any other agenda items I missed?
15:02:37 <adamw> not here
15:02:54 * sgallagh will take that as a "no"
15:02:58 <sgallagh> #topic New WG Members
15:03:25 <sgallagh> So we need to fill a missing chair on the WG and we have three self-nominated candidates.
15:03:41 <sgallagh> adamw: hmm?
15:03:58 <sgallagh> #info Dan Mossor: https://lists.fedoraproject.org/pipermail/server/2014-April/001094.html
15:04:05 <sgallagh> #info Stef Walter: https://lists.fedoraproject.org/pipermail/server/2014-April/001091.html
15:04:11 <sgallagh> #info Thomas Woerner: https://lists.fedoraproject.org/pipermail/server/2014-May/001102.html
15:05:06 <sgallagh> Having not faced a situation previously where we had more candidates than seats, we should decide how best to proceed.
15:05:42 <simo> sgallagh: hard to decide :)
15:05:50 <sgallagh> Our charter requires majority consensus to fill a seat
15:05:55 <davidstrauss> Presumably, we vote here and forward a choice to FESCo?
15:05:57 <mizmo> these are three very strong candidates
15:06:05 <sgallagh> davidstrauss: FESCo isn't involved here
15:06:14 <tuanta> So hard :)
15:06:34 <simo> ok as a first observation I can say that stef and twoerner kind of overlap in experience and background
15:06:53 <simo> so may be we can simplify the choice by using binary exclusion
15:07:01 <simo> ie we put people in this tree
15:07:01 <sgallagh> stefw, twoerner, danofsatx-work: I would also like to reiterate that, regardless of a voting seat, you are all encouraged to continue participating in our SIG and meetings
15:07:10 <stefw> certainly
15:07:15 <twoerner> sgallagh: sure
15:07:20 <simo> top - ((Dan), (Stef, Thomas))
15:07:21 <adamw> i'd be inclined to pick danofsatx, on the basis he's a solid non-RH candidate: there seems to be a degree of discontent about fedora.next being overly RH-driven. and it'd be nice to have another person representing the target user base of the product rather than another person likely to be involved in building it.
15:07:56 <davidstrauss> My pick is Stef
15:07:57 <mizmo> we are very RH-employee heavy right now
15:08:02 <simo> adamw: that was one of my considerations too
15:08:19 <sgallagh> adamw: I was writing something similar; Jim Perrin was originally chosen to represent the needs of downstream. It might be sensible to pick someone else who represents a consumer rather than a producer.
15:08:24 <mitr> Yeah, pragmatically (cynically?) people who are going to participate in any case don't so much need the mild encouragement of a regularly scheduled meeting
15:08:27 <simo> but I was more atracted by the non-pure-engineer aspect
15:08:29 <tuanta> +1 mizmo
15:08:36 <adamw> mitr: point
15:08:46 <simo> because too many of us are already sw engineers involved in server software
15:09:24 <simo> tbh I would welcome them all
15:09:28 <mitr> That said, about everyone has experience with UNIX-style servers, and having a very visible voice from Stef, involved in an explicitly not-old-UNIX GUI, would also be valuable
15:09:42 <sgallagh> simo: Agreed. I wouldn't say "no" to any of these candidates.
15:09:45 <simo> but the wg seat is only about steering not necessarily doing
15:10:01 <simo> hopefully the engineers will have their voice anyway by *doing*
15:10:26 <simo> so I think in the end I would agree with adamw for a variety of reason mostly to do with diversity of the group
15:11:21 <sgallagh> Given the choice, I think I'd rather have steering weighted towards user concerns rather than engineering ones.
15:12:18 <davidstrauss> Dan's perspective on user concerns is very different from mine.
15:12:29 <davidstrauss> He's the "pet" perspective.
15:12:37 <mizmo> davidstrauss, what do you mean by pet perspective
15:12:43 <davidstrauss> To my "livestock."
15:12:52 <mizmo> ahhhh
15:13:34 <masta> the pets&cattle meme
15:14:25 <mizmo> is anybody not comfortable voting on a choice right now?
15:14:38 <davidstrauss> Tools like Roles are actually more for pet keepers than livestock keepers.
15:14:50 <sgallagh> I'd ideally like to seek consensus on a choice here.
15:15:10 <sgallagh> So I'd prefer to start with "Does anyone want to recommend *against* a particular candidate?"
15:15:19 <davidstrauss> So, I'll motion to appoint danofsatx.
15:15:21 <davidstrauss> Oh
15:15:24 <davidstrauss> nvm
15:15:34 <sgallagh> davidstrauss: We could do that too
15:15:39 <mizmo> i think they are all great candidates, so for me it's more, which way do we want to go
15:15:47 <simo> I vote against the "pet&cattle" meme, I really hate that ...
15:15:52 <mizmo> it sounds like we may be leaning towards having a more full complement of user input
15:15:54 <sgallagh> As I said, my ideal state is that we have consensus.
15:16:03 * adamw not strongly against anyone
15:16:20 <mizmo> does everybody have a choice in mind at this point or is anybody still struggling to choose
15:16:32 <simo> sgallagh: I find it hard to get consesus about picking one in my own brain
15:16:39 <davidstrauss> I think the views of the other two (not Dan) will get represented regardless of our decision.
15:16:43 <simo> hopefully will be easier for others
15:16:44 <sgallagh> simo: Fair enough
15:16:55 <mizmo> also evolution left right? why did he leave? lack of time?
15:17:01 <sgallagh> mizmo: Lack of time, yes
15:17:07 <mizmo> how is the time availability for the current candidates
15:17:54 <tuanta> I think they nominated themselves
15:17:56 <mizmo> danofsatx-work, stefw, twoerner - do you guys think you'll have sufficient time to commit to this?
15:18:13 <mizmo> eg following the threads on the list and this meeting weekly
15:18:26 <stefw> in my case i'm working on cockpit, and trying to deliver it for fedora 21, and i've checked with my manager about spending time on the WG
15:18:29 <stefw> so that's a yes.
15:18:29 <sgallagh> Good point. The candidates should be aware that the commitment isn't just the hour a week for the meeting. It may include research and other involvement
15:19:34 * stefw agrees with the points about having sysadmins properly represented in the WG
15:19:37 <twoerner> I will also have time for the server WG
15:19:44 <twoerner> I also spoke with my manager about this
15:20:16 <sgallagh> danofsatx-work: Can you confirm as well?
15:20:43 <simo> yeah time is fundamental, if there is no commitment I that should be an exclusion cirteria
15:21:07 <simo> proposal: if there is no explicit time commitment the candidate will be excluded
15:21:28 <mizmo> well and to be fair we should make clear the time commitment required, which can be sometimes quite high depending on the volume of list threads
15:21:56 <sgallagh> I'm not sure we need to enshrine this in policy.
15:22:11 <sgallagh> I trust that people who discover they don't have time will do as Jim did and voluntarily vacate the position
15:22:32 <davidstrauss> danofsatx-work: Still here?
15:22:32 <simo> mizmo: well I would say no less than 2 hours a week but be available occasionally for more, depending on task assignment
15:22:47 <simo> 1 hour is the meeting
15:22:59 <simo> 1 hour to be up to date with mailing list, meeting notes etc
15:23:13 <simo> more as needed but not required necessarily every week
15:24:35 <sgallagh> I think we may need to assume that danofsatx-work does not meet the time requirements if he is unable to participate in his own nomination :-/
15:24:45 * mizmo now you see how tricky mizmo is :)
15:24:47 <davidstrauss> sgallagh: Agreed
15:25:10 <adamw> unfortunate, but yeah, it seems to be a concern.
15:25:19 <mizmo> there isn't anybody working on cockpit currently in the wg now right
15:25:31 <davidstrauss> My second choice is stefw, mostly because I think Cockpit is more germane to our current work than firewalld.
15:25:51 <sgallagh> mizmo: Not directly, no
15:26:11 <stefw> until sgallagh starts contributing to cockpit :P
15:26:23 <simo> oh man
15:26:24 <sgallagh> stefw: I have three patches contributed!
15:26:25 <adamw> i'd be OK with that
15:26:34 <simo> it choosing Dan would have made things easier
15:26:36 <sgallagh> Granted they're all trivial...
15:26:36 <stefw> sgallagh, i stand corrected :D
15:26:50 <simo> now we need to choose between the rock and the hard place :-D
15:27:10 * davidstrauss nominates the rock.
15:27:23 <sgallagh> For the sake of translation, which one is the rock? :)
15:27:34 <tuanta> :)
15:28:00 <mizmo> i think twoerner and stefw are both great :(
15:28:08 <sgallagh> #info danofsatx-work has been disqualified from nomination due to inability to meet the time requirements.
15:28:57 <mizmo> eenie meenie minie mo
15:29:04 <sgallagh> I do as well. Personal bias leads me to recommend stefw slightly over twoerner. This is entirely due to my having worked with stefw in the past.
15:29:49 <simo> ok can we have a deathmatch or some gladiator style selection process ?
15:29:49 <mitr> I hope that both will be deeply involved in any case, but I do want to have the GUI / interactive behavior concerns with an extra strong voice.  So I'd prefer Stef.
15:30:07 * adamw votes for a gladiatorial contest
15:30:12 <mizmo> cage fight
15:30:18 <sgallagh> Tux Racer?
15:30:20 <mizmo> bzflag deathmath?
15:30:22 <tuanta> I will use a coin
15:30:24 <mitr> simo: No loosing arms, we hope to receive patches from both
15:30:24 <mizmo> er deathmatch
15:30:27 <twoerner> lol
15:30:29 <mizmo> altho deathmath sounds good too
15:30:35 <sgallagh> hehehe
15:30:38 <davidstrauss> More seriously, I motion for stefw to fill the vacant seat.
15:30:50 <sgallagh> davidstrauss: +1
15:30:56 <mitr> +1
15:31:02 <mizmo> neither is a bad choice, +1
15:31:03 <tuanta> +1
15:31:14 <simo> ok I'll chip in, I'll go with Stef as he was proactive and nominated himself even before we officially looked out, he demonstrated extreme attention to the WG
15:31:25 <adamw> +1
15:31:25 <simo> +1
15:32:02 <mitr> stefw: contgratulations on your new burden :)
15:32:03 <sgallagh> I count +7 (all attending members)
15:32:09 * mizmo updates wiki
15:32:13 <stefw> mitr, oh my. thanks
15:32:26 <sgallagh> #agreed stefw (Stef Walter) is selected to serve on the Fedora Server Working Group
15:32:33 <twoerner> stefw: grats
15:32:37 <stefw> thanks
15:32:40 <sgallagh> Welcome aboard, stefw!
15:32:46 <sgallagh> #chair stefw
15:32:46 <zodbot> Current chairs: Evolution adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:32:48 <adamw> hi stefw!
15:32:53 <sgallagh> #unchair Evolution
15:32:53 <zodbot> Current chairs: adamw davidstrauss mitr mizmo nirik sgallagh simo stefw tuanta
15:32:58 <masta> congrats stefw
15:33:21 <tuanta> Congrats stefw.
15:33:28 <sgallagh> #topic Server Role API Discussion
15:33:59 <davidstrauss> I'd like to emphasize our continued invitation for twoerner to continue participating.
15:34:02 <sgallagh> twoerner and I continued discussing this a bit on Friday last week
15:34:14 <stefw> if another solid contributor does show up to help balance the redhatness of the WG, i'd be happy to swap out
15:34:23 <sgallagh> davidstrauss: And danofsatx-work as well, whenever he is able
15:34:29 <davidstrauss> Yes
15:34:53 <sgallagh> #undo
15:34:53 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x13554d90>
15:35:11 <sgallagh> #info The Server WG thanks all candidates and hopes they will continue to participate
15:35:15 <sgallagh> #topic Server Role API Discussion
15:35:35 <danofsatx-work> sorry got called into a meeting here :)
15:35:38 <sgallagh> twoerner: So where are we at this point?
15:35:38 <danofsatx-work> er, :(
15:37:00 <sgallagh> twoerner: Specifically, what open questions do we have left?
15:37:19 <twoerner> sgallagh: I still have some open questions.. :-)
15:37:28 * stefw notes that twoerner and i discussed a bit about how cockpit might (initially) use the API
15:37:45 <sgallagh> #info  twoerner and stefw have discussed a bit about how cockpit might (initially) use the API
15:37:57 <twoerner> sgallagh: but at first I think it would be good to collect all things the API and a role shoud/could do
15:38:05 <simo> danofsatx-work: sorry, we had too choose, and it was a very hard choice to make, we would welcome any contribution you can keep making though
15:38:17 <danofsatx-work> i understand
15:39:43 <mitr> So what can and should we solve about this API here?
15:39:48 <sgallagh> I started a piratepad for requiresments at https://www.piratepad.ca/p/ServerRoleRequirements
15:39:59 <twoerner> sgallagh: and aditionally a schedule for the parts and the whole thing
15:40:42 <stefw> cockpit will likely handle installation of a server role in a non-generic manner
15:40:43 <mitr> (As an aside, IMHO it would be generally beneficial to hold most of the conversation, or at least to record results of personal conversations, on the mailing list; IRC is great for clarifications of misunderstandings but random IRC chats over the week are difficult for people with incompatible schedules to follow)
15:40:47 <davidstrauss> How generically is Cockpit wrapping DBus APIs?
15:41:02 <stefw> davidstrauss, very generically, we can (now) talk to any system service
15:41:10 <stefw> even ones that are pretty ugly like NetworkManager
15:41:22 <stefw> cockpit will likely handle status of a server role in a generic manner
15:41:46 <davidstrauss> stefw: So the client connects to the API as a proxy to send, say, native systemd DBus requests?
15:41:47 <stefw> sgallagh, should i add the sort of status things cockpit would like to inquire about installed roles ... to the piratpad?
15:41:52 <mitr> sgallagh: Most of those "must be able to indicate" should also include "... and act on it", e.g. the "install a working role" call.
15:41:56 <sgallagh> stefw: please do
15:41:59 <stefw> davidstrauss, yes, via cockpit-agent
15:42:44 <sgallagh> mitr: +1 Feel free to edit the pad
15:42:50 <sgallagh> #url https://www.piratepad.ca/p/ServerRoleRequirements
15:42:57 <stefw> davidstrauss, https://raw.githubusercontent.com/cockpit-project/cockpit/master/doc/cockpit-transport.png
15:44:16 * davidstrauss added a proposed API for config file listing
15:45:32 <sgallagh> Sidebar: does 'rpm -ql' have a mechanism for listing %config entries only?
15:45:46 <mitr> sgallagh: -qlc
15:45:54 <sgallagh> mitr: Good to know, thanks
15:47:55 <davidstrauss> Back when I worked on bcfg2, we used that mechanism to audit our way to 100% classification of config files into (1) defaults, (2) desired changes to defaults, and (3) extra, desired files
15:48:03 <stefw> in general i would say that any configuration and or installation apis should be specific to the role.
15:48:08 <sgallagh> For the sake of not scaring twoerner away, can we agree that all NTH items are post-F21 work?
15:48:20 <davidstrauss> sgallagh: Sure
15:48:32 <mitr> stefw: for config, do you mean "specific to the role but using that D-Bus service", or "a completely separate role-specific implementation not even necessarily using D-Bus"?
15:48:37 <twoerner> sgallagh: this is the next question on my list.. :-)
15:49:00 <stefw> mitr, as far as cockpit is concerned it's either one
15:49:17 <stefw> but i understand that option a) would be easier for both a command line tool *and* cockpit to make use of
15:49:22 <stefw> at least that's the impression i got
15:49:37 <mitr> stefw: Fair.  From the command-line/automation POV having a single "kickstart-like" format (with role-specific items) would be desirable
15:49:37 <sgallagh> stefw: I was just typing exactly that
15:49:43 <davidstrauss> My additions aren't really server-role centric
15:50:24 <davidstrauss> But they'd be useful for maintaining installed roles
15:50:31 <stefw> anyway, my point is merely that the installation and configuration apis for the freeipa role and the database role are very distinct
15:50:53 <stefw> whereas the ongoing status, backup, monitoring, upgrade are served well by a generic api
15:51:04 <sgallagh> stefw: Yes, absolutely
15:51:09 <stefw> this generic api should be able to handle roles in containers
15:51:18 <stefw> but that's not a big leap ... just stating the obvious
15:52:03 <davidstrauss> stefw: +1
15:54:22 * davidstrauss has to head off.
15:54:46 <sgallagh> Can we move the openlmi question in the piratepad back here?
15:54:57 <stefw> o/
15:55:10 <sgallagh> What, specifically, is the concern?
15:55:10 <stefw> so openlmi providers exit when not in use (after a timeout)
15:55:16 * tuanta got FAmSCo meeting in next five minutes
15:55:26 <sgallagh> Yes, unless they have active indications registered
15:55:31 <sgallagh> (Same as my comment about D-BUS signals)
15:55:35 <stefw> nod
15:55:41 <twoerner> ok, that is ok
15:56:02 <sgallagh> The master Pegasus process does not yet also terminate, but that's in progress
15:56:07 <sgallagh> (Currently under review upstream, IIRC)
15:56:10 <mitr> I think that exiting when not in use is nice-to-have but not at all a "must" and IMHO not even a priority.
15:56:21 <stefw> twoerner, storaged has a solid race-free implementation of dbus services exiting when not in use.
15:56:27 <stefw> the realmd one is a bit more complex.
15:56:46 <stefw> if you want i'd be happy to document how it works.
15:57:03 <stefw> mitr, i disagree
15:57:05 <stefw> these are servers
15:57:06 <twoerner> stefw: sure, that would be good
15:57:13 <stefw> they're not here to be configured, but are here to do the work tehy've been configured to do.
15:57:19 <sgallagh> It's also easier to do this right at the start than change it later.
15:57:25 <mitr> stefw: what's the impact?  A few megabytes in swap space?
15:57:30 <sgallagh> "Shut down when not in use" is a fundamental design decision
15:57:34 <stefw> mitr, adoption
15:57:37 <stefw> adoption of fedora server
15:58:04 <sgallagh> mitr: For reference, when I gave the Summit talk on OpenLMI, the first question we received was "Does this require a daemon running all the time?"
15:58:05 <stefw> many people are already having a hard enough time seeing all the daemons we're running
15:58:11 <sgallagh> Real users don't like that.
15:58:22 <mitr> OK; I don't think it's that important (people who really care won't be using the generalized roles) but I can see the case.
15:58:23 <stefw> especially since this daemon essentially does configuration that a tool could do.
15:58:33 <stefw> obviously the dbus api is a nice structured way of accomplishing it.
15:58:40 <mizmo> guys i gotta go, i have a 12pm meeting
15:58:50 <twoerner> I have to leave in 2 mins also
15:59:07 <sgallagh> Ok, we can't really continue without twoerner here, so shall we adjourn for today?
15:59:15 <sgallagh> #topic Open Floor
15:59:23 <sgallagh> Anything quick for Open Floor?
15:59:39 * stefw is making some effort to make polkit and dbus services usable by non-console users
15:59:40 <mitr> I'd just like to repeat my plea to have the API discussion more on-list.
15:59:44 <danofsatx-work> I would like to apologize for getting pulled away. It was unavoidable at that point in time.
15:59:56 * danofsatx-work congratulates stefw
16:00:27 <sgallagh> mitr: Agreed.
16:00:36 <stefw> thanks danofsatx-work, hope to see you around, and looking forward to your insight/angle on fedora server
16:00:49 <danofsatx-work> I'll be here ;)
16:00:51 <adamw> nothing from me
16:00:53 <sgallagh> twoerner: Please ask further questions by email and we'll use the piratepad for capturing the results
16:01:32 <twoerner> sgallagh: ok
16:01:34 <twoerner> will do
16:01:46 <sgallagh> Thank you all for coming
16:01:48 <sgallagh> #endmeeting