fpc
LOGS
16:01:41 <abadger1999> #startmeeting fpc
16:01:41 <zodbot_> Meeting started Thu May  1 16:01:41 2014 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:41 <zodbot_> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:46 <abadger1999> #meetingname fpc
16:01:46 <zodbot_> The meeting name has been set to 'fpc'
16:01:58 <abadger1999> #topic Roll Call
16:01:59 <abadger1999> Who's here?
16:02:05 * geppetto is here
16:02:27 <abadger1999> #chair geppetto
16:02:27 <zodbot_> Current chairs: abadger1999 geppetto
16:02:51 <abadger1999> spot, tibbs, limburgher, SmootherFrOgZ: FPC ping
16:03:31 * limburgher is hereish
16:03:39 <abadger1999> geppetto: how'd things go while I was on vacation?
16:03:42 <abadger1999> #chair limburgher
16:03:42 <zodbot_> Current chairs: abadger1999 geppetto limburgher
16:04:52 <geppetto> abadger1999: not great … nirik complained because we only had quorom 1 of the 3 weeks
16:05:03 <abadger1999> <nod>
16:05:06 <geppetto> abadger1999: I think I managed to run it ok for the week it ran though
16:05:27 <abadger1999> geppetto: Sometimes it's good to discuss things in the meeting and then call for additional votes in ticket.
16:05:52 <geppetto> yeh, we ended up doing that on the quorum week too … when people dropped out :)
16:06:01 <abadger1999> Cool.
16:06:08 <geppetto> hence the 3 or 4 tickets with +4
16:06:26 <abadger1999> k
16:07:07 <abadger1999> Maybe we should start posting a list of tickets that are pending votes to the packaging list every week or sending out email to FPC members specifically.
16:07:08 <geppetto> abadger1999: you spoken to spot recently?
16:07:15 <abadger1999> geppetto: I spoke to him at pycon.
16:07:27 <abadger1999> It seems that he's currently just double booked for travel.
16:07:33 * geppetto nods
16:07:58 <geppetto> I know his FB updates are all about traveling
16:08:02 <abadger1999> Because he's got commitments to attend conferences from his old Fedora Eng role and new commitments from his OSAS role.
16:08:12 <geppetto> ahh
16:09:10 <abadger1999> as time goes on, that will go down since he won't be taking on new fedora eng conferences.
16:09:16 <abadger1999> tibbs|w: Greetings
16:09:24 <tibbs|w> Sorry, folks; bad morning.
16:09:25 <abadger1999> #chair tibbs|w
16:09:25 <zodbot_> Current chairs: abadger1999 geppetto limburgher tibbs|w
16:10:23 <abadger1999> #info spot is currently double booked for travel due to having both old-job and new-job commitments.  Will be more present in the future.
16:11:19 <abadger1999> Well that's four and it doesn't look like we'll get more today.
16:11:29 * abadger1999 looks for tickets we can discuss.
16:11:48 <abadger1999> SCLs is what I'm going to pick up again now that I'm back from vacation
16:11:58 <abadger1999> Go lang, I'll ping the ticket for an update from vbatts
16:12:05 <geppetto> can you wait a week on SCLs
16:12:43 <abadger1999> geppetto: meaning, discuss it again two weeks from now?
16:13:59 <geppetto> one week might be fine
16:14:33 <geppetto> just that I'm pretty close to having my first SCL go public, and another week shouldn't hurt
16:14:52 <abadger1999> geppetto: Okay.
16:17:08 <abadger1999> FOX bundling: https://fedorahosted.org/fpc/ticket/400  Looks like someone needs to comment on how that would work.  Does anyone remember what precedent we have?
16:17:36 <abadger1999> I know there's a few libraries that we've done this but I can't remember off hand.
16:18:46 <abadger1999> Alright.. I'll try to do some research into that.
16:18:59 <abadger1999> #topic #407     Bundled lib exception request (copylibs) for sha1
16:19:06 <abadger1999> This one passed.
16:19:17 <abadger1999> #topic #408     Temporary jquery bundling exception for libserialport
16:20:30 <abadger1999> This one also passed
16:20:57 <abadger1999> #topic #416     Temporary bundling exception for ipython
16:21:04 <abadger1999> https://fedorahosted.org/fpc/ticket/416
16:22:10 <abadger1999> If I recall this one got some votes at the meeting?
16:22:38 <tibbs|w> Yeah, I thought we voted on it.
16:23:11 <abadger1999> Remi, geppetto, tibbs|w, SmootherFrOgZ, and Rathann in ticket voted for a temporary exception.
16:23:13 <abadger1999> That's 5.
16:23:20 <abadger1999> Some questions though:
16:23:24 <abadger1999> What's the time frame?
16:23:27 <tibbs|w> I concur from reading the logs.
16:23:33 <tibbs|w> Well, it's javascript.
16:23:47 <abadger1999> If the timeframe is "When the javascript libraries are in fedora", do we need to make sure someone is working on those particular libraries?
16:24:09 <tibbs|w> Honestly I'm not sure that's entirely reasonable.
16:24:17 <abadger1999> (For jquery, we have jamielinux and patches working on it -- but I don't know if they're also working on random other js libraries)
16:24:59 <tibbs|w> I think the smart thing is to do jquery, then see how that goes, then make a hit list of other stuff that needs unbundling and see if anyone wants to deal with it.
16:25:22 <tibbs|w> Making the hit list should be easy if we have bundled(whatever) tags all set up for packages which bundle javascript.
16:25:50 <tibbs|w> Just getting all of those actually set up for the existing packages which bundle would be enough effort.
16:26:06 <abadger1999> <nod>
16:29:26 <abadger1999> okay -- so something like "jquery temporary exception lasts until the release that jquery enters the repository.  For now, plan on temporary exception for other libraries will expire one release after jquery unbundling has entered the repository.   Lessons from the jquery unbundling may lead us to change that time frame as it is our proof of concept of how to unbundle.  Please use the following virtual provides: [...]"
16:29:55 <abadger1999> Does that look good to everyone?
16:30:53 <tibbs|w> Seems reasonable.
16:31:51 <abadger1999> #info Temporary bundling of javascript libraries in ipython passed previously (+1:5, 0:0, -1:0).  Timeframe relative to jquery unbundling has been added.
16:32:10 <abadger1999> #undo
16:32:10 <zodbot_> Removing item from minutes: INFO by abadger1999 at 16:31:51 : Temporary bundling of javascript libraries in ipython passed previously (+1:5, 0:0, -1:0).  Timeframe relative to jquery unbundling has been added.
16:32:16 <abadger1999> #info Temporary bundling of javascript libraries in ipython passed previously (+1:5, 0:0, -1:1).  Timeframe relative to jquery unbundling has been added.
16:32:22 * abadger1999 forgot racor's vote in ticket
16:32:35 <abadger1999> #topic #420     PHP Guidelines change - numeric prefix
16:32:41 <abadger1999> https://fedorahosted.org/fpc/ticket/420
16:33:10 <abadger1999> This was approved with a final +1 in the ticket as well.
16:33:35 <abadger1999> #topic #411     proposal: migrate license files to %license instead of %doc
16:33:40 <abadger1999> https://fedorahosted.org/fpc/ticket/411
16:34:39 <abadger1999> So far in ticket we have one +1 and one -1
16:35:51 <geppetto> I'm +1
16:36:16 <geppetto> I think ralf underestimates how big the sizes are here
16:36:58 <limburgher> I'm. . . .+1
16:38:16 <abadger1999> tibbs|w: If you care to vote I can ask for the remaining vote in ticket (judging from spot's willingness to work on it, I think that he could be the 5th +1 there).
16:38:23 <tibbs|w> +1 from me.
16:38:35 <tibbs|w> We've wanted this for a long time.
16:39:14 <abadger1999> #info Vote on migrate license files to %license currently at (+1:4, 0:0, -1:1)  Will seek remaining vote in ticket.
16:39:29 <abadger1999> #topic #413     Bundling exception request for nodejs-shelljs
16:41:18 <geppetto> I guess +1 with all the other JS stuff.
16:41:27 <tibbs|w> This seems like way more than plain bundling anyway.
16:41:42 <tibbs|w> Take a little bit of code, add a bunch of stuff to is.
16:41:43 <tibbs|w> it
16:42:09 <limburgher> Looks forky.
16:42:23 <abadger1999> <nod>
16:42:28 * abadger1999 agrees it looks forky.
16:43:04 <abadger1999> I think this is okay as a fork, no need to mark it as a bundle.
16:43:40 <limburgher> Glad they asked, though.
16:44:05 <abadger1999> Proposal: these uses are forks.  No need to mark it as a bundled library.  Kudos for asking us to look at this
16:44:10 <abadger1999> +1
16:44:14 <limburgher> +1
16:44:46 <abadger1999> tibbs|w: are you officially a +1 as well?
16:44:57 <tibbs|w> Sorry, yeah, +1.
16:45:19 <geppetto> +1
16:45:48 <abadger1999> #info Proposal: nodejs-shell's use of wrench.js code are considered forks.  No need to mark it as a bundled library.  Kudos for asking us to look at this Currently at: (+1:4, 0:0, -1:0) Will seek remaining vote in ticket.
16:47:54 <abadger1999> Since we're closing in on an hour,  I'm going to skip to the ruby scl for a moment:
16:48:07 <abadger1999> #topic #419     ruby193 in SCL
16:48:13 <abadger1999> https://fedorahosted.org/fpc/ticket/419
16:48:19 <abadger1999> This is needed for a fedora change.
16:49:23 <abadger1999> This is the first set of scls that we're going to be approving.
16:49:53 <abadger1999> So we'll need to evaluate it based on: https://fedoraproject.org/wiki/User:Toshio/SCL_Guidelines_(draft)#SCL_Approval
16:50:09 * geppetto nods
16:50:30 <tibbs|w> For some reason I read that you were going to skip the ruby scl and was overjoyed.
16:52:02 <abadger1999> I've got some nits on the Requests (package naming, compat guarantee should be more formal) but I think all three of the proposed scls fit the criteria.
16:52:49 <abadger1999> Does anyone have anything they want to bring up about them right now?
16:54:22 <abadger1999> Okay, cool.  I'll see where we are with overall scl guidelines next week but we can probably vote on these scls going in prior ot the scl guidelines being finalized.
16:54:48 <abadger1999> So maybe next week.
16:55:03 <abadger1999> #topic #414     Please consider requiring AppData for all desktop applications
16:55:07 <abadger1999> https://fedorahosted.org/fpc/ticket/414
16:56:48 <geppetto> meh.
16:57:10 <abadger1999> yeah, I'm on the fence here.
16:57:48 <limburgher> I packages an NCURSES app that runs in a terminal but has a .desktop file.  Would it need AppData?
16:58:00 <abadger1999> limburgher: yes.
16:58:21 <geppetto> My understanding was that Richard only cared about GUI "apps"
16:58:22 <abadger1999> but -- the consequence of not having it appears to be that the gnome software center wouldn't show it.
16:58:37 <abadger1999> so I'm not certain that richard cares :-)
16:59:09 <tibbs|w> Even aside from the difficult question of "what's a desktop app" I just don't see why people who care wouldn't be welcome to provide these, but demanding packagers create them seems tough.
16:59:35 <limburgher> I'm not against AppData, but it's a non-trivial effort.
16:59:53 <tibbs|w> Of course it's horrible XML.  Maybe if someone whipped up a web app that generated the file so packagers wouldn't have to care so much.
16:59:55 <geppetto> Yeh, you'd think that "displaying better in gnome-software" would be it's own reward
17:00:18 <tibbs|w> I don't know; I've never used gnome-software or whatever it is and could not possibly care less.
17:00:36 <abadger1999> We do have a requirement that gui apps ship a .desktop file.
17:00:40 <abadger1999> that's from the fedora.us days.
17:00:42 <geppetto> On the other side, it sure feels like gnome-software could try a whole lot harder than "use appdata, or revert to just LANG=C name"
17:01:06 <abadger1999> https://fedoraproject.org/wiki/Packaging:Guidelines#Desktop_files
17:01:30 <limburgher> Yeah, providing a poor experience to apps that don't play along seems. . .pouty.
17:01:51 <geppetto> yeh, although to be fair: those files are much easier … and were a significant std. with multiple implementations
17:01:59 <abadger1999> <nod>
17:02:06 <tibbs|w> Most people seem to take that guideline as "if you want it to show up in the menus, you know you need to include a .desktop file, right?"
17:02:15 <tibbs|w> Which is kind of the point.
17:02:50 <geppetto> In that vein I'm happy for something like "if you want it to show up in gnome-software, you need to provide app. data"
17:02:55 <abadger1999> yeah -- so maybe we should make that clearer in the .desktop file guideline and then write the AppData guideline to be similar?
17:02:58 <limburgher> And I have no problem with that, but couldn't it default to if no AppData, show something from .desktop?  Or does it do that?  Again, I don't use it.
17:03:34 <abadger1999> limburgher: I think it currently does but rhughes wants to change that?  (That's how I read his initial ticket description)
17:04:19 <tibbs|w> I guess there's a valid question in there somewhere about how many different types of metadata we have to haul around to describe the same thing.
17:04:44 <limburgher> I guess it comes down to your definition of "poor user experience", a terse description, or only showing a tiny fraction of available software.
17:06:42 <abadger1999> limburgher: I'm wondering if those questions are really fesco decisions?  (Whether to force some piece of software in fedora to provide a specific experience).
17:07:01 <limburgher> abadger1999:  Quite possibly.
17:07:20 <limburgher> FESCO is usually "do this", FPC is "do it this way"
17:07:21 <rdieter> abadger1999: +1 (even though I traded in my fpc awhile back)
17:07:31 <rdieter> my fpc hat, that is
17:09:11 <rdieter> abadger1999: but, perhaps fesco going along with it as a good idea may be assumed as a given
17:09:12 <mbooth> FWIW, as a mere packager I agree with tibbs|w assessment that it should more like the desktop file guideline
17:09:16 <tibbs|w> Aargh, I keep typing long things and deleting them because they don't really reflect what I want to say.
17:09:38 <tibbs|w> Basically, at this point, +1 for SHOULD, not convinced about MUST at this point.
17:09:47 <limburgher> tibbs|w: <nods>
17:10:08 <tibbs|w> I like the idea but think that extending the .desktop file would have been a thousand times smarter.
17:10:33 <tibbs|w> And requiring packagers to deal with XML is just dumb, because many won't.
17:10:54 <abadger1999> Okay -- I'll draft a change to the desktop guidelines that makes it clear that it should be applied if the packager wants it to appear in the menus (rather than if it's a GUI app).  Then I'll ask rhughes to propose a draft that follows the .desktop guidelines style with the gating factor being "if you want to appear in gnome software center"
17:11:12 <abadger1999> for AppData
17:11:17 <geppetto> ok, seems reasonable
17:11:22 <tibbs|w> What I really don't like is that a lot of this duplicates what's already in the damn spec file.
17:11:37 <abadger1999> <nod>
17:11:50 <tibbs|w> So, hooray, now you change piece of info and you get to change it in three different places.
17:11:55 <limburgher> Yeah.  I've often wondered what the benefits of AppData are over the equivalent of parsing rpm -qi.
17:12:02 <abadger1999> We're 11 minutes into the second hour.  Are people okay to continue?
17:12:04 <tibbs|w> You get screenshots!
17:12:26 <limburgher> Make ASCII screenshots!
17:12:40 <limburgher> <_==>    - - - -- - - -    x
17:12:44 <limburgher> pew pew pew
17:13:19 <limburgher> I can stay a little while.
17:13:22 <geppetto> It was more fun inventing some new XML thing than fixing translations on specfile data
17:13:30 <tibbs|w> I'm not going anywhere.
17:13:33 <geppetto> I can stay
17:13:41 <tibbs|w> Now, specspo was indeed bad.  Yes.
17:13:46 <tibbs|w> Or whatever it was called.
17:14:26 <geppetto> Yeh, but it wasn't the only option … and appdata tried to use the same design as specspo when it started
17:14:38 * geppetto shrugs … it is what it is
17:15:29 <abadger1999> Since limburgher might leave soon
17:15:31 <abadger1999> #topic #425     systemd or systemd-units should not be required if a spec file does a %systemd_post command
17:15:35 <abadger1999> https://fedorahosted.org/fpc/ticket/425
17:15:40 <abadger1999> This one looks easy
17:16:15 <geppetto> you think so?
17:16:30 <tibbs|w> Depends on whose politics you pay attention to.
17:17:12 <geppetto> I think I'd rather have something like … packages using systemctl in post should require a systemdctl-post … that is provided by systemd-units
17:17:36 <geppetto> Then someone just creates a fake provider for that, for the docker/container case where they don't want systemd inside the container
17:18:01 <geppetto> just removing the real dep. seems like a horrible solution
17:18:28 <abadger1999> What's the difference between this solution and icon cache? https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Icon_Cache
17:20:17 <tibbs|w> So, maybe this is dumb, but what's going to provide the necessary directories and such if there's no package dependency on systemd?
17:20:31 <limburgher> systemd-filesystem!  /me ducks
17:20:46 <tibbs|w> I guess that's what geppetto said.
17:21:31 <limburgher> Yeah.  I mean, I think that's the least worst way.
17:21:32 <geppetto> abadger1999: I can see the similarities … but it feels really different, to me
17:21:45 <abadger1999> tibbs|w: that's a good point -- directories could be added to filesystem.
17:22:00 <abadger1999> but we'd need to make that a requirement of approval
17:22:29 <tibbs|w> I think there are three issues: what provides the filesystem stuff so the unit files get installed properly, whether it's reasonable to install a daemon with nothing around to actually start it, and how systemd gets installed on a system where you actually want it as pid1.
17:22:39 <geppetto> abadger1999: The icon thing feels more like "we put files here, and if this app. is installed we do something" … where the systemd thing is more like "we need systemd, but sometimes it's provided magically so we just lie in the packaging"
17:22:52 <tibbs|w> I guess they've answered the second question already; I assume this docker thing can start daemons.
17:23:39 <tibbs|w> This sort of feels like we're sort of allowing some situation-specific alternate init system.  Not that I have a problem with that.
17:23:42 <geppetto> tibbs: The way it works with docker is that the systemd on the host also runs inside the docker container
17:24:15 <limburgher> In that case isn't the installed systemd sort of a noop?
17:24:28 <limburgher> Or should be?
17:24:34 <tibbs|w> But it does take up disk space, I guess.
17:25:11 <limburgher> 11MB or so if my math is right.
17:25:28 <geppetto> limburgher: the daemon part, yeh … AIUI. But all the client parts could be useful (to talk to the running systemd, which is from outside … so might be incompatible, who knows).
17:27:41 <tibbs|w> So, look, if the filesystem gets solved and systemd still gets onto a system when things don't depend on it, I'm +1 on this.
17:28:07 <limburgher> did you mean *do* depend on it?
17:28:20 <tibbs|w> I mean don't.
17:28:36 <tibbs|w> As that's the point of this proposal, right?  To have fewer things depend on systemd.
17:29:05 <limburgher> OIC.  Gotcha.  I understood something about 35 degrees to the left of what you wrote.  Carry on.
17:29:57 <tibbs|w> I just want to make sure we don't have a situation where systemd really do need systemd but nothing actually depends on it so it doesn't get installed.  But I assume it's in @base or whatever so that shouldn't be an issue.
17:30:04 <limburgher> I can be +1 under those conditions as well.
17:30:12 <limburgher> Right.
17:30:18 <tibbs|w> I'm just looking at what currently depends on it but wouldn't, and it's kind of a lot of stuff.
17:30:20 <geppetto> tibbs: I think the point of the proposal is that there are cases where they don't want systemd installed
17:31:03 <geppetto> tibbs: For the normal "fedora" case I wouldn't be shocked if they ended up relying on the fact systemd is in @core or whatever.
17:31:15 <tibbs|w> Yes, I understand that.  My point is that when bringing up a system, we certainly do want it installed because we can't boot without it.  So how would it get brought in if nothing depends on it?
17:31:29 <geppetto> Being in @core
17:31:32 <tibbs|w> I assume the installer would take care of it, but someone at least needs to say "yeah, it will still work".
17:31:56 <geppetto> Well, I think that's a given … because if it doesn't work, nothing works :)
17:32:00 <tibbs|w> I guess kernel depends on it currently, though I'm not quite sure why.
17:33:14 <kalev> I'd like to comment on this, can I speak?
17:33:21 <abadger1999> kalev: yes please
17:33:49 <kalev> this is about %systemd_post, which expands to a 'systemd preset'
17:33:53 <geppetto> I want to know why they can't do it some better way than "just delete all the deps. and assume it'll work anyway" … I understand this is the super easy hack fix, but I'm not against other people doing more work to make it less hacky.
17:34:10 <kalev> what 'what systemd preset' does is that it creates symlinks if a service should be enabled
17:34:50 <kalev> if we look at a regular fedora installation, whether it's done by anaconda or livecd-creator
17:34:59 <kalev> they install the whole set of rpms in one transaction
17:35:12 <kalev> which means that both systemd and all the services are in one transaction
17:36:04 <kalev> in such a setup, rpm uses Requires(post): systemd to order the transaction so that systemd gets installed first, and the packages that run %systemd_post get installed later
17:36:22 <kalev> this ensures that at the time %systemd_post runs, systemctl is actually installed
17:36:54 <kalev> if it gets installed later, what could happen is that some services that should get enabled, don't get enabled because systemctl got installed too late, within that transaction
17:37:33 <kalev> so just removing the dep would break the first install scenarion
17:37:56 <kalev> someone mentioned earlier that the icon cache doesn't have the dependencies
17:38:12 <kalev> this is because icon cache is regenerated in post transaction, not in postinstall
17:38:14 <tibbs|w> The icon cache is just a cache, though.
17:38:26 <geppetto> tibbs: pretty sure kalev was just about to say that :)
17:38:29 <tibbs|w> Things still work if it doesn't get regenerated.
17:38:34 <kalev> right, and that too
17:38:51 <tibbs|w> I just think the icon cache thing is a distraction and not a good example for anyone to use.
17:38:57 <abadger1999> k
17:39:18 <tibbs|w> Anyway, can you formulate that as a question for dwalsh and stick it in the ticket?
17:40:03 <kalev> sure, I can do that, but I guess the FPC would be more qualified to come up with a good solution
17:40:11 <geppetto> I'll comment
17:40:29 <abadger1999> kalev: From what I'm hearing, I think we'd recommend to dwalsh to go with his original plan to create a fakesystemd package.
17:40:31 <geppetto> then see if you want to say anymore
17:41:22 <kalev> abadger1999: I guess that might be easiest for a short term solution
17:41:27 <tibbs|w> FPC doesn't generally come up with the solutions in any case.
17:41:56 <kalev> anyway, I have some ideas how to solve the transaction ordering issue
17:42:13 <kalev> one idea is that anaconda and livecd-creator could install systemd in a two-step process
17:42:29 <kalev> first a base system (which includes systemd), and then run another transaction with the rest of the packages
17:42:46 <kalev> but this requires quite a bit of work on the tooling side so it is definitely not a short term solution
17:43:06 <kalev> another solution might be to move the 'systemct preset' command to a post transaction script
17:43:28 <geppetto> kalev: That implies no daemons in base system … also you hit other problems with two installs, like not getting no fsync. for free (ostree currently does this)
17:43:33 <kalev> which removes the ordering problem, because before the posttrans script runs, all the packages will have been installed already
17:43:45 <kalev> geppetto: yep, lots of problems there
17:45:51 <abadger1999> #action geppetto and kalev to update the ticket with problems with removing Requires(post): systemd and possible alternatives.
17:46:11 <kalev> the people who wrote the original systemd guidelines would know best, but my guess is that 'systemctl preset' is currently in %post because it's easy to distinguish between package install and update and removal there
17:46:30 <kalev> if it was moved to posttrans, we'd have to carry over the state to make sure it only runs on install
17:46:53 <kalev> which would mean writing a file to the fs, I guess?
17:47:32 <limburgher> I have to go. . .
17:47:48 <abadger1999> limburgher: thanks for coming.
17:47:52 <kalev> nod, I have said what I had in mind too
17:48:06 <abadger1999> Okay, we've gone through a sizable chunk of hte tickets.
17:48:12 * limburgher tips hat, ducks out
17:48:19 <abadger1999> #topic Open Floor
17:48:32 <abadger1999> Any issues people want to bring up?
17:48:48 <abadger1999> If not I'll close out in 60s
17:48:57 <geppetto> Ok, I just posted my comment to #425 … feel free to take a look and let me know if I screwed up, or add a comment if you want.
17:49:12 <kalev> geppetto: will do, thanks
17:50:02 <kalev> geppetto: looks right to me
17:51:33 <abadger1999> Thanks for coming everyone!
17:51:41 <abadger1999> #endmeeting