releng
LOGS
15:34:40 <dgilmore> #startmeeting
15:34:40 <zodbot> Meeting started Mon Apr 28 15:34:40 2014 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:34:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:34:47 <dgilmore> #meetingname releng
15:34:47 <zodbot> The meeting name has been set to 'releng'
15:35:19 <dgilmore> #chair dwa nirik sharkcz tyll
15:35:19 <zodbot> Current chairs: dgilmore dwa nirik sharkcz tyll
15:35:43 <dgilmore> #topic roll call
15:35:47 <dgilmore> who is here?
15:35:54 * tyll is
15:37:10 <dgilmore> #chair masta
15:37:10 <zodbot> Current chairs: dgilmore dwa masta nirik sharkcz tyll
15:37:12 * sharkcz is here
15:38:15 <nirik> morning
15:38:36 <dgilmore> lets get started
15:38:54 <dgilmore> #topic tickets https://fedorahosted.org/rel-eng/report/10
15:40:14 <dgilmore> one sec need to haul out some rubbish
15:44:43 <dgilmore> sorry done
15:45:00 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5854
15:45:03 <dgilmore> masta: ?
15:47:50 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5362
15:48:13 <dgilmore> #info updating pungi and mash is on my todo list for this week
15:48:28 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5846
15:48:49 <nirik> cool.
15:48:58 <dgilmore> bochecha is not here
15:49:19 <nirik> I think the last plan I saw was fine... I'd be good with moving ahead with implementing it.
15:49:24 <nirik> or did we have outstanding questions?
15:50:11 <tyll> I noticed there was one mentioning of MD5
15:50:52 <tyll> https://github.com/tyll/fedora-infrastructure/commit/5af9e96d670197ba8ec968bfbea32057864542fd
15:51:01 <tyll> +unneccessary
15:52:06 <tyll> A timeline is missing, e.g. when do we patch which part
15:52:27 <dgilmore> yeah we dont have an implementation timeline
15:53:03 <tyll> Is there some kind of staging system to test the patches?
15:53:30 <dgilmore> nirik: we have a staging pkgs right?
15:53:41 <nirik> yep.
15:53:48 <nirik> we need to sync it
15:53:56 <nirik> but it's there.
15:53:56 <dgilmore> okay
15:54:05 <tyll> So the next step would be to test it there imho
15:54:11 * nirik nods
15:54:16 <dgilmore> so yeah we should get stg done
15:54:43 <nirik> pkgs.stg should be pretty complete.
15:54:56 <nirik> it's the koji / builder part thats not really there
15:55:07 <tyll> #info test patches in staging pkgs
15:56:08 <dgilmore> #action get stage converted
15:56:29 <dgilmore> #info test everything then work out timeline to migrate production
15:57:35 <dgilmore> anyone have anything else here?
15:57:47 <tyll> I don't
15:58:41 * nirik doesn't
15:58:42 <dgilmore> anyone want to commit to converting stage?
15:59:38 <dgilmore> okay lets move on
15:59:42 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5870
15:59:47 <dgilmore> nirik: any updates?
16:00:10 <nirik> not really, but would be nice to try and move it forward. ;)
16:00:18 <nirik> did we decide what key(s) we would use?
16:00:31 <nirik> could we then look at doing a 'best effort' manual signing as a stopgap?
16:00:37 <dgilmore> well sigul cant do it right
16:01:07 <dgilmore> we could do manual signing with the f21 key today
16:01:16 <dgilmore> but packages will get out unsigned
16:01:24 <nirik> we can setup a fedmsg listening thing to sign with... but it would take some work to sigul (which mitr can't commit to, but perhaps we could find someone else)
16:01:27 <nirik> right
16:01:34 <nirik> just a best effort type thing.
16:02:45 * nirik updates the ticket, since I failed to
16:02:58 <tyll> http://meetbot.fedoraproject.org/teams/releng/releng.2014-03-31-15.30.html
16:03:19 <tyll> at branch, f21 gets all f21 signed and rawhide gets all f21 signed from there, but f22 after that (tyll_, 15:55:24)
16:03:57 * nirik nods.
16:04:15 <nirik> so, we could sign them all with f21 now, but there will always be some not yet signed.
16:04:34 <nirik> we could gate them, but that could be anoying to people...
16:04:55 <nirik> ie, builds go into f21-pending, and when we sign them, we move them to f21
16:05:47 <dgilmore> would add a possible delay to some builds getting out
16:05:51 <nirik> I can update the ticket with those ideas and we can ponder on it?
16:05:53 <nirik> dgilmore: yep.
16:06:13 <dgilmore> some people think things are too slow already
16:07:33 <tyll> not sure whether gnome-software supports it, but an iterim step would be to sign the repodata, so packages can be verified against the metadata
16:07:35 <nirik> yeah, impatience is common. )
16:07:50 <tyll> then only one additional signature would be required
16:07:58 <nirik> tyll: has the same disadvantage as gating... need someone to sign every compose repodata
16:08:27 <dgilmore> tyll: signing the metadata adds manual intervention at the end of the process
16:08:43 <dgilmore> and would require us to redo all of our processes
16:08:52 <tyll> ok
16:09:48 <nirik> unless I'm missing something (possible) we already do get the metadata via https to mirrorlists (metalink)
16:09:56 <dgilmore> i honestly don't care if gnome-software supports it or not. i think it would depend on the backend
16:10:01 <dgilmore> yum supports it
16:10:05 <dgilmore> not sure about dnf
16:10:36 <nirik> I don't think it gets us much... signing packages is better for being able to verify them after the fact, etc
16:12:37 <dgilmore> right
16:13:21 <dgilmore> anything else here?
16:14:08 <nirik> lets get some feedback if the manual stuff would be worth doing...
16:14:11 <nirik> I updated the ticket..
16:14:39 <dgilmore> okay
16:14:47 <dgilmore> #topic secondary arches
16:14:53 <dgilmore> #topic secondary arches - s390
16:15:01 <dgilmore> sharkcz: got an update for us?
16:15:33 <sharkcz> not much, working on partial rebootstrap due glibc ABI breakage, starting with binary perl modules
16:15:43 <dgilmore> fun
16:16:14 <sharkcz> yep, it took quite long to realize what went broken, what are the consequences
16:16:48 <sharkcz> but the f21 mass rebuild will clean up everything
16:17:01 <sharkcz> so it's not that bad :-)
16:17:50 <dgilmore> cool
16:17:58 <dgilmore> #topic secondary arches - ppc
16:18:08 <dgilmore> dwa: got an update for us?
16:18:59 <sharkcz> I think there are just the regular breakages big vs. little endian, etc, webkit and others
16:19:17 <dgilmore> okay
16:19:30 <dgilmore> #topic secondary arches - aarch64
16:19:48 <dgilmore> aarch64 is moving along pretty well
16:19:59 <dgilmore> its catching up to primary
16:20:17 <dgilmore> most things are bootstrapped
16:20:37 <dgilmore> gnat i think will be bootstrapped soon
16:21:05 <dgilmore> #topic openfloor
16:21:22 <dgilmore> anyone have anything to bring up?
16:21:53 <nirik> just a FYI about storage...
16:21:56 <sharkcz> https://bugzilla.redhat.com/show_bug.cgi?id=1091708 - createrepo in rhel7 is broken for koji with external repos, I've cloend the fedora bug to el7
16:22:15 <dgilmore> sharkcz: okay
16:22:23 <dgilmore> nirik: any progress?
16:22:26 <nirik> we are going to be migrating our storage tomorrow night. There's not supposed to be any outage, but we will see... after that hopefully things like rawhide composes should be much faster
16:23:02 <dgilmore> that woudl be nice
16:23:53 <nirik> we will see. ;)
16:24:15 <dgilmore> indeed
16:24:23 <dgilmore> anything else?
16:24:34 <dgilmore> if not will end the meeting
16:26:15 <masta> ah geez.... sry I'm late
16:27:12 <dgilmore> #endmeeting