releng
LOGS
15:37:37 <tyll> #startmeeting
15:37:37 <zodbot> Meeting started Mon Apr 14 15:37:37 2014 UTC.  The chair is tyll. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:37:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:37:43 <tyll> #meetingname releng
15:37:43 <zodbot> The meeting name has been set to 'releng'
15:37:57 <tyll> #chair nirik sharkcz masta
15:37:57 <zodbot> Current chairs: masta nirik sharkcz tyll
15:38:32 <tyll> #topic roll call
15:38:41 * nirik is around
15:38:52 <tyll> dgilmore: ?
15:39:23 * sharkcz is still here :-)
15:39:52 * masta is half here - (bad internet today)
15:40:50 <nirik> shall we go over meeting tickets? or secondary arches?
15:41:22 <tyll> we can look into tickets, but I guess it will not be much news
15:41:42 <tyll> #topic tickets https://fedorahosted.org/rel-eng/report/10
15:41:44 <masta> ok so a few things before being knocked offline, I have a ticket to patch a script, which I'm (regretably) still behind on. Also, I'm on push duty this week.
15:41:54 <tyll> #topic https://fedorahosted.org/rel-eng/ticket/5854
15:42:25 <masta> yeah, that one...
15:42:32 <tyll> #info < masta> ok so a few things before being knocked offline, I have a ticket to patch a script, which I'm (regretably) still behind on. Also, I'm on push duty this week.
15:42:35 <masta> no update this week.
15:42:48 <tyll> #topic https://fedorahosted.org/rel-eng/ticket/5362
15:43:01 <tyll> #info Use XZ for repository metadata compression
15:43:16 <nirik> I think dgilmore was going to work on that...
15:43:29 <tyll> #info dgilmore is working on it
15:43:31 <nirik> where exactly were we? a mash patch needed?
15:43:40 <tyll> there are two patches needed
15:44:02 <tyll> #link https://fedorahosted.org/rel-eng/ticket/5362#comment:17
15:44:18 <nirik> yep, ok
15:44:48 <tyll> #info I looked into mash, because it was supposed to call createrepo, but it looked to me that it might also use the python API
15:45:48 <tyll> #topic https://fedorahosted.org/rel-eng/ticket/5870 - Rawhide signing
15:46:10 <nirik> not much news here.... although it seems sigul folks are pretty set on using obs-signd
15:46:33 <tyll> #info < nirik> not much news here.... although it seems sigul folks are pretty set on using obs-signd
15:47:12 <tyll> Ok, these were the tickets with meeting keyword - is there any ticket missing that someone would like to discuss?
15:47:49 * nirik glances over the list
15:48:36 <tyll> we have https://fedorahosted.org/rel-eng/ticket/5886 about urgent pushes, not sure whether we need to discuss something
15:49:08 <nirik> yeah. will need drafting up a detailed plan if someone wants to work on that
15:49:46 <tyll> #topic https://fedorahosted.org/rel-eng/ticket/5886 - method for urgent update pushes
15:49:56 <tyll> Any volunteer?
15:50:10 * nirik already has too much on his plate. ;)
15:51:29 <tyll> ok, then let's defer it - I am not so familiar with the push process to come up with a detailed plan
15:51:47 <tyll> #note someone needs to draft a detailed plan
15:52:01 <nirik> yeah
15:52:24 <tyll> #topic secondary architectures
15:52:47 <tyll> Is there something to mention/discuss?
15:52:59 <tyll> sharkcz: do you have something maybe?
15:53:40 <sharkcz> I have, I need to rebootstrap s390 rawhide (partially) for an incompatible ABI change in glibc, still working on the scope and plan
15:54:15 <tyll> #info < sharkcz> I have, I need to rebootstrap s390 rawhide (partially) for an incompatible ABI change in glibc, still working on the scope and plan
15:54:33 <sharkcz> problem is when a process mixes binary objects built with both old and new glibc, typically perl modules and stuff that uses perl
15:54:36 <tyll> Should it be tracked in a ticket?
15:54:54 <sharkcz> not necessary, it's all on my back
15:55:28 <tyll> ok
15:56:12 <tyll> #topic open floor
15:56:35 * bochecha missed the meeting again, will read the minutes
15:56:51 <sharkcz> and I have one more - ppc64 little endian bootstrap is now running publicly
15:57:11 <tyll> #halp
15:57:24 <tyll> #undo
15:57:24 <zodbot> Removing item from minutes: HELP by tyll at 15:57:11 :
15:57:30 <tyll> #undo
15:57:30 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x21fcd510>
15:57:51 <tyll> #info < sharkcz> and I have one more - ppc64 little endian bootstrap is now running publicly
15:58:42 <tyll> #topic open floor
15:59:15 <tyll> bochecha: Do you want to discuss something about the hash migration for the lookaside cache?
15:59:34 <bochecha> yeha, I was wondering if people had had time to look at my email, and had any thoughts :)
15:59:59 <nirik> I'm fine with 512 and just doing it. ;)
16:00:19 <tyll> #topic Stronger hashes for the lookaside cache - https://fedorahosted.org/rel-eng/ticket/5846
16:00:43 <tyll> I would prefer to add the hash algo to the path to ease future migrations
16:01:14 <bochecha> tyll: agreed, as mentioned in the email I'll rework one of the infra patch to do that (or maybe just add one on top)
16:01:48 <nirik> sure, having it in the path would be ok
16:01:51 <tyll> bochecha: btw. did you have time to setup a git repo with the patches?
16:02:26 <bochecha> tyll: no, last couple of weeks were pretty busy, but now that I'm unemployed, I'll have more time to work on stuff :)
16:02:48 <nirik> unemployed? ;(
16:03:16 <bochecha> nirik: no need for sad face, I quit my job here in Hong Kong, moving back to France :)
16:03:25 <nirik> ah.. ok. Cool.
16:03:37 <bochecha> but that's probably off-topic for the meeting, the point is, I have much more free-time :P
16:04:43 <tyll> bochecha: ok - since the hash algorithm is also submitted in the upload process, the changes would let us enough freedom to improve them later if necessary
16:04:53 <bochecha> tyll: yup
16:05:04 <tyll> #action add hash algorithm to storage path
16:05:26 <tyll> #topic open floor
16:05:31 <tyll> something else?
16:05:58 * nirik has nothing
16:05:59 <tyll> I will close the meeting in a minute if nobody comes up with something
16:06:06 <bochecha> nothing else fromme either
16:07:28 <tyll> ok, thank you everyone
16:07:32 <tyll> #endmeeting