fedora-meeting-1
MINUTES

#fedora-meeting-1: Fedora ARM status meeting

Meeting started by pwhalen at 21:00:30 UTC (full logs).

Meeting summary

  1. 1) Kernel Update (pwhalen, 21:02:58)
    1. 3.13 appears solid for supported targets (bconoboy, 21:07:03)
    2. 3.14 is being worked on now, utilite is being investigated, other imx6 device support is likely to work as well. (bconoboy, 21:07:31)
    3. 3.14 looking good on aarch64 foundation model (bconoboy, 21:07:46)
    4. Some known issues in 3.13/3.14 with displays on trimslice/bbb, need investigation (bconoboy, 21:09:38)
    5. ACTION: pwhalen to file BZs on display issues (bconoboy, 21:10:17)

  2. 2) Creating Fedora ARM Remixes (pwhalen, 21:11:37)
    1. https://fedoraproject.org/wiki/Architectures/ARM/Creating_Remixes (pwhalen, 21:14:14)
    2. The number of supported devices has decreased over time due to semiconductor decisions (EOL omap3/4 etc) (bconoboy, 21:17:53)
    3. We want to start ramping up the number of supported devices through the use of remixes until F21 comes out (bconoboy, 21:18:34)
    4. Today's how to make a remix documentation is at https://fedoraproject.org/wiki/Architectures/ARM/Creating_Remixes (bconoboy, 21:20:20)

  3. 3) ARM representation in Fedora Working Groups (pwhalen, 21:26:08)
    1. Per dgilmore, server wg is considering arm, cloud is keeping it on the radar, workstation is only thinking of x86_64 (bconoboy, 21:29:56)
    2. https://fedoraproject.org/wiki/Cloud_Changelist (dgilmore, 21:30:36)
    3. https://fedoraproject.org/wiki/Workstation/Technical_Specification (dgilmore, 21:31:01)
    4. https://fedoraproject.org/wiki/Server/Technical_Specification (dgilmore, 21:31:23)
    5. Cloud WG info https://fedoraproject.org/wiki/Cloud_Changelist (bconoboy, 21:31:41)
    6. Workstation technical spec: https://fedoraproject.org/wiki/Workstation/Technical_Specification (bconoboy, 21:31:52)
    7. Server technical spec: https://fedoraproject.org/wiki/Server/Technical_Specification (bconoboy, 21:31:59)
    8. Server WG is considering xfs for /boot, but uboot doesn't support xfs meaning arm cannot follow this spec. (bconoboy, 21:32:52)
    9. Workstation spec is 64 bit only and requires 3d drivers: Could be extended to arm32 if 3d drivers become available (bconoboy, 21:36:27)
    10. ACTION: masta to keep an eye on server WG for armv7hl: follow up on HW virt hardware remix and ext2fs issue (bconoboy, 21:49:56)
    11. ACTION: dgilmore to keep an eye on workstation WG for armv7hl: follow up on 3d graphics driver (bconoboy, 21:50:13)

  4. 4) Open Floor (pwhalen, 21:53:59)
    1. dgilmore is working on swtiching all uboots to use extlinux.conf (bconoboy, 21:56:37)
    2. http://fedoraproject.org/wiki/Changes/u-boot_syslinux (dgilmore, 21:57:09)
    3. http://fedoraproject.org/wiki/Changes/u-boot_syslinux (pbrobinson, 21:57:25)
    4. ACTION: kwizart will file BZes for his rtc and fbdev issues (bconoboy, 22:13:02)


Meeting ended at 22:13:19 UTC (full logs).

Action items

  1. pwhalen to file BZs on display issues
  2. masta to keep an eye on server WG for armv7hl: follow up on HW virt hardware remix and ext2fs issue
  3. dgilmore to keep an eye on workstation WG for armv7hl: follow up on 3d graphics driver
  4. kwizart will file BZes for his rtc and fbdev issues


Action items, by person

  1. dgilmore
    1. dgilmore to keep an eye on workstation WG for armv7hl: follow up on 3d graphics driver
  2. kwizart
    1. kwizart will file BZes for his rtc and fbdev issues
  3. masta
    1. masta to keep an eye on server WG for armv7hl: follow up on HW virt hardware remix and ext2fs issue
  4. pwhalen
    1. pwhalen to file BZs on display issues


People present (lines said)

  1. pbrobinson (95)
  2. dgilmore (77)
  3. bconoboy (66)
  4. pwhalen (48)
  5. masta (34)
  6. kwizart (27)
  7. mjg59 (9)
  8. zodbot (7)
  9. hrw (3)
  10. kylem (2)
  11. pwhalen_ (2)
  12. dmarlin (1)
  13. jcapik (1)
  14. ahs3 (0)
  15. msalter (0)
  16. jdisnard (0)
  17. ctyler (0)
  18. agreene (0)
  19. handsome_pirate (0)
  20. jonmasters (0)
  21. ddd (0)


Generated by MeetBot 0.1.4.