fedora_board
LOGS
19:01:29 <rbergeron> #startmeeting Fedora Board Meeting
19:01:30 <zodbot> Meeting started Thu Jan 23 19:01:29 2014 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:36 <rbergeron> #meetingname Fedora Board
19:01:36 <zodbot> The meeting name has been set to 'fedora_board'
19:01:46 <mjg59> Afternoon
19:01:58 <rbergeron> #topic Who's here?
19:02:02 <jwb> hello
19:02:03 <mjg59> \o/
19:02:05 * inode0 waves
19:02:06 <cschalle_> yo
19:02:07 * jreznik is (semi)here
19:02:14 <hadess> kind of here as well
19:02:29 <gholms> Bacon
19:02:42 <rbergeron> #chair rdieter mjg59 jwb inode0 jreznik mitr gholms
19:02:42 <zodbot> Current chairs: gholms inode0 jreznik jwb mitr mjg59 rbergeron rdieter
19:02:50 * abadger1999 clones himself into two meeting channels
19:02:58 * adamw around.
19:02:59 * gholms pokes mattdm
19:03:00 <drago01_> .
19:03:21 <mattdm> hi
19:03:32 <rbergeron> #info Board folks present: gholms inode0 jreznik jwb mitr mjg59 rbergeron
19:03:32 * randomuser lurks
19:03:40 <cschalle_> mclasen is on the way
19:03:48 * mitr is not a board member actually
19:04:04 <rbergeron> mitr: augh, sorry; i totally was looking for misc and
19:04:12 <rbergeron> apparently i'm silly and blind
19:04:19 <rbergeron> #undo
19:04:19 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x31f59990>
19:04:26 <drago01_> mitr: well that was a short term ;)
19:04:32 * nirik is sorta of here, but also running an infrastructure meeting.
19:04:34 <rbergeron> #info Board folks present: gholms inode0 jreznik jwb mjg59 rbergeron
19:04:37 <gholms> mitr: Maybe it still counts.  :)
19:04:45 <jreznik> mitr should be appointed to all committeess in fedora :)
19:04:58 * rbergeron gets out her magic wand...
19:04:58 <gholms> 8^)
19:05:03 <rbergeron> no, kidding
19:05:08 <cschalle_> rdieter is here too right? (and on the board)
19:05:15 <rbergeron> okay, i'll cover the other invited folks in a second - just wnat to post agenda
19:05:16 <rdieter> think so, yo
19:05:24 <inode0> Sparks: ?
19:05:32 <rbergeron> yeah, and i chaired him, just failed to mention ihs name, but is not any indicator of a lack of love
19:05:44 <rbergeron> #info also present: rdieter, who i would never intentionally forget :)
19:05:49 <rbergeron> #topic Agenda
19:06:21 <rbergeron> #info Today's agenda posted here: https://lists.fedoraproject.org/pipermail/advisory-board/2014-January/012416.html
19:06:47 * sgallagh is lurking
19:06:54 <rbergeron> #info Topic at hand: Getting to a conclusion on the third-party repo discussion as initiated by cschalle_ on the advisory-board list
19:07:34 * jreznik will be back in sec
19:07:46 <rbergeron> We have a few additional "invitees" today; jwb, would you like to list those folks out, lest I continue to fail with my name-listing-abilities?
19:08:33 <jwb> i belive Chrisian Schaller (cschalle_ ) and Matthias Clasen (mclasen) are here from the Workstation WG
19:08:39 * mclasen is here
19:08:42 <jwb> as well as many FESCo members i would assume
19:08:46 <jwb> ugh
19:08:59 <jwb> Christian, not Chrisian.  thanks for cursing me with typos rbergeron
19:09:06 <gholms> Heh
19:09:35 <rbergeron> sorry. it's contagious
19:09:41 <rbergeron> okay.
19:10:39 <rbergeron> I think we're going to go with following the standard board irc meeting protocol as well. Since we have a lot of topics, an lot of eyeballs, a heated topic, and ... a clock.
19:10:46 * Sparks is here
19:10:53 <rbergeron> #link https://fedoraproject.org/wiki/Board_public_IRC_meetings?rd=Board/IRC#Meeting_protocol
19:11:02 <gholms> Dang, you beat me to it.
19:11:04 <rbergeron> #info also present: sparks for board
19:11:13 * inode0 goes to read since we never follow protocol
19:11:13 <rbergeron> And so: per the mail:
19:11:30 <rbergeron> inode0: it's the standard ! / ? / etc.
19:11:46 <rbergeron> ~ for bacon.
19:11:49 <rbergeron> No, not really.
19:11:54 <rbergeron> So topic #1, here we come.
19:12:09 <rbergeron> #topic 1) Does the Board agree with FESCo's determination around third party repositories
19:12:23 <mjg59> ?
19:12:30 <rbergeron> #link https://fedoraproject.org/wiki/Third_Party_Repository_Policy
19:12:56 <rbergeron> mjg59: yes
19:13:26 <mjg59> The proposed change has been fairly well described, but the justification still seems somewhat nebulous
19:13:50 <mjg59> (1) What is the expected increase in userbase as a result of this change?
19:14:11 <mjg59> (2) What alternative approaches to increasing userbase were considered?
19:14:15 <mjg59> eof
19:15:01 * rbergeron would like to clarify her statement on protocol to indicate that board emmbers can type freely, just don't want to get out of control with 400 people typing.
19:15:13 <inode0> thank you
19:15:23 <rbergeron> mjg59: would you be kosher with adding that to the end of this, as part of "geting to a decision"?
19:15:49 <mjg59> rbergeron: Oh sorry I entirely misread the topic. My mistake. Yes, please do.
19:15:53 <rbergeron> inode0: yeah. sorry - I mistakenly thought that that was a written detail but .. nope.
19:16:00 <rbergeron> mjg59: excellent, thanks
19:16:09 <mjg59> I'm ok with the FESCO determination
19:16:22 <jreznik> rbergeron: I agree with that FESCo document, so for me +1
19:16:23 <rbergeron> #info Add mjg59's questions at :13, :14 to end of agenda
19:16:44 <gholms> Yep.  I completely agree.
19:16:46 <inode0> I'm ok with it also although I don't personally agree with the Other Repositories section
19:17:12 <rdieter> inode0: how so?
19:17:44 <inode0> I don't like the bias against aggregate repositories and I think it encourages people not to participate in them.
19:17:53 <jreznik> inode0: with that option or just that Board should decide on that?
19:18:23 <jreznik> ah, sorry, other repos is second
19:18:24 <inode0> No, I accept it as FESCo's decision, I'm just saying I don't personally endorse that section.
19:18:34 <rdieter> The part about "Third party repositories that host diverse pieces of software..." I assume
19:18:43 <abadger1999> !
19:18:53 <jwb> that's a fedora legal requirement as i understand things
19:18:56 <rbergeron> abadger1999: go ahead :)
19:19:13 <abadger1999> Yeah, I don't like the disadvantage it places on aggregate repos either but the reason we added that limitation
19:19:31 <jreznik> abadger1999: how do you define aggregated repo?
19:19:38 <abadger1999> is that aggregate repositories put a much higher burden onto Fedora Legal reviewing the repository contents.
19:20:19 <abadger1999> It didn't seem like we could realistically sak them to do that so it seemed better to set expectations than to have people submit them and then say no.
19:20:20 <jwb> jreznik, "contains more than a single piece of specifically vetted software"
19:20:34 <jreznik> are "diverse pieces of software" coprs with one desktop app and one kernel module? is aggregated repo kf5 framework copr with dozens packages (as it's pretty huge?)
19:20:49 <abadger1999> jreznik: Something like jwb says... it's a tad harder since there might be several packages which together enable one new application.
19:20:50 <inode0> I accept the reasons but I think it might harm aggregate repos which benefit users IMO and I think it gives favored treatment to less community minded enterprises that would create a repo with one package in it.
19:20:59 <abadger1999> jreznik: but that's the general idea.
19:21:20 <jreznik> so it would be nice to extend it there...
19:21:27 <rdieter> is ok with the decision too, +1.  baby steps...
19:21:37 <jwb> jreznik, coprs cannot have anything which is not allowable in fedora.  kernel modules as separate packages are not allowed in fedora
19:22:03 <jreznik> jwb: kernel module was just an example of "diverse" - I know it's not allowed
19:22:04 <jwb> the legal requirement on coprs is already sufficient to cover coprs that have multiple things in them.
19:22:05 <abadger1999> inode0: I agree in principle.  If you can think of ways to address the probelms, fesco would revisit.  Or if  the board thinks we should say no to all third party repositories out of fairness, fesco could also revisit.
19:22:20 <jreznik> or non-copr free and open repo
19:22:31 <abadger1999> eof
19:22:43 <handsome_pirate> Okay
19:22:49 * handsome_pirate is against
19:22:54 <handsome_pirate> Just so it's known
19:22:54 <rbergeron> so I count 4 +1s (with some concerns from inode0 regarding some portions of the text but still +1)
19:22:57 <jreznik> jwb: fair enough
19:23:01 <stickster> !
19:23:12 <handsome_pirate> !
19:23:16 <rbergeron> handsome_pirate: thank you for your input. we're doing IRC protocols for this meeting ot keep it in order :)
19:23:23 <handsome_pirate> rbergeron:  Roger
19:23:25 <rbergeron> stickster: go ahead
19:23:28 <jreznik> (for copr but that section is for non-copr)
19:23:51 <handsome_pirate> rbergeron:  Can I get a link to the current proposal?
19:24:01 <stickster> I just wanted to point out spot's statement on advisory-board, re: auditing work: https://lists.fedoraproject.org/pipermail/advisory-board/2014-January/012284.html
19:24:16 <jreznik> handsome_pirate: this is what we talk about now https://fedoraproject.org/wiki/Third_Party_Repository_Policy
19:24:20 <stickster> eof
19:24:23 <Sparks> rbergeron: I'm +1 to FESCo's policy.
19:24:30 <rbergeron> stickster: thank you.
19:24:56 * jreznik is still +1 but would like to clarify that other non-copr repositories what diverse mean
19:25:07 <jwb> i will note that the answers to further questions may result in FESCo having to revisit this anyway
19:25:23 * rbergeron counts 5 +1's now; sparks, mjg59, inode0, rdieter, gholms, now +6 with jreznik.
19:25:28 <inode0> jreznik: it means contains more than one package as I read it
19:25:29 <handsome_pirate> !
19:25:54 <handsome_pirate> What statement is being voted on?
19:26:02 <mjg59> 19:24 < jreznik> handsome_pirate: this is what we talk about now https://fedoraproject.org/wiki/Third_Party_Repository_Policy
19:26:04 <sgallagh> !
19:26:08 * rbergeron notes the clock - plenty of other topics to cover.
19:26:15 <rbergeron> sgallagh: yes
19:26:31 <jreznik> inode0: no, jwb and abadger1999 explained it above but it's not written there that way
19:26:41 <jwb> rbergeron, yes, we have enough votes to settle this question.  i suggest we move on
19:26:48 <jreznik> but let's move on - we can ask FESCo to clarify it later, we have some kind of general agreement here
19:27:02 <sgallagh> For the record, I'd like to suggest "diverse" means "contains more than one package that people would want to install directly" (to differentiate from "contains an app and six dependent libraries" as qualifying for diverse)
19:27:05 <sgallagh> EOF
19:27:06 <rdieter> handsome_pirate: see /topic "Does the Board agree with FESCo's determination around third party repositories"
19:27:37 <handsome_pirate> !
19:28:13 <jwb> handsome_pirate, can you ask your questions in #fedora-devel if you're trying to play catchup?  we have a lot of ground to cover
19:28:23 <handsome_pirate> jwb:  No, I'm caught up
19:28:24 <rbergeron> #agreed +6 in favor of "Board agrees with FESCo's determination around third-party repositories"
19:28:32 <gholms> (Or #fedora-advisory-board)
19:28:39 * inode0 notes it is enough for him to understand it excludes everything in every community driven aggregate repository from consideration
19:28:47 * handsome_pirate had a specific question
19:29:07 <rbergeron> #topic 2a) Do Fedora's foundations allow for any ease of use around non-free software?
19:29:09 <inode0> no point dwelling on it further
19:29:24 <mjg59> Ease of use is a bit handwavy here
19:29:28 <rbergeron> especially since I changed the topic. :D
19:29:48 <mjg59> We already make no distinction between third-party repositories containing free software and third-party repositories containing non-free software
19:30:04 <jreznik> yep, I'd like to talk about that specific proposal - for it in that form I'm -1 but I can imagine some way of ease of use that I'd be ok with
19:30:11 <mjg59> Or, rather, we *currently* don't
19:30:17 <mjg59> (The earlier topic changes that)
19:30:19 <Sparks> Fedora allows the addition of third-party repos (manually) which then allows non-free software to be installed.  I'm good with that.
19:31:13 <jwb> might i suggest we let cschalle_ and/or mclasen speak to the ease of use part if people think it's handwavy?
19:31:17 <rdieter> jreznik: I appreciate that point of view, but I don't agree.  the policy task is on us, the specific implementation details... not necessarily
19:31:17 <jreznik> so I'd change that question to "what would be required to allow easier installation of 3rd party apps/repos enablement"
19:31:18 <otaylor> !
19:31:18 <Sparks> Seem easy enough to me.
19:32:01 <cschalle_> should I speak?
19:32:12 <jreznik> rdieter: for me it really depends on implementation - I can imagine implementation I'd be ok, even endorse but also implementation I'd never vote for
19:32:14 <handsome_pirate> !
19:32:15 <rbergeron> sure.
19:32:36 * jreznik is trying to find some balance/compromise solution that would still fit (somehow) our values
19:32:41 <rdieter> jreznik: again, we're here to decide policy first.  then we (and others) can determine implementation
19:33:12 <rdieter> jreznik: the topic above is fairly black and white
19:33:28 <rdieter> if no, then we're done talking.  If yes, keep going
19:33:41 <mjg59> rdieter: I have no idea what "ease of use" is in this context, so I don't think it is black and white
19:33:48 <jreznik> rdieter: so I'd say - I'm ok with current values/foundation, I don't want to change them but I'm willing to agree with some kind of compromise if our user would get advantage from that
19:34:02 <mjg59> And so I think we should shut up and let cschalle_ speak
19:34:10 * rdieter shuts up
19:34:18 <cschalle_> well a lot of ground on this has been covered already in the email thread. I think the thing I would like to make clear that the reasoning from the WG is that we want to attract users, especially developers, who are not specifically interesting in working on Fedora. And today Fedora seems to appeal to users who wants to work on fedora itself.
19:34:38 <cschalle_> So we want to bring down the barriers for their use of fedora as far as possible, with this and other proposals
19:34:39 <jreznik> so for that question in topic I'd say yes but personally for me the implementation would be the key --- shutting up :D
19:34:49 <rbergeron> IIt could be yes or no; if yes, depends on what that degree of ease actually is.
19:35:06 <cschalle_> EOF
19:35:21 <mclasen> !
19:35:38 <rbergeron> mclasen: go ahead
19:35:39 <Sparks> cschalle_: Exactly what barriers are you proposing be reduced?
19:35:49 <cschalle_> !
19:36:06 <mclasen> about the 'degree of ease': cschalle_ posted some mockups of what we are envisioning in the email discussion
19:36:31 <rbergeron> cschalle_: go ahead also
19:36:38 <mclasen> we have designs for showing 3rd party software in the app installer e.g. in response to searches
19:36:53 <handsome_pirate> !
19:36:56 <gholms> mclasen: Working that way out of the box, I presume?
19:36:57 <mclasen> and would want to offer the user some information about the software, as well as a switch to enable the repo
19:37:07 <jreznik> mclasen: that mockup is what I don't and can't agree with if I understand it correctly but I can discuss other options :)
19:37:13 <mclasen> to do that, we need to include some information about those approved repositories
19:37:22 <rbergeron> handsome_pirate: yes
19:37:23 <cschalle_> sparks: well in this specific case we want to enable people to get the tools they need as easy as possible, without having to pop onto google every time to find some random repository somewhere or read some howto on a forum
19:37:39 <mjg59> cschalle_: What evidence do we have that ease of availability of third-party software is a significant factor in dissuading developers from running Fedora?
19:38:08 <handsome_pirate> Okay, my concerns are two:  Can we get a clear action plan for testing this?  And, can we get a commitment of resources to test?  EOF
19:38:10 <Sparks> cschalle_: By shipping repo information for potentially non-freee repositories like Adobe Flash?
19:38:14 <jreznik> mclasen: so, do I understand that mockup correctly - does it allow search for 3rd party software before the repo is added and approved by user? and if so, it asks for repository addition when that software is selected?
19:38:21 * rbergeron would prefer to have something defining what that "ease of use line" might actually be, rather than mockups (although they are useful) - simply to provide black and white consistency in the future, rather than the handwaviness
19:38:24 <mjg59> handsome_pirate: Those really aren't relevant questions at the moment
19:38:41 <cschalle_> mjg59, well Fedora being a distro for the specially interested seem to be a common thread in reviews and other distros who have more ease of use are more popular than us
19:38:41 <rbergeron> handsome_pirate: that's probably questions for theend. we have 4 more things to cover in like, 20m. Or would be a good question forthe discussion on the advisory-board list.
19:38:50 <mjg59> cschalle_: That doesn't answer my question
19:38:59 <mclasen> jreznik: what I have suggested before is that we want to be able to tell the user who searches for say "chrome"
19:39:08 <drago01_> ?
19:39:22 <mjg59> cschalle_: There's many things about Fedora that compromise our ease of use. Why is availability of non-free software being considered the most significant factor?
19:39:29 <mclasen> 'this is not part of fedora, but we know where you can get it,there's some downsides... but if you want to go ahead, click here'
19:39:31 <otaylor> !
19:39:43 <rbergeron> otaylor: yes
19:40:08 <otaylor> mjg59: I think it's a bit of a red herring to look at whether this is a blocking issue for anyone
19:40:09 <mitr> !
19:40:30 <otaylor> Most of our users, most reviewers, and the target developer's *can* figure this out
19:40:32 <cschalle_> mjg59, this is part of a bigger proposal and a bigger list of ideas. the reason we are discussing it and not the rest is because it challenges long held fedora policies. Nobody is claiming it is the single most significant factor, we are just saying it is a factor that should be fixed
19:40:45 <mjg59> cschalle_: Ok, thanks
19:40:51 <Sparks> rbergeron: I'd really like an answer to my question as it seems that it's common among at least a few Board members.
19:40:58 <otaylor> But what we're doing is creating a bad experience for all our users
19:41:01 <jreznik> mclasen: for me the key is - user should allow it explicitly before everything third party is shown in search result, even if it would be one spoke in installer with big warning and "enable all known 3rd party repos" - not specific ones
19:41:18 <kushal> !
19:41:23 <otaylor> And then thinking that a bad experience is going to inform people about software freedom
19:41:34 <rdieter> jreznik: +1, I think I'd be happier if this were somehow opt-in too
19:41:45 <rbergeron> sparks: can you reiterate?
19:41:59 <EvilBob> slippery slope IMO
19:42:02 <rbergeron> kushal: go ahead
19:42:07 <mjg59> otaylor: I agree that the current experience is bad. But there's a spectrum of options between the status quo and having the software centre default to offering non-free software.
19:42:14 <otaylor> It most likely instead just makes fedora low quality. It's hard to *quantify* this in terms of user count - but that doesn't mean that we shouldn't be trying to fix it in some way that is consistent with the ideas of fedora
19:42:17 <gholms> rdieter: Opt-in is better, but a slippery slope.
19:42:17 <jreznik> rdieter: that was my point of implementation - there's implementation I can't live with (opt-out) but implementation I can live with (opt-in)
19:42:38 <mclasen> jreznik: that will end up being just the first item on the 'things you must do to fix fedora aftr installation' lists that people post - what does it add, other than making us feel morally superior ?
19:42:42 <kushal> Sorry if I missed the info, but are we going to provide the repo files directly? or are we staying the old way, just pointing people.
19:42:46 <rdieter> jreznik: I figured that was more what 2b on the agenda was about, we're still at stage 2a
19:42:55 <mjg59> kushal: The proposal is to include the repositories by default
19:42:55 <otaylor> eof
19:42:57 <cschalle_> jreznik, well we would be fine with a outcome here that is 'yes, but some details will need to be worked out with the board'
19:43:12 <EvilBob> Setting up and enabling third party repos is not that hard now.
19:43:22 <randomuser> !
19:43:22 <jreznik> cschalle_: that's my point, I already said yes but based on implementation
19:43:24 <mjg59> EvilBob: Please follow the meeting process
19:43:41 <EvilBob> There is no reason other than laziness that needs it to be easier
19:43:41 <inode0> mclasen: perhaps it binds a large community together around a set of common values?!
19:43:56 <rbergeron> evilbob: we're doing protocol today, lest this turns into craziness
19:43:59 <jreznik> mclasen: if it would be part of installation, it does not have to be on any list
19:44:12 <kushal> mjg59, Ok, that will make kind of difficult to explain FOSS ideologies and Fedora's stand <eof>
19:44:12 <EvilBob> rbergeron: Sorry, I just logged on
19:44:48 <rbergeron> cschalle_: do you consider the entirety of your plan unworkable without this detail enabled?
19:44:51 <jreznik> and again implementation - it should be part of installer to install required bits when doing installation (aka someone agrees with NVidia repo, he wants system to be installed with NVidia drivers and ready fter first reboot)
19:45:11 <cschalle_> Sparks, sorry, are you referring to your flash question? to me this is not about flash or any other specific app, it is just the principle, the mockups is in no way a final list of apps or for that matter apps we will for sure include as that requires legal clearance etc. and vendor interest
19:45:28 <Sparks_too> My question is whether or not the proposal is to ship third-party repos that contain non-free software in Fedora?
19:45:47 <jwb> Sparks_too, as in fedora creates and provides the actual repositories?  no
19:45:59 <Sparks_too> Cschalle_: flash was an example.
19:46:01 <mjg59> jwb: But as in Fedora ships the repositories as part of the default install?
19:46:02 <cschalle_> rbergeron, I consider this an important part of it, I think the other parts of the plan are good in their own rights, but I do think this is an important issue that will be unfortunate to not get fixed
19:46:22 <adamw> !
19:46:27 <jforbes> !
19:46:30 <jwb> mjg59, the .repo files, perhaps.  Fedora is not hosting or providing software in this proposal
19:46:34 <cschalle_> Sparks_too, so yes, by allowing ease of install of any tool people need we hope to make fedora a more attractive platform
19:46:35 * rbergeron does a clock check - 14 minutes left in the hour.
19:46:36 <mclasen> !
19:46:52 <Sparks_too> Okay, then I'm -1
19:47:01 <rbergeron> adamw, mclasen: go ahead - jforbes, you're next up :)
19:47:04 <mjg59> cschalle_: Is there any level of additional user effort required to add third party repositories that you would feel acceptable?
19:47:07 <jreznik> jwb: well I'd say it should (not hosting but providing as opensuse does for example for nvidia drivers)
19:47:14 <drago01_> !
19:47:21 <cschalle_> Sparks_too, PyCharm would to me be maybe a better example here as something I think would be a great interest to python devs if it was easier to find and install on fedora
19:47:27 <mclasen> jreznik: 'we can ask in the installer' is not a good answer to any question
19:47:45 <mjg59> I agree with mclasen on that point
19:47:46 <cschalle_> mjg59, well a 'enable third party' repos button would be ok with me
19:47:50 <adamw> I'd just like to say that I think discussing this in context of 'ease of use' is unfortunate. For me the vital question is whether there is a clear 'bright line' between Fedora and non-Fedora; I don't see an effective difference between us shipping the repos and us shipping some sort of metadata that points to them.
19:47:53 <mjg59> cschalle_: But nothing beyond that?
19:48:03 <EvilBob> !
19:48:05 * rbergeron feels tha ta proposal describing where the line is would be helpful, or at least a proposal along the lines of "open to some options which need to be further defined in words"
19:48:15 <adamw> so yeah: the 'bright line' is the key thing. It doesn't need to be 'difficult' to clear in the sense of 'unnecessarily onerous', but it needs to make it very clear what the line is, and what's on one side and what's on the other.
19:48:15 <randomuser> adamw, +1
19:48:28 <jreznik> my answer is to the question is - yes, if opt-in; no, if opt-out
19:48:29 <cschalle_> mjg59, I haven't yet seen or heard any other idea I feel is truly making a difference for this particular problem
19:48:50 <mjg59> cschalle_: Ok.
19:49:24 <adamw> oh, i'd also ask if the board has talked to the FSF about this, or intends to. eom
19:49:40 <jwb> adamw, no, we haven't.
19:49:45 <mjg59> cschalle_: In the event that the board is unwilling to permit the shipping of repositories containing non-free software as part of Fedora, would the WG spend time looking into alternatives?
19:50:08 <jwb> ngh
19:50:13 <Sparks_too> Adamw: We don't currently meet their standards so either way this won't change our standings with them.
19:50:14 <jwb> shipping of .repo files
19:50:44 <mjg59> jwb: I'm aware that nobody is proposing including non-free software in Fedora directly
19:50:44 <cschalle_> mjg59, if someone comes up with a bright idea we think actually will make a difference of course
19:50:58 * rdieter would be happy with a very small/limited proposal to define the bright-line to something easy and clear, say, only COPR content for now.  Then, if all goes well, and at some future hand-wavy date, consider more.
19:51:06 <jwb> mjg59, i would very much like it if we could phrase things to make it clear that fedora is not hosting, shipping, or supporting said repositories
19:51:09 <adamw> Sparks: it's generally accepted that we meet their standards in just about every respect except our difference of opinion on non-free firmware, AIUI. this would make that considerably more of a delta.
19:51:11 <mjg59> cschalle_: But otherwise you'd just leave things as the status quo
19:51:25 <mjg59> ?
19:51:32 <jwb> rdieter, that's essentially the FESCo policy
19:51:41 <cschalle_> mjg59, yes, if we can't come up with a plan for a action we would take no action :)
19:51:51 <Sparks_too> Adamw: Agreed
19:51:53 <rdieter> jwb: except there's the business of these mock-up implementations
19:52:16 <jreznik> jwb: actually I'd say if it is all about ease of use, we should somehow support it on work on these repos... otherwise it could end exactly opposit way - mess for users
19:52:17 <abadger1999> !
19:52:26 <jwb> rdieter, well, that's why we're discussing this specific question... if we can extend it beyond coprs
19:52:27 <mjg59> cschalle_: You don't feel that spending time standardising terminology around repository metadata and making it easier for users to install that would increase ease of installation of third-party software?
19:52:37 <rbergeron> jforbes: sorry, you wanted to speak, and abadger1999, both go ahead
19:52:39 <jforbes> Here is my concern. We are going to potentially drive away existing contributers over a change in our principals, to gain users unwilling to do a quick google search and follow the how to that is published for every release. And those users we gain will still complain that we don't provide mp3, etc here. They are going to have to look at the same docs anyway. This is a legal issue we can't solve, and I understand that, but is it worth this risk
19:52:42 <rdieter> jwb: do we necessarily have to decide both *now*?
19:53:00 <jwb> rdieter, if you are against that, then your answer to this question is likely "no" because we've already approved the FESCo policy with the previous topic
19:53:14 <jwb> rdieter, and the entire point of this ticket/meeting is to decide this NOW, yes
19:53:20 <abadger1999> rdieter: For coprs, I think that fesco can just evaluate whether the mockups satisfy whether they establish the line between fedora and non-fedora that we wanted.
19:53:25 <abadger1999> rdieter: Not too controversial
19:53:32 <rdieter> I see lots of disucssion about the implementation details
19:53:35 <abadger1999> rdieter: But coprs will not ship anything nonfree
19:53:36 <cschalle_> mjg59, I am not convinced it makes for more than a marginal difference, so speaking for myself I would not take action in that regard without first starting to believe it would produce significant results
19:53:44 <mjg59> cschalle_: Ok, thanks
19:53:47 <abadger1999> rdieter: So they don't address the question of non-free at all.
19:53:51 <inode0> rdieter: as I understand it we are just talking about non-free stuff here
19:53:56 <abadger1999> eof
19:54:18 <jforbes> eof
19:54:20 * gholms agrees with abadger1999
19:54:34 <adamw> ! (short one)
19:54:36 <jwb> inode0, basically correct.  the FESCo policy covers everything else
19:54:43 <rbergeron> Proposals? Anyone?
19:54:50 * rbergeron gets out the cat prod
19:54:58 <rbergeron> adamw: go
19:55:09 <mjg59> So: I am fine with making it easier to install non-free software in Fedora, but primarily in the context of making it easier to manage third-party repositories in general. So my answer to the current topic (as I understand it) is yes. But I am not ok with Fedora shipping repository metadata that points to non-free software.
19:55:17 <adamw> i'd just note the existence of things like Korora
19:55:29 <jreznik> mjg59: exactly same here
19:55:46 <notting> !
19:55:46 <adamw> we already have a reasonable channel for the production of what is essentially a Fedora variant with less strict freedom policies; seems like something to consider.
19:55:50 <rbergeron> Or vote as proposed.
19:55:59 <jreznik> but I'd add "without users consent"
19:55:59 <rbergeron> notting: yes
19:56:00 <mjg59> Or for Fedora to host a service that does so, or ship tools that are primarily intended to facilitate the finding of third party repository metadata
19:56:07 <jwb> adamw, are you suggesting the Workstation WG move their efforts to the korora project?
19:56:08 * gholms attempts to write a little proposal
19:56:09 <mclasen> ?
19:56:09 <Sparks> Shipping third-party repos could also be a security concern since we'll have no control over what goes into those repos.
19:56:22 <mjg59> Sparks: That's more a fesco-level issue
19:56:22 * mclasen retracts his questions as jwb essentially just asked it
19:56:35 <Sparks> mjg59: Just pointing oiut the obvious here.
19:56:50 <mclasen> !
19:57:03 <rbergeron> mclasen: yes
19:57:05 <notting> well,mjg59 sort of answered what i was going to ask - if the user accepts third-party software as an option, do board members consider it "ok" if that enables a service that returns both free and non-free software? (for reasons explained on the list, i think shipping repository information/metadata in fedora/packages is a bad idea.)
19:57:06 <adamw> jwb: well, depends what you mean by 'efforts'. 'efforts' in this *specific* direction could be accomplished with less necessity to modify fedora's foundations by collaboration with a non-fedora branded project.
19:57:15 <mclasen> Sparks: enabling the repos will still be an explicit user action - how is a nonenabled repo a security issue ?
19:57:16 <mjg59> jwb: I think the question is more: If the only difference between Fedora and Korora were the shipping of repository metadata for non-free software, would that be considered wasted time on the part of the workstation working group?
19:57:38 <jreznik> adamw: from the beginning (or even before products) I was ok with Fedora being a platform for products that would go beyond Fedora
19:57:42 <Sparks> mclasen: Depends on the implementation.
19:57:58 <jwb> adamw, mjg59, it has implications as to which project the WG recommends as "best of class", which impacts the marketing of the product, which impacts Fedora
19:58:31 <otaylor> !
19:58:34 <rbergeron> folks: I hate to oint out that we are 3 min. from thehour with several questions left on the table. But I'm doing it anyway.
19:58:35 <adamw> jwb: sure. I agree. my intent was not to make a specific suggestion, just to ensure the discussion considered the 'non-Fedora-branded, Fedora-derived' product class.
19:58:57 <mjg59> Proposal: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations
19:59:00 <jwb> adamw, mjg59: fair.  i simply do not think driving desktop/workstation users to another project is going to help increase Fedora users or contributors
19:59:11 <cschalle_> adamw, well I think if we where to consider anything apart from fedora itself, CentOS is probably the closest due to latest developments
19:59:22 <mclasen> ?
20:00:10 <mjg59> cschalle_: Sorry, I may be reading too much into that - you're not suggesting that the workstation WG should base its product on CentOS, are you?
20:00:14 <jreznik> mclasen: not security but I can imagine legal - now, if you install Fedora, you can be pretty much sure it's all free open under sane license... could be problem for companies - you're right repo would not be enabled but still showing in results something, that could break policies is not good and everyone would have to audit what's in search results (or disallow users to add repos - not ease of use anymore)
20:00:37 <jwb> mjg59, probably no more than you/adamw were suggesting it base it on korora
20:00:41 <cschalle_> mjg59, I was just responding to adamw, that if we where to move the effort off fedora as he suggested, centos would be a more likely target
20:00:44 <sgallagh> !
20:00:48 <rbergeron> mjg59: Would it be fairl to add something along the lines of, "but is willing to consider other options"
20:00:50 <mjg59> cschalle_: I think you're misinterpreting adamw
20:00:54 <rbergeron> or not really.
20:01:03 <rbergeron> sgallagh: yes
20:01:17 <sgallagh> jreznik: Companies installing Fedora generally are either behaving in a BYOD mode or else have strict policies on what software can be installed.
20:01:20 <gholms> mjg59: +1, but I'd like to mention that that should not preclude ease-of-use improvements for adding third party repositories in general
20:01:39 <gholms> If there's a way to make it easier to manage repositories, that's still a good thing.
20:01:47 <jreznik> sgallagh: small companies? yes, I know, small companies does not take care of licenses but...
20:01:52 <sgallagh> jreznik: I'm not sure the licensing of the repos is a concern in either case. (In the first, it's up to the user of the device, the second the corporate policy) EOF
20:02:02 * inode0 agrees with mjg59's proposal as stated
20:02:09 <mjg59> cschalle_: He's suggsting that if Fedora were a perfect OS with the exception of including repository metadata pointing at non-free software, then some Fedora derivative could provide that additional functionality
20:02:16 <mclasen> ?
20:02:29 <rbergeron> mclasen: go ahead
20:02:47 <EvilBob> rbergeron: I posted a ! 15 minutes ago
20:03:01 <jwb> EvilBob, thank you for being patient
20:03:02 <rbergeron> EvilBob: augh. i apologize - go ahead.
20:03:06 <EvilBob> How is Red Hat legal going to approve any of this? Have the laws changed that much, or is it the staff that has changed? Once upon a time we could not even mention third party repos. I know there is a lot of "looking the other way" as far as the Wiki goes but is that really a good enough excuse?
20:03:12 <mclasen> mjg59: do you consider shipping data that would allow us to go from a search term like 'chrome' to a repo url to be 'shipping repository information' ?
20:03:19 <mjg59> Proposal 2: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations. However, this should not be interpreted as making it easier for users to make an informed choice to install non-free software provided by third parties.
20:03:34 <mjg59> mclasen: If that's the primary purpose of that data, yes
20:03:41 <EvilBob> I don't get why this is even a question now, it's been denied in the past.
20:03:49 <EvilBob> repeatedly
20:03:53 <jreznik> mjg59: proposal #2 is better
20:04:11 <jreznik> EvilBob: we can't live in the past forever
20:04:14 <jwb> EvilBob, the difference is these repositories will be very limited in what they can offer.  e.g. mp3 codecs: no.  a specific repo for flash, possibly if legal approves
20:04:38 <jwb> EvilBob, this is not approval of e.g. rpmfusion.  and i believe cschalle_ did some due diligence with legal before bringing this to the table to begin with
20:04:48 <cschalle_> I did
20:04:48 <gholms> mjg59: +1, as written.  Thank you.
20:04:53 <rdieter> EvilBob: true, legal requirements will greatly limit the scope of how this works, no matter what.
20:05:07 <mitr> mjg59: "informed choice" like e.g. a link that can be clicked to download the software?  I'm getting lost in the word-splitting.
20:05:21 <adamw> is there a word missing from proposal #2? I cannot parse it as written.
20:05:21 <EvilBob> jwb: With legal? That's great, I don't see how they have done ANYTHING in understanding Fedora™
20:05:30 <mjg59> jwb: Eh, mp3 codecs aren't inherently problematic, as long as there's an associated patent license
20:05:37 * spot eyes EvilBob
20:05:44 <jreznik> mitr: for me informed choice would be even more than link and it could be part of fedora itself
20:05:49 <adamw> how can a 'negative' determination be 'interpreted as making it easier for users to make an informed choice'?
20:05:52 <jwb> EvilBob, lawyers evaluate what is legally possible.  they do not speak to morals, or project foundations
20:05:52 <mjg59> jwb: So, for instance, legal would presumably be fine with shipping a pointer to the Fluendo codcs (given that they were before)
20:06:16 <jwb> mjg59, IANAL, but if money were paid for a license, maybe.
20:06:24 <mjg59> jwb: It was in that case
20:06:24 <jwb> mjg59, i would put the chances of that fairly low
20:06:31 <Sparks_too> I like proposal 1 better.
20:06:33 <jreznik> it is
20:06:43 <jwb> mjg59, the board killed that iirc, not legal
20:07:00 <jreznik> and for example I'd be ok with revisiting this
20:07:03 <mjg59> jwb: That seems in line with what I said?
20:07:19 <jwb> mjg59, oh, yes.  i misread
20:07:19 <mitr> jreznik: how is that different from a repo, really?
20:07:20 <jreznik> (as part of this discussion)
20:07:27 <rbergeron> mjg59: I think proposal #2 might need a "should not be interepreted as not desiring to make it easier" .. ?
20:07:38 <jwb> rbergeron, i was thinking the same
20:07:54 <jreznik> mitr: no difference, I don't have problem with repo enabled by user consent, I have problem with having that metadata searched before the repo is enabled
20:08:06 <mjg59> rbergeron: Sorry, yes
20:08:10 <mjg59> Let me reword that
20:08:18 <mjg59> Proposal 2: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations. However,  this should not be interpreted as making it easier for users to make an informed choice to install non-free software provided by third parties.
20:08:24 <mjg59> Crap.
20:08:27 <adamw> =)
20:08:54 <mjg59> Proposal 2: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations. However,  this should not be interpreted as a restriction on making it easier for users to make an informed choice to install non-free software provided by third parties.
20:08:57 <cschalle_> freudian slip :)
20:09:09 * gholms accidentally read it that way initially  >_>
20:09:14 <rbergeron> gholms: me too.
20:09:41 * inode0 prefers it without the second sentence which sort of implies we support making it easier in some way which isn't really clear to me either
20:09:54 <rbergeron> Can we vote on proposal 2, now that we're in teh second hour here :) (/me notes the europeans may want to sleep at some point, or possibly the bar...)
20:09:55 <mjg59> inode0: Ok hang on
20:09:59 <Sparks_too> I'm not sure how we can make users have an informed decision without shipping bits telling them about the non-free software.
20:10:00 <inode0> and is a separate question
20:10:12 <gholms> inode0: I support that mainly because I support making it easier to manage all third-party repos.
20:10:15 <mjg59> Proposal 2: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations. However,  this should not be interpreted as a restriction on making it easier for users to make an informed choice to install software provided by third parties
20:10:27 <drago01_> ?
20:10:28 <gholms> Yeah.  Like that.  :)
20:10:29 <mjg59> (free or otherwise)
20:11:15 <Sparks_too> Again, how do we inform users of "other" choices without shipping other choices?
20:11:24 * rdieter thinks people will "interpret" any decision whether not you say "should not be interpreted" at all
20:11:25 <jreznik> Sparks_too: for me that second question could be that "opt-in" thing
20:11:37 <mjg59> Sparks_too: We don't
20:12:21 <mjg59> Sparks_too: We just make it easier for them to use any third party repositories that they find via whatever means
20:12:28 <gholms> Sparks_too: People punch it into Google and find a wiki page, same as they do for Debian.
20:12:28 <jreznik> Sparks_too: so I'm ok with shipping some information by default - it's better to educate than hide
20:12:31 <Sparks_too> Then the proposal doesn't make sense to me.  I'm +1 to the original proposal but I don't like the addition of that sentence.
20:12:47 <mjg59> Sparks_too: I'm answering the question that's in the topic
20:12:59 <robyduck> jreznik: but educating adding a pointer will not work IMHO
20:13:01 <randomuser> !
20:13:07 <mjg59> Sparks_too: We have been specifically asked about ease of use. I don't want us to answer a different question.
20:13:10 <Sparks_too> Mjg59: I'm asking about prop 2
20:13:55 <rbergeron> .....
20:14:05 <mjg59> Sparks_too: Yes, it's a direct response to the question in the topic
20:14:14 * gholms suspects rbergeron is hungry
20:14:31 <rbergeron> no, i'm just trying to move us along as there are other questions
20:14:47 <jwb> rbergeron, i believe the other questions are moot if the answer to this one is essentially "no"
20:14:51 <rdieter> should we have a formal vote then?
20:14:53 * gholms is +1 to mjg59's second proposal
20:15:05 <inode0> My answer is maybe but not in a way that conflicts with the 1st sentence in the proposal ... :)
20:15:26 <Sparks_too> I like the first sentence, not the second.
20:15:26 <rbergeron> rdieter: indeed.
20:15:40 <robyduck> Sparks_too: +1
20:15:44 <jreznik> that proposal sound like no, as I said several times - I can imagine implementation that's anwer would be yea
20:15:52 <mjg59> Sparks_too: Do you feel that Fedora's foundations make it unacceptable to make it easier for users to install non-free software?
20:16:05 <Sparks_too> Yes
20:16:30 <inode0> c'mon
20:16:34 <gholms> Sparks_too: Do you feel that Fedora's foundations make it unacceptable to make it easier for users to install free software that isn't in Fedora?
20:16:45 <Sparks_too> We do not make it more difficult or in any way block non-free software now.
20:16:50 <mjg59> Sparks_too: Do you feel that Fedora's foundations make it unacceptable to make it easier for users to install free but patent-restricted software?
20:17:15 <adamw> !
20:17:24 <Sparks_too> Gholms: who's definition of free?
20:17:38 <robyduck> mjg59: my personal opinion is, it's already easy, but adding a pinter would mean "Fedora now suggest to install 3d party software", and this would be against the 4 foundations.
20:17:38 <Sparks_too> Mjg59: yes
20:17:48 <mjg59> Sparks_too: Ok, I think we're going to disagree on that point
20:17:50 <EvilBob> robyduck: +1
20:18:01 <mjg59> robyduck: I'm not suggesting adding a pointer
20:18:03 <Sparks_too> Robyduck: +1
20:18:06 <robyduck> eof (will not add more confusion)
20:18:29 <kushal> robyduck, +1
20:18:49 <gholms> Sparks_too: Ours.  Stuff that could be added, but isn't.
20:19:06 <Sparks_too> Then add it.
20:19:12 <jwb> i've lost exactly what is being discussed at the moment
20:19:18 <rdieter> sounds like Sparks_too is against COPR's too then
20:19:19 <rbergeron> okay:
20:19:19 <gholms> Sparks_too: Is that a no?
20:19:21 <rbergeron> jwb: yeah...
20:19:26 <jreznik> robyduck: I still think there's space to let users choose non free option if they wish and not hide it but say - what does it mean, what are our values... maybe this issue we are trying to solve now is because we failed to explain this to user... within community we understand it...
20:19:56 <jwb> mjg59 has put a proposal on the table.  please vote, or counter-propose
20:20:01 <rbergeron> I think we still have some grey areas around the wording in mjg59's proposal, or people just flat out against anything at all other than .. editing a text file?
20:20:12 <Sparks_too> Gholms: I'll agree that there is some software that could be used in Fedora that isn't.  It's a slippery slope and there are lots of concerns I have around those repos.
20:20:27 <mjg59> Sparks_too: We're being asked about the foundations
20:20:34 <mjg59> Sparks_too: We're not being asked about whether certain things are a good idea
20:20:39 <robyduck> jreznik: I'm not against let people do what they want, but adding something that could be understand as an official suggestion, that's wrong in my eyes
20:20:58 <mjg59> Sparks_too: I don't think the second sentence in my proposal in any way contradicts our foundations
20:21:18 <Sparks_too> Mjg59: which is why I have to assume those things are being asked and why I won't to allow things like that in.
20:21:32 <mjg59> Sparks_too: We've already (earlier in this meeting!) voted to support fesco's position on third-party repositories
20:21:50 <jreznik> mjg59: yep, let's skip this part
20:21:58 <mjg59> Anyway.
20:22:03 <drago01_> ?
20:22:04 <mjg59> Can we vote on:
20:22:06 * rbergeron sighs
20:22:10 <mjg59> Proposal 2: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations. However,  this should not be interpreted as a restriction on making it easier for users to make an informed choice to install software provided by third parties
20:22:10 <Sparks_too> I'm okay with the first sentence of the proposal.
20:22:16 <mjg59> Sparks_too: So vote -1
20:22:23 <Sparks_too> -1
20:22:24 <mjg59> Sparks_too: And if it doesn't pass then we can just vote on the first sentence
20:22:27 <mjg59> +1
20:22:39 <rbergeron> that sounds reasonable.
20:23:06 <rbergeron> Other votes?
20:23:10 * gholms is +1 either way
20:23:12 <rdieter> -1
20:23:24 * jreznik is still trying to understand all implications of this proposal
20:24:15 <inode0> +1
20:25:04 <jwb> to be clear, if the vote on this proposal fails the question remains unanswered and another proposal will have to be worked out
20:25:16 <jreznik> -1, the first sentence is strict "No" to the question, second sentence let's some possibilities... my answer to the question is more "Yes, but with limitations"
20:25:28 <mjg59> jreznik: No, that's not what it says
20:25:35 <rbergeron> jreznik: I think in essence it says "not okay with this particular methodology, but would consider others that involved an informed choice"
20:26:10 <mjg59> What I *actually* want to say is "The answer to 2(a) is yes, but the answer to what we're really being asked is no"
20:26:26 <mjg59> But anyway
20:26:40 <jreznik> mjg59: then say it, clearly
20:26:45 <mjg59> jreznik: That's what it says
20:27:01 <Sparks> jreznik: I agree with you.  That's how it seems.  No, but maybe.
20:27:05 <jwb> it says, in simple language: "you cannot enable non-free repositories in Fedora.  We encourage you to investigate making it easier to enable third party repositories that do not host non-free software"
20:27:29 <EvilBob> !
20:27:34 <jreznik> mjg59: I'm not native speaker, for me with my English skill I read it as what Sparks said - "No, but maybe"
20:27:37 <mjg59> jwb: In that case I'm not making it clear
20:27:42 <mjg59> jwb: Because that's not what I intended to say
20:27:47 <jwb> then please clarify
20:27:48 <rbergeron> EvilBob: yessir.
20:27:50 <EvilBob> jwb: Then put it in simple language
20:27:56 <jreznik> jwb: exactly
20:28:01 <mjg59> Ok.
20:28:12 <EvilBob> If  you have to explain something in "simple language" you are doing it wrong to start with.
20:28:38 <EvilBob> EOF
20:28:44 <mjg59> Proposal 3: The board does not consider the shipping of repository metadata for facilitating the installation of non-free software to be compatible with Fedora's foundations. Improving the ease of installation of third party repository metadata is not incompatible with Fedora's foundations.
20:28:46 <rdieter> seems I want about the same thing as mjg59 too
20:29:09 * gholms was halfway through typing almost exactly the same thing  :)
20:29:25 <inode0> +1 again and I like this proposal better
20:29:26 <Sparks> mjg59: Why just restrict it to repository metadata?
20:29:34 <rdieter> though I'm finding it difficult to say yes to both 2a/topic and the proposal at the same time.
20:29:36 <mjg59> Sparks: Because that's what we're being asked?
20:29:42 <gholms> Sparks: What would you like to add?
20:30:02 <stickster> !
20:30:03 <Sparks> I'd say that we shouldn't provide/ship anything relating to non-free software.
20:30:13 <rbergeron> stickster: yessir.
20:30:21 <kushal> Sparks, +1
20:30:21 <mjg59> Sparks: Nobody is asking us to ship non-free software
20:30:26 <rdieter> frankly, I'm open to options that allow this stuff
20:30:28 <jreznik> rdieter: I can say yes to 2a, not the proposal... we should vote directly on that proposal and ask people who proposed it to do the changes that could be acceptable for us
20:30:38 <Sparks> mjg59: I didn't say we were
20:30:40 <jreznik> rdieter: +1
20:30:45 <stickster> mjg59: rbergeron: Not sure whether I'm allowed to suggest a proposal rewrite.
20:30:50 <mjg59> stickster: Sure
20:30:56 <rbergeron> stickster: you're the wordsmith :)
20:31:00 <rdieter> and I interpret the proposal as saying no, we don't want this
20:31:01 <stickster> mjg59: rbergeron: I have no desire to confuse anyone. I'm trying to make an honest try at a better #3
20:31:30 <jreznik> rdieter: yes, I'm not sure how to put it into proposal
20:31:32 <rbergeron> stickster: by all means, please share.
20:31:33 <stickster> "The Board does not find it acceptable to ship repository metadata for non-free software.  However, the Board is willing to consider other ways for users to choose third-party software that don't require Fedora to ship repository metadata."
20:32:07 <mjg59> stickster: No, that's not really the same thing
20:32:08 <rdieter> silly question, why is repository metadata bad?
20:32:16 <jreznik> stickster: for me this is still pretty strict no - also a bit game what metadata would mean in this context
20:32:25 <mjg59> rdieter: Because it results in us advertising non-free software
20:32:34 <jreznik> rdieter: and what everything metadata means now?
20:32:38 <Sparks> I still don't like leaving the window open to shipping information on non-free software in other than repo metadata.
20:32:40 <rdieter> as long as it's opt-in, I don't mind
20:32:59 <jreznik> rdieter: +1
20:33:01 <rdieter> that's why I'm voting -1
20:33:03 <mitr> mjg59: providing "informed choice" does just as well
20:33:03 <stickster> OK, I thought I was capturing the idea, but missed. Please disregard.
20:33:06 <stickster> eof
20:33:58 <jreznik> rdieter: any idea how to put it into words/proposal? /me is thinking but it's thin ice
20:34:00 <mjg59> Basically: If a user makes an informed choice to search for non-free software, I want there to be as few *technical* barriers to that as possible
20:34:33 <EvilBob> !
20:34:35 <stickster> !
20:34:40 <jwb> Sparks, regardless of my stance on software, i think it's important to honor a user's choice
20:34:51 <jreznik> mjg59: does opt-in fit this?
20:34:51 <rbergeron> evilbob and stickster, go ahead.
20:34:54 <mjg59> jreznik: No
20:34:54 <EvilBob> mjg59: How is installing an rpm a barrier?
20:35:08 <Sparks> I want this to be a clear line that we don't advocate, ship, or advertise the use of any non-free software.
20:35:10 <EvilBob> mjg59: Really I want to know who this is "hard" for
20:35:12 <mjg59> EvilBob: I'm going to ignore that question because I think it demonstrates that you don't understand what we're talking about
20:35:14 <jreznik> mjg59: that's why I'm -1
20:35:24 <mjg59> jreznik: That's fine
20:35:36 <EvilBob> You are talking about making something that is NOT hard, easier, I want to understand.
20:35:50 <jreznik> and for me "informed choice" is opt-in
20:35:51 <mjg59> EvilBob: It is not easy, and people do not find it difficult because they are stupid or lazy
20:35:56 <robyduck> EvilBob: +1
20:36:07 <rdieter> EvilBob: it's only about making it easier, even if the starting point isn't all that hard to begin with.
20:36:28 <stickster> ISTM there's a question about what spans the gap to the user making that informed choice.
20:36:47 <stickster> That's the gap that I see cschalle_ struggling with.
20:36:52 <jreznik> stickster: yep
20:36:54 <rbergeron> Sparks: so - informed choice, essentially. Where we are informing them of what Fedora does / does not provide, but not pointing them to specific places.
20:37:17 <adamw> ! (quick one)
20:37:34 <rbergeron> adamw: go.
20:37:35 <adamw> the "informed choice" wording was dropped from both proposal 3 and stickster's rewrite.
20:37:36 <mjg59> stickster: Given that installing Acrobat Reader on Windows involves obtaining it from adobe.com, I don't think the majority of users find explicitly searching for a piece of non-free software an insurmountable barrier
20:38:05 <stickster> adamw: True, and I was kind of realizing the above based on the reaction to the rewrite.
20:38:06 <inode0> I could not agree more on that point
20:38:19 <drago01_> rbergeron: am I on some kind of blacklist or what I am doing wrong?
20:38:21 <mitr> Actually I'd expect  this to benefit popularity of the GNOME app installer more than some of the the proprietary applications...
20:38:42 <rbergeron> drago01_: sorry, did i miss you? /me apologizes - go ahead
20:38:43 <Sparkz> Rbergeron: It's okay for the user to go install a third-party repo but we shouldn't have anything to do with that.
20:38:45 <mjg59> mitr: I would expect the GNOME app installer to continue to be the UI that people would use to actually install the software
20:38:45 <stickster> So what I'm saying is, the Board may be answering useful questions here, but also that gap needs to be addressed.
20:38:49 <stickster> eof
20:38:53 <pjones> mjg59: to be fair, there are millions of links to install that particular malware all over the internet.
20:38:55 <adamw> oh, eof.
20:39:02 <rbergeron> lots of things scrolling by and also thinking as well.
20:39:11 <mitr> mjg59: "continue to" is rather a stretch at least around here
20:39:36 <mjg59> mitr: We're expecting it to be the primary software installation UI in the workstation product
20:39:45 <jwb> mitr, this is a proposal brought by the Workstation product
20:39:54 <jwb> the other products/WGs don't have to adopt it
20:40:08 <jwb> though tbf, we haven't officially declared a DE yet
20:40:20 <drago01_> mjg59: that's not true because windows user just buy pcs with the software preinstaleld ... but anyway my question is "what are we trying to achieve by not allowing pointing to such repos?" just pretending that something does not exits does not make it not exists
20:40:47 <drago01_> "censorship" and freedom somehow do not mix
20:40:48 <drago01_> eof
20:40:54 <mjg59> drago01_: It's not censorship
20:41:03 <mjg59> Because it's our speech
20:41:12 <stickster> !
20:41:16 <mjg59> Nobody external is controlling it for us
20:41:28 * jreznik still thinks we should vote on original cschalle_ proposal and if we say no (and it seems like we say no to that explicit proposal), tell them in what cases it would be ok to make users life easier and ask them to rework
20:41:34 <threebean> mjg59: +1
20:41:45 <mjg59> jreznik: I believe that this proposal does that
20:41:59 <rdieter> mjg59: I don't think it does
20:42:01 <robyduck> mjg59: for me it does not
20:42:05 <drago01_> mjg59: thats why I used quotes
20:42:12 <mjg59> Ok so let's break this down.
20:42:13 <jreznik> mjg59: no, it doesn't, it solves some generic question that is in the topic
20:42:31 <drago01_> mjg59: but that doesn't answer my question
20:42:33 <mjg59> 1) Is it compatible with Fedora's foundations to ship repository metadata that points at non-free software?
20:42:54 <mjg59> 2) Is it compatible with Fedora's foundations to reduce technical barriers to user installation of third-party software, non-free or otherwise?
20:43:42 <mjg59> Where agreeing with (1) means putting it on the install media would be unacceptable even if it was disabled by default
20:43:54 <inode0> yes, no
20:43:56 <Sparks_too> No / depends
20:44:04 <inode0> sorry
20:44:16 <inode0> no, maybe
20:44:26 <mjg59> Ok
20:44:33 <jwb> does everyone agree the answer to 1 is "no"?
20:44:36 <rbergeron> yes.
20:44:42 <jwb> well, everyone that voted anyway
20:44:44 <mjg59> I don't think everyone agrees with that
20:44:54 <jreznik> I don't agree with that
20:44:54 <jwb> so vote one 1 please
20:45:03 * gholms agrees that the answer to 1 is "no"
20:45:13 <mjg59> Proposal: The board believes that shipping repository metadata that points at non-free software is incompatible with Fedora's foundations
20:45:17 <mjg59> +1
20:45:21 <gholms> Sure.  +1.
20:45:24 <gholms> Still.
20:45:24 <rdieter> -1
20:45:25 <inode0> +1
20:45:28 <jreznik> -1
20:45:30 <Sparks> +1
20:45:42 <mjg59> +4/-2
20:45:48 <mjg59> jwb: Are you recusing yourself?
20:45:53 <jwb> i am
20:45:58 <rdieter> wimp
20:46:02 <gholms> Heh
20:46:03 <rbergeron> hey now :)
20:46:03 <rdieter> :)
20:46:14 <jwb> i'd be happy to state an opinion
20:46:20 <jwb> but i'm recusing myself from the vote
20:46:33 * rbergeron is +1
20:46:38 <mjg59> +5/-2
20:46:41 <jwb> that's quorum
20:46:45 <mjg59> Ok
20:46:47 <jreznik> jwb: what would be that opinion?
20:46:59 <jwb> later.  let's finish this
20:47:15 <mjg59> Proposal 2: The board believes that reducing technical barriers to explicit user choice to install third-party software (non-free or otherwise) is compatible with Fedora's foundations
20:47:21 <rdieter> +1
20:47:24 <mjg59> +1
20:47:27 <jreznik> so seems like +5 for 1) means answer for cschalle_ proposal is -1
20:47:27 <jwb> #agreed The board believes that shipping repository metadata  that points at non-free software is incompatible with Fedora's  foundations
20:47:38 <gholms> +1
20:47:41 <jreznik> +1, sure
20:47:46 <mitr> https://fedoraproject.org/wiki/Board_public_IRC_meetings?rd=Board/IRC#Meeting_protocol says the quorum is +6 ???
20:47:53 <rbergeron> +1
20:47:56 <Sparks_too> Depends on what "easier" means.
20:48:04 <jwb> mitr, it also says DRAFT
20:48:07 * jwb shrugs
20:48:26 <mjg59> jwb's recused, and we're missing two people
20:48:48 <jwb> mjg59, correct
20:48:49 <mjg59> So we can move it to trac, but the only possible remaining outcome is +5/+5
20:49:05 <jwb> +5/+4
20:49:05 <Sparks_too> Sorry, depends on what is meant by reducing.
20:49:11 <inode0> +1 but again how might matter
20:49:19 <pjones> mjg59: which is merely not accepted rather than rejected?
20:49:29 <mjg59> jwb: Oh, true
20:49:42 <mjg59> jwb: Which is if anything even more difficult because then you can't just give someone a casting vote
20:49:43 <drago01_> pjones: the difference is ?
20:49:51 <abadger1999> !
20:49:56 <rbergeron> abadger1999: yes
20:50:07 <pjones> drago01_: I wasn't intending to suggest that the difference is meaningful
20:50:15 <drago01_> pjones: ok
20:50:38 <abadger1999> Since fesco's position is that an active change is needed to make no-free repositories acceptable, a tie vote in the board would probably also mean rejection of cshalle_'s proposal
20:50:45 * gholms counts +5 for the current vote
20:50:45 <abadger1999> eof
20:50:58 <mjg59> Who hasn't voted on poposal 2? Sparks and…
20:51:14 <pjones> abadger1999: as a fesco member that'd be my interpretation as well.
20:51:28 <rbergeron> myself
20:51:37 <Sparks_too> 0
20:51:48 <mjg59> rbergeron: Oh, sorry, yes
20:51:58 <rbergeron> +1 on #2
20:52:03 <gholms> #accepted The board believes that reducing technical barriers to explicit user choice to install third-party software (non-free or otherwise) is compatible with Fedora's foundations. (+6, 1, -0)
20:52:13 <Sparks_too> I'm concerned that this is leeway to advertising non-free software outside a repo.
20:52:32 <mjg59> Sparks_too: We arguably do that at present (in the form of the wiki)
20:52:45 <mjg59> Sparks_too: So that's something we probably need to have a broader discussion about
20:52:52 <jwb> yes.  which is a point i was trying to make that seems to have been entirely lost
20:52:54 <adamw> i'd have found 'not inherently incompatible' a less loophole-y wording, but it doesn't seem bad.
20:53:02 <Sparks_too> Yes, and that's not technically supposed to be there.
20:53:03 <pjones> From a technical perspective, I would say that #2 would allow us to, for example, explain how to configure a nonfree repo on a website.
20:53:17 <inode0> I would agree with adamw there
20:53:20 <jwb> gholms, does accepted work with zodbot the same was agreed does?
20:53:31 <hadess> mjg59, do we have somewhere planned a discussion about free but restricted software?
20:53:38 <jreznik> let's do agreed
20:53:40 <jwb> gholms, ah, seems yes
20:53:41 <mjg59> hadess: As in patent-restricted?
20:53:53 <mjg59> hadess: Or other geographical/political reasons?
20:53:55 <jreznik> pjones: I understand it that way too
20:53:56 <gholms> jwb: #accepted and #rejected are relatively recent additions that work similarly.
20:54:05 <jwb> gholms, yeah, thanks
20:54:11 <hadess> mjg59, mostly patent-restricted
20:54:16 <rbergeron> okay.
20:54:19 <hadess> mjg59, i don't really know about the latter
20:54:20 <jreznik> hadess: restricted is something that would never pass legal
20:54:23 <mjg59> hadess: I think shipping that would be compatible with Fedora's foundations
20:54:33 <mjg59> hadess: But incompatible with our legal restrictions
20:54:36 <jreznik> mjg59: yep
20:54:39 <gholms> ^ Yep.  That.
20:54:58 <mjg59> hadess: So if you can work out a technical mechanism that solves that problem to legal's satisfaction, I don't see it as being something (personal opinion) that the board would have a problem with
20:55:04 <rbergeron> i'm doing a clock check; we have questions remaining still
20:55:04 <Sparks_too> If it makes it difficult/impossible for others to remix Fedora...
20:55:14 <hadess> mjg59, as somebody asked legal to find a way?
20:55:24 <hadess> s/as/has/
20:55:29 <spot> !
20:55:42 <rbergeron> spot: go
20:55:43 <jreznik> rbergeron: no more questions please! not today!
20:56:03 <spot> The wiki page was created with careful and explicit approved wording choices as "the way".
20:56:05 <spot> eof
20:56:24 <drago01_> spot: link?
20:56:38 <spot> https://fedoraproject.org/wiki/Third_party_repositories
20:56:47 <drago01_> thx
20:57:09 <jreznik> spot: so this way free but restricted bits fits the second proposal we agreed on and such there's no difference
20:57:51 <hadess> spot, and there's no way to do any more than that, even using geolocation as a restriction, etc.?
20:58:13 <spot> hadess: no, because red hat is still the liable distributor.
20:58:24 <jwb> does anyone see any reason to continue with the other sub-questions on the agenda?  i believe they are rendered moot by this decision, and it's why i structured them as sub-questions
20:58:24 <mjg59> hadess: I think that's a conversation that would work better elsewhere
20:58:53 <spot> hadess: i'd be happy to discuss this directly with you (or whomever) separately
20:59:04 <mjg59> jwb: I don't see any obvious reason to continue
20:59:09 <hadess> mjg59, sure, that was pretty much the only thing that was of interest to me in this meeting
20:59:15 <rbergeron> jwb: i think you're right
20:59:45 <mjg59> hadess: Like I said, from the board perspective I suspect it would be fine
20:59:47 <jreznik> hadess: we can try to find donors to pay licenses for that restricted pieces :) that's probably one solution
20:59:54 <hadess> spot, i'll drop you mail then
20:59:56 <mjg59> hadess: Figuring out implementation details that legal would be happy with is kind of out of scope
21:00:00 <hadess> jreznik, i have no interest in that
21:00:06 <inode0> well, we did not rule out ease of use improvements so 2b seems still barely alive
21:00:14 <hadess> mjg59, point taken
21:00:15 <abadger1999> !
21:00:17 <rbergeron> if no objections i'll end; any volunteers to summarize / do minutes?
21:00:30 <rbergeron> abadger1999: go
21:00:38 <abadger1999> jreznik: Be careful about thinking of licensing in that way.
21:01:00 <abadger1999> Even if we get a license to distribute, it probably would not extend to other people redistributing us.
21:01:12 <jreznik> abadger1999: ah, correct
21:01:17 <abadger1999> Which would bring it back to a baord question of non-free software.
21:01:17 <Sparks_too> Abadger1999: +1
21:01:18 <abadger1999> eof
21:01:34 <gholms> Let's worry about that distraction later.
21:01:39 <mjg59> jwb: As the remaining WG member here, do you think 2(b) needs to be discussed?
21:01:58 <jwb> mjg59, no
21:02:04 <mjg59> Sounds reasonable
21:02:05 <drago01_> one more question how is christians proposal different from lets say firefox's plugin finder?
21:02:05 <inode0> ok
21:02:33 <mjg59> drago01_: That is an excellent thing to have a discussion about
21:03:00 <mjg59> drago01_: I don't think this is exactly the place for it, though
21:03:16 <mjg59> (Well, s/place/time/)
21:03:25 <Sparks_too> !
21:03:28 <drago01_> mjg59: maybe not time but if that isn't the place what is it?
21:03:36 <drago01_> mjg59: ok
21:03:39 <rbergeron> okay;i'll take minutes duty... anytjing else?
21:03:43 <mjg59> drago01_: advisory-board seems like a good option
21:03:59 <Sparks_too> I think we left open the window to allowing advertisement of non-free software outside of a repo.
21:04:00 <rbergeron> sparks: yez
21:04:21 <gholms> Sparks_too: Yes, we did.  We can address that when needed.
21:04:43 <jreznik> drago01_: especially as it pretty much fails in fedora...
21:04:52 <Sparks_too> I'm not sure that we'd get the question since we already left the window open.
21:05:23 <adamw> that's what i wanted to preserve with the 'not necessarily incompatible' wording instead of 'compatible'; the board's right to look at future proposals.
21:05:23 <inode0> would like to discuss our advertising of it elsewhere as well?
21:05:27 <drago01_> jreznik: that's not the point though
21:05:45 <mjg59> adamw: We're not dealing with legislation here
21:05:46 <jreznik> drago01_: but I know where you're heading and I was thinking about it too
21:06:01 <mjg59> adamw: We're free to clarify things later
21:06:15 <pjones> adamw: the board, like fesco, always retains the right to rule on things again later.
21:06:28 <adamw> mjg59: i think the way the structures are set up - 'don't call in the board unless you have to' - you have to be careful with it, though. the statement as it reads is kind of invitation for people to try and get clever with the wording. still, it's not too bad.
21:06:29 <Sparks_too> Inode0: as a matter of Project-wide policy, sure.
21:07:13 <mjg59> Sparks_too: Please, bring this up on advisory-board
21:07:26 <rbergeron> i would like to think people arent goibg to quietly exploit loopholes in the next week or two. i think we can further clarify, but this is a start.
21:07:29 <Sparks_too> Okay, I can do that.
21:07:32 <mjg59> And let's see where people feel that the boundaries should be
21:07:33 <jreznik> adamw: if people would be too clever and would invent ways how to not follow Board agreement, we can always step into
21:07:54 <rbergeron> and with that.
21:08:06 <adamw> jreznik: yup, as long as people keep an eye on what's happening i'm sure it'll be fine.
21:08:11 <Sparks_too> Jreznik: And we all know how well that works...
21:08:16 <rbergeron> i'm going to end meeting.
21:08:18 <jreznik> btw. this topic could be revisited pretty soon as the new board would be established pretty soon
21:08:20 <pjones> rbergeron: would it be worth appending that the ruling is intended to be guidance for further proposals, rather than a hard and fast ruling on a new thing that's allowed?
21:08:31 <jreznik> Sparks_too: does not work at all, I know :D
21:08:36 <drago01_> I don't think we have any reason to think that people will sneak in stuff
21:08:36 <pjones> rbergeron: specifically on #2 that is
21:08:58 <Sparks_too> Jreznik: fool me once...
21:09:03 <drago01_> if we have that much trust in people doing things we should just give up now
21:09:10 <jreznik> btw. can we move to open floor, I have one topic to raise
21:09:27 <rbergeron> pjones: sure, if nodoy else objects.
21:09:32 <mjg59> jreznik: I don't see anyone objecting
21:09:44 <jreznik> ok, thanks rbergeron
21:09:51 <inode0> what is guidance now?
21:10:24 <jreznik> regarding elections, we hit it yesterday on fesco meeting - we're pretty much delayed as cwickert is f*cking busy (using his words to emph it)
21:10:44 <jreznik> so help is needed
21:10:56 <jreznik> and we should officially announce delay in elections
21:11:33 <Sparks_too> Jreznik: What is needed?
21:11:35 <jreznik> and I have to agree with pjones what he said yesterday  - we have to make that process better
21:11:59 <jreznik> Sparks_too: I'd say new Elections Wrangler or at least assistant to him
21:12:32 <Sparks_too> Just someone to setup the software and do the announcing?
21:12:36 * abadger1999 can handle the technical aspect of entering the election into the system if needed but someone else should do all the policy/announce stuff. -- new election wrangler would be even better as I'm a candidate this cycle.
21:13:17 <abadger1999> and if the new wrangler wanted to do the software setup, that's even better for the same "i'm a candidate" reason.
21:13:37 <jreznik> Sparks_too: there were some questions asked - christoph wanted it to be covered on townhalls, but even townhalls were delayed as it's pretty hard to schedule them
21:13:38 <Sparks_too> I'm happy to do the announcing and the software if I can find the doc.
21:14:15 <Sparks_too> I'm afraid I don't have a lot of time to spend on townhalls.
21:14:18 <abadger1999> Sparks_too: I'll point you to the software doc after the meeting... don't know about the rest of the election wrangler duties
21:14:19 <jreznik> so now, I'd say we should delat elections and one remaining question is what to do with questionaires and townhalls
21:14:42 <jreznik> abadger1999: schedule townhalls, process questionaires
21:14:49 <jreznik> and do proper announcements
21:14:50 <rbergeron> were questionnaires sent out?
21:14:50 <inode0> there were no questions so there is no questionnaire
21:14:54 <inode0> that part is easy
21:14:59 <rbergeron> ah yes
21:15:00 <Sparks_too> Done!
21:15:03 <jreznik> inode0: there were questions!
21:15:05 <Sparks_too> :)
21:15:09 <inode0> not when I looked
21:15:36 <jreznik> inode0: mattdm asked question and christoph confirmed to me were there and he wanted to cover them as part of townhalls
21:16:02 <jreznik> but got stuck with scheduling timehalls - it's hard to do so especially if you're busy with non-fedora stuff
21:16:24 <mattdm> I may have put the questions into the wrong wiki page....
21:16:28 <abadger1999> Sparks_too: software setup doc: http://infrastructure.fedoraproject.org/infra/docs/voting.txt
21:16:31 <gholms> D:
21:16:41 <inode0> I'm looking at the page and it doesn't appear there were any questions posted by the deadline - but we can be flexible
21:16:42 <jreznik> so he asked me, if I can find help
21:16:43 <jreznik> it's not stepping on his role, life happens
21:16:44 <Sparks> abadger1999: Okay
21:17:24 <jreznik> so if there's anybody to process that questions and try to organize townhalls or do we actaully still want townhalls?
21:17:46 <Sparks> jreznik: I can probably set everything up if I can find someone to host the townhalls.
21:17:47 <jwb> no
21:18:20 <inode0> https://fedoraproject.org/wiki/Elections/Questionnaire
21:18:25 <rdieter> is ok with no townhalls, or even leave it to the discretion of the wrangler
21:18:28 <inode0> mattdm: is your question there?
21:19:19 <pjones> Can we add "is shipping repository metadata that points at non-free software incompatible with Fedora's foundations?"
21:19:45 <jreznik> pjones: and this could drive elections...
21:19:49 <adamw> it appears to be open for additions
21:19:52 <pjones> jreznik: I very much think it should.
21:20:00 <adamw> pjones: i was about to add something like that right now.
21:20:08 <mattdm> inode0 no,  I mistakenly put them into https://fedoraproject.org/wiki/Development/SteeringCommittee/Nominations
21:20:14 <inode0> yeah, the deadline was the 13th though, it just wasn't tended to
21:20:15 <pjones> adamw: okay, I'll let you do it if you're already on it.
21:20:23 <mattdm> there was a section which looked right at the time
21:20:26 <adamw> yup.
21:20:29 <mattdm> but clearly is wrong
21:20:47 <jreznik> so proposal: continue with questionaire, extend deadline for it and dismiss townhalls
21:21:02 <mattdm> they aren't the most bestest questions ever, but I thought we should have at least some
21:21:15 <rbergeron> sure. +1.
21:21:21 <gholms> Sure.  That works.
21:21:35 <jreznik> it also means slip voting
21:21:53 <Sparks> jreznik: Ehh, the ballot counters won't mind.
21:22:14 <rbergeron> jreznik: by what, a few days?
21:22:18 <inode0> we are already slipping voting
21:22:21 <jreznik> yep
21:22:36 <gholms> Since that's going to happen anyway, though...
21:22:47 <jreznik> so use that voting period as extended time for questionaires, deadline jan 30
21:23:10 <inode0> we could restart at schedule townhalls and go, or just reschedule voting and go
21:23:11 <jreznik> and then voting by 6th?
21:23:40 <jreznik> inode0: that's the question if we still want townhalls... it's hard to setup and outcome is minimal
21:23:50 <rbergeron> thta's a long time to answer how many questions?
21:23:53 <inode0> I don't think townhalls are our choice
21:24:11 <inode0> do fesco and famsco still want them
21:24:20 * Sparks has to go collect 'the boy'.
21:24:27 <rbergeron> sparks: give him hugs. thanks for coming
21:24:42 <Sparks> I'll happily handle the elections stuff for this round, though.
21:24:52 <rbergeron> sparks: thank you for that.
21:25:04 <jreznik> so do we prefer what inode0 said - restart from the point of townhalls?
21:25:30 <Sparks> jreznik: Yeah, even if there isn't a lot of participation it's good to have the option to ask questions.
21:25:31 * gholms has to go now
21:25:33 <inode0> we can ask fesco and famsco if we can drop the townhalls too
21:25:45 <jreznik> as it's correct fesco or famsco can be in favor of townhalls and one question for both could be - do we want to get rid of townhalls?
21:26:09 <mjg59> One thing we should probably consider is whether "Reopen nominations" is a rational thing to add in the case of a small number of candidates
21:26:10 * inode0 does want to get rid of them in their current form
21:26:10 <jreznik> inode0: so let's follow old process this time and ask famsco, fesco
21:26:25 <jreznik> inode0: +1
21:26:55 <jreznik> mjg59: are you going to force people to run for elections? /me usually tries it with a few folks...
21:27:21 <adamw> jreznik: i suspect more people may be interested in running as a result of this meeting.
21:27:24 <adamw> s/suspect/know/
21:27:39 <jreznik> adamw: that's what I was thinking about too
21:27:49 <inode0> mjg59: do you mean now or add that to our rules so we don't end up with everyone running getting elected?
21:27:51 * jreznik is ok with both
21:28:08 <mjg59> inode0: To our rules. I think it's unreasonable to alter election rules once we're at this point of the cycle.
21:28:24 <inode0> ok, that is fine with me
21:28:24 <jreznik> but needs some sleep as he's ready-to-be sicks and can't afford being sick this week
21:28:41 * abadger1999 not on board but agrees with mjg59
21:28:41 <mjg59> I'll bring that up on advisory-board
21:29:12 <jreznik> mjg59: thanks
21:29:38 <inode0> I'm not opposed to the way the board rules are either - waiting/delaying things to get one person to run and lose doesn't seem entirely productive to me
21:29:58 <jreznik> and thanks Sparks for volunteering - it would be nice to sync with cwickert not to act both
21:30:55 <rbergeron> okay.
21:31:28 <rbergeron> are we clear on action items now or still have questions
21:32:11 <jreznik> if I understand it correctly - put elections on hold now and discuss it on advisory-board (restart nominations? restart from townhalls etc)...
21:32:50 <jreznik> and we should announce this "on hold" thing or call it delay whatever
21:33:22 <rbergeron> I think so.
21:33:36 <rbergeron> Do we need an announcement wrangler or is that part of what sparks signed up for
21:34:20 <jreznik> part of what Sparks signed up for
21:34:25 <rbergeron> okay.
21:34:33 <rbergeron> So I think we have that solved -
21:34:35 <jreznik> but would be nice to have more people around and coordinated
21:34:47 <rbergeron> can we .. end? :)
21:35:01 <jreznik> rbergeron: yes please!
21:35:12 <jreznik> Sparks: could you ack that announcement part?
21:36:04 <rbergeron> sparks had to go pick up kid.
21:36:11 <rbergeron> we can sync with him later on :)
21:36:38 <rbergeron> okay. I'm ending the torture. Guys: I really super appreciate your effort today - I know this was a heinously long meeting.
21:37:25 <rbergeron> I'll send out minutes after I grab my kids from schooling.
21:37:32 <rbergeron> #endmeeting