fpc
LOGS
17:01:55 <abadger1999> #startmeeting fpc
17:01:55 <zodbot> Meeting started Thu Dec 12 17:01:55 2013 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:01 <abadger1999> #meetingname fpc
17:02:01 <zodbot> The meeting name has been set to 'fpc'
17:02:06 <abadger1999> #topic Roll Call
17:02:21 * RemiFedora here
17:02:23 <abadger1999> tibbs|w and limburgher are here but busy with other things as well.
17:02:32 * SmootherFrOgZ here
17:02:35 <abadger1999> #chair tibbs|w limburgher RemiFedora SmootherFrOgZ
17:02:35 <zodbot> Current chairs: RemiFedora SmootherFrOgZ abadger1999 limburgher tibbs|w
17:02:55 <abadger1999> geppetto: are you here?
17:02:57 * limburgher but here-ish
17:03:05 <abadger1999> racor sent his regrets
17:03:24 * geppetto is here
17:03:29 <tibbs|w> I also have a hard stop in just over an hour.  Busy day.
17:03:36 <abadger1999> #chair geppetto
17:03:36 <zodbot> Current chairs: RemiFedora SmootherFrOgZ abadger1999 geppetto limburgher tibbs|w
17:03:40 <abadger1999> tibbs|w: okay.
17:05:13 <abadger1999> #topic SCLs
17:05:28 <abadger1999> I've been looking at this but...
17:06:38 <abadger1999> The problem of multi-vendors seems to affect a lot of the guidelines.
17:06:55 <abadger1999> I'm going to bounce some ideas off mattdm and see if there's a direction I should take.
17:07:17 <abadger1999> #topic #358 autotools guidelines
17:07:41 <abadger1999> I havent had time to work on this this week.  If anyone else does, feel free.
17:08:11 <abadger1999> 372 and 362 were taken care of already (kernel event lib and lpf)
17:08:19 <abadger1999> #topic #371     Packages approved without satisfied dependencies
17:08:23 <abadger1999> https://fedorahosted.org/fpc/ticket/371
17:08:59 <tibbs|w> Definite -1 from me.
17:09:19 <limburgher> A draft would be neato-keen.
17:09:24 <tibbs|w> Otherwise reviewing some dependent packages becomes even longer of a process than it is now.
17:09:46 <Rathann> hi, sorry for being late
17:10:17 <abadger1999> #chair Rathann
17:10:17 <zodbot> Current chairs: Rathann RemiFedora SmootherFrOgZ abadger1999 geppetto limburgher tibbs|w
17:10:21 <RemiFedora> -1
17:10:52 <RemiFedora> as sometime have to approve package without their dependency (packages stack, with some circular dep)
17:11:34 * Rathann notes it's a SHOULD not a MUST
17:11:51 <RemiFedora> right
17:11:59 <abadger1999> yeah, I'm -1 to the draft in the proposal
17:12:06 <RemiFedora> fedora-review already have a check 'package should install"
17:12:10 <limburgher> I'm -1 also.
17:12:24 <SmootherFrOgZ> -1 as well.
17:12:37 <limburgher> RemiFedora: Not everyone uses that, some do it manually, the old-fashioned way. ;)
17:12:41 <Rathann> +1 from me, actually
17:12:49 <Rathann> exactly for that reason
17:13:02 <geppetto> I mean … I see too much stuff where an update has the same problem.
17:13:06 <abadger1999> #info Blocking a package review until all dependencies of hte package are satisfied rejected (+1:1, 0:0, -1:5)
17:13:36 <abadger1999> Do we want to add a guideline that says packages shouldn't be built until all their dependencies are met?
17:13:56 <SmootherFrOgZ> well, that should be obvious
17:14:00 <geppetto> :)
17:14:02 <abadger1999> (Even though it won't affect package reviews and therefore won't have a way of being enforced)
17:14:31 <limburgher> abdager1999:  It *should* be obvious. . .but. . .maybe we need to spell it out. . .
17:14:32 <abadger1999> SmootherFrOgZ: Yep, agreed.  But we've had to write obvious guidelines before.
17:14:40 <geppetto> It'd be better if they didn't get into the compose if they didn't have their deps. met … but we've been saying that for like 10 years :)
17:14:48 <abadger1999> common sense isn't common :-/
17:15:09 <abadger1999> OTOH -- I bet that the majority of these cases are simply that a packager forgot about the missing dep
17:15:21 <abadger1999> So a guideline won't help.
17:15:30 <geppetto> yeh, or it changed/etc.
17:16:12 <geppetto> They generally hear about it pretty quickly … maybe would hear about it faster if the update didn't get into the compose (and that would still allow the older working version) … but, meh.
17:17:18 <abadger1999> I guess no way to know unless we vote..
17:17:20 <abadger1999> Proposal: Packages should not be built unless all of their Dependencies are satisfied
17:17:50 <abadger1999> weak +1
17:18:08 <abadger1999> don't think it will help but otoh, it won't hurt.
17:18:19 <SmootherFrOgZ> yeah +1 then
17:18:21 <limburgher> meh.  +1
17:18:23 <geppetto> I guess +1
17:18:34 <Rathann> +1
17:19:18 <abadger1999> #info Packages should not be built unless all of their Dependencies are satisfied Passed: (+1:5, 0:0, -1:0)
17:19:25 <tibbs|w> +1 I guess.
17:19:28 <tibbs|w> Sorry, too slow.
17:19:38 <abadger1999> #undo
17:19:38 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1084f690>
17:19:42 <abadger1999> #info Packages should not be built unless all of their Dependencies are satisfied Passed: (+1:6, 0:0, -1:0)
17:19:54 <abadger1999> #topic Bundling exception for slic3r
17:19:56 <abadger1999> https://fedorahosted.org/fpc/ticket/368
17:20:26 <abadger1999> It's a request for a temporary bundling exception through  F20
17:20:45 <tibbs|w> This is kind of odd.
17:20:53 <tibbs|w> Temporary until it needs to be permanent.
17:20:55 <abadger1999> The exception submitter is slowly merging changes into our system copy of the bundled library
17:21:06 <abadger1999> but he's not yet sure if he'll be able to merge all of the changes.
17:21:29 <abadger1999> So For F21 he'll either know that all changes were okay and he can unbundle
17:21:38 <abadger1999> Or that he needs to reuest a permanent exception.
17:22:00 <SmootherFrOgZ> hm...
17:22:25 <tibbs|w> I mean, I don't have any particular problem with a temporary exception in this case.
17:23:26 <abadger1999> <nod> Yeah I think a temporary exception is fine.
17:23:50 <SmootherFrOgZ> so exception till release f21 to revisit it, +1 I'd say.
17:23:57 <abadger1999> We can look more closely if a permanent exception is reuested for f21.
17:24:30 <geppetto> meh. … it's not like it looks good though.
17:24:35 <abadger1999> Proposal: Grant a temporary exception through F20.  Will revisit if necessary for F21.
17:24:40 <tibbs|w> +1
17:24:44 <limburgher> +1
17:24:45 <abadger1999> +1
17:25:01 <geppetto> I guess I'm ok putting it off until he's tried merging, and see how bad it all is.
17:25:02 <geppetto> +1
17:26:06 <Rathann> +1 from me as well
17:26:10 <RemiFedora> +1
17:26:15 <abadger1999> #info Temporary exception for slic3r to bundle admesh through F20.  Will revisit if necessary for F21.  Passed (+1:7, 0:0, -1:0)
17:27:14 <abadger1999> #topic 374 Ada guidelines changes for Comfignat and runpaths
17:27:19 <abadger1999> https://fedorahosted.org/fpc/ticket/374
17:28:25 <tibbs|w> Way out of my ken here.
17:28:43 <abadger1999> yeah.
17:28:48 * abadger1999 catching up on the ml thread
17:31:42 <limburgher> GNAT_add_rpath?  If that does what I think it does. . .
17:32:47 * SmootherFrOgZ brb
17:33:08 <geppetto> limburgher: see the text, it's supposed to be for %check stuff.
17:33:26 <geppetto> Eg. stuff not installed.
17:33:30 <limburgher> geppetto: OIC, I missed that, thanks.
17:33:54 <geppetto> no problem … my first reaction was also WTF :)
17:34:14 <abadger1999> I think I'm +1 to the comfignat change although I'll reorder it so that gnatmake and gnatbuild isntructions come first and comfignat comes second.
17:34:26 <abadger1999> The GNAT_add_rpath I'm not so certain of.
17:34:32 <abadger1999> I mean, I see what it should be used for
17:34:52 <abadger1999> But I don't see that there's any safeguard to make sure that that's the only place it's used.
17:34:54 <Rathann> I'd add explicit language saying this (GNAT_add_rpath) is not to be used during build, only %check, if at all - you can use LD_LIBRARY_PATH after all
17:35:43 <limburgher> I'm always dubious of %check running on something other than what's installed.  It's either pointless or could generate false positives or negatives.
17:35:52 <geppetto> I'm kind of the other way … in that I understand what the rpath is for, and that seems sane (maybe being a bit more explicit would be good) … but I've no idea about the first change.
17:36:16 <limburgher> So why use rpath in check if it's not in the deployed package?
17:36:16 <limburgher> What am I missing?
17:36:37 <geppetto> limburgher: Library's build programs to test themselves.
17:36:42 <abadger1999> For the comfignat stuff... it seems like it's just another build tool.  but one that's targetted specifically at ada.
17:37:05 <abadger1999> we do document nay build tool that people send us guidelines for.
17:37:05 <limburgher> geppetto:  A very common procedure.  Which needs rpath because?
17:37:21 <abadger1999> so I'd accept that we should document comfignat
17:37:40 <geppetto> limburgher: It's either that or all your simple test programs need to use libtool :-o
17:37:52 <geppetto> which == fun.
17:37:54 <SmootherFrOgZ> abadger1999: yes
17:38:00 <limburgher> geppetto:  And the problem there? ;)
17:38:18 <geppetto> :p~
17:38:24 <abadger1999> limburgher: the argument in the thread is that it doesn't need rpath but it's easier to use that than to define LD_LIBRARY_PATH=$directory_of_newly_built_lib run-program
17:38:33 <limburgher> Bah.
17:38:40 * limburgher pouts
17:39:24 <limburgher> I think the latter is a better test. :(
17:39:30 <geppetto> I'm mostly happy to let people do the right/easy thing … but I'm not going to complain if you think it's better to just ban it and make them workaround.
17:39:32 <Rathann> I see no harm in mentioning another build system provided it has some support from the community
17:40:04 <limburgher> I mean, it seems like running drug trials on adults to get them approved for use in children.
17:40:50 <geppetto> Indeed … everyone knows you should test on the children, they are easier to replace ;-o
17:40:53 <limburgher> At some point it's like using a slinky and a ouija board to detect gravity waves.
17:41:09 * limburgher throws tribble at geppetto
17:42:06 <geppetto> limburgher: You happy with the first part (comfignat)?
17:42:22 <limburgher> geppetto:  I think so.
17:42:48 <geppetto> abadger1999: Ok, want to propose just the first change and we can ACK that?
17:43:01 <abadger1999> Change is here: https://fedoraproject.org/w/index.php?title=User:Rombobeorn/Ada_Guidelines_Changes_2&diff=361215&oldid=361212
17:43:21 <abadger1999> Proposal: Add information about Comfignat build tool to the Ada Guidelines
17:43:27 <geppetto> +1
17:43:28 <abadger1999> +1
17:43:34 <SmootherFrOgZ> +1 with proposal
17:43:36 <RemiFedora> +1
17:43:36 <limburgher> +1
17:44:02 <tibbs|w> +1
17:44:03 <abadger1999> #info Add information about Comfignat build tool to the Ada Guidelines Passed (+1:5, 0:0, -1:0)
17:44:08 <abadger1999> #undo
17:44:08 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0xef0cf90>
17:44:12 <abadger1999> #info Add information about Comfignat build tool to the Ada Guidelines Passed (+1:6, 0:0, -1:0)
17:44:38 <abadger1999> We ready to vote on the second part or do we want to ask questions of the reporter?
17:45:23 <geppetto> pretty sure we are ready to -1 it :)
17:46:33 <abadger1999> Proposal: Add explanation of the  GNAT_add_rpath macro to the Ada guidelines
17:47:00 <abadger1999> +0
17:47:07 <geppetto> I guess if the reporter can come up with better wording and/or reasons why it is much better than  LD_LIBRARY_PATH=... we should give him a chance to do so.
17:47:13 <geppetto> +0
17:47:50 <limburgher> +0
17:48:04 <limburgher> Agreed.  A great argument could convince me.
17:48:17 <RemiFedora> should be a great one
17:48:18 <RemiFedora> 0
17:48:20 <SmootherFrOgZ> geppetto: +1.
17:48:29 <SmootherFrOgZ> 0 on proposal
17:48:56 <abadger1999> #info Add explanation of the  GNAT_add_rpath macro to the Ada guidelines did not pass.  Feedback given in ticket (+1:0, 0:4, -1:0)
17:49:25 <abadger1999> I'll add geppetto's wording as feedback.
17:49:30 <abadger1999> #topic Open Floor
17:50:16 <tibbs|w> Surely this is not possible.
17:50:29 <geppetto> abadger1999: I'll comment directly, if you haven't already.
17:50:41 <abadger1999> geppetto: That works even better :-)
17:50:50 <geppetto> ok, cool.
17:50:50 <abadger1999> tibbs|w: Welcome to the twilight zone.
17:51:12 <limburgher> Up is down, dry is wet, nyancat is rational.
17:51:39 <limburgher> Also, here, pi==78
17:51:54 <geppetto> it's a Saturnalia miracle.
17:52:23 <RemiFedora> I think we need to make package EOL more explicit
17:52:26 <abadger1999> There's one issue that I've been meaning to get around to revisiting... you know, in my copious spare time.
17:52:28 <abadger1999> https://fedorahosted.org/fpc/ticket/303
17:52:42 <limburgher> Ugh.
17:52:43 * RemiFedora refers to php-symfony issue in F20
17:53:12 <abadger1999> The BuildRequires isa issue
17:53:21 <abadger1999> #topic Package EOL
17:53:27 <abadger1999> take it away RemiFedora
17:53:41 <RemiFedora> abadger1999, ?
17:53:53 <abadger1999> RemiFedora: what's the package EOL ideas you have?
17:54:15 <RemiFedora> to NOT retire the obsoleted packaged until the new is pushed
17:54:16 <abadger1999> I'm thinking we might be able to complete that in 7 minutes... we won't be able to complete isa in BR's :-)
17:54:39 <abadger1999> RemiFedora: k.  So this is for Package renames?
17:54:40 <RemiFedora> and to NOT retire packages during "freeze"
17:55:36 <abadger1999> which freeze was it retired in?
17:55:46 <RemiFedora> F20 freeze
17:55:54 <RemiFedora> (last week)
17:56:32 <RemiFedora> Freeze deny to add the new one... but allow to removed the old one... creating borken deps...
17:56:49 <abadger1999> Why was the old one retired?
17:57:02 <RemiFedora> renamed
17:57:21 <Rathann> RemiFedora: makes sense and is something perhaps not everyone is aware of, so +1 to your proposal, but where do we put it in the guidelines?
17:57:27 * abadger1999 notes that right now if a package is not retired before the release goes out, the package cannot be retired later.
17:57:28 <RemiFedora> well, in fact, switch from multi-spec to single-spec-telive-like...
17:57:47 <abadger1999> although dennis and I are currently in disagreement about how that should apply to package renames
17:58:10 <RemiFedora> I will try to find where to add something, and propose this for next meeting
17:58:31 <abadger1999> can't the new one go in as a freeze exception?
17:58:53 <RemiFedora> abadger1999, yes, it's the solution used to fix the broken dep
17:58:58 <abadger1999> I thought that packages that didn't end up on media were generally allowed through.
17:59:07 <abadger1999> k
17:59:31 <abadger1999> #action RemiFedora to write up something about Package retiring and freezes for next meeting
17:59:54 <abadger1999> RemiFedora: Also note -- it is possible this is a fesco policy rarther than a packaging guideline.
18:00:12 <abadger1999> I believe that the act of retiring a package is currently fesco policy
18:00:33 <abadger1999> how to manage the Provvides and obsoletes in the spec files is packaging guidelines.
18:00:46 <abadger1999> Okay.  We're out of time (1 hour!)
18:01:00 <RemiFedora> short meeting this week ;)
18:01:01 <abadger1999> I'll close the meeting unless someone hollers in 10
18:01:10 <abadger1999> 5
18:01:13 <abadger1999> 1
18:01:18 <abadger1999> #endmeeting