fedora-meeting-1
MINUTES

#fedora-meeting-1: Server Working Group Weekly Meeting (2013-12-03)

Meeting started by sgallagh at 15:59:30 UTC (full logs).

Meeting summary

  1. roll call (sgallagh, 15:59:34)
  2. Adam Williamson Confirmation (sgallagh, 16:05:36)
    1. AGREED: Adam Williamson is confirmed as a voting member of the Server Working Group (+7, 0, -0) (sgallagh, 16:12:52)

  3. Discuss role implementation (sgallagh, 16:13:11)
    1. http://cockpit-project.org (stefw, 16:14:52)
    2. http://cockpit-project.org (sgallagh, 16:15:00)
    3. The vision for role installation so far is that users can select roles to add to a system, and would be provided with a (wordpress first-run like) wizard for some initial information and they'll be given a working server using sane defaults. (mizmo, 16:48:28)
    4. Optionally, the user should also be able to deploy the role in a mass deployment without having to interact with the wizard. How to achieve this is an implementation detail (answer file possible) (mizmo, 16:49:02)
    5. The configuration should be able to be modified post-install, but not necessarily via GUI right away (hard to commit to this) (mizmo, 16:49:42)
    6. One major concern is manpower / ability to maintain framework / configs for this role installation vision (mizmo, 16:50:04)
    7. We very much prefer to find pre-existing projects / technology to make role installation possible, which should help alleviate concerns about manpower (mizmo, 16:52:18)
    8. We will need maintainers for the roles, which is much less load than rolling our own (mizmo, 16:53:02)
    9. Another part of role vision: roles as maintainable objects in a repo managed with Fedora maintainer standards, integrated & coherent for things like email server, groupware, etc. (mizmo, 16:55:47)
    10. https://www.openshift.com/application-gallery (davidstrauss, 16:59:51)
    11. ACTION: sgallagh to write up a high-level role example using FreeIPA as a straw-man and send to the list. (sgallagh, 17:13:27)


Meeting ended at 17:14:42 UTC (full logs).

Action items

  1. sgallagh to write up a high-level role example using FreeIPA as a straw-man and send to the list.


Action items, by person

  1. sgallagh
    1. sgallagh to write up a high-level role example using FreeIPA as a straw-man and send to the list.


People present (lines said)

  1. simo (114)
  2. sgallagh (102)
  3. davidstrauss (58)
  4. mizmo (56)
  5. nirik (42)
  6. stefw (33)
  7. adamw (27)
  8. mitr (23)
  9. zodbot (11)
  10. Evolution (5)
  11. tflink (4)
  12. jwb (4)
  13. andreasn (2)
  14. Viking-Ice (2)
  15. tuanta (0)


Generated by MeetBot 0.1.4.