fedora-meeting-1
LOGS
17:00:31 <samkottler> #startmeeting Cloud WG weekly meeting
17:00:31 <zodbot> Meeting started Wed Nov 13 17:00:31 2013 UTC.  The chair is samkottler. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:49 <samkottler> #chair frankieonuonga mrunge mattdm rbergeron number80 geppetto
17:00:49 <zodbot> Current chairs: frankieonuonga geppetto mattdm mrunge number80 rbergeron samkottler
17:01:11 <samkottler> anyone I missed?
17:02:00 <samkottler> #topic rollcall
17:02:05 * frankieonuonga is here
17:02:18 * mrunge is here
17:02:19 * gholms takes a seat in the bleachers
17:02:52 * samkottler waits for a few more people to show up
17:03:28 * frankieonuonga suggests three min
17:03:29 <mrunge> imho red_trela said, he didn't had time for this meeting
17:04:16 <mattdm> hi  all
17:04:22 <samkottler> hey mattdm!
17:04:25 <mrunge> hey
17:04:28 <number80> hi
17:04:30 <mattdm> sorry I am in a seriously split brain state :)
17:04:39 <gholms> mattdm: Isn't that the norm these days?  :P
17:05:01 <mattdm> gholms apparently. :)
17:05:14 <mattdm> I'd take some time off to collect myself but that would just make the problem worse.
17:05:18 <mattdm> so here we are. :)
17:05:23 <samkottler> I have to head into a read-only state at 12:30
17:05:30 <samkottler> mattdm: are you okay with taking over at 12:30?
17:05:32 <mattdm> okay let's go then. :)
17:05:36 <mattdm> samkottler yep
17:05:39 <frankieonuonga> lets play
17:05:40 <samkottler> mattdm: thanks
17:05:45 <frankieonuonga> welcome guys
17:05:51 <frankieonuonga> i mean welcome folks
17:05:55 <samkottler> #topic agenda items
17:06:01 <samkottler> so GCE
17:06:15 <samkottler> I've been talking with the GCE people this past week and have good news
17:06:22 <mattdm> cool
17:06:26 <frankieonuonga> amazing .
17:06:34 <frankieonuonga> whats up ?
17:06:35 <samkottler> there are a few tools that need to get packaged, but all of them are free software and are on github
17:06:39 <mrunge> what is GCE ?
17:06:44 <samkottler> mrunge: google compute
17:06:48 <gholms> Google compute engine
17:06:55 <mrunge> ah, thanks, I see.
17:06:56 <mattdm> Google Compute Engine. A public cloud provider
17:06:56 <number80> samkottler: list them
17:07:19 <frankieonuonga> cool.
17:07:41 <frankieonuonga> samkottler: packaging should be easy
17:07:42 <samkottler> gcutil and image_bundler are the main two
17:07:48 <frankieonuonga> and at least they are open source
17:07:53 <samkottler> s/image_bundler/image_bundle
17:07:58 <gholms> #info A few tools need to get packaged for GCE support, primarily gcutil and image_bundle.  All of them are free software and on GitHub.
17:08:20 <mattdm> I looked at the "what does the image need to look like" instructions
17:08:32 <mattdm> it seems like we are mostly in good shape already
17:09:20 <samkottler> I also spoke with dgilmore about how to get images built in koji and we will likely need to work with mikem to write a plugin to handle it
17:09:31 <mattdm> samkottler what format do the images need to be in?
17:09:44 <samkottler> #action samkottler to figure out what's needed in koji to get images built there
17:09:53 <frankieonuonga> samkottler and dgilmore please loop me into it
17:10:03 <frankieonuonga> that is what is needed for koji
17:10:16 <mattdm> samkottler I think they just want a raw disk file, actually. we already make that
17:10:19 <samkottler> frankieonuonga: absolutely, if you want to take charge on that item feel free :)
17:10:20 <frankieonuonga> this should go in line with rel-eng tasks right ?
17:10:30 <samkottler> mattdm: right, but do we need koji to upload it
17:10:39 <frankieonuonga> ok.
17:10:46 <mattdm> samkottler right now dennis uploads the ec2 images by hand
17:10:46 <samkottler> or do we just handle that externally?
17:10:49 <mattdm> koji doesn't do any uploading
17:11:01 <mattdm> we have the start of a separate uploader service for ec2
17:11:18 <mattdm> but it needs polish and finish. (the stuff andrew worked on last summer)
17:12:20 <samkottler> does someone want to take ownership of creating gcutil and image_bundle packages?
17:12:29 <samkottler> I can do a review for them, but I'm pretty swamped this week
17:12:40 <mattdm> we also maybe should look at GCE cloud-init integration
17:12:43 <mattdm> http://lists.debian.org/debian-cloud/2013/10/msg00004.html
17:12:45 <mattdm> gholms ^
17:12:47 <frankieonuonga> I can take that
17:12:50 <frankieonuonga> not a problem
17:13:02 <frankieonuonga> how soon are they required ?
17:13:22 <mattdm> frankieonuonga it would be pretty nice to have this with F20
17:13:27 <mattdm> so soon :)
17:13:31 <samkottler> frankieonuonga: the sooner the better at this point
17:13:38 <samkottler> yeah, I'd love to get the tools into f20
17:14:04 <frankieonuonga> :-) ok. will look into it and mail you guys tomorrow..but i think i would like to be done by sat
17:14:10 * gholms attempts to find those tools on github
17:14:13 <number80> #info hguemar is looking to package gcutil and image_bundle
17:14:23 <dgilmore> samkottler: we need something out of koji that can run on a releng box and do the uploading
17:14:28 <number80> gcutil is on google code
17:14:41 <samkottler> number80: frankieonuonga already volunteered
17:14:45 <samkottler> you two wanna work together on that?
17:14:59 <samkottler> number80: yeah, I just sent searching again for it, too, and google code is the place
17:15:08 <samkottler> the google folks told me github, not sure why
17:15:18 <gholms> https://code.google.com/p/google-compute-engine-tools/
17:15:24 <number80> https://github.com/GoogleCloudPlatform/compute-image-packages/tree/master/image-bundle
17:15:35 <number80> i found image_bundle, quite well hidden
17:15:46 <mattdm> number80, gholms, samkottler -- looks like debian is going with the cloud-init integration for running *in* the image
17:16:07 <gholms> mattdm: That's the idea, yeah.  Do you happen to know if they bothered to ask upstream as well?
17:16:24 <number80> samkottler: ok, i already started with gcutil last week but i'm fine with leaving image_bundle
17:16:26 <number80> #undo
17:16:26 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x128aebd0>
17:16:28 <mattdm> gholms they said that they would but it might take some time. not sure what that's all about
17:16:45 <samkottler> #link https://code.google.com/p/google-compute-engine-tools/
17:16:49 <frankieonuonga> samkottler: sure we can work on it together with hguemar
17:16:56 <gholms> samkottler: I already posted that one.  ;)
17:17:03 <number80> yup
17:17:15 <samkottler> gholms: without hash-link :)
17:17:37 <gholms> samkottler: meetbot has picked up messages that start with links since 2010.
17:17:44 <samkottler> #undo
17:17:44 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x15360710>
17:17:52 <samkottler> gholms: still fresh at this - thanks :)
17:18:05 <gholms> No worries.  I'm happy to help.  ;)
17:18:18 <samkottler> https://github.com/GoogleCloudPlatform/compute-image-packages
17:18:53 <gholms> I'm a little concerned by that google code page's source browser not actually containing any code, but I guess that's the best we're likely to get.
17:20:26 <samkottler> gholms: yeah, I noticed that too, not really sure what the deal is with it
17:20:30 <samkottler> I can ask the google folks
17:21:01 <samkottler> anyone else got stuff to add before we move on?
17:21:20 * gholms hopes all the bundled libs for gcutil are easy to split out
17:21:27 <mattdm> At some point we will have to decide if we want to configure the instance with cloud-init or google-startup-scripts
17:21:45 <frankieonuonga> mattdm: yeah you are right
17:21:49 <frankieonuonga> i totally agree.
17:22:12 <mattdm> but having them all available seems like a good start :)
17:22:12 <gholms> mattdm: Is the "one image for everything" idea still important?
17:22:12 <samkottler> I don't really like cloud-init all that much, but it's a known beast
17:22:20 <mattdm> samkottler +1
17:22:41 <gholms> cloud-init is kind of annoying, but on the bright side it's portable.
17:22:41 <samkottler> gholms: it is right now, that's a topic for another meeting
17:22:46 <frankieonuonga> can we lay down all pros and cons on email then decide
17:22:52 * gholms nods
17:22:53 <mattdm> +1 to take to email
17:23:00 <frankieonuonga> +1
17:23:12 <samkottler> who wants to kick off that thread?
17:23:49 <mattdm> #action mattdm to kick of thread re google scripts vs cloud-init
17:23:52 <mattdm> me
17:23:52 <number80> +1
17:23:58 <mrunge> +1
17:24:01 <samkottler> thanks mattdm
17:24:45 <samkottler> can we move on to the governance doc?
17:24:56 <number80> yes
17:25:10 <samkottler> #topic governance document review before submission to FESCo
17:25:25 <samkottler> mattdm: this will run longer than 5 minutes, so do you want to take over?
17:25:36 <mattdm> sure
17:25:56 <mattdm> although, um, I think the state of it is "mattdm said he would make some changes and isn't really done doing everything he said he would do"
17:26:06 * nirik has something for open floor if someone can ping me when it gets to that. ;)
17:26:28 * frankieonuonga will ping nirik
17:26:29 <mattdm> also, I think we should take a look at the docs from other groups and regularize language where we can
17:26:40 <number80> just to notice that there were no changes for 2 weeks
17:26:48 <frankieonuonga> is this the PRD?
17:26:50 <mattdm> so my proposal is for me to actually do those things and bring it back next week
17:26:56 <mattdm> frankieonuonga no, governance doc
17:27:01 <number80> frankieonuonga: nope: https://fedoraproject.org/wiki/Cloud/Governance
17:27:01 <mattdm> number80 see above :)
17:27:02 <samkottler> mattdm: isn't it due tomorrow?
17:27:08 <frankieonuonga> I see.
17:27:15 <mattdm> gah. lookit the time.
17:27:31 <mattdm> okay so. new plan. :)
17:27:38 <gholms> Heh
17:28:02 <frankieonuonga> we might need to finlize this thing like now..in terms of pressing issues to be discussed .
17:28:05 <mattdm> I edited the document with the basic changes we agreed to last time.
17:28:15 * samkottler has to go mostly offline now
17:28:20 <mattdm> samkottler kk
17:28:57 <frankieonuonga> so what is basically expected in this doc that is not there
17:29:03 <mrunge> is there anything missing in that document?
17:29:07 <frankieonuonga> are there any issues that need clarification ?
17:29:48 <mattdm> one of the issues in the other documents is quorum
17:30:06 <frankieonuonga> mattdm: kindly expound
17:30:17 <mattdm> eh wait we covered that too
17:30:34 <frankieonuonga> oh yeah…two meetings ago
17:30:37 <frankieonuonga> that we did .
17:30:37 <number80> a quorum of 5 should be ok
17:30:55 <frankieonuonga> we just need to access that log and do what we agreed
17:30:56 <mattdm> okay, so the other thing is that the server wg has a bit about "Each voting member of the working group will confirm their continued membership every six months."
17:30:59 <mattdm> do we want that?
17:31:13 <frankieonuonga> we had talked about this right
17:31:21 <frankieonuonga> we agreed for now..no way.
17:31:34 <frankieonuonga> reasoning behind it was it is a short time to get things going
17:31:43 <frankieonuonga> especially in a field that is still fresh
17:31:57 <mattdm> frankieonuonga I think this was just a way for making sure everyone involved was still active
17:32:04 <mattdm> not a need for a revote
17:32:07 <number80> that's neat though i'd prefer people resigning by themselves
17:32:11 <mrunge> I don't see any issue with refreshing
17:32:27 <number80> the same
17:32:33 <frankieonuonga> wasnt this voted on in that meeting.
17:32:53 <mattdm> frankieonuonga yeah I just wanted to know if we wanted to add their idea
17:32:54 <frankieonuonga> sorry but I feel we might be having the same conversation again
17:33:03 <mrunge> I agree, when anyone can foresee, he has no time to work in the group, I'd expect him/her to resign
17:33:12 <mattdm> okay, so, sounds like we want to leave it as is.
17:33:34 * frankieonuonga nods
17:33:40 <mattdm> do we want to approve it as it is?
17:33:57 <mattdm> do we actually have quorum to do so?
17:33:57 <frankieonuonga> yes.
17:34:01 <mrunge> so, it's and appointment for lifetime?
17:34:10 <mrunge> s/and/an/
17:34:13 <frankieonuonga> i think we need that until we are good to go..
17:34:25 <frankieonuonga> or at least until things are of the ground
17:34:26 <mattdm> mrunge we assume there will be enough natural turnover
17:34:44 <mattdm> other groups went the same way
17:34:45 <number80> mrunge: until you're unable to serve like FPC
17:34:50 <mrunge> mattdm, if we can guarantee that
17:35:00 * croberts croberts is here running late
17:35:12 <mattdm> mrunge what, by making sure we burn everyone out? :)
17:35:18 * frankieonuonga waving at croberts
17:35:29 * mrunge likes fresh ideas from fresh people from time to time
17:35:50 <frankieonuonga> i think if we change ideas too soon when starting we will end up failing
17:35:54 <frankieonuonga> sorry to insist on this
17:36:04 <frankieonuonga> but this was discussed in length earlier
17:36:07 <frankieonuonga> with so many reasons
17:36:10 <samkottler> I'm lurking so I think we have quorum
17:36:15 <mrunge> and refreshing is something like refreshing commitment
17:36:55 <mattdm> mrunge okay, so, like the server wg wording? appointments stay until you step down, but you do need to say you still want to be involved?
17:37:05 <mattdm> I'm okay with either adding that or leaving it open as it is now.
17:37:27 <mattdm> "able and willing", with no hard-coded definition of what that means
17:37:30 <mrunge> mattdm, yes, I like that. that's more encouraging
17:37:54 <mrunge> ...encouraging people to do something,
17:38:22 <mrunge> we might want to change that, e.g time-span, if refreshing just becomes tedious
17:38:33 <mattdm> okay, so: proposal: add wording like server wg's about members confirming their membership every six months
17:38:39 <mattdm> +1 to my own proposal
17:38:45 <frankieonuonga> +1
17:38:49 <geppetto> +1
17:38:49 <mrunge> +1 for that
17:39:10 <number80> +1
17:39:15 <samkottler> +1
17:39:38 <croberts> +1
17:40:00 <mattdm> croberts wait that confuses my counting :)
17:40:11 <mrunge> heh
17:40:27 <mattdm> but anyway
17:40:28 <croberts> :P
17:40:53 <frankieonuonga> :-)
17:40:58 <mattdm> #accepted add wording to charter about commiting to membership every 6 months like server wg (+6)
17:41:06 <mattdm> anything else anyone wants to raise?
17:41:28 <mattdm> i went ahead and did that :)
17:41:52 <mattdm> so: proposal: accept governance charter as https://fedoraproject.org/w/index.php?title=Cloud/Governance&oldid=360627
17:42:07 <mattdm> +1 to myself, again
17:42:08 <frankieonuonga> is there any missing content
17:42:19 <frankieonuonga> maybe something to be included ?
17:42:21 <frankieonuonga> i am not sure
17:42:26 <frankieonuonga> that is why i am asking
17:42:46 <mattdm> frankieonuonga Maybe. I like simple. We can always add additional rules / bylaws if needed
17:43:17 <samkottler> remember that we can always amend stuff
17:43:18 <mrunge> do we want to keep the list of members in that document?
17:43:27 <geppetto> mattdm: +1 … seems simple enough.
17:43:29 <frankieonuonga> ok . sounds fine. I know nothing about this ..so I will just agree
17:43:44 <mrunge> ... if members change, that document needs to be reviewed again...
17:43:45 <mattdm> mrunge I think so, because it's important for that to be easily findable.
17:43:46 <samkottler> mattdm: +1
17:43:57 <frankieonuonga> +1
17:44:04 <number80> mattdm: +1
17:44:05 <mrunge> ok. +1 tjem
17:44:09 <mrunge> then
17:44:15 <mattdm> mrunge i think it's implied that that section can change to match reality
17:44:23 <mattdm> okay so that's 6
17:44:39 <mattdm> #accepted governance charter as of https://fedoraproject.org/w/index.php?title=Cloud/Governance&oldid=360627 ratified
17:44:40 <mrunge> I'd expect that kind of information somewhere, mattdm
17:44:53 <mrunge> (members etc.)
17:45:16 * mattdm notes that when the fedora board changed this year, it took 6 months for the list to get updated. :)
17:45:30 <mattdm> okay, so, fesco meeting soon so let's move on.
17:45:35 <mattdm> #topic open floor
17:45:42 <mattdm> nirik?
17:45:47 <frankieonuonga> let me get nirik
17:45:47 <mrunge> yes
17:45:57 <nirik> Just something to ponder on/bring up:
17:46:31 <nirik> how do you folks see the interaction between the server wg and cloud wg? do you want us to handle the server end and you just do images? or you do both? or ?
17:46:57 <nirik> for example, an openstack server is something we might want to make a server role...
17:47:09 <mrunge> well....
17:47:24 <frankieonuonga> I have a diff opinion
17:47:26 <nirik> I don't know that we need an answer right now, but something to think about?
17:47:26 <mattdm> nirik I think that that's what we're thinking, yes.
17:47:39 <mattdm> nirik looks like we don't have consensus :)
17:47:56 <frankieonuonga> we may need someone on both ends
17:48:00 <mattdm> i think we might provide images for compute hosts in openstack
17:48:06 <frankieonuonga> cause one can not exist without the other
17:48:25 <mrunge> frankieonuonga, no. a server could live without a cloud image
17:48:28 <frankieonuonga> I think that we also need top look at all other platforms
17:48:54 <frankieonuonga> to look i mean
17:49:00 <frankieonuonga> a server could do that
17:49:07 <mrunge> my initial thought saw the cloud wg as wg to provide infrastructure to host cloud images
17:49:20 <number80> nirik: the server WG is quite central due to the various usage, i think that cloud WG will serve as a stakeholder for cloud hosting and we will probably participate to the making and testing
17:49:21 <frankieonuonga> but a server can also exist without having open stack.
17:49:23 <mrunge> and everything in that image will be filled by server wg
17:49:31 <frankieonuonga> there are too many variables
17:50:00 <nirik> right, it's interaction on many levels. ;)
17:50:25 <mattdm> mrunge The Fedora Cloud SIG has traditionally been focused on making Amazon images... in your model there's nothing for us to do. :)
17:50:29 <nirik> there's the bare metal side/server, and then inside cloud instances there could be many servers that people want to run
17:51:08 <frankieonuonga> I think this is something we need to look into for sur e
17:51:10 <frankieonuonga> sure i mean
17:51:20 <mrunge> mattdm, oh yes, there is. but I agreed to shut up ;-)
17:51:27 <mattdm> mrunge lol :)
17:51:43 <mattdm> nirik does that answer your question? heh.
17:51:48 <frankieonuonga> mrunge: dont shut up
17:52:04 <mrunge> frankieonuonga, let's discuss that at a different time
17:52:06 <frankieonuonga> I think this is a healthy conversation
17:52:11 <mattdm> +1 :)
17:52:19 <frankieonuonga> I think we should kick it of on email
17:52:23 <number80> +1
17:52:35 <nirik> yeah, just wanted to start everyone thinking about it.
17:52:44 <frankieonuonga> thanks nirik
17:52:52 <mattdm> frankieonuonga i think this is the 'ZOMG WHAT ARE WE BUILDING?!' thread from last week?
17:53:03 <mattdm> but another thread with a more specific title wouldn't hurt :)
17:53:14 <mattdm> frankieonuonga or mrunge you want to do that?
17:53:25 <mrunge> and I guess, there was an earlier thread as well
17:53:35 <mattdm> #info we need to figure out our interaction with the server wg and how we define what we're doing
17:53:41 <mrunge> mattdm, I can do that
17:53:41 <frankieonuonga> I have already taken a task…I dont want to seem like i am hogging
17:53:54 <mattdm> cool mrunge go for it :)
17:53:56 * frankieonuonga thankful that mrunge has taken that
17:54:15 <mrunge> as if my plate wasn't already full enough
17:54:30 <mattdm> I hear you. :)
17:54:35 <mrunge> no, will do that
17:54:35 <frankieonuonga> no offence
17:54:41 <mattdm> okay, so other topics :)
17:54:45 <mattdm> if any.
17:54:46 <frankieonuonga> which reminds me..what happen to that google thing we were to sign for non disclosure or something like that ?
17:54:56 <mattdm> frankieonuonga ping samkottler on that?
17:55:06 <samkottler> frankieonuonga: email me and I'll have them reach out
17:55:06 <frankieonuonga> ok will do
17:55:13 <frankieonuonga> will do
17:55:39 <mrunge> why should there be an nda? it's under ASL, right?
17:55:55 <mrunge> but confirming is better
17:56:57 <mattdm> okay, so I'm going to end the meeting because I need to grab food quick before fesco starts.
17:57:01 <mattdm> #endmeeting