f20-alpha-readiness-meeting
LOGS
19:00:05 <jreznik> #startmeeting F20 Alpha Readiness Meeting
19:00:05 <zodbot> Meeting started Thu Sep 12 19:00:05 2013 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:18 * nirik waves.
19:00:18 <jreznik> #meetingname f20-alpha-readiness-meeting
19:00:18 <zodbot> The meeting name has been set to 'f20-alpha-readiness-meeting'
19:00:20 * rbergeron arrives
19:00:36 * jreznik waves back to nirik
19:00:44 <jreznik> #topic Purpose of this meeting
19:00:48 * pschindl is here
19:00:53 * randomuser is here for as long as he can manage
19:01:00 <jreznik> #info "Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well coordinated."
19:01:02 <jreznik> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:01:18 <jreznik> #topic Current status
19:01:47 <jreznik> sad news, we had to slip by one week but that gives us more time get everything done for F20 Alpha!
19:01:59 <jreznik> #info at the Go/No-Go meeting it was decided to slip one week with release date on Sep-24, next Go/No-Go Sep-19
19:02:38 <jreznik> #link https://fedoraproject.org/wiki/Releases/20/Schedule
19:02:48 <jreznik> updated schedule above ^^^
19:03:40 <jreznik> any questions? otherwise I'll start the status updates fun!
19:04:21 <jreznik> #topic Ambassadors
19:04:59 * jreznik is looking for sesivany
19:05:05 * tflink shows up late
19:06:12 <jreznik> seems like he's not here, does not react on pings -> /me will check with him offline
19:06:29 <jreznik> #action jreznik to sync with sesivany offline for Ambassadors status
19:06:49 <jreznik> #topic Design
19:08:28 <jreznik> f20 alpha artwork was delayed but we made it - https://bugzilla.redhat.com/show_bug.cgi?id=1005251
19:09:01 * jreznik is looking for Design guys to show up
19:09:31 <jreznik> gnokii: anything from you?
19:10:22 <jreznik> ok, so I'll sync offline or later
19:10:41 <jreznik> #action jreznik to sync with Design team offline
19:10:54 <jreznik> #topic Documentation
19:10:59 <randomuser> hi
19:11:05 <rbergeron> YAY
19:11:27 <rbergeron> :D people really are here. okay, i'll be quiet again
19:11:32 <randomuser> Docs is where we expect to be at this point, which is basically not much done
19:12:07 <jreznik> randomuser: hi
19:12:42 <jreznik> rbergeron: we need badge - on time for readiness meeting!
19:12:55 <randomuser> we have a little bit of a start on RNs and guides progress at their own pace
19:13:04 <jreznik> randomuser: how does it look like with docs bugs assignment?
19:13:28 <jreznik> #info docs is where we expect to be at this point, which is basically not much done
19:13:38 <randomuser> jreznik, well, I thought it was a good idea :)
19:13:52 <jreznik> #info a little bit of a start on RNs and guides progress at their own pace
19:14:10 <jreznik> randomuser: so far I like bugzilla for tracking stuff
19:14:34 <jreznik> anything else for Alpha?
19:14:39 <randomuser> jreznik, the new process with bugs hasn't caused more or less participation, as far as I can tell, but even if it comes down to just me I appreciate tracking it somehow
19:15:18 <jreznik> randomuser: yeah, I hoped for people being more active - especially as it's pretty transparent now
19:15:28 <randomuser> #info anyone can add info to https://fedoraproject.org/wiki/Category:Documentation_beats?rd=Docs/Beats
19:15:38 <jreznik> and I'd expect more activity later
19:16:03 <jreznik> also all updates are collected on one place with history to pick it up
19:16:58 <jreznik> what about RNs for Alpha - share it again with Announcement as the last time for F19?
19:17:50 <jreznik> randomuser: ^^^
19:18:43 * jreznik will move on
19:18:53 <jreznik> #topic FESCo
19:19:02 <jreznik> nirik: anything from FESCo?
19:19:33 <nirik> nope. I think we are all set... there was some last minute stuff around gnome-software backend, but I think it got sorted ok
19:20:06 <randomuser> jreznik, sorry, on MiFi in overcommitted area; please do share alpha RNs (read:skip, not available) with release announcement. We end up finding things to add to RNs from the announcement, anyway :)
19:20:18 <jreznik> #info FESCo is all set; gnome-software backend stuff sorted out
19:20:20 <abadger1999> yeah - it'll ship with the yum backend instead of the hawkey backend
19:20:43 <jreznik> seems like a good compromise for F20 as it's tech-preview
19:21:03 <tflink> the deadline for working with qa on that was beta, right?
19:21:19 <nirik> yeah.
19:21:20 * tflink hasn't been following the gnome-software stuff all that closely
19:21:33 <nirik> but it's not needed anymore, since it's using the yum backend by default.
19:21:40 <jreznik> is it still needed now for F20 or is it more F21 stuff now?
19:21:42 <nirik> although you can switch it and test with the other one I suppose
19:21:58 <jreznik> nirik: yep, it should be possible
19:23:21 <jreznik> #info QA involvement for AppInstaller Change is not needed anymore as default backend was switched to yum
19:23:35 <jreznik> anything else from FESCo?
19:23:40 <nirik> nope.
19:23:50 <jreznik> ARM was at least for now sorted out too
19:24:35 * jreznik still hears complaints about access to real HW from developers
19:24:49 <jreznik> so maybe we should do more advertising of options developers have
19:25:11 <nirik> we could. I was/am planning on making logins available to all packagers.
19:25:17 <nirik> but it's stalled waiting on a firmware update.
19:25:51 <jreznik> ok
19:26:21 <jreznik> +qemu etc. and maybe a list of budget hw to buy for people not familiar with arm at all
19:26:45 <jreznik> pwhalen: do we something like this? ^^^
19:27:06 <jwb> budget hardware has the problem that it will be stale and unsupported in a relatively short period of time, as well as being less than useful
19:27:12 <jwb> like raspberry pi.
19:27:42 <nirik> well, BBB would be nice if it was working. ;(
19:28:31 <jreznik> but we can't ask anybody to buy calxedas to work on (if someone insists on having physical HW on his table)
19:28:52 <jreznik> just my idea to make it easier for devels
19:28:53 <pwhalen> jreznik, I can inquire, but the bbb's were our hope to increase hw testers
19:29:27 * randomuser needs to check out, bye all
19:30:23 <jreznik> pwhalen: thanks - BBB seems like option, QA has one - would be nice to solve issues with it as it's the only HW they have (at least in Brno)
19:30:58 <tflink> jreznik: actually 3 - i have one, adam has one and brno folks have one
19:31:15 <jreznik> but moving on - I see this as obstacle for some people so I'd like to make it a better to help (it's first release so everyone is still trying to get what's going on)
19:31:36 <jreznik> tflink: even better but I suppose it's useless now
19:32:21 <jreznik> so I expect other eng stuff is covered, moving on
19:32:26 <jreznik> #topic Fedora Engineering Manager
19:32:41 <jreznik> quick question for spot - are you online, anything from you?
19:33:31 <jwb> i believe he's unavailable today
19:33:55 <jreznik> jwb: ok but usually there's nothing from him and I'm wondering if we still want it on the list
19:34:09 <jwb> that doesn't need to be settled right now though
19:34:29 <jreznik> jwb: yep, I'll ask him offline
19:34:38 <jreznik> #action jreznik to sync with spot offline
19:35:02 * jreznik is going to skip translations now - I don't see noriko here and we are in touch
19:35:18 <jreznik> I hope no objections or anybody from Trans team?
19:36:13 <jreznik> #topic Fedora Project Leader
19:36:21 <rbergeron> Hai.
19:36:44 <jreznik> anything from you?
19:37:02 <rbergeron> I have not much, though wondering if i am filling in for marketing in this mtg as well
19:37:54 <rbergeron> in which case i have things for saying
19:38:11 <rbergeron> or can say if nobody else is here. but not much from fpl land.
19:38:20 <jreznik> rbergeron: suehle should be online, pinged me right after go/no-go but that doesn't mean you can't say anything you have on your mind :)
19:39:01 <jreznik> #info no new updates from FPL
19:39:07 <jreznik> #topic Marketing
19:39:24 <jreznik> suehle: ping, also rbergeron - feel free
19:39:26 <jzb> rbergeron: I'm here, I can sub for mktg I guess
19:39:38 <rbergeron> jreznik: i was only going to mention -
19:39:39 <rbergeron> oh
19:39:43 * jzb is new to the readiness meetings, though.
19:39:54 <rbergeron> i was going to say - not sure if jzb is on the appropriate list for these mtgs
19:40:10 <jzb> rbergeron: I don't know that I am, I just heard about it through the grapevine
19:40:10 <rbergeron> but as he did lots of the content - might be useful.
19:40:18 <rbergeron> thank you thank you thank you
19:40:20 <rbergeron> jz
19:40:39 <jzb> so - we have a draft of the alpha release and alpha talking points
19:40:47 <rbergeron> jzb: logistics list gets the mails.
19:40:51 <jzb> which, I think, is most of what we need for the alphas
19:40:57 <jreznik> well, I'd really like to make announcement for this meeting more broader... it's already in fedocal... and it's better to have more people... just I was a bit busy this week
19:40:59 <jzb> rbergeron: ah, that.  Just signed up for it today :-)
19:41:16 <jzb> jreznik: I can put it on Fedora Magazine for next week, would that help?
19:41:27 <rbergeron> jzb: the only other detail i can cover with you is - taking the info in wiki and ... flat-texting it to send to release engineering
19:41:37 <jreznik> #link https://fedoraproject.org/wiki/F20_Alpha_release_announcement
19:41:43 <rbergeron> for alpha/beta - as they send out the announcement
19:41:51 <jzb> rbergeron: OK, happy to do that.
19:41:52 <rbergeron> jzb: also, we slipped a week
19:41:58 <jzb> rbergeron: yeah, I saw that :-)
19:42:05 <jreznik> jzb, rbergeron: fyi dgilmore will not be available on release day
19:42:14 <rbergeron> ah, i saw you type next week and.. yeah
19:42:37 <rbergeron> jreznik: okay, will it be nirik or myself, then?
19:42:39 * dgilmore is here
19:42:50 <jzb> rbergeron: ah, I meant a post about the readiness meeting, to make the announcement for the readiness meeting.
19:43:00 * jzb is assuming this is weekly. Maybe wrong about that.
19:43:01 <jreznik> so it will be up to you or nirik or dgilmore's at command (but that means to have it ready earlier)
19:43:03 <dgilmore> rbergeron: only thing that will need doing is announcement email
19:43:07 * rbergeron wonders if that flat-text is better sent to logistics list than one or two people directly
19:43:19 <jreznik> jzb: no, only once for every milestone (alpha, beta, final)
19:43:24 * nirik is happy to send as long as you tell me I should before hand. ;)
19:43:24 <rbergeron> jzb: nope. just one per alpha/beta/final
19:43:33 <jzb> jreznik: ah, gotcha. OK, then I can do that for beta.
19:44:01 <jreznik> rbergeron: as a backup solution, yes, but still CC that one/two people directly
19:44:29 <jzb> I think that's all mktg has for the alpha release...
19:44:52 <jzb> #link http://fedorapeople.org/groups/schedule/f-20/f-20-marketing-tasks.html
19:44:55 <jreznik> nirik: it would be probably easier if you could do it (don't want to take that 5 minutes of fame from dgilmore ;-)
19:45:10 <jreznik> jzb: btw. I did a review of release announcement
19:45:15 <nirik> sure, if everyone wants me to happy to.
19:45:16 <jreznik> to check the state of changes
19:45:18 <rbergeron> nod. jzb: let's get together next week and see if we can document the flattexting and mailing and etc. process so we all know.
19:45:37 <jzb> rbergeron: OK, wanna sit down Monday or Tuesday on that?
19:45:47 <jreznik> jzb: vagrant seems not to be prime time for Alpha
19:45:48 <jzb> jreznik: I saw that, thanks very muchly!
19:45:56 <jzb> jreznik: noted
19:46:14 <jreznik> (if you take a look on the list I sent you - bugs with MODIFIED should be testable and ready for Alpha)
19:47:07 <rbergeron> jzb: sure, we'll be f2f and all that
19:47:09 <jreznik> anything else for now? I'll stop by at the next marketing meeting to recheck status
19:47:37 <jzb> jreznik: sounds good. I may or may not actually be in the meeting as I'll be on the ground at LinuxCon
19:47:42 <jzb> but Monday should be rather tame.
19:47:48 <jreznik> ok
19:48:08 <jreznik> feel free to ping me if anything else will be needed for announcement etc.
19:48:18 <jreznik> moving on
19:48:18 <jzb> jreznik: will do
19:48:22 <jreznik> #topic Infrastructure
19:48:33 <jreznik> nirik: anything from infra?
19:48:46 <nirik> we are in pretty good shape... just need things to sync out. ;)
19:48:58 <rbergeron> "still standing" :D
19:49:10 * rbergeron finds a big block of wood
19:49:28 <jreznik> #info infra in pretty good shape, needs things to sync out
19:49:45 <jreznik> #topic Websites
19:50:05 <jreznik> shaiton: robyduck: what about websites?
19:50:11 <robyduck> websites are set, we only need the usual things
19:50:27 <robyduck> when RC will be declared as GO
19:50:34 <jreznik> #info websites are set, only needs the usual things
19:50:37 <robyduck> checksums etc...and release notes
19:50:49 <jreznik> robyduck: nice! great job!
19:50:56 <robyduck> ;)
19:51:07 <shaiton> :)
19:51:12 * jreznik saw pretty lot of stuff done there
19:51:30 <jreznik> so, moving on, 9 minutes left
19:51:32 <jreznik> #topic QA
19:51:54 <jreznik> tflink, pschindl: I expect QA is covered by Go/No-Go, right? anything else to mention?
19:52:11 <tflink> not that I'm aware of
19:52:24 <tflink> just more testing of cloud needed but that's been covered :)
19:52:56 <pschindl> nothing what wasn't told on Go/No-Go
19:53:00 <jreznik> #info more cloud testing coverage is needed
19:53:03 <jreznik> ok, thanks
19:53:15 <jreznik> #topic Release Engineering
19:53:23 <jreznik> dgilmore: anything from releng?
19:53:50 <tflink> i think he just went afk
19:54:33 <jreznik> ok, so skipping
19:55:01 <jreznik> he pinged me he won't be available on the release day, so we're aware of that
19:55:04 <jreznik> #topic Open floor
19:55:42 <jreznik> anyone, anything? :)
19:56:24 * jsmith has nothing
19:56:46 <jreznik> jsmith: :D
19:56:53 <jreznik> setting fuse
19:57:31 <jreznik> thanks everyone for coming, I'll check offline with the rest! you deserves badge (/me will request it for Beta ;-)
19:57:33 <jreznik> 3...
19:58:09 <jreznik> 2...
19:58:59 <jreznik> 1...
20:00:04 <jreznik> #endmeeting