fedora-meeting-1
LOGS
20:00:17 <pwhalen> #startmeeting Fedora ARM weekly status meeting
20:00:17 <zodbot> Meeting started Wed Aug 28 20:00:17 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:17 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin masta handsome_pirate msalter ahs3 agreene jcapik
20:00:17 <zodbot> Current chairs: agreene ahs3 bconoboy ctyler dgilmore dmarlin handsome_pirate jcapik jonmasters masta msalter pbrobinson pwhalen
20:00:24 <pwhalen> .fas pwhalen
20:00:24 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:00:32 <pwhalen> afternoon all
20:00:35 * handsome_pirate waves from the Crow's Nest
20:00:45 * masta is here
20:00:47 <masta> howdy folks
20:01:37 <jcapik> .fas jcapik
20:01:38 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:02:04 * pbrobinson is here
20:03:54 <jonmasters> pwhalen: let's do it
20:03:56 <jonmasters> .fas jonmasters
20:03:56 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:03:58 <pwhalen> alright, shall we get started
20:04:10 <pwhalen> #topic 1) Problem packages
20:04:27 <pbrobinson> so the glibc issue on tegra is resolved thanks to kylem
20:04:57 <pbrobinson> jonmasters: do you have a status update on the glibc stack protector issue?
20:05:04 <pwhalen> I installed on an f19 trimslice, got some off output kyles been looking at
20:05:31 <pwhalen> http://ur1.ca/f9nys
20:05:42 <jonmasters> pbrobinson: you mean on getting the support updated?
20:05:52 <jonmasters> pbrobinson: so Linaro/ARM are still working on it last I heard
20:06:07 <pbrobinson> jonmasters: yes, so can you organise to get an update on where we are on that
20:06:08 <jonmasters> pbrobinson: they're not likely to change the global canary though
20:06:26 <jonmasters> pbrobinson: sure, we'll circle back with Matthew
20:06:34 <jonmasters> (toolchain lead)
20:06:49 <pbrobinson> and llvm is the other one on my list
20:06:55 <pbrobinson> for problem packages
20:06:58 <jonmasters> pbrobinson: the v8 side gets more exciting, but that's not an issue here. Anyway, I'll get an update sent out about glibc
20:07:19 <pbrobinson> v8?
20:07:29 <pbrobinson> ah armv8
20:07:37 <pbrobinson> sorry was thinking of the other one
20:07:53 <jonmasters> on AArch64 the stack frames are more excitingly optimized and will make that implementation harder for stack protector
20:08:07 <jonmasters> sure yea, v8 (the google one) is something we're following up with ARM on for AArch64
20:08:42 <pbrobinson> so for the glibc and llvm I'm concentrating on v7
20:08:46 <jonmasters> but that's all a tangent, anything other than llvm broken on 32-bit?
20:09:01 <pbrobinson> IE things that might well cause us issues coming into alpha
20:09:36 <handsome_pirate> pbrobinson:  I'll upload what I've got on llvm to my fedorapeople space
20:09:56 <pwhalen> tested the new version of initial-setup, initial-setup-text is displayed on console for trimslice, vexpress, omap
20:10:00 <handsome_pirate> pbrobinson:  I just have been pulled in too many directions at once to get as much work done as I'd like
20:10:13 <jonmasters> pwhalen: great
20:10:24 <pbrobinson> handsome_pirate: are you talking about llvmpipe or the triplet issue
20:10:37 <handsome_pirate> pbrobinson:  Triplet issue
20:10:59 <pbrobinson> kylem: do you have an update on the llvmpipe issue?
20:11:19 <masta> pwhalen: great news about initial-setup... I'll test that on some remixes too
20:11:37 <pwhalen> masta, please do
20:12:49 <pwhalen> initial-setup-graphical also does not run, complains about a missing hostname. there are several bugs revolving around this as well
20:13:28 <pwhalen> root cause seems to be missing '/etc/hostname'
20:13:30 <handsome_pirate> pwhalen:  I'd reccomend you go ahead and file a bug just for that, since it seems like spstarr doesn't have a clue what he's doing
20:13:35 <jonmasters> and there are open BZs as pwhalen has mentioned
20:13:46 <pwhalen> handsome_pirate, agreed on opening a bug
20:14:10 <pbrobinson> pwhalen: is there BZ for the hostname issues?
20:14:24 <handsome_pirate> pbrobinson:  Sort of, but it got hijacked
20:14:25 <pwhalen> there were several, all pointing to this root cause, but non explicitly for ours
20:14:35 <pwhalen> https://bugzilla.redhat.com/show_bug.cgi?id=1000715
20:14:42 <pwhalen> thats the last open one iiuc
20:15:06 <handsome_pirate> pwhalen:  It got turned into an internationalization bug
20:15:21 <pwhalen> right
20:15:23 <handsome_pirate> pwhalen:  It looks like two issues are causing the same error output
20:15:29 <kylem> pbrobinson, nah, same as last time, works with mcjit + llvm 3.2, fails with 3.3
20:15:41 <pbrobinson> kylem: thx
20:15:54 <kylem> pbrobinson, i'll look at it when i finish fixing trimslice. and beaglebone black. and all the other things in the world. 8)
20:16:11 <handsome_pirate> pwhalen:  I note that there has been at least one instance of x86 hitting the bug
20:16:11 <pbrobinson> kylem: :-P
20:16:48 <handsome_pirate> pwhalen:  But, the dude is clueless when it comes to properly testing and not screwing up repeatability
20:16:50 <pbrobinson> I doubt it's arm specific, it's probably just not triggered in the std x86 use case
20:17:18 <pwhalen> I tried on x86 in a vm, but initial-setup ran okay
20:17:24 <handsome_pirate> pbrobinson:  Aye, because generally initial setup isn't run on x86 any more, it's been replaced by bits in Anaconda
20:17:43 <handsome_pirate> pwhalen:  It also seems to be a bit of a hysenbug
20:18:00 <pwhalen> during install just dont create a user, initial-setup will run
20:18:24 <handsome_pirate> pwhalen:  But, if /etc/hostname is missing, anaconda will bork
20:18:29 <handsome_pirate> With the same error message
20:18:30 <pwhalen> I will file a new bug on this
20:18:42 <pwhalen> anything else for problem packages?
20:18:59 <pwhalen> alright..
20:19:02 <pwhalen> #topic 2) Kernel Status Update
20:19:40 <pbrobinson> kylem: I'll leave that to you
20:20:03 * handsome_pirate notes that lpae seems to be broken in 3.11-rcx
20:20:11 <kylem> heh. there's really no updates since last time. trimslice has busted pci which results in r8169 not working (so no ethernet) and i'm not having any luck fixing omap.
20:20:24 <handsome_pirate> wcohen and I have both hit that
20:21:12 <jonmasters> in our discussion earlier we agreed that upstream omap isn't exactly in good shape
20:21:24 <jonmasters> so the suggestion was of any of those targets, focus on BBB
20:21:35 <jonmasters> then OMAP4/3 are nice to haves
20:21:39 <kylem> so this segues nicely into talking about supported boards. i think we're going to focus on BBB for F20 and if omap gets fixed, good on it. otherwise people can stay on f19 or remix the f19 kernel + f20.
20:21:50 <jonmasters> +1
20:21:56 <jonmasters> (or do a remix)
20:22:01 <handsome_pirate> kylem:  pwhalen and I had a discussion about that earlier
20:22:04 <pbrobinson> I'm got some bandwidth (for once) so I can poke at omap over the next couple of days
20:22:06 <handsome_pirate> re supported stuff
20:22:24 <handsome_pirate> pwhalen:  You want to sumarize?
20:22:35 <pbrobinson> jonmasters: I believe if we get BBB we'll get most of OMAP anyway but agreed the BB is the core focus
20:22:49 <handsome_pirate> Well
20:23:03 * jsmith bought a BBB in anticipation :-)
20:23:13 <handsome_pirate> Anyway, with x86, we don't list 'supported h/w'
20:23:35 <pwhalen> sorry back
20:23:35 <handsome_pirate> We do have a *short* listing of *unsupported* h/w
20:23:42 <pbrobinson> handsome_pirate pwhalen: I think that conversation would be good summarised to the list
20:23:42 <jsmith> handsome_pirate: We do -- on the DVD sleeves
20:23:48 <jonmasters> pbrobinson: +1
20:23:58 <jonmasters> pbrobinson: (on the BBB/OMAP tradeoffs)
20:24:00 <handsome_pirate> pbrobinson:  It is relevant
20:24:11 <pwhalen> we discussed earlier that we should perhaps not have a supported list, but an enabled list of hw, with some being tested
20:24:19 <jonmasters> pwhalen: +1
20:24:24 <pbrobinson> handsome_pirate: I don't disagree but I would like it also discussed on the list
20:24:27 <masta> BBB would be realyl ncie to have
20:24:33 <masta> nice to have even
20:24:35 <pwhalen> with alpha, and rc's kernels, its not easy to have everything working at the alpha stage
20:24:50 <pbrobinson> pwhalen: that sounds good... I like "enabled HW" as a term :-P
20:25:14 <pwhalen> I agree..
20:25:16 <handsome_pirate> It's a better wording, and also eases QA tension
20:25:22 <kylem> part of the problem is we can't leverage other distros, since most of them don't build -rc kernels for general consumption like we do.
20:25:45 <masta> yea "enabled" is nice sounding
20:25:53 <handsome_pirate> kylem:  Aye, they leverage us :)
20:25:59 <pbrobinson> kylem: a lot of the other distros don't even use upstream kernels but use vendor kernel branches/forks
20:26:31 <kylem> sure. so we have an uphill battle where things may or may not work upstream, and very little interest in bashing things into working order.
20:26:44 <handsome_pirate> masta:  It also fixes the problem of "Oh, crap, it's Freeze and our supported h/w doesn't work"
20:26:59 <pbrobinson> kylem: now you know the shit I've been dealing with over the last couple of years ;-)
20:27:01 <handsome_pirate> masta:  Doesn't mean it entirely goes away, but it effectively does
20:27:17 <masta> so we pave the way forward
20:27:24 <handsome_pirate> masta:  Indeed
20:27:29 <kylem> pbrobinson, yeah, i don't know how you still have a full head of hair
20:27:35 <pwhalen> dgilmore?
20:27:40 <pbrobinson> it's just all grey :-D
20:27:53 <masta> so what are we going to enable?
20:28:04 <pbrobinson> right so from a kernel PoV tegra is good but has PCI issue
20:28:11 <jonmasters> drink more caffeine. It'll be like mine
20:28:13 <handsome_pirate> masta:  Whatever works is what works, that's the beauty of it
20:28:15 <pbrobinson> but kylem is dealing
20:28:25 <handsome_pirate> masta:  Without blocking the distro
20:28:26 <pbrobinson> I'll have a look at TI over the next couple of day
20:28:36 <handsome_pirate> masta:  That's something we don't want to do
20:28:51 <pbrobinson> I believe Calxeda is looking good but we're awaiting a patchset for midway for lpae
20:28:59 <kylem> i may just revert the removal of omap4-panda.c from 3.11 and we can try again for 3.12
20:29:02 <pbrobinson> anyone know the state of vexpress
20:29:07 <handsome_pirate> pbrobinson:  Is lpae busted on Calxeda, too?
20:29:13 <pwhalen> vexpress is working with graphics in tc1
20:29:29 <pbrobinson> handsome_pirate: no but it needs some patches to make it bette
20:29:30 <masta> kylem: wow! the nuke from orbit way
20:29:32 <kylem> pbrobinson, vexpress is fine without dtb use, and works with serial with dtb use, so no changes since f19
20:29:40 <handsome_pirate> pbrobinson:  On exynos, lpae is busted
20:29:54 <pbrobinson> has anyone tested any of the virtio-mmio stuff?
20:30:13 <handsome_pirate> pbrobinson:  It's on my todo list
20:30:31 <masta> ctyler: have you tried the latest lpae kernel on yoru arndale board yet?
20:30:54 <masta> sadly my arndale board has not arrive, had hoped it would be here by branching, but not yet....
20:30:56 <pwhalen> does anyone disagree with the suggestion of enabled hw versus supported hw list?
20:31:36 <masta> pwhalen: do not disagree, enabled > *
20:31:44 <mrunge> you should make it clear, what enabled means, then
20:31:51 <mrunge> enabled == tested?
20:32:03 <handsome_pirate> mrunge:  Aye, that's the general idea
20:32:03 <mrunge> or enabled == should run in theory
20:32:12 <handsome_pirate> enabled == tested
20:32:23 <pwhalen> enabled meaning soc's that should work, and a list of hw thats been tested
20:32:28 <mrunge> so: why don't you say supported
20:32:40 <handsome_pirate> mrunge:  It's a QA thing
20:32:48 <mrunge> I agree
20:32:54 <handsome_pirate> mrunge:  In QA, we have a specific definition of Supported
20:33:02 <mrunge> still, someone should make that clear ;-)
20:33:12 <handsome_pirate> mrunge:  It is, if you look at the QA docs
20:33:41 <mrunge> will do so, thanks for the pointer
20:34:04 <pbrobinson> mrunge: so it would be OMAP3 is enabled and testing on Beagle xM, so it might work on others but it depends
20:34:13 <handsome_pirate> masta:  wcohen and I are both hitting the lpae on exynos issue, so, yes, someone testing with another board would help
20:34:18 <handsome_pirate> ctyler:  ^^
20:35:04 <pwhalen> pbrobinson, right..
20:35:47 <pbrobinson> so I think we're OK with kernel... what's next?
20:36:10 <pwhalen> #topic 3a) Aarch64 - Status Update
20:37:17 <bconoboy> hi
20:37:19 <pwhalen> not sure if anyone is able to give us an update here
20:37:23 <pwhalen> there he is!
20:37:28 <bconoboy> right on target
20:37:30 <pwhalen> :)
20:37:41 <bconoboy> we're 2 package short of 12000
20:37:50 <bconoboy> 11998 of 13606 done
20:37:56 <handsome_pirate> noice
20:37:59 <bconoboy> current rate is about 5 packages per day
20:38:28 <bconoboy> next week Marcin Juszkiewicz is joining Red Hat and that rate should improve
20:38:46 <bconoboy> You've probably already seen him in #fedora-arm as user 'hrw'
20:39:00 <pwhalen> seems slow. I've been noticing builders tend to be unproductive for - out of memory, the build just hangs, and some just seem to go out to lunch.. no clear reason
20:39:01 <bconoboy> His primary task will be getting packages built/ported
20:39:28 <bconoboy> We've long since run out of packages to build from F19-GA
20:39:42 <bconoboy> As we pull in F19-Updates there are some aarch64 fixes here and there, so those succeed
20:39:50 <bconoboy> ... and they fulfill dependencies for others to succeed
20:40:00 <bconoboy> But we're basically at the point where every build is hard-won
20:40:20 <bconoboy> Getting qt sorted should unlock quite a few (order of several hundred)
20:40:30 <bconoboy> Everything else will just unlock little dependency pockets
20:40:48 <bconoboy> #info 11998/13606 packages built
20:40:59 <jonmasters> yep
20:41:14 <handsome_pirate> bconoboy:  I note that my project is still blocking on upstream
20:41:21 <handsome_pirate> ghc upstream is dragging their heals
20:41:43 <bconoboy> The next big step is going to be moving to F20 where more aarch64 fixes will be coming in.  We'll also be reminded of anywhere we had to write a patch and didn't get that patch back upstream because we'll have to do it again.
20:41:58 <bconoboy> #info It's time to move to F20
20:42:23 <bconoboy> pwhalen: I'd guess most of the packages that are hanging are using qt.  It's built but multithreaded code that uses it is hanging
20:42:35 <bconoboy> #info ghc upstream is unresponsive so ghc-using packages aren't built
20:43:14 <bconoboy> Any questions?
20:43:16 <jonmasters> so on the builder/koji/f20 side of things...
20:43:25 <jonmasters> ;)
20:43:45 <pwhalen> #topic 3b) Aarch64 - Koji
20:44:19 <jonmasters> any recent news on getting a koji instance up to host aarch64?
20:44:27 <jonmasters> I haven't heard anything lately
20:44:41 <nirik> I've had no time to work on it... I asked dgilmore and he said he would try and find time to set things up...
20:44:42 <handsome_pirate> jonmasters:  dgilmore is likely busy with building TCs and the like
20:45:00 <handsome_pirate> jonmasters:  Considering we just branched last week ...
20:45:05 <jonmasters> handsome_pirate: indeed, hence I asked that it be on today's agenda so that we could figure out if nirik or anyone else had time
20:45:18 <bconoboy> dgilmore: any update or eta?
20:45:19 <handsome_pirate> nirik:  ^^
20:45:33 * jonmasters wonders if there might be anyone else with cycles. Dennis is awfully busy
20:45:47 <nirik> see above? ;) I've not had time... hopefully dgilmore can. If someone else can I can see about helping them.
20:46:04 <jonmasters> is there anyone else who might beyond the two of you?
20:46:18 * handsome_pirate *might* be able to help out in a couple of weeks
20:46:37 <handsome_pirate> Likely not, though
20:46:45 <handsome_pirate> I'll be up to my eyeballs in QA
20:46:48 <nirik> jonmasters: not sure. Might be some internal folks who work with koji that could help?
20:47:17 <masta> I'd be interested to give it a whirl
20:47:41 * masta has been considering to setup koji here at the house anyhoo
20:47:49 <jonmasters> nirik: if you can think of names, would be awesome, otherwise we could ask John?
20:48:02 <jonmasters> ok, maybe the action here is
20:48:12 <nirik> I can ask around
20:48:16 <handsome_pirate> Gotta go
20:48:19 <handsome_pirate> Peace, y'all
20:48:28 <jonmasters> #action Wait for update from Dennis on Koji for AArch64, possibly ask around inside RH for assistance
20:48:33 <pwhalen> handsome_pirate, thanks for joining
20:49:14 <pwhalen> #topic 4) F20 Hardware Blockers - Should we define hw blockers at all?
20:49:36 <pwhalen> this was already covered.. anything left here?
20:50:13 <pwhalen> #topic 5) Should we reschedule the weekly ARM meeting?
20:50:32 <pwhalen> I know the meeting doesnt seem to work for a number of people
20:50:34 <bconoboy> what's the proposed reschedule purpose and time?
20:51:03 <pwhalen> that, I dont know.. I just know it doesnt work for many folks
20:51:03 <bconoboy> pwhalen: We probably need to hear from those we would be rescheduling it for, when works for them
20:51:08 * jsmith thinks the current time works OK for him
20:51:48 <pwhalen> bconoboy, right..
20:51:56 <bconoboy> My guess is some of our european colleagues would prefer an earlier time slot
20:52:20 <pwhalen> alright, I'll do a mailing list item to see
20:52:24 <bconoboy> +1
20:52:25 <pwhalen> #topic 6) Open Floor
20:53:07 <pbrobinson> it's no better or worse than any other time for me but it varies week to week
20:54:12 <pwhalen> nothing for open floor?!
20:54:14 <jsmith> Zach Oglesby (zoglesby) and I have been working on the formal ARM guide as part of the docs SIG
20:54:42 <jsmith> (mostly based on the outline we looked at during Flock and the Secret Decoder Ring wiki page)
20:54:52 <jsmith> It's still pretty rough, but slowly coming together
20:55:07 <pwhalen> #info F20 Alpha TC2 has been requested and should be out soon, testing appreciated!
20:56:04 <pwhalen> jsmith, any link or too early yet?
20:57:07 <jsmith> pwhalen: It's just a git repo at the moment -- we haven't published it anywhere yet
20:57:13 <jsmith> pwhalen: I'll send more info to the mailing list
20:57:25 <pwhalen> ok, thanks.. let us know if we can help!
20:57:39 <pwhalen> last call for open floor...
20:57:59 <jsmith> Of course -- anyone can help that wants to!
20:58:24 <pwhalen> #endmeeting