fedora_board
LOGS
18:01:28 <rbergeron> #startmeeting Fedora Board
18:01:28 <zodbot> Meeting started Thu Aug 15 18:01:28 2013 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:40 <rbergeron> #meetingname Fedora Board
18:01:40 <zodbot> The meeting name has been set to 'fedora_board'
18:02:06 <rbergeron> #chair jreznik_dac misc jwb mhayden inode0
18:02:06 <zodbot> Current chairs: inode0 jreznik_dac jwb mhayden misc rbergeron
18:02:52 * Sparks is here
18:03:13 <rbergeron> #chair rdieter sparks
18:03:13 <zodbot> Current chairs: inode0 jreznik_dac jwb mhayden misc rbergeron rdieter sparks
18:03:20 <rdieter> hola
18:03:28 <rbergeron> hiya rex.
18:03:49 <rbergeron> #chair inode0
18:03:49 <zodbot> Current chairs: inode0 jreznik_dac jwb mhayden misc rbergeron rdieter sparks
18:04:41 <rbergeron> okee dokee.
18:04:48 <rbergeron> #topic Welcome and agenda
18:04:55 <rbergeron> Hi guys.
18:05:09 <rbergeron> I think some of you just flew in aand boyyyyyyy, are your arms tired, so thanks for coming.
18:05:51 <rbergeron> I posted an agenda but I'll recap quickly as humanly possible:
18:05:55 <rbergeron> #link https://lists.fedoraproject.org/pipermail/advisory-board/2013-August/012105.html
18:06:10 <rbergeron> (In fact, twice, because mail is apparently hard to move through the intertubes)
18:06:41 <rbergeron> #info Proposals for the future architecture of Fedora were made at Flock
18:07:22 <rbergeron> #info Going hand in hand with one of these proposals is what is currently an "informal proposal" about Fedora's "delivery method" (for lack of a better term)
18:07:39 <mhayden> so, if i'm reading this properly, we're talking about a very small "Base" package set with the kernel and minimal bootup/toolchain items?
18:07:49 <mhayden> and then stacking product/package groups on top of it?
18:08:04 <rbergeron> #info Specifically - as individual "products" vs. one thing that fits all of the needs, geared towards specific use cases.
18:08:23 <misc> mhayden: yeah
18:08:25 <rbergeron> mhayden: more or less, though I want to make sure we don't get wrapped around the implementation axle today.
18:08:28 <jwb> mhayden, yes, basically
18:08:33 <jreznik_dac> Is mattdm here to give a brief overview?
18:09:04 <mjg59> Hi
18:09:16 <mjg59> Sorry for lateness
18:09:28 <mjg59> Also I probably need to bail early - cat's sick and needs to be taken to the vet
18:09:41 <rbergeron> ie: Fesco has things they will work on, that specific groups will work on, and we're not really here to dictate those things; Fesco has tentatively approved this in concept, and is looking for general approval about the thought.
18:09:47 <rbergeron> mjg59: :( sorry to hear that
18:09:49 <rbergeron> #chair mjg59
18:09:49 <zodbot> Current chairs: inode0 jreznik_dac jwb mhayden misc mjg59 rbergeron rdieter sparks
18:09:52 <misc> jreznik_dac: away from irc it seems
18:10:33 <rbergeron> does anyone want to pipe up on behalf of fesco as far as a concise description goes?
18:10:47 <rbergeron> Most of the really vague thought is outlined in the mails linked.
18:11:39 <rbergeron> Does anyone desperately need to hear a solid description from fesco at this moment or do the mails suffice?
18:11:50 <jwb> i'm good with the mails and slides
18:11:51 * inode0 is good
18:12:02 <misc> the mail suffice for me to see what they mean, but not to say i agree
18:12:03 <mjg59> From the mails, slides and having followed the fesco discussion yesterday, I'm good
18:12:21 * jreznik_dac is good too
18:12:46 <jreznik_dac> Just want Board to be involved in working group, FESCo was against
18:12:59 <jwb> misc, agree with what?  they're basically looking for "can we continue to define this"
18:13:04 <jwb> jreznik_dac, FESCo was against what?
18:13:10 <mjg59> One thing I brought up in fesco was that when a proposal is made, I'd like to see a description of the changes involved in leadership
18:13:18 <misc> jwb: well, yeah, they can continue , I didn't expressed myself clearly
18:13:27 <jwb> misc, ah, ok.  thanks.
18:13:33 <misc> (ie, i just wanted to say "there isn't enough to give a opinion)
18:13:39 <jwb> sure
18:13:42 <rbergeron> okay. So (since I am still in the agenda portion of the meeting... because I am winning) - today would like to see if we can get general approval (or disapproval if necessary) - or if we can have a list of questions/concerns about proposal as it is.
18:14:18 <rbergeron> I think we will eventually see a formal proposal, but if we're just living on two different planets then we should make sure we know that up front :)
18:14:25 <mjg59> The biggest concern I have is that there's almost certainly going to be some mismatch between the existing desktop SIG and the a definition of Workstation
18:14:33 <mhayden> i like the idea... it's revolutionary -- i'd just like to see more of an end-user experience defined
18:14:59 <rbergeron> So I'm just going to move into the "whatcha thinking" portion just to separate out notes - I will switch the topic
18:14:59 <jreznik_dac> Jwb, Board involvement in the working group
18:15:00 <mhayden> for example, if i use fedora for a webserver (using apache or something), does my user experience change with this?
18:15:02 <mjg59> I'm left with a vague feeling that the existing proposal views Workstation as something slightly different from the existing desktop spin
18:15:09 <jwb> mhayden, i'd say evolutionary more than revolutionary.  i mean, it's essentially taking the critpath idea and actually making it _work_
18:15:16 <jwb> and then expanding on it
18:15:19 <mhayden> jwb: i'm all in on that
18:15:30 <jreznik_dac> Jwb, right, it's evolution
18:15:33 <rbergeron> #topic Thoughts and Comments on high-level proposal
18:15:41 <jwb> jreznik_dac, there are board members on fesco.  too bad if they don't want board involvement
18:15:42 <inode0> It does sound like either something different will be asked of the desktop sig or it will get replaced with some other group willing - but that isn't very clear yet
18:15:49 <misc> mjg59: well, they target a more business/ productivity orented crowd, at least from what I understood from sgalager post
18:15:53 * inode0 agrees with mjg59's feeling though
18:15:55 <misc> mjg59: so i agree
18:16:00 * rbergeron hands you all info's and ideas and pound signs.
18:16:10 <misc> but the current desktop sig target is maybe not that defined in the first place
18:16:13 <jreznik_dac> And we have a lot of stuff already in, it's just adding some kind of flexibility to Fedora
18:16:33 <nirik> jreznik_dac: can't speak for all of fesco, just myself, but I was just saying we shouldn't require board members on every working group. We were wanting to populate them with folks interested in and knowledgable in those areas. If board members are, then great.
18:16:59 <misc> rbergeron: na, our brillants ideas and ramblings cannot be expressed by simple #info :p
18:17:01 <rbergeron> #idea perceive a mismatch between existing desktop SIG and definition of workstation
18:17:11 <jreznik_dac> nirik, ok
18:17:15 <mjg59> So, like I said, *personally* I'd like to ensure that the proposal ends up being written with input from the existing stakeholders rather than ending up seeming like something that's being imposed on them
18:17:34 <jwb> mjg59, agreed
18:17:40 <rbergeron> #idea how will this work with existing desktop SIG vs. another group?
18:17:50 <rbergeron> mjg59: as in "people in the SIGs producing things" ?
18:17:57 <mjg59> I don't really end up with the same feeling about server and cloud
18:18:05 <rbergeron> (desktop, cloud, etc)
18:18:10 <inode0> I don't know it is really the sig - the people who actually make the current desktop :)
18:18:36 <misc> well, for cloud, having a clearly defined document is also needed
18:18:44 <rbergeron> mjg59: you mean server and cloud are different things? or?
18:18:58 <jwb> misc, document?
18:19:03 <misc> is cloud "cloud image", cloud infrastructure (openstack), cloud related stuff (puppet, chef) ?
18:19:04 <rbergeron> (/me just wants to clarify what you are saying, not questioning truthiness)
18:19:11 <mjg59> rbergeron: No, I mean that the people making the proposal are already much more involved with the existing server and cloud spins, so I'm less worried about there being conflict :)
18:19:12 <inode0> they don't seem to intrude on anyone's turf
18:19:24 <inode0> anyone not involved
18:19:35 <jwb> misc, ah.  definition then
18:19:38 <rbergeron> #idea is cloud "cloud image", cloud infra (openstack), cloud-related things (puppet, chef)
18:19:38 <mhayden> is anyone worried that this method of operating might lead to groups working in silos?
18:20:08 <inode0> yes, but that is part of the benefit too in some cases
18:20:16 <nirik> all groups would need to cooperate on the 'ring 0' or whatever they all share at least.
18:20:19 <misc> jwb: yeah, my english fail a lot today :/
18:20:22 <jwb> mhayden, possible, but i think unlikely.  everything would depend on core and base "rings", so conflicting needs from those would need to be discussed
18:20:30 <jwb> misc, nah, i'm just easily confused
18:20:31 <mhayden> makes sense
18:20:39 <jreznik_dac> Yeah
18:20:44 <rbergeron> mhayden: (insert cliche'd silo photograph from every devops presentation ever here)
18:20:46 <mjg59> But sure, I think having someone bring us a vision is going to be a better way to discuss it than us coming up with a vision and asking them to implement it
18:20:55 <mhayden> would there be a group that "owns" ring 0, or would it be something shared between SIGs
18:20:59 <mjg59> I just think we're going to spend a while talking about that vision
18:21:09 <mhayden> rbergeron: haha, believe me, i thought of the same thing ;)
18:21:46 <rbergeron> mhayden: so as matt presented it - it's sort of what we used to consider as "core"
18:21:53 <jwb> i don't know the devops.  i miss out on all the silo fun.
18:22:13 <rbergeron> mhayden: with the distinct difference that it is not core in the way it used to be from a community angle (ie: will not be "red hat only" and full of fail)
18:22:16 <misc> if we decide to use something else than rpm, do we also have legal requirement that should be pushed to the tools used ( like, making sure there is way to express a license, making sure there is a way to have a repeatable process , etc )
18:22:43 <jwb> rbergeron, hey now... could still be full of fail.  but community fail.  we all fail or succeed together
18:22:53 <rdieter> fail faster!
18:23:17 <mhayden> rbergeron: i was a Fedora Core user but i didn't know enough about the operations then to know what "core" refers to
18:23:21 <rbergeron> jwb: indeedly
18:23:28 <jreznik_dac> Misc, post rpm world is far in the future I'd say, it's more about having infra to allow it one day
18:23:32 <rbergeron> mhayden: the word brings up seizures in some people from ye olden days
18:23:43 <jwb> misc, i was confused about the "not rpm" aspect too, but i think that isn't really clear or even planned now
18:23:47 <mhayden> got it
18:24:00 <misc> jreznik_dac: that's a good point, then let's add a timeline of the various plan to what we would like to see :)
18:24:08 <jwb> at least within the scope of the project.  people still use stuff like pip and cpan, etc to install outside of rpm
18:24:13 <jreznik_dac> Jwb, yep, it's future as far as I understand it
18:25:07 <rbergeron> (jwb: conceptually, something like this - http://www.confio.com/media/328543/silos_450x219.jpg - groups not talking to each other (in a prod env) - articles like this are explanatory http://www.tlnt.com/2012/07/16/five-steps-to-break-out-of-your-organizations-business-silo-mentality/ )
18:25:15 <misc> well, if people do it now, that's the present
18:25:33 <jwb> rbergeron, ah.  so devops _fixes_ this
18:25:36 <jreznik_dac> First step is define core, empower sigs and let's have software collections from Flock
18:25:41 <rbergeron> Okay, so: this is a departure from the "we have one thing" type of universe that we have had from a .. immediate perspective
18:26:11 <jwb> by thing you mean product?
18:26:17 <rbergeron> we have always had spins and etc, but mainly, there's been one "fedora" you would download off of get.fp.o - not multiple, individual products.
18:26:28 <rbergeron> jwb: I think we have called it an offering, officially :)
18:26:31 <jreznik_dac> We had it
18:26:33 <jwb> sure
18:27:06 <mjg59> rbergeron: That's not true in a de-facto way
18:27:24 <mjg59> rbergeron: If you go to www.fedoraproject.org and click "Download Now!", you get the desktop spin
18:27:45 <mjg59> Despite that not being the product that "we" develop
18:28:13 <rbergeron> mjg59: and that is the thing we have said is the "default offering" in the past. I guess what I am saying is: We could have multiple default offerings.
18:28:33 <Sparks> The cloud image or other spins are in no way less Fedora than the Desktop offering.
18:28:43 <mjg59> rbergeron: Sure
18:29:10 <misc> Sparks: upon what point do we decide something is less fedora than now, in fact ?
18:29:20 <inode0> Sparks: I hate to disagree with that but I do
18:29:29 <jwb> we call things that aren't Fedora "Fedora Remixes"
18:29:30 <mjg59> rbergeron: But our existing governance isn't really set up for something other than the non-spin Fedora being default
18:29:36 <rbergeron> sparks: no, they're not, but it's different from what we've said before, and probably brings in new considerations for marketing, QA, etc.
18:29:55 <rbergeron> and governance, indeed.
18:29:58 <mjg59> rbergeron: For instance, Fesco making decisions about what should be in standard, spins (including the default offering) then being able to ignore that
18:30:14 <Sparks> How Fedora SIGs spin the Fedora packages does not make them less important that Desktop.
18:30:25 <Sparks> jwb: remixes are different than spins
18:30:28 <mhayden> mjg59: good point on the desktop being the default d/l; i admire ubuntu for having a server installer right there for download (not netinstall)
18:30:34 <mjg59> Sparks: The most important thing we produce is the thing that users get from us when they visit our website
18:30:43 <jwb> Sparks, spins are fedora.  remixes aren't.  that's the line we've drawn.
18:30:53 <mjg59> Sparks: Because that's what most people are going to perceive as Fedora
18:30:55 <Sparks> jwb: Agreed
18:31:07 <Sparks> mjg59: And what do most people want?  Do you know?
18:31:17 <misc> mhayden: but they also have a product a little bit more suited to server due to lifecycle than we do. but that's chicken/egg issue
18:31:23 <mjg59> Sparks: That's really not the point
18:31:41 <Sparks> There is no reason to not bring our other efforts to the forefront.
18:31:43 <mjg59> Sparks: It may be that what we're offering isn't what we should be offering
18:31:45 <rbergeron> Sparks: I think ew all agree in principal that things are not less important or less fedora than others (until we get to hte remix line); that said, what we point people at "by default"  is a desktop.
18:31:49 <misc> mhayden: so should we start by offering it as download to get users/contributers, or the reverse ?
18:31:51 <mjg59> Sparks: But right now, desktop *is* the most important
18:32:07 <rbergeron> it's the thing we point people to. for better or worse.
18:32:15 <Sparks> mjg59: In your opinion
18:32:20 <rdieter> rbergeron: +1
18:32:21 <mjg59> Sparks: No, in reality.
18:32:25 <Sparks> mjg59: Prove it
18:32:29 <mjg59> Sparks: And perhaps we should change that reality
18:32:39 <jwb> Sparks, it's the default download....
18:32:43 <mjg59> Which is part of what this proposal is about
18:32:46 <mhayden> misc: i think it might interest some users to have a "server" installer available that isn't a livecd and isn't a netinstall and isn't a full blown dvd
18:32:46 <Sparks> jwb: And?
18:32:50 <rbergeron> Sparks: I think he means "it's the important thing, because we have labeled it as the default thing, upon which mos tof our criteria and decisions are made"
18:33:01 <mhayden> misc: i think centos has a "minimal" iso that does that (but i'm getting into the weeds here)
18:33:02 <rbergeron> not saying "that's correct"
18:33:10 <Sparks> rbergeron: It's important because we say it's important.
18:33:12 <jwb> Sparks, whether we care equally about other spins or not, it's the thing that gets downloaded most.  it's the thing we promote the most.  it's the thing we hand out at conferences
18:33:38 <Sparks> jwb: Sure because most people take it and install it and then customize it for their purposes.
18:33:50 <misc> mhayden: I do prefer boot.iso for server, but that seems reasonable
18:33:55 <rbergeron> we we will have 3 importantish things, in theory, per this proposal.
18:33:55 <inode0> we have out all the live desktops at conferences for the record
18:34:00 <jwb> Sparks, doesn't matter.  our actions as a project say it's the most important.  as mjg59 says, maybe it's time to re-evaluate.
18:34:00 <mjg59> If we end up providing roughly equal promotion to workstation, cloud and server then it's becaus we consider those more important than things like KDE and electronics design
18:34:14 <mhayden> misc: i use PXE, so i'm a weirdo :)
18:34:24 <Sparks> jwb: And I'm offering a way to think about re-evaluating, that's all.
18:34:28 <mjg59> But right now we seem to be busily bikeshedding a proposal that doesn't exist yet
18:34:34 <jwb> i guess i missed your proposal
18:34:36 <Sparks> mhayden: People still use PXE?
18:34:38 * Sparks ducks
18:34:40 <mhayden> mjg59: i like that last statement about workstation/cloud/server
18:34:49 <mhayden> Sparks: oops
18:36:07 <mjg59> #proposal We agree with the development of a working group to describe an implementation proposal for the future of Fedora, and encourage the involvement of existing desktop, cloud and server contributors in the process
18:36:09 <rbergeron> mjg59: yes, it doesn't exist, but "does this seem to be the wrong direction entirely" - I'm not getting that feeling from anyone here. If i should be, please be more blunt.
18:36:23 <inode0> +1
18:36:48 <misc> +1
18:36:54 <mjg59> +1
18:37:03 <rdieter> +1
18:37:23 <Sparks> +1
18:37:28 <jwb> +1
18:37:31 <mhayden> i love this direction and i want to subscribe to mjg59's newsletter
18:38:02 <rbergeron> +1 as well.
18:39:30 <rbergeron> I think my only concern here is that noen of these diverge away from the fast-moving, advancing the future kinds of things that we do well.
18:40:07 <jwb> hm
18:40:25 <rbergeron> ie: I don't think server and fast-moving are exclusive of one another. But I think most of that goes to 'target audience' questions
18:40:52 <mjg59> rbergeron: Let's get a proposal and then see whether we have fundamental disagreements over the effective target audience it contains
18:41:19 <rbergeron> jwb: you're hm-ing.
18:41:35 <jreznik_dac> +1
18:41:37 <jwb> rbergeron, i would be surprised if there wasn't at least some slowdown to the core set of packages.  certainly nothing RHEL like, but still
18:41:47 <jwb> rbergeron, anyway, to be defined and discussed.
18:41:51 <jwb> so just hmming
18:41:52 <jwb> :)
18:42:11 <misc> there is a demand for a slower pace
18:42:42 <inode0> yeah, I wouldn't want to rule out slowing bits down either - or slower moving blobs sitting on top
18:42:44 <misc> or rather for less breakage
18:42:45 <rdieter> there's demand for ponies and pixie dust too.
18:43:23 <jwb> come now.  nobody wants pixie dust.  makes you sneese.
18:43:26 <jwb> sneeze even
18:43:26 <mjg59> There's potential for this to result in default offerings that are "slower" without reducing the ability to innovate in non-default offerings
18:43:57 * nirik notes that many/most of the things that would be in the 'core' already are slower moving or provide abi/api compatibility... or try very hard not to break things that depend on them.
18:44:22 <rbergeron> unicorn dust.
18:45:22 <rdieter> nirik: <nod>.  this will hopefully end in a good mixture of better defining what is (the status quo) as well as facilitate where folks want to go too
18:45:23 <mjg59> But like I said, let's get an actual proposal
18:45:39 <mjg59> We can work on fine tuning later
18:45:45 * nirik nods.
18:45:49 <mjg59> Anyway, got to head now
18:46:05 <rdieter> well wishes to your cat
18:46:27 <inode0> If we are going to get into the latter part of the agenda I'd prefer to do it when mjg59 can be with us
18:47:00 <rbergeron> inode0: the target audience portion?
18:47:04 <inode0> yes
18:47:39 <misc> so you want to report to next meeting ?
18:47:42 * inode0 believes he has opinions about that
18:48:01 <misc> (on the other hand, i would surprised that the discussion would finish today)
18:48:13 <rbergeron> yes, he does.
18:48:43 <rbergeron> I'm okay with holding that until the next meeting. I don't know what the timeline is for a proposal but I don't think it will be by next week from a working group.
18:49:12 <misc> ok for me too
18:49:19 <jwb> sure
18:50:03 <rbergeron> #agreed hold off on target audience until next week for discussion. will do an IRC meeting. (assuming concerned parties are avaialble)
18:50:17 <rbergeron> Does anyone else have anything of note they'd like to bring up from flock?
18:50:26 <rbergeron> Other than thanks to our lovely organizers?
18:52:13 <rbergeron> Nothing?
18:52:13 <inode0> As mostly unavailable bystander I want to thank mizmo for all she did for us - extremely valuable
18:52:21 * rbergeron taps the microphone
18:52:22 <rbergeron> ah.
18:52:34 <jwb> yeah, i think mizmo did a great job with remote access
18:52:46 <rbergeron> Indeed. Mizmo did a lot of the ... coordinating and info-feeding and transcriptionizing and remotee-love.
18:52:49 * rdieter was happy to watch remotely several presentations live, very nice
18:52:55 <rbergeron> #info THANKS MIZMO!
18:53:01 <rbergeron> rdieter: yeah, it's nice to see things from afar
18:53:30 <rdieter> a highlight was watching smooge dance
18:54:27 <rbergeron> what about toshio? lol
18:54:42 <jwb> i didn't think toshio's dance was broadcast
18:55:36 <rbergeron> jwb: ah. bummer. I have some in my camera but I have yet to down/upload it
18:56:21 <rbergeron> okay. Well then -
18:57:02 <rbergeron> thanks to josh and others for getting the page up to date - for you board humans who have not put your bios in - please do. or we will make something up.
18:57:33 <rbergeron> I think re-updating the meeting page with secretary names would be useful/helpful as well.
18:58:39 <rbergeron> Annnnnnd I think everyone went to sleep, or to lag.
18:58:51 <jwb> nope, i think it's just time to wrap up
18:58:54 <misc> yep
18:58:58 <rbergeron> Okay.
18:59:00 * mhayden searches for caffeine
18:59:48 <rbergeron> Go eat or recover from your day or whatever it is time to do, folks. Thanks for coming. I'll shoot the minutes out - jwb, are you willing to "relay the message to fesco" (in case they can't read, and for officialness's sake)?
18:59:58 <jwb> rbergeron, sure
19:00:02 <rbergeron> (since i saw you offering to sort of bridge that earlier in mail)
19:00:17 <jwb> yeah no problem
19:00:30 <rbergeron> #action jwb to relay info to fesco
19:00:36 <rbergeron> thanks, yo :)
19:00:38 <rbergeron> #endmeeting