fedora-meeting-1
MINUTES

#fedora-meeting-1: Fedora ARM weekly status meeting

Meeting started by bconoboy at 20:02:26 UTC (full logs).

Meeting summary

  1. 1) Problem packages (bconoboy, 20:03:25)
    1. per arm@lists.fp.o, llvm needs love (bconoboy, 20:05:01)
    2. Ghostscript broken on arm in both f20 and f19: https://bugzilla.redhat.com/show_bug.cgi?id=979681 (bconoboy, 20:08:46)

  2. 2) Kernel Status Update (bconoboy, 20:10:03)
    1. kernel 3.11 will have wifi, usb3, hdmi, audio over hdmi support on exynos5 (Arndale&Samsung Chromebook) (bconoboy, 20:12:06)
    2. As of 3.11-git2 the config options look sane for ARM (bconoboy, 20:13:48)
    3. kylem/pbrobinson are working on merging arm32 and aarch64 common configs into config-arm-generic (bconoboy, 20:14:50)
    4. ACTION: kylem to create a list of new supported platforms in 3.11 (bconoboy, 20:16:16)
    5. Latest 3.11 kernel config http://kyle.fedorapeople.org/kernel-3.11.0-armv7hl-lpae.config (bconoboy, 20:17:47)

  3. 3) Aarch64 - Status Update, problem packages (bconoboy, 20:18:48)
    1. 11000+ of 13600 packages are now built (bconoboy, 20:19:33)
    2. stage3 has been retired- stage4 is self sufficient (bconoboy, 20:19:56)
    3. Top blockers: ghc, java, kdelibs (4) (bconoboy, 20:21:08)
    4. ghc has been blocked on llvm, which is available in stage 4 (bconoboy, 20:23:00)
    5. ACTION: handsome_pirate Is talking to ghc upstream (bconoboy, 20:23:20)
    6. ACTION: jonmasters to get details for building openjdk to fulfill java dependency (bconoboy, 20:24:19)
    7. Somebody with qt-expertise would be beneficial to get kdelibs-4 deps built (bconoboy, 20:29:55)
    8. Koji VMs for aarch64 builders are setup (Thanks Nirik!) (bconoboy, 20:32:40)
    9. ACTION: dgilmore to setup koji hub&db for aarch64 (bconoboy, 20:33:02)

  4. 4) F20 PA Promotion (bconoboy, 20:33:40)
    1. Proposal posted on devel-list by Jaroslav Reznik on Tuesday https://lists.fedoraproject.org/pipermail/devel/2013-July/184962.html (bconoboy, 20:36:27)
    2. Numerous issues raised on list: (bconoboy, 20:37:14)
    3. 1: llvm still broken, causing llvmpipe to fail, removing 3d graphics support and no gnome desktop (bconoboy, 20:37:47)
    4. 2: stackprotector support in glibc questionable (bconoboy, 20:38:12)
    5. 3: Delta between build times is still being raised. This is a particular problem for eclipse and other java-using packages since openjdk is less optimized (bconoboy, 20:39:21)
    6. stack protection is supposed to be working (according to ARM's tools team). We are looking into that. (jonmasters, 20:42:26)
    7. llvmpipe has a crash issue in the binary, which can be dug into. Suggestion is to raise whether GNOME desktop really has to be a blocker for PA (jonmasters, 20:42:59)
    8. FYI, ARM BZs are tracked in the 'ARMTracker' alias (bconoboy, 20:57:56)
    9. https://bugzilla.redhat.com/showdependencytree.cgi?id=245418&hide_resolved=1 (nirik, 21:00:52)
    10. Currently open armtracker bugs: https://bugzilla.redhat.com/showdependencytree.cgi?id=245418&hide_resolved=1 (bconoboy, 21:01:34)

  5. 5) Open Floor (bconoboy, 21:03:01)
    1. https://fedoraproject.org/wiki/Architectures/ARM/qa-machines (nirik, 21:06:50)
    2. nirik is looking into adding limited external access to arm hosts - contact with your feedback (bconoboy, 21:09:32)
    3. Linaro Connect is taking place this week- check out the latest at http://www.linaro.org/connect (bconoboy, 21:13:05)


Meeting ended at 21:13:42 UTC (full logs).

Action items

  1. kylem to create a list of new supported platforms in 3.11
  2. handsome_pirate Is talking to ghc upstream
  3. jonmasters to get details for building openjdk to fulfill java dependency
  4. dgilmore to setup koji hub&db for aarch64


Action items, by person

  1. dgilmore
    1. dgilmore to setup koji hub&db for aarch64
  2. handsome_pirate
    1. handsome_pirate Is talking to ghc upstream
  3. jonmasters
    1. jonmasters to get details for building openjdk to fulfill java dependency
  4. kylem
    1. kylem to create a list of new supported platforms in 3.11


People present (lines said)

  1. bconoboy (98)
  2. pbrobinson (45)
  3. handsome_pirate (38)
  4. nirik (33)
  5. mjg59 (31)
  6. jonmasters (28)
  7. kylem (13)
  8. zodbot (9)
  9. msalter_ (6)
  10. shisatum (4)
  11. masta (4)
  12. dmarlin (1)
  13. jcapik (1)
  14. pwhalen (0)
  15. ahs3 (0)
  16. msalter (0)
  17. j_dulaney (0)
  18. ctyler (0)
  19. agreene (0)
  20. ddd (0)
  21. dgilmore (0)


Generated by MeetBot 0.1.4.