fedora-meeting-1
LOGS
20:00:37 <pwhalen> #startmeeting Fedora ARM weekly status meeting
20:00:37 <zodbot> Meeting started Wed May 22 20:00:37 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:37 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin masta j_dulaney msalter ahs3 agreene jcapik ddd
20:00:37 <zodbot> Current chairs: agreene ahs3 bconoboy ctyler ddd dgilmore dmarlin j_dulaney jcapik jonmasters masta msalter pbrobinson pwhalen
20:00:47 <pwhalen> good afternoon all
20:00:52 <pwhalen> .fas pwhalen
20:00:53 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:00:54 <whenry> hi
20:01:04 <jonmasters_> .fas jonmasters
20:01:05 <jonmasters_> good afternoon Mr. Whalen!
20:01:07 <zodbot> jonmasters_: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:01:07 <bconoboy> .fas blc@
20:01:08 <jonmasters_> (done in my best elementary school voice)
20:01:10 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:01:57 <j_dulaney> hellomynameis jdulaney
20:02:08 <j_dulaney> .hellomynameis jdulaney
20:02:10 <zodbot> j_dulaney: jdulaney 'John Dulaney' <j_dulaney@live.com>
20:02:39 <pwhalen> #topic 0) Status of ACTION items from our previous meeting
20:02:39 <pwhalen> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2013-05-15/fedora-meeting-1.2013-05-15-20.18.html
20:02:46 <jcapik> .fas jcapik
20:02:46 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:02:50 <pwhalen> #info INCOMPLETE -jonmasters to help review 3.10 test kernels, and assist pwhalen with vexpress
20:02:50 <pwhalen> #action jonmasters to help review 3.10 test kernels, and assist pwhalen with vexpress
20:03:05 <pwhalen> #info INPROGRESS- pwhalen to post new image/instructions to the wiki for aarch64 quickstart
20:03:05 <pwhalen> #info INPROGRSSS- jonmasters will check vexpress or omap over weekend
20:03:05 <pwhalen> #info INPROGRESS- pwhalen will investigate tegra options
20:03:17 <pwhalen> #info -COMPLETE- ctyler to send an email to the list with Pidora (Raspberry Pi Fedora 18 Remix armv6hl version) image link
20:03:17 <pwhalen> #info Congrats on the new Pidora release Seneca ARM Team!
20:03:22 <bconoboy> \o/
20:03:47 <pwhalen> as for my two inprogress, will have those finished today/tomorrow
20:03:48 <dmarlin> .fas dmarlin
20:03:49 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
20:04:10 * nirik notes we have now: .hellomynameis youraccountname
20:04:39 <pwhalen> anything else from last week to discuss, or shall we go on?
20:04:49 <bconoboy> next
20:04:58 <pwhalen> #topic 1) Problem packages
20:05:49 <bconoboy> The 3.10 kernel has some issues
20:05:56 <pwhalen> pinged Peter, not sure if hes joining us, anyone else aware of problems packages?
20:05:56 <bconoboy> 1. It doesn't boot yet
20:06:03 <pwhalen> right
20:06:14 <bconoboy> 2. It relies on systemd instead of grubby to install the new kernel infrastructure
20:06:21 <bconoboy> But systemd is broken in this regard.
20:06:31 <bconoboy> This is BZ #965897
20:06:39 * j_dulaney has something while we're on kernel
20:06:41 <dmarlin> Bah!  say it ain't so!
20:06:51 <jonmasters_> dmarlin: :)
20:07:10 <pwhalen> #info systemd's kernel-install calls new-kernel-pkg with wrong parameters
20:07:10 <ddd__> jonmasters hugs his favorite systemd ... :) :) :)
20:07:16 <jonmasters_> :)
20:07:17 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=965897
20:07:26 <bconoboy> that's all I have
20:07:51 <dmarlin> bconoboy: does anyone doing systemd now how to install an arm kernel, and what is needed?
20:07:52 <j_dulaney> Chromebook has to wait until 3.11
20:08:05 <dmarlin> s/now/know/
20:08:19 <bconoboy> dmarlin: systemd itself calls new-kernel-pkg, but uses a bad command line parameter.  I put a patch into the bz that fixes it
20:08:38 <jonmasters_> thanks Brendan
20:09:28 <dmarlin> bconoboy: does systemd require uboot-tools as a dependencyon arm?
20:09:40 <pwhalen> is java-1.7.0-openjdk fixed?
20:09:46 <pwhalen> (from last week)
20:09:59 <bconoboy> dmarlin: no, but grubby does
20:10:03 <pwhalen> looks like we have a build in progress now
20:10:19 <jonmasters_> bconoboy: that --install thing might be a problem since I can see them saying that's by design, but..we'll see how that BZ goes
20:11:00 <pwhalen> anyone aware of anything else?
20:11:27 <pwhalen> ok, moving on..
20:11:35 <bconoboy> It looks like othe recent openjdk builds succeeded
20:12:17 <pwhalen> looks like dgilmore is working on it
20:12:40 <pwhalen> #topic 2) Kernel Status Update
20:12:57 <jonmasters_> bconoboy: btw Linaro report zero build of OpenJDK on AArch64
20:13:11 <jonmasters_> (just while mentioning OpenJDK)
20:13:22 <pwhalen> this is also Peter's topic, in my testing 3.10 is not yet booting on any platform
20:13:42 <pwhalen> anyone else have anything to add to the kernel status?
20:13:49 <j_dulaney> See my above
20:13:54 * j_dulaney should have waited
20:14:00 <jonmasters_> I think basically 3.10 needs some love
20:14:01 <bconoboy> #info 3.10 not yet fully baked
20:14:30 <jonmasters_> but also perhaps worth mentioning that Linaro have someone who will work with Paul to help testing of upstream kernels
20:14:32 <ddd__> +1
20:15:28 <pwhalen> next?
20:15:33 <bconoboy> y
20:15:47 <bconoboy> #undo
20:15:47 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2c05d890>
20:15:56 <bconoboy> #info 3.10 not yet booting on any arm platform successfully
20:15:58 <pwhalen> #topic 3) Aarch64
20:16:00 <bconoboy> (tnx dmarlin)
20:16:07 <dmarlin> ty
20:16:11 <pwhalen> #topic 3a) aarch64 status update
20:16:20 <ddd__> jonmasters_: what kernel rev is Linaro based on atm ?
20:16:30 <bconoboy> The aarch64 package queue is more or less empty now
20:16:43 <bconoboy> At this point we need to fix failed builds to make further progress
20:17:02 <jcapik> bconoboy: anything to be fixed urgently?
20:17:18 <bconoboy> MSalter is building qt now- that will free up a lot of packages
20:17:54 <bconoboy> When we rebuild gcc with java support that will also help
20:18:17 <bconoboy> If you look at the nightly report just have a gander at the top-10 missing dependency list
20:19:01 <bconoboy> On that you'll see ghc, qt (kde needs qt), java, SDL_mixer-devel and globus-core
20:19:09 <bconoboy> Not sure what's holding back SDL
20:19:20 * j_dulaney is still poking ghc
20:19:23 <jonmasters_> ddd__: https://git.linaro.org/gitweb?p=kernel/linux-linaro-tracking.git;a=summary
20:19:24 <dmarlin> we also have a page that shows the packages that fail to build for non-dependecy issues:
20:19:27 <dmarlin> https://fedoraproject.org/wiki/Architectures/ARM/AArch64/Stage4_Problem_Packages
20:19:28 <jonmasters_> ddd__: https://wiki.linaro.org/Platform/DevPlatform/LinuxLinaroKernelTreeProcess
20:19:49 <bconoboy> #link Help with broken builds, adopt one on https://fedoraproject.org/wiki/Architectures/ARM/AArch64/Stage4_Problem_Packages
20:20:12 <jcapik> bconoboy: i could look at the SDL
20:20:13 <ddd__> jonmasters_: yeah, already found it; /me inpatient.... thanks for verification I got it right though.... Linaro has quite the git list!
20:20:21 <jonmasters_> yup
20:20:24 <bconoboy> msalter: Are you doing something with SDL now?
20:20:42 <jonmasters_> it'll be funny if we fix SDL before we're really using systems with framebuffers
20:21:23 <jcapik> jonmasters_: if it builds, it doesn't necesarilly mean it works :D
20:21:36 <jonmasters_> :)
20:21:39 * j_dulaney knows that all too well
20:21:40 <bconoboy> Basically we can try unlocking builds by solving dependencies, but it's really time to track down individual build failures.  Please visit dmarlin's list and grab something interesting.
20:21:51 <jcapik> jonmasters_: I guess we only need to build that
20:22:09 <jonmasters_> jcapik: Marcin already found that with the Xorg binaries - weird endian issue was resulting in byte swapped framebuffer
20:22:19 <jonmasters_> bconoboy: thanks
20:22:23 <jcapik> jonmasters_: :D :D
20:22:36 <jcapik> jonmasters_: i wanna see a photo!
20:22:52 <jonmasters_> jcapik: G+ has one somewhere - if I see it (it was a while back) I'll show you
20:23:03 <jcapik> thx
20:23:21 <bconoboy> pwhalen: I think that's it
20:23:38 <pwhalen> #topic 4) Fedora 19 beta for ARM
20:23:46 <pwhalen> #topic 4a) Fedora 19 Beta  for ARM - adding a GUI to the unified image
20:24:15 <dmarlin> is there any technical reason we are not including XFCE on the image?
20:24:34 <bconoboy> dgilmore: We'd like an f19 beta rc image with xfce or similar installed for testing
20:25:05 <pwhalen> that would be great, easier to test..installing now on the rc2
20:25:37 <bconoboy> Since tegra evidently has the ability, we should provide the binaries needed in beta.
20:25:53 <bconoboy> Not to mention we'll want it to diagnose the issues with vexpress and panda
20:25:59 <pwhalen> agreed, if we want to ship for final
20:26:18 <pwhalen> going to also test on omap as well, see if anything has changed
20:26:32 <pwhalen> or Panda specifically
20:26:37 <bconoboy> dgilmore?
20:26:56 * masta waves
20:27:04 <bconoboy> #info These is a desire in the fedora-arm community for an xfce f19-beta image
20:27:26 <pwhalen> ok, next?
20:28:02 <pwhalen> #topic 4b) Fedora 19 for ARM - VFAD Results summary
20:28:11 <pwhalen> #link https://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/2013-05-21-VFAD-Fedora_19_Beta_RC2
20:28:35 <dmarlin> thank you, pwhalen, for all your testing.
20:28:37 <bconoboy> good job pwhalen.  we are all lazy slackers because you let us be :-)
20:29:07 <j_dulaney> +1
20:29:10 <pwhalen> everything is looking better, omap should be fixed in the next RC, will be working nicely with abc now.. trimslice works great, and highbank installs without input, using abc at the end
20:29:14 <pwhalen> of the ks
20:29:37 <pwhalen> exynos5 testing welcome! and beagleboard
20:30:05 <dmarlin> pwhalen: are the kickstarts used for making image and installing available anywhere?
20:30:07 <pwhalen> anything else? questions?
20:30:36 <jonmasters_> oh, worth noting RH got two Arndales
20:30:40 <pwhalen> dmarlin, not the one I used, it was your ks with the removal of the boot.scr bits and addition of abc
20:30:47 <j_dulaney> pwhalen:  exynos5 boots, but drivers are not loading
20:30:53 <jonmasters_> I reached out to Samsung and got them, so we can at least internally help with some Exynos5 Arndale testing
20:31:01 <dmarlin> pwhalen: it might be nice to post those somewhere, for reference
20:31:04 <jonmasters_> (in addition to Chromebook)
20:31:14 <bconoboy> pwhalen: perhaps you could attached the ks used somewhere and point to it from the vfad page?
20:31:15 <pwhalen> cool! j_dulaney it was a long shot, but thanks for testing..
20:31:20 * whenry got his beaglebone back yesterday
20:31:31 <pwhalen> bconoboy, sure can, will add to my people acct, link forth coming
20:31:43 <dmarlin> pwhalen: thanks
20:31:54 <Sparks> [1;3D/win 11
20:31:54 <j_dulaney> pwhalen:  I only knew it was booting at all by tapping the serial console over uart
20:31:54 <bconoboy> pwhalen: perfecto
20:32:15 <pwhalen> #action pwhalen to post ks used for highbank F19 Beta RC2 Install, add to the vfad wiki page
20:32:17 * whenry wonders if he can help with dmarlin's list
20:32:18 <bconoboy> jonmasters: We'll need to figure out the uboot+blob situation to officially support arndale- perhaps we can discuss during open floor
20:33:38 <bconoboy> next?
20:33:40 <pwhalen> ok
20:33:48 <pwhalen> #topic 5) Flock Plannning
20:34:08 <bconoboy> Roll Call: Who is definitely going?  Who is definitely not going?
20:34:09 <pwhalen> this one would be good to have Peter here for, I know he was planning a talk, is anyone else?
20:34:23 * bconoboy is firmly a maybe
20:34:34 * pwhalen would like to
20:34:36 * j_dulaney is more than likely going to be there
20:35:21 <j_dulaney> It's only a 3.5 hour drive for me
20:35:36 <bconoboy> perhaps some arm car pooling is in order
20:35:38 <j_dulaney> Assuming I don't hitch a ride with the RH Party Van as it comes by from Raleigh
20:35:50 <bconoboy> Ooh, party van, even better
20:35:51 <jonmasters_> bconoboy: on blob question I also need to come back with a technical solution for Paul on AXF images that include an initramfs </side note>
20:36:15 * jonmasters_ is planning to go to Flock
20:36:31 <jonmasters_> however, I fly to the UK last day of Flock, so I have to back in Boston that afternoon for another plane
20:36:39 <bconoboy> #info jonmasters, pwhalen, j_dulaney to attend
20:36:39 <pwhalen> yiikes
20:37:01 <bconoboy> anybody who was at fudcon planning on *not* being at flock?
20:37:12 <jonmasters_> I'll probably leave late on the 12th - still gives 4 days there!
20:37:43 * j_dulaney notes that he has a talk on arm virt
20:38:06 <bconoboy> #info j_dulaney to give talk on arm virt
20:38:07 <pwhalen> j_dulaney, cool
20:39:15 <pwhalen> anything else for flock? open floor is next
20:39:35 <pwhalen> #topic 6) Open Floor
20:40:13 <pwhalen> #info Pidora - Fedora Remix now available!
20:40:14 <bconoboy> arndale: I don't think we can officially support it in f19
20:40:17 <pwhalen> #link http://pidora.ca/
20:40:45 <j_dulaney> bconoboy:  I'm assured that the final exynos5 bits should land in 3.11
20:41:30 <j_dulaney> git clone:  Why u no go faster?
20:41:33 <bconoboy> j_dulaney: we need uboot to get upstream, blob to be sorted out- it's an f20 aspiration
20:41:55 <j_dulaney> bconoboy:  That, too.
20:42:17 <j_dulaney> bconoboy:  Although uboot has support for the SoC
20:42:46 <bconoboy> linaro's uboot does, upstream does not, no?
20:43:03 * j_dulaney thought it was upstream
20:43:28 * whenry is trying to look up flock dates but fedora 18 and browsing have become very frustrating
20:43:28 * j_dulaney may be wrong, however
20:43:53 <bconoboy> anyway, that's it for me
20:44:00 <j_dulaney> whenry:  http://fedoraproject.org/wiki/Flock
20:44:00 <pwhalen> whenry, http://fedoraproject.org/wiki/Flock
20:44:03 <pwhalen> :)
20:44:09 <j_dulaney> Beat ye!
20:44:17 <pwhalen> not on my screen :)
20:44:30 <whenry> thanks
20:44:34 <j_dulaney> bconoboy:  Who won?
20:45:09 <pwhalen> anything else for open floor? we're ending early folks, doesnt happen all that often
20:45:17 <bconoboy> j_dulaney: We're all winners (what?)
20:45:24 <pwhalen> bconoboy, thats right
20:45:27 <j_dulaney> LOL
20:45:38 <dmarlin> this is an exhibition, not a competition, so please, no wagering.   ;-)
20:45:40 <pwhalen> going once..
20:46:03 <pwhalen> sold!
20:46:04 <pwhalen> #endmeeting