f19-alpha-readiness-meeting
LOGS
19:01:20 <jreznik> #startmeeting F19 Alpha Readiness Meeting
19:01:20 <zodbot> Meeting started Thu Apr 11 19:01:20 2013 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:34 <rbergeron> I put your meeting in a container in a vm in a meeting
19:01:42 <rbergeron> and detached it using screen
19:01:42 <jreznik> rbergeron: two dogs, no time for meetings!
19:01:55 <jreznik> #meetingname f19-alpha-readiness-meeting
19:01:55 <zodbot> The meeting name has been set to 'f19-alpha-readiness-meeting'
19:02:04 <jreznik> #topic Purpose of this meeting
19:02:10 * nirik adds meeting in meeting support for meetbot.
19:02:24 <jreznik> #info "Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well coordinated."
19:02:41 <jreznik> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:03:27 * jreznik is spamming around...
19:03:53 <jreznik> #topic Current status
19:03:56 <tflink> jreznik: that doesn't sound good
19:04:03 * rbergeron queues the sadface
19:04:37 <jreznik> tflink: what doesn't sound good?
19:04:44 <tflink> jreznik: spamming around
19:05:42 <jreznik> #info at the Go/No-Go meeting it was decided to slip one week with release date on Apr-23, next Go/No-Go Apr-18
19:05:57 <jreznik> tflink: me knows...
19:06:50 <randomuser`> jreznik, i made it!
19:07:10 <jreznik> so that means, we have one more (I hope) week to finish alpha release
19:07:21 <jreznik> let's start
19:07:25 <jreznik> #topic Ambassadors
19:07:44 <jreznik> sesivany already left the channel but I have a report
19:08:22 <jreznik> #info sesivany reports that Ambassadors are ready, they don't have any specific Alpha action item
19:08:50 <jreznik> #topic Design
19:09:01 <jreznik> mizmo: ping, are you around?
19:11:01 <jreznik> seems like we don't have anybody from Design team here, I'll try to reach the team over email but we have Alpha backgrounds and (some) Alpha banners
19:11:21 <shaiton> jreznik: the easiest would probably to fill a ticket to give the state "design ready, or design blocked by..."
19:11:30 <shaiton> (ok, that's out of topic..)
19:11:33 <jreznik> #action jreznik to reach Design team offline for detailed status
19:12:53 <jreznik> shaiton: not a bad idea, I'll take a look
19:13:00 <jreznik> #topic Documentation
19:13:09 <jreznik> randomuser`: your turn
19:13:11 <randomuser`> Hello
19:13:29 <randomuser`> A lot of the docs work only begins at alpha, and we have no specific action items at this time
19:14:22 <jreznik> anything really needed for alpha from docs?
19:14:28 <rbergeron> randomuser`: alpha release notes?
19:14:35 <randomuser`> that said. given the slip, I'll probably push a generic 'we don't have release notes for alpha, give us a heads up if you spot something significant' type content for the release notes rpm
19:15:11 <jreznik> and yep, release notes and announcement was my second question, rbergeron was faster
19:15:39 <jreznik> randomuser`: thanks
19:15:43 <randomuser`> people seem to expect to work with the wiki until beta, so I'm not sure how much time i want to invest in converting to docbook at this time - though I'm open to opposing arguments
19:15:57 <rbergeron> jreznik: I can wait until mktg for announcement
19:16:39 <shaiton> randomuser`: we used to have http://fedoraproject.org/wiki/Fedora_XX_Alpha_release_notes at some point
19:16:46 <shaiton> not sure for last 2 releases
19:17:27 * randomuser` nods
19:17:30 <jreznik> rbergeron: wasn't the idea for f18 that docs create it and marketing makes it nice?
19:17:39 <rbergeron> release notes?
19:17:42 <rbergeron> or the announcement
19:17:50 <jreznik> announcement
19:18:05 <rbergeron> docs creates it, marketing makes it nice
19:18:21 <randomuser`> shaiton, i can either invest my time into herding the available content into such pages, or into working on new content.
19:18:31 <rbergeron> but i went ahead and wrote something since i'm leaving this weekend for a week and yesterday it looked like... you know, we were going to ship
19:18:34 <rbergeron> and there was nothing written
19:18:50 <randomuser`> thanks, rbergeron
19:18:51 <rbergeron> https://fedoraproject.org/wiki/F19_Alpha_release_announcement
19:19:24 <rbergeron> https://fedoraproject.org/wiki/Fedora_19_talking_points <-- put some love into that as well
19:19:35 <jreznik> rbergeron: thanks, we talked about it with randomuser` on Monday's meeting and it's always great to have something to start with for newcomer to this area
19:19:58 <shaiton> randomuser`: tell me, I can do a redirect to the rbergeron announcement for the release page note (alpha). It does not makes sense to have both
19:20:08 <rbergeron> release announcement content could use some polishing
19:20:24 <rbergeron> historically didn't the release notes have a bit more ... technical content and less... you know, marketing fluff :)
19:20:47 <shaiton> you mean, indigest things?
19:20:50 <shaiton> :)
19:20:53 <rbergeron> LOL
19:21:05 <randomuser`> shaiton, it would make sense to work off rbergeron's page, a redirect at this point would be ok
19:21:21 <rbergeron> either way - if we are short on time and want to link one to the other, or whatever, i think it would work
19:21:22 <jreznik> but it still somehow overlaps - would be better to try to merge these two at least for alpha/beta?
19:21:50 <randomuser`> i'm hoping we'll have more to show for beta
19:21:59 <rbergeron> i think the beta release notes are sort of beta-ish for the actual release notes... if not the content will still need to be made for folks to get started on trans and such?
19:22:16 <randomuser`> indeed
19:22:32 * rbergeron shrugs - i think we have alpha sorted - let's tackle beta on docs list to ge ta game plan going
19:23:08 <jreznik> ok
19:23:34 <rbergeron> sorry, /me is slightly sleepy - don't mean to be grumpycat
19:23:46 <randomuser`> i think we're open to ideas - the current plan is to plow away at content and scramble to push to translators and RPM
19:23:46 <jreznik> rbergeron: same here...
19:24:10 <randomuser`> ...roughly so, anyway
19:24:33 <rbergeron> does that cover docs stuff?
19:24:48 * rbergeron didn't mean to take over with marketing stuff too
19:24:57 <randomuser`> no, it's related
19:25:05 <randomuser`> I think we're covered for docs
19:26:12 <jreznik> so for alpha - do we want seperate release notes and announcement or do we want to go with some linking or merging? /me is not sure I understood the discussion correctly (XXX meeting today, where XXX>unlimited)
19:27:13 <randomuser`> i think the best use of our time would be to polish rbergeron's announcement, rather than start over with a seperate release notes
19:27:23 <randomuser`> It's not ideal, but it's the practical plan
19:27:45 <jreznik> ok
19:28:14 <jreznik> #info alpha announcement sorted out by rbergeron, release notes based on the announcement
19:28:39 <jreznik> #topic FESCo
19:28:52 <jreznik> nirik: anything from FESCo lands?
19:29:03 <nirik> nothing I can think of. ;)
19:29:09 <nirik> things have been pretty quiet.
19:29:54 <jreznik> #info things have been pretty quiet, no issues reported by FESCo
19:30:03 <jreznik> nirik: compared to F18...
19:30:14 <nirik> yeah.
19:30:17 <nirik> no kidding
19:31:08 <jreznik> let's move on and hope it will stay pretty quiet till GA
19:31:12 <jreznik> #topic Fedora Engineering Manager
19:31:21 <jreznik> spot: are you around? anything to add?
19:32:22 <noriko> jreznik,
19:32:31 <noriko> can I say from translation?
19:32:45 <jreznik> noriko: sure, mmt
19:33:04 <jreznik> Fedora Engineering is usually ok, let's skip to translation
19:33:05 <noriko> ops, sorry i should wait for Engineering manager report
19:33:32 <jreznik> #topic Translation
19:33:32 <noriko> k
19:33:59 <jreznik> noriko: for you, your turn :)
19:34:08 <noriko> string freeze 2-apr, we are busy to work on translation, and deadline is 16-apr.
19:34:35 <noriko> this time the time frame is quite short, thus atm the completion ratio looks not good as previous releases :-(
19:35:04 <noriko> we have had l10n QA test day 11-apr as well
19:35:18 <noriko> no big issue, but one request.
19:35:36 <jreznik> #info l10n QA test day on 11-apr
19:36:01 <jreznik> noriko: do you need any changes in schedule?
19:36:03 <noriko> for any package, if any string freeze and would like to update the translation, please do not hesitate but let us know.
19:36:23 <noriko> update comes in silently can be missed out easily.
19:36:53 <jreznik> #info the completion ratio looks not good as previous releases
19:36:59 <noriko> I am still thinking more update for anaconda, I see some part appeared in English at today's test day while translation hits 100%.
19:37:33 <jreznik> noriko: it's probably best to talk to anaconda guys, I expect they will still do more changes there...
19:37:52 <noriko> jreznik, to whom can you tell?
19:37:55 <jreznik> as there's still ongoing development, as always for anaconda it is
19:38:08 <jreznik> noriko: I'd ask clumens in #anaconda
19:38:17 <noriko> okay
19:38:39 <rbergeron> i think it would be useful to do some noise around having teams tell trans, vs. them checking in with a zillion folks. helps them out quite a bit at this time
19:39:11 <jreznik> rbergeron: for anaconda - it makes sense to talk directly to guys, we know there's ongoing work
19:39:13 <noriko> jreznik, yea... usually we are annoying to them by filing a lot of bugs
19:39:15 <jreznik> for the rest, I agree
19:39:43 <noriko> k, will do
19:39:57 <jreznik> noriko: I like rbergeron's idea to make noise, if you will need any help - let me know, I'll help you
19:40:29 <jreznik> anything else for translation?
19:40:52 <noriko> k, :)
19:41:34 <jreznik> let's move on, let me know in case you'll need anything
19:41:37 <jreznik> #topic Fedora Project Leader
19:41:46 <jreznik> rbergeron: anything from you?
19:42:26 <rbergeron> not other than what was said already
19:42:31 <rbergeron> next week :D
19:42:42 * rbergeron crosses ingers
19:42:46 <rbergeron> fingers, too
19:43:09 * jreznik too
19:43:44 <jreznik> #info FPL crosses fingers for the next week
19:43:47 <jreznik> ;-)
19:44:03 <jreznik> #topic Marketing
19:44:14 <rbergeron> also, i'm in portland all week next week, but i'll be around the ircs and mail and stuff
19:44:15 * jreznik thinks we covered marketing already
19:44:21 <rbergeron> so... yeah
19:44:27 <jreznik> rbergeron: ok, thanks for heads up
19:44:32 <rbergeron> suehle: anything else here?
19:45:26 * jreznik skipped infra :)
19:45:29 <rbergeron> okay, i guess that's it
19:45:33 <jreznik> thanks
19:45:53 <jreznik> #info marketing was already covered within docs topic
19:46:00 <jreznik> #topic Infrastructure
19:46:17 <jreznik> nirik: ?
19:46:25 <shaiton> (infra meeting just ended)
19:47:03 <nirik> we are all ready I think.
19:47:08 <nirik> we just need bits to mirror out. ;)
19:47:17 <shaiton> :)
19:47:29 <nirik> There's no issues affecting composes or distribution that I am aware of.
19:47:57 <shaiton> nirik: does anyone will get the torrent file through fedmsg?
19:47:59 <shaiton> :p
19:48:01 <mizmo> jreznik, sorry ive been afk
19:48:10 <jreznik> #info infra ready to mirrors bits out, no issues affecting composes or distribution
19:48:16 <jreznik> thanks
19:48:18 <nirik> shaiton: heh. ;) wonder if we could distribute it that way. ;)
19:48:27 <jreznik> mizmo: np
19:48:40 <jreznik> #topic Design
19:48:50 <jreznik> mizmo: another try if you have something to share with us
19:49:00 <mizmo> jreznik, nothing to report
19:49:23 <jreznik> mizmo: websites guys just asked if Alpha banners are final
19:49:48 <mizmo> jreznik, lemme 2x check
19:50:14 <jreznik> we can cover it as websites topic if there's nothing specific to Design team
19:50:23 <jreznik> #topic Websites
19:50:46 <mizmo> jreznik, this is the one to use https://fedoraproject.org/wiki/F19_Artwork/Submissions/Banners#Alpha_Release_Banner
19:50:47 <jreznik> shaiton, robyduck: your turn while mizmo is here
19:51:01 <shaiton> We are ready, just waiting for the checksum to add. Actual at https://stg.fedoraproject.org/
19:51:13 <shaiton> mizmo: you can see if it's the right banner
19:51:30 <jreznik> #info websites ready, staged, waiting for checksum
19:51:33 <robyduck> mizmo: banner is larger than usually this time?
19:51:40 <mizmo> shaiton, looks perfect
19:51:48 <shaiton> info we changed the publishing process, should be smoother for trans, infra and web
19:51:52 <mizmo> robyduck, i dont think so
19:51:56 <robyduck> 210px
19:52:12 <robyduck> instead of 200, no?
19:52:28 <robyduck> but no prob...could be a problem for external websites
19:52:34 <jreznik> #info websites team changed the publishing process, should be smoother for trans, infra and web
19:52:45 * shaiton still see rbergeron community Marketeer on the home page... :p
19:52:45 * rbergeron lols at banner text
19:53:04 <mizmo> hehe
19:53:09 <rbergeron> shaiton: well....
19:53:20 <jreznik> one thing - seems like live isos naming changed
19:53:54 <shaiton> oh?
19:53:56 <robyduck> :/
19:54:01 <adamw> due to changes in koji, apparently
19:54:04 <adamw> i wish that hadn't happened
19:54:13 <shaiton> Smoother1rOgZ: ?
19:54:19 <shaiton> :p
19:54:54 <shaiton> jreznik: ok, we will have to check that once they are composed when adding checksums
19:55:01 <jreznik> shaiton: see https://fedorahosted.org/rel-eng/ticket/5545#comment:10
19:55:02 <shaiton> thanks
19:55:10 <jreznik> kparal talked with dgilmore about it
19:55:17 <jreznik> today
19:55:44 <jreznik> but I see in the ticket "they will change again going forward"
19:56:04 <shaiton> yep :s
19:56:16 <shaiton> It will be fast to fix
19:56:21 <jreznik> dgilmore: are the names final? from the discussion with kamil I understood yes but it's confusing
19:56:22 <shaiton> (in our side...)
19:56:39 <nirik> This is due to the changes for the cloud media creation stuff.
19:57:04 <jreznik> nirik: so final change?
19:57:11 * nirik doesn't have a clear idea if they will change or not. It depends on koji developers.
19:57:32 <nirik> we can't say for sure they won't without some promise from koji upstream
19:57:43 <jreznik> so just heads up for webs - it changed and it may change in the future again
19:58:07 <jreznik> #info live isos naming changed and may change again
19:58:07 <shaiton> sure. Thanks
19:58:12 <robyduck> ok, but we can manage this easily I think
19:58:14 <nirik> I'd love for them not to change, but thats not my call. ;(
19:58:38 <jreznik> anything else for websites?
19:59:05 <jreznik> moving on
19:59:08 <jreznik> #topic QA
19:59:10 <robyduck> no, we are ready
19:59:11 <jreznik> adamw: ?
19:59:15 <rbergeron> nirik: will changing of names affect statistics collection at all?
19:59:21 <rbergeron> oops, sorry
19:59:27 <adamw> yo
19:59:35 <nirik> rbergeron: not sure, but something to check for sure.
19:59:52 <adamw> so, we don't really have much to note, we have decent test coverage so far, we really just have to wait for devs to come up with the uefi fixes then re-spin and re-test.
20:00:13 <adamw> aside from the uefi stuff, this is looking like a pretty solid alpha.
20:00:44 <rbergeron> indeed. thoug we may be scarred by last time around :D
20:00:57 <rbergeron> but it does seem to be going remarkably well
20:01:03 * rbergeron knocks on wood
20:01:27 * jreznik is a little bit scared from that uefi mess as nothing is sure there...
20:01:55 <jreznik> #info decent test coverage so far, have to wait for devs to come up with the uefi fixes then re-spin and re-test
20:02:16 <jreznik> #info we have pretty solid alpha (aside from uefi)
20:04:18 <jreznik> #topic Release Engineering
20:04:35 <jreznik> dgilmore: are you around? or should I ask nirik again? ;-)
20:04:39 <nirik> :)
20:04:59 <jreznik> sorry, you're easy target :)
20:04:59 <nirik> releng should be all fine... just need uefi fixes to spin the next rc.
20:05:29 <nirik> we did note a issue with our compose host, but it just makes things slower than they need to be. Will fix that after alpha goes out.
20:06:04 <nirik> updates pushes are going along fine, but I still need to push those things stable adamw requested a few days ago.
20:06:51 <jreznik> #info releng should be all fine, need uefi fixes to spin the next rc
20:07:22 <jreznik> #info updates pushes are going along fine, still need to push things stable adamw requested
20:07:56 <jreznik> #info issues with compose host notes, will be fixed after Alpha goes out
20:08:13 <jreznik> #topic Open floor
20:08:49 <jreznik> thanks everyone for coming, we are slightly 1 hour+, if you have anything on your mind, speak up, otherwise I'll end the meeting
20:10:08 <jreznik> setting fuse to 3...
20:10:25 <dgilmore> jreznik: sorry never got a notice for the meeting, im dealing with a flooded basement
20:10:49 <jreznik> dgilmore: not a problem
20:11:13 * jreznik hopes he added you to CC, will recheck
20:11:29 <jreznik> dgilmore: what happened? :(
20:11:50 <jreznik> (to the basement)
20:12:04 <dgilmore> jreznik: we had storms, and the water seeped in. seem to have a sewer problem also
20:12:10 <rbergeron> jreznik: thanks :D
20:12:25 <dgilmore> jreznik: never made it to my calander
20:12:27 <rbergeron> and run while you can... lol
20:13:05 <jreznik> dgilmore: well, I send it in email, not adding to calendar but I can schedule it next time at least for people with Zimbra
20:13:51 <jreznik> #endmeeting