fedora-meeting-1
LOGS
20:00:52 <pwhalen> #startmeeting Fedora ARM weekly status meeting
20:00:52 <zodbot> Meeting started Wed Mar 13 20:00:52 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:52 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore
20:00:52 <zodbot> Current chairs: bconoboy ctyler dgilmore jonmasters pbrobinson pwhalen
20:00:58 <pwhalen> .fas pwhalen
20:00:59 <bconoboy> .fas blc@
20:00:59 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:01:01 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:01:03 <pwhalen> afternoon everyone
20:01:06 <dmarlin> .fas dmarlin
20:01:07 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
20:01:37 * masta looks in
20:02:54 * ahs3 makes more coffee
20:03:09 <ahs3> .fas ahs3
20:03:10 <zodbot> ahs3: ahs3 'Al Stone' <ahs3@redhat.com>
20:03:45 <pwhalen> #topic 0) Status of ACTION items from our previous meeting
20:04:07 <pwhalen> #info - INPROGRESS - pbrobinson/bconoboy investigating tog-pegasus - testsuite hangs, needs a BZ filed
20:04:37 <pwhalen> #info - INPROGRESS - bconoboy and dmarlin to do before/after patchify builds on critical path packages to demonstrate safety - Patches posted to the list for feedback
20:04:45 <jonmasters> .fas jonmasters
20:04:46 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:05:00 <pwhalen> #info - bconoboy to write fesco ticket (waiting on package analysis)
20:05:12 <pwhalen> #info - COMPLETE - jonmasters to followup with what Debian and OpenSuSE did for automated patching - They did not automate patching.
20:05:54 <pwhalen> #info - INPROGRESS - jonmasters to reply to the fedora list with his dtb idea
20:06:01 <masta> http://meetbot.fedoraproject.org/fedora-meeting-1/2013-03-06/fedora-meeting-1.2013-03-06-21.00.html
20:06:11 <masta> ^&^ last weeks meeting minutes for action items ^^
20:06:31 <pwhalen> thanks
20:06:49 <oatley> .fas oatley
20:06:50 <zodbot> oatley: oatley 'Andrew Oatley-Willis' <andrew.oatley-willis@senecacollege.ca>
20:06:56 <pwhalen> anything folks would like to discuss there?
20:07:36 <pwhalen> ok, moving forward then..
20:07:41 <masta> ok so the big thing is the patchify
20:08:00 <pwhalen> we have patching on todays agenda, so perhaps we'll come to it then
20:08:21 <masta> we branched so that changed things and I think the engineering meeting is/was today or yesterday, right?
20:08:30 <masta> ok ok, sry
20:08:39 <pwhalen> fesco was today
20:08:54 <pwhalen> #topic 1) Problem Packages
20:09:31 <pwhalen> Peter's a little tied up, is anyone else aware of our current blockers?
20:09:42 <bconoboy> java is still ongoing
20:10:47 <pwhalen> the stats look much better today
20:11:38 <pwhalen> I assume tog-pegasus, java remain as the top blockers (that was the case last week)
20:13:18 <pwhalen> #info problem packages - tog-pegasus, java, python-pillow
20:14:18 <pwhalen> Peter mentions python-pillow is holding back quite a bit, but is working on it and should have it fixed this evening (and patched for aarch64?)
20:15:35 <pwhalen> anything else?
20:15:54 * jonmasters is in a meeting, reading this, sorry about lag
20:16:54 <pwhalen> ok, moving on then ..
20:17:04 <pwhalen> #topic 2) Aarch64 patching
20:17:55 <pwhalen> not sure what the status here is, anyone able to update?
20:18:57 <ahs3> well, my apologies for not being able to attend last week -- the script for generating patches is my fault :)
20:19:19 <bconoboy> looks like msalter isn't here to comment
20:19:35 <dmarlin> bconoboy: do we have a plan yet?
20:20:10 <bconoboy> oh, patching. doh.
20:20:20 <dmarlin> :)
20:20:23 <bconoboy> I sent patches to pbrobinson and dgilmore. Waiting for reply.
20:21:50 <bconoboy> (EOM)
20:21:50 <pwhalen> #info bconoboy sent aarch64 patches to pbrobinson and dgilmore for feedback.
20:21:56 * ahs3 will start another package scan this evening (found a couple of possible bugs in patchify)
20:22:09 <pwhalen> #action pbrobinson/dgilmore to provide feedback on aarch64 patches
20:23:57 <bconoboy> next?
20:24:01 <ahs3> any interest in some of the metrics?
20:24:07 <bconoboy> ahs3: yes please
20:24:37 <pwhalen> ahs3, did you want to send it to the list? I'll add an action item
20:25:14 <ahs3> i can send to the list, too.  just a couple of quick ones: 2459 packages have config.{sub,guess} in them (of > 13K packages)
20:25:51 <pwhalen> #action ahs3 to do another package scan this evening for aarch64 patching, send to the list for review
20:25:59 <ahs3> the script generates patches for 1228 (which is a bit low, hence running it again)
20:26:19 <ahs3> 467 of those with config.* have already been fixed upstream
20:27:05 <ahs3> the weird number is that there are 620 dead packages
20:27:46 <ahs3> (weird == i was surprised it was that big)
20:28:13 <pwhalen> ahs3, thanks, any thoughts on this, or shall we move on ?
20:28:42 <ahs3> pwhalen: i've done enough damage.  let's move on.
20:28:51 <pwhalen> #topic 3) Creating test candidate images for F19
20:29:38 <pwhalen> dgilmore, are you around to give us an update as to where are, and what the plan is?
20:30:40 <pwhalen> he wasnt sure if he would be here, so perhaps we can discuss this one on the list.
20:31:24 <pwhalen> #topic 4) Release Criteria - changes required for ARM
20:31:48 <pwhalen> not sure if anyone had a moment to review the re-write of the release criteria
20:32:27 <pwhalen> #link https://fedoraproject.org/wiki/User:Adamwill/Draft_alpha_criteria_sandbox
20:33:00 <pwhalen> at the qa meeting this week we discussed some of the areas that are challenges for ARM.
20:33:12 <dmarlin> I scanned it... is the blocker desktop still the biggest issue for arm?
20:33:47 <pwhalen> 1) release blocking desktop is defined as GNOME and KDE - we have been using XFCE for ours.
20:34:17 <pwhalen> it was discussed and the suggestion was it was a FESCo decision and should be included in the PA proposal
20:35:02 <pwhalen> 2) All criteria surrounding the installer - altering the wording to be more arm friendly then it exists now.
20:35:59 <pwhalen> the consensus there was that the criteria wouldnt be changed until arm was promoted to PA.
20:36:16 <pwhalen> wouldnt/shouldnt
20:36:48 <pwhalen> any thoughts?
20:37:07 * jonmasters needs to think some more - sorry, in a meeting
20:39:21 <pwhalen> I'll look at the language surrounding the installer, but its a little ambiguous (imo)
20:39:45 <pwhalen> ok, moving on then I guess.
20:40:11 <pwhalen> #topic 5) Open Floor
20:40:44 <pwhalen> anything else for today ?
20:41:02 <nirik> oh, if you like a status update on more machines in phx2...
20:41:15 <pwhalen> nirik, sure! thanks
20:41:17 <nirik> we have the networks setup now, just trying to get the chassis on the right lans
20:41:26 <nirik> once that happens we can install and add them in.
20:41:54 <nirik> I think dgilmore was taking about adding 24 more to current setup, then have some for releng/qa and some for primary arch builders.
20:42:20 <pwhalen> excellent
20:42:56 <pwhalen> thanks for the update
20:43:02 <nirik> anyhow, will provide more info as we know it. ;)
20:43:15 <pwhalen> great
20:43:27 <pwhalen> anything else for today?
20:44:34 <pwhalen> thanks all!
20:44:36 <pwhalen> #endmeeting