f18_final_gono-go_meeting
MINUTES

#fedora-meeting-1: F18 Final Go/No-Go meeting

Meeting started by jreznik at 17:01:20 UTC (full logs).

Meeting summary

  1. Roll Call (jreznik, 17:01:48)
  2. Purpose of this meeting (jreznik, 17:07:00)
    1. Purpose of this meeting is to see whether or not F18 Final is ready for shipment, according to the release criteria. (jreznik, 17:07:16)
    2. This is determined in a few ways: (jreznik, 17:07:23)
    3. No remaining blocker bugs (jreznik, 17:07:30)
    4. Test matrices for Final are fully completed (jreznik, 17:07:37)
    5. http://qa.fedoraproject.org/blockerbugs/milestone/18/final/buglist (jreznik, 17:07:44)
    6. http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria (jreznik, 17:07:49)
    7. https://fedoraproject.org/wiki/Test_Results:Current_Base_Test (jreznik, 17:07:55)
    8. http://fedoraproject.org/wiki/Test_Results:Current_Installation_Test (jreznik, 17:08:00)
    9. http://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test (jreznik, 17:08:05)

  3. agenda (jreznik, 17:08:59)
  4. current status (jreznik, 17:12:40)
    1. Fedora 18 Final Test Compose (TC4) is available, no release candidate (RC) yet (jreznik, 17:13:44)
    2. currently 7 blocker bugs are unresolved (not in ON_QA/VERIFIED/CLOSED state) based on accepted blocker bug list (jreznik, 17:14:56)
    3. 3 proposed blockers (minus the KDE tracking one) (jreznik, 17:15:37)

  5. "mini" review of accepted/proposed blocker bugs (jreznik, 17:17:56)
  6. (891443) crash when reusing existing Btrfs volume (adamw, 17:20:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=891443 (adamw, 17:20:20)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:20:20)
    3. AGREED: 891443 is accepted as a blocker per criterion "The installer's custom partitioning mode must be capable of the following: Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types" (adamw, 17:30:01)

  7. (881624) U.S. keyboard layout used for encryption passphrase entry during fedup second phase (adamw, 17:30:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=881624 (adamw, 17:30:12)
    2. Proposed Blocker, fedup, NEW (adamw, 17:30:12)
    3. AGREED: taking into consideration the general tenor of the wider devel@ discussion, the fact that this is likely documentable and workaroundable and that it could well be fixed with an update to f17's fedup, 881624 is rejected as a blocker (adamw, 17:48:16)

  8. (889699) systemd drops X11 keyboard layout settings during upgrade (adamw, 17:49:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=889699 (adamw, 17:49:01)
    2. Proposed Blocker, systemd, ASSIGNED (adamw, 17:49:01)
    3. AGREED: 889699 is accepted as a blocker per criterion "...it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using any officially recommended upgrade mechanisms. The upgraded system must meet all release criteria." in the case of non-U.S. keymaps (adamw, 18:20:21)

  9. (888089) ValueError: A RAID0 set requires at least 2 members (adamw, 18:24:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=888089 (adamw, 18:24:28)
    2. Accepted Blocker, anaconda, POST (adamw, 18:24:28)
    3. this is now committed and awaiting a new anaconda build / compose / test cycle (adamw, 18:26:51)

  10. (832510) vnc server starts before the network (adamw, 18:26:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=832510 (adamw, 18:26:56)
    2. Accepted Blocker, anaconda, NEW (adamw, 18:26:57)
    3. developer (rvykydal) is on PTO this week, bcl is trying to take a look on the issue (jreznik, 18:29:22)

  11. (877658) [i18n] some storage-related error messages not marked for translation: "Not enough free space on disks for automatic partitioning" (adamw, 18:29:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=877658 (adamw, 18:29:38)
    2. Accepted Blocker, anaconda, ASSIGNED (adamw, 18:29:38)
    3. this just needs an anaconda rebuild, should be fixed with a new build (adamw, 18:32:16)

  12. (890577) drop to dracut shell if /usr is on a btrfs subvol (adamw, 18:32:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=890577 (adamw, 18:32:26)
    2. Accepted Blocker, dracut, ON_QA (adamw, 18:32:27)
    3. we need to do a TC5/RC1 with the updated dracut to fix and test this (adamw, 18:39:06)

  13. (883075) fedup upgrading is too quiet (adamw, 18:39:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=883075 (adamw, 18:39:37)
    2. Accepted Blocker, fedup-dracut, MODIFIED (adamw, 18:39:37)
    3. this either needs some kind of action to build a new upgrade.img or can be considered done with tc4, need to clarify with tflink (adamw, 18:41:47)

  14. (875846) [i18n] "ON" and "OFF" not translated in switches on DVD (gtk30.mo not on DVD) (adamw, 18:41:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=875846 (adamw, 18:41:57)
    2. Accepted Blocker, lorax, ASSIGNED (adamw, 18:41:57)
    3. this just needs a re-spin with new lorax (adamw, 18:43:21)

  15. (889562) Console keymap set to "us" if you install with a keymap not provided by systemd-localed (adamw, 18:43:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=889562 (adamw, 18:43:27)
    2. Accepted Blocker, systemd, NEW (adamw, 18:43:28)
    3. plan here is to try and fix up the most prominent missing conversions in systemd's kbd-model-map where corresponding console keymaps are actually available (adamw, 18:49:31)

  16. (876218) pxeboot/netinst + nfsiso repo = hang on reboot (adamw, 18:51:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=876218 (adamw, 18:51:36)
    2. Accepted Blocker, systemd, ASSIGNED (adamw, 18:51:36)
    3. we still seem to be playing hot potato between anaconda, systemd and nfs developers here. poettering believes it is an anaconda bug (adamw, 18:56:47)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=876218#c17 is relevant here. we *did* waive a similar bug for f17 final. qa in general thought that was a fudge too far. (adamw, 19:05:04)
    5. ball is in development team's court, we need anaconda, systemd and nfs folks to agree on a plan and just fix the damn thing, jreznik and rbergeron please supervise (adamw, 19:15:18)

  17. (891489) anaconda cannot find matching keyboard layouts for several languages, sets them to U.S. English (adamw, 19:15:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=891489 (adamw, 19:15:48)
    2. Proposed NTH, anaconda, POST (adamw, 19:15:48)
    3. AGREED: 891489 is accepted as NTH: it's a safe improvement to language->keymap mapping in anaconda which is desirable for non-english installs (adamw, 19:18:56)

  18. (891487) Anaconda keyboard layout list is missing many offered by GNOME, including some associated with languages for which we offer a translation (adamw, 19:19:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=891487 (adamw, 19:19:03)
    2. Proposed NTH, anaconda, NEW (adamw, 19:19:03)
    3. AGREED: 891487 is accepted as NTH as a potential improvement in keymap availability, we may choose not to take the change if it is too big (adamw, 19:22:03)

  19. (855250) Change the default filtering for Quick and Cangjie (adamw, 19:23:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=855250 (adamw, 19:23:00)
    2. Proposed NTH, ibus-table-chinese, ASSIGNED (adamw, 19:23:00)
    3. AGREED: 855250 accepted as NTH, improves default input config for Hong Kong users, safe change that does not affect anything else (adamw, 19:24:17)

  20. (854557) Keyboard layout testing doesn't work as expected and lacks indication of the active layout (adamw, 19:24:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=854557 (adamw, 19:24:27)
    2. Proposed NTH, anaconda, MODIFIED (adamw, 19:24:27)
    3. AGREED: 854557 is rejected as NTH as the fix just clarifies the input dialog a bit, it doesn't improve the interface, and would necessitate new translations (adamw, 19:28:17)

  21. go/no-go (jreznik, 19:28:57)
    1. there's no RC build, there are outstanding accepted blockers, and test coverage is incomplete. so in accordance with policies, QA votes no-go (jreznik, 19:30:05)
    2. AGREED: to no-go (jreznik, 19:31:19)
    3. AGREED: to slip one week with release date on Tue 2012-01-15 and Go/No-Go meeting on Wed 2012-01-09 (jreznik, 20:04:42)
    4. the possibility of another Fri Go/No-Go will be discussed in case of problems, with possibility to release on Thu 2012-01-17 (jreznik, 20:05:29)


Meeting ended at 20:09:19 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (264)
  2. jreznik (182)
  3. nirik (102)
  4. rbergeron (73)
  5. poettering (61)
  6. drago01_ (26)
  7. drago01 (17)
  8. dgilmore (17)
  9. zodbot (7)
  10. Martix (4)
  11. kmacleod (4)
  12. k0Do (4)
  13. bcl (3)
  14. rtcm (3)
  15. dingtav (3)
  16. jwb (3)
  17. satellit (2)
  18. j_dulaney (1)
  19. BobLfoot (1)
  20. tuanta (1)


Generated by MeetBot 0.1.4.