fedora-meeting-1
LOGS
21:00:48 <pwhalen> #startmeeting
21:00:48 <zodbot> Meeting started Wed Jan  2 21:00:48 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:49 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore
21:00:49 <zodbot> Current chairs: bconoboy ctyler dgilmore jonmasters pbrobinson pwhalen
21:01:05 <pwhalen> happy new year all and welcome back!
21:01:12 <pwhalen> .fas pwhalen
21:01:13 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
21:01:26 <dmarlin> .fas dmarlin
21:01:27 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
21:01:35 <jcapik> .fas jcapik
21:01:35 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
21:01:49 <DarthJava> .fas darthjava
21:01:52 <zodbot> DarthJava: darthjava 'Dmitry Kozunov' <dmitry.kozunov@senecac.on.ca>
21:01:54 <ahs3> and a happy new year to you, too!
21:01:55 <bconoboy> .fas blc@
21:01:56 <zodbot> bconoboy: blc '' <blc@redhat.com>
21:01:59 <ahs3> .fas ahs3
21:02:00 <zodbot> ahs3: ahs3 'Al Stone' <ahs3@redhat.com>
21:02:24 <jonmasters> .fas jonmasters
21:02:25 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
21:02:56 <pwhalen> #topic 1) Current Problem packages
21:03:18 <pwhalen> not sure if anyone has had a chance to review our current problem packages?
21:03:36 <jonmasters> I haven't so far today. I do know that I still need to look at condor and mongodb
21:03:56 <pwhalen> I've pinged Peter, but not sure if he'll be joining us today
21:04:54 <dgilmore> hola
21:05:19 <bconoboy> I don't nkow if it's a problem package or a repo issue, but f19 appears to have a lot of unbuilt packages
21:06:32 <jonmasters> I am about to poke some more at something pbrobinson pointed me at easlier
21:07:01 <bconoboy> jonmasters: pointer for the record?
21:07:21 <jonmasters> http://arm.koji.fedoraproject.org/koji/getfile?taskID=1343837&name=build.log
21:07:38 <jonmasters> that is an example build that is failing weirdly currently
21:07:48 <bconoboy> #link jonmasters to look at http://arm.koji.fedoraproject.org/koji/getfile?taskID=1343837&name=build.log
21:08:27 <bconoboy> pwhalen: with pbr here I'm not sure what else we have for this topic
21:08:28 <jonmasters> some libtool issue perhaps
21:08:29 <pwhalen> perhaps we can come back if Peter joins us later..
21:08:39 <pwhalen> #topic 2) F18 Beta release - remaining blockers
21:08:46 <jonmasters> Peter and I will ponder the createrepo issue later
21:08:51 <jonmasters> (if indeed there is one)
21:08:56 <bconoboy> dgilmore: that's you :-)
21:09:05 <jonmasters> sorry, we've moved on...oops :)
21:09:43 <bconoboy> f18 beta images are ready to go- we're just waiting on highbank installer tree
21:10:11 <dgilmore> ok. my plan is to run pungi this afternoon, which will make a pxe installable Fedora tree and then will need to test and its done
21:10:28 <bconoboy> #info The TC3 images will be the canned-image portion of the F18 beta release
21:10:40 <dmarlin> bconoboy:: I think the images need to be renamed, signed, and then pushed out
21:10:53 <dmarlin> bconoboy: but not sure about the process
21:11:23 <bconoboy> #info Pungi will be used to create anaconda install trees (EG, for highbank)
21:11:42 <bconoboy> #action dgilmore to build and test pungi-created pxe install tree
21:11:54 <bconoboy> dgilmore: will you be looking for help on the install testing?
21:12:01 <jonmasters> assuming that is done, are we happy to use the TC3 testing and treat that as valid?
21:12:10 <jonmasters> (for non-install tree targets)
21:12:21 <bconoboy> #action bconoboy to rename canned images for consistency
21:13:02 <pwhalen> if all goes smoothly target Friday for release?
21:13:10 <bconoboy> +1
21:13:17 <dgilmore> bconoboy: we can make them available for extra testing, there will be limited hardware support, for GA Im going to have to patch lorax to run mkimgae on the upgrade initramfs files
21:13:18 <dmarlin> +1
21:13:29 <dgilmore> though upgrades likely will not be supported
21:13:52 <dgilmore> i think we should do tuesday release
21:13:59 <bconoboy> tuesday?
21:13:59 <dgilmore> since fedora releases on tuesdays
21:14:15 <dgilmore> but thats just my opinion
21:14:17 <dmarlin> dgilmore: has lorax in f18 not already been patched for that?
21:14:34 <dmarlin> dgilmore: I think we are creating upgrade images already
21:14:45 <bconoboy> when is primary going final?  I hope it's not tuesday :-)
21:15:21 <dgilmore> dmarlin: no
21:15:32 <dgilmore> dmarlin: theupgrade images are made
21:15:43 <dgilmore> dmarlin: but they dont get mkimage run on them
21:15:55 <bconoboy> Hmm according to https://fedoraproject.org/wiki/Releases/18/Schedule?rd=Releases/18 the fedora 18 final release is tuesday.  I'd rather we have beta out before then.
21:16:01 <dgilmore> bconoboy: its supposed to be tuesday but likely the 15th
21:16:18 <dgilmore> bconoboy: we have not composed a RC for f18 ga
21:16:26 <dgilmore> and there is still a bunch of blocker bugs
21:16:32 <dgilmore> its not going out tuesday
21:16:44 <bconoboy> dgilmore: even so, considering the small delta between f18 arm beta and final I think earlier is better
21:16:59 <dgilmore> http://qa.fedoraproject.org/blockerbugs/milestone/18/final/buglist
21:17:12 <dgilmore> bconoboy: thats the proposed and accepted blockers
21:18:59 <bconoboy> dgilmore: I can support tuesday if we can make sure to not slip- IE, even kicking out highbank install tree if it's not ready by then.
21:19:20 <dgilmore> bconoboy: ill be putting on the mirrors friday
21:19:31 <dgilmore> it will give them the weekend to sync it
21:19:44 <bconoboy> dgilmore: So it'll populate over the weekend, and we announce on tuesday?
21:19:51 <dgilmore> bconoboy: yes
21:20:04 <jonmasters> cool
21:20:12 <bconoboy> dgilmore: so, technically, somebody could get to it saturday :-)  Okay, that's fine with me
21:20:17 <bconoboy> any dissenters?
21:20:38 <dgilmore> bconoboy: right
21:20:53 <bconoboy> #info F18 Beta to finalize on Friday, release announcement on Tuesday
21:21:19 * jonmasters vehemently agrees
21:21:20 <pwhalen> #topic 3) Fedora ARM t-shirts for FUDCon
21:21:23 <dmarlin> dgilmore: not sure if it's relevant, but highbank does not use the u-boot wrapped images for anaconda installs
21:21:38 * jonmasters provides an update on t-shirts
21:21:52 <jonmasters> ok so there is approval from ARM to use their "Connected Community" logo
21:22:08 <jonmasters> Red Hat is part of the ARM Connected Community, and Fedora legally is a Red Hat thing, so this is ok with ARM
21:22:19 <jonmasters> however, they will need to approve the final proof before printing
21:22:21 <dgilmore> dmarlin: right, its not a hugely critical thing, thats why i said it should be fixed for GA and then its just for consistency
21:22:37 <jonmasters> this means that we should get a t-shirt design this week, and submit for approval if we have any hope of printing some before FUDCon
21:23:50 <pwhalen> has anyone looked at doing a design? or anyone artistically inclined who would like to?
21:24:22 <jcapik> I've seen nice t-shirts with picture of muscled arm (flexing) ...
21:25:36 <jonmasters> I'm thinking make it really really simple. Just have the Fedora logo and "Fedora ARM" on the front, and the ARM Connected Community logo somewhere
21:26:20 <jonmasters> perhaps even just a single front print as that's lower cost. Could have the Fedora and ARM Logos on the front with "Fedora ARM" on the lapel and a URL
21:26:26 <jonmasters> I guess let's discuss on the list
21:26:40 <jonmasters> does it make any sense to try to pull this off this week?
21:26:59 <pwhalen> being so simple, should help us do so
21:27:39 <jonmasters> ok, so I'll send the ARM guidelines, and then let's open this up to the floor
21:27:45 <jonmasters> who has time to own doing the design this week?
21:28:10 <jonmasters> and that means, doing it tomorrow and sending it out before the end of the day Eastern time so that we have chance to send to ARM for them to approve on Friday
21:28:22 <jonmasters> (and they are UK, so it needs to be done by tomorrow night)
21:28:41 <jonmasters> I could own it as a fallback, but I would rather find someone else
21:28:42 <jonmasters> :)
21:28:50 <bconoboy> damnit jim, I'm a cart herder, not a graphic design artist
21:29:20 <pwhalen> I dont mind, not sure whats needed
21:29:31 <bconoboy> isn't there a fedora community we can tap for this?
21:29:37 <jcapik> I've done some logos in the past, but art isn't a factory
21:29:52 <jonmasters> there's the #fedora-art IRC
21:30:06 <jonmasters> pwhalen: let's do this
21:30:32 <jonmasters> pwhalen: I'll send the guidelines out for the logos, and then you write up what we just discussed above ^^^ my comments, any thoughts you have, you raise in #fedora-art
21:30:41 <pwhalen> sounds good
21:30:49 <jonmasters> pwhalen: also bring it up on their mailing list, and ping mizmo and ask her if she would have chance to assist
21:31:09 <jonmasters> Mo is able to do amazing things in near zero time
21:31:31 <jonmasters> pwhalen: so you don't need to own the design, just drive the car
21:31:32 <jonmasters> :)
21:32:04 <jonmasters> #action pwhalen to collate initial comments on t-shirt designs, ping #fedora-art, and their mailing list, and mizmo directly
21:32:25 <jonmasters> #action jonmasters to forward ARM logo guidelines
21:32:41 <pwhalen> sounds good, thanks
21:32:53 <pwhalen> #topic 4) your topic here
21:33:31 <bconoboy> zoglesby: ping
21:33:48 <bconoboy> Okay, I have a topic:
21:33:57 <bconoboy> Question: What do people want to do at fudcon?
21:34:19 <zoglesby> sorry I am here
21:34:35 <bconoboy> Anybody have any particular thing they want to discuss, work on, etc while there?
21:35:23 * masta looks in
21:35:24 <jonmasters> I would like us to make sure we have that room booked. Is that done?
21:35:26 <bconoboy> My list is: Talk about primary architecture move, talk about phoenix move, work on arm remix guidelines, and create a place to store our wishlists for what fedora-arm has become
21:35:48 <bconoboy> er, s/has/can/
21:35:58 <bconoboy> (y'know, simple stuff)
21:36:03 <ahs3> well, i plan on bringing my random collection of ARM boxes to see what i can get working with fedora...
21:36:11 <jonmasters> Over the holidays, I read about these book writing hackathons where in 2 days a room creates a fully published book from scratch. It made me think we really ought to be able to get some good wiki content done in the same time :)
21:36:24 <ahs3> ...and showing off the armv8 bootstrap :)
21:36:37 <jonmasters> right, we'll definitely talk ARMv8
21:36:56 <zoglesby> jonmasters: I can help with getting that into docbook and on docs.fp.o
21:37:02 <jonmasters> but we should default in the rest of the time to getting good docs on the wiki, figuring out plans for primary, infrastructure movement, and the like
21:37:13 <bconoboy> #info Fudcon topics: primary architecture move, phx move, remix guidelines (remixathon!), making new contribution roles, v8 bootstrap demo...
21:37:19 <ahs3> the wiki's an interesting idea -- are there specific topics to cover?
21:37:32 <bconoboy> #info ... wiki hacking (integrate our stuff into PA wiki?) ...
21:37:36 <jonmasters> zoglesby: to be clear, I don't mean to actually write a book, I was just using that as a comparison to show how we ought to be able to get our wiki into shape within 2 days
21:37:48 <jonmasters> ahs3: wishlists and todo lists
21:37:54 <masta> some wiki updates would be good
21:38:09 <masta> Ian said we can just snag a room
21:38:19 <zoglesby> jonmasters: indeed, but if it ends up being a guide its a good idea to keep it on docs
21:38:23 <ahs3> maybe even just a review of what's already there....
21:38:24 <jonmasters> wishlists, todo lists, builder configuration, individual board install pages, "getting started" documentation, wiki content around what we are working on before the next FUDCon
21:38:42 <masta> so nothing is booked, but we might press for a room if it's still...
21:38:50 <masta> desired
21:38:54 <jonmasters> process documentation is important too
21:39:21 <jonmasters> how we are doing releases, what our criteria are, what our goals are for ARMv5/v7/v8
21:39:36 <bconoboy> #info Discuss v5, v6, v7, and v8 plans
21:39:46 <jonmasters> we should set aside time early on to figure out what we want to write in the wiki and have little subgroups spend spare time during FUDCon working on it
21:40:19 <jonmasters> I'd rather just gather on the Friday morning, grab a whiteboard, figure this all out, then make a commitment to get these things done during the FUDCon and summrized on the Sunday
21:40:56 <jonmasters> we should do the same with other FUDCon stuff. We need to meet for a 1-2 hour session at the begining, intro the project, who's who, and then spend time figuring out what we are doing for the three days
21:41:11 <jonmasters> input before then is of course good - we should have a list going in, and we already have various topics on that list
21:41:53 <jonmasters> (side note that I am leaving Sunday after lunch or so - not sure exactly yet)
21:42:45 <bconoboy> #info Have an intro session
21:42:45 <ahs3> wfm.  i like that as a plan, for my $0.02 worth
21:43:05 <bconoboy> we should make sure we have arm specific door signage
21:43:24 <bconoboy> last year we just had fedora paper and hand written "ARM"
21:44:08 <bconoboy> Oh, an perhaps we ought to have a meeting of secondary architectures groups once more?
21:46:31 <bconoboy> Okay, that's probably a good stopping point for this topic
21:46:41 <bconoboy> anybody else?
21:47:25 <zoglesby> I was told to ask here about ways I can help, specifically on wiki and qa processes
21:47:58 <zoglesby> would it be easier to wait until FUDCon to get a better idea?
21:48:06 <bconoboy> zoglesby: will you be at fudcon?
21:48:12 <zoglesby> bconoboy: yes
21:48:16 <bconoboy> cool!
21:48:28 <jonmasters> ok, any other topics?
21:48:54 <bconoboy> zoglesby: our wiki needs some serious gardening.  have you looked at it?
21:49:30 <zoglesby> only a little
21:49:36 <ahs3> just an fyi: January is expected to be slighter colder than normal with slightly above normal precipitation on the Great Plains.  dress warm for FUDcon :)
21:49:48 <bconoboy> if anybody has some wish list items they want to see done please let zoglesby know- volunteers are awesome!
21:50:15 <bconoboy> ahs3: perhaps we should provide warmy hats instead of shirts...
21:50:43 <jonmasters> ahs3: on that note, I am bringing my running gear. If anyone would like to go (outdoor) running, let me know :)
21:50:45 <ahs3> bconoboy: oooo...with furry ear flaps....
21:51:00 <bconoboy> ahs3: right- fedora logo on one flap, arm logo on the other
21:51:14 <ahs3> lol.  i *want* one!
21:51:41 <bconoboy> with the little clasp that connects the two to hold the flaps up...
21:51:42 <jonmasters> bconoboy: the other option of course would be cup holder/warmer things
21:52:03 <jonmasters> I still think t-shirts are the easiest, but there's a thought
21:53:11 <bconoboy> pwhalen: anything else?
21:53:12 <pwhalen> shall we wrap?
21:53:20 <bconoboy> +1
21:53:21 <pwhalen> nothing from me
21:53:29 <jonmasters> +1
21:53:31 <pwhalen> #endmeeting