fedora-meeting-1
LOGS
21:00:28 <pwhalen> #startmeeting
21:00:28 <zodbot> Meeting started Wed Nov  7 21:00:28 2012 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:28 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore
21:00:28 <zodbot> Current chairs: bconoboy ctyler dgilmore jonmasters pbrobinson pwhalen
21:00:38 <pwhalen> good afternoon
21:00:42 <pwhalen> .fas pwhalen
21:00:42 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
21:00:46 <ctyler> .fas chris@tylers.info
21:00:46 <zodbot> ctyler: ctyler 'Chris Tyler' <chris@tylers.info>
21:00:50 <ctyler> Howdy!
21:01:28 * masta waves
21:01:44 * pbrobinson waves
21:02:33 <ahs3> .fas ahs3
21:02:36 <zodbot> ahs3: ahs3 'Al Stone' <ahs3@redhat.com>
21:03:14 <pwhalen> looks like we're waiting on a couple folks, but lets get started
21:03:18 <pwhalen> #topic 1) F18/19 build status - problem packages?
21:03:22 <pbrobinson> texlive
21:03:23 <dmarlin> .fas dmarlin
21:03:23 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
21:03:50 <pbrobinson> it's large at like 1.5gb for the source package. It's affecting both f18 and rawhide
21:04:30 <bconoboy> I'm testing the srpm on an x86_64 host now
21:04:30 <pbrobinson> and unfortunately now it's update has been unblocked from legal issues it seems it will be a regular feature in this session
21:04:54 <fossjon> heaviest builders only then
21:05:05 <fossjon> 100+ cores
21:05:12 <pwhalen> sounds like bconoboy has the ball on that one, are there any others?
21:05:17 <pbrobinson> eclipse still isn't fixed but we have forward momentum and now koji is responsive I'm hopeful we'll have it done and dusted this week
21:05:45 <pbrobinson> it's not about cores it's about IO and bandwidth. The texlive package isn't heavy to builds
21:05:58 <bconoboy> needs a lot of disk space though
21:06:08 <bconoboy> standard nfs loopback mount builders can't handle it
21:06:15 <pbrobinson> Gbit  local network and a 120Gb SSD would do it :)
21:06:33 <fossjon> sounds good
21:07:23 <pbrobinson> I'm wondering whether we can somehow isolate it to the cdot tegra devices as then its local to koji and we don't have to drag it to HSV, they have decent pcie network and a local HDD
21:07:39 <pbrobinson> and I think we have a v5 and v7 tegra there
21:07:44 <bconoboy> yeah, it'd be better to keep it on the ethernet
21:07:55 <ctyler> we'd need a separate class, but it could be done
21:07:56 <bconoboy> 13-1 and 14-3 maybe?
21:08:14 <ctyler> I'll make sure that's in place tomorrow
21:08:33 <bconoboy> #action ctyler to setup a new build server class to handle texlive on local ethernet
21:08:35 <pbrobinson> I think a separate "total fucker" class would be worth it for these ones if there's going to be a number of updates to them
21:09:08 <pbrobinson> and while the tegra isn't the fastest I don't think speed is so much the issue.
21:09:46 <bconoboy> a 1.4GB download will require some swap.  I think the download happens all in ram.
21:10:10 <pbrobinson> yes
21:10:28 <pbrobinson> do those trimslices have HDD or SSD?
21:10:31 <ctyler> what? We download totally in RAM?!
21:10:37 <masta> how come it goes to ram?
21:10:44 <ctyler> pbrobinson: at least two are HDD, I think all four are
21:10:55 <bconoboy> ctyler: I might be wrong. dunno.
21:11:20 <pbrobinson> I think if it was all in RAM libreoffice would have killed us long ago
21:11:31 <bconoboy> okay, perhaps not
21:11:44 <fossjon> while(true){d=f.read(2**20);g.write(d);}
21:11:44 <pwhalen> anything else for problem packages?
21:12:03 <bconoboy> fwiw, http://arm.koji.fedoraproject.org/wold/1352274291.597445.fLZfqMvL/texlive-2012-5.20121024_r28063.fc19.src.rpm untars correctly on x86_64... testing arm next
21:12:17 <pbrobinson> eclipse is still there, I've mitigated some of those issues and I think it should be closed out this week
21:12:47 <pbrobinson> and I need to do another 3.7 kernel but it's not blocking much yet
21:12:59 <pwhalen> #info eclipse build issues should be cleared by the end of the week
21:13:05 <masta> bconoboy: you're doing the rpm2cpio ?
21:13:09 <pbrobinson> but rawhide today is moving forwards which is nice
21:13:09 <bconoboy> masta: y
21:13:22 <bconoboy> if that works I'll do an rpm -i... see if there is some 1GB file limit or somesuch issue
21:13:45 <pbrobinson> if people want things to work on look trought the ARMTracker list for things to pick out
21:14:02 <bconoboy> pbrobinson: are all problem packages in armtracker now?
21:14:02 * pbrobinson takes a quick look at logs
21:14:09 <masta> ??
21:14:19 <masta> how to find the tracker?
21:14:42 <fossjon> isnt rpm data compressed?
21:14:46 <pbrobinson> python-greenlet is blocking gluster
21:14:47 <bconoboy> #link https://bugzilla.redhat.com/show_bug.cgi?id=245418
21:15:00 <bconoboy> #info the above is the URL for all armtracker bugs
21:15:07 <bconoboy> masta: just visit the link
21:15:17 <pbrobinson> bconoboy: most not all, I'm adding more as I get the urge to triage and deal with BZ
21:15:38 <pbrobinson> I've fixed a number of small breakages over the last week. Things missing small deps etc
21:16:06 <pbrobinson> you'll notice the f18 and f18-updates-testing diffs come down quite substantially
21:16:28 <bconoboy> 173 and 32- looking good!
21:16:36 <pbrobinson> the ones that I can fix quicker than filing a BZ I just do myself
21:17:10 <pwhalen> #topic 2) F18 Beta Release Criteria - items left unresolved from Alpha
21:17:12 <pbrobinson> I need to deal with the F17 kernel at some point as it'd broken but it's not as high on my prio as 18/rawhide kernels
21:17:38 <bconoboy> 2 issues come to mind: pxe installer for highbank and selinux
21:17:41 <pwhalen> #link http://fedoraproject.org/wiki/Architectures/ARM/Fedora_18_Beta_Release_Criteria
21:17:43 * pbrobinson notes it's worth reading the FESCo meeting notes when they hit devel@
21:17:54 <pbrobinson> beta has been pushed out
21:17:54 <bconoboy> oh, and possibly expanding scope, armv5tel kirkwood image
21:18:12 <pbrobinson> I would LOVE to see BeagleBoard images. We had them for F17
21:18:19 <pbrobinson> and suse has them ;-)
21:18:33 <bconoboy> dmarlin: who's doing the dreamplug image?
21:18:34 <pbrobinson> and the only real difference to panda should be the uboot
21:18:37 <pwhalen> sounds like good progress is being made on v5
21:18:42 <pwhalen> (images)
21:18:57 <bconoboy> we're also lacking beagleboard images, haven't heard any complaints though
21:19:26 <ctyler> some of my students are running into missing BB images
21:19:26 * pbrobinson IS COMPLAINING
21:19:41 * pbrobinson slaps bconoboy
21:19:42 <bconoboy> ctyler; perhaps one of them could take the lead on creating them?
21:19:42 <ctyler> So the OMAP kernel should cover both BB and Panda?
21:19:50 <pbrobinson> yes
21:19:51 * bconoboy parries
21:19:58 <pbrobinson> only difference is uboot
21:20:11 <ctyler> Ok, I'll get someone to look at that.
21:20:28 <pbrobinson> ctyler: thanks
21:20:40 <masta> and they have diff .dtb
21:20:41 * ctyler is hacking with a student on this at 9:30 tomorrow morning anyways
21:21:33 <bconoboy> ctyler: dmarlin's writeup on how to make images should be pretty much all they need, just tweak the panda kickstart a bit
21:21:46 <bconoboy> #action seneca to look into creating f18 beagleboard images
21:22:18 <dmarlin> bconoboy: most likely just include the right u-boot, and adjust the boot.scr/uEnv.txt is all that's needed
21:22:46 <pwhalen> #link https://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/2012-10-26-VFAD-Fedora_18_Test_Day
21:22:53 <pwhalen> #info F18 Alpha results
21:22:57 <pbrobinson> the uEnv.txt should almost be the same I think
21:23:20 <pwhalen> the other issues mostly involved xfce.
21:23:50 <bconoboy> Does anybody want to add additional requirements to beta?
21:24:11 <pwhalen> I did notice that when SELinux in enforcing there is sometimes an issue with the network (as reported during the vfad)
21:24:59 <masta> yes the selinux thing effects NetworkManager.service on panda
21:25:15 <bconoboy> only panda?
21:25:29 <pbrobinson> dmarlin pwhalen masta: can you reply to Dan Walsh's email with in depth details about selinux issues, he's the man to fix the selinux issues
21:25:32 <ctyler> Dan Walsh seemed willing to get involved
21:25:38 <masta> AFAIK only panda images were reported ot have the issue
21:25:46 <pwhalen> I only tested the panda today and noticed the issue
21:25:55 <pwhalen> was gathering some info to send Dan
21:26:09 <masta> pbrobinson: will do
21:26:10 <pbrobinson> give dwalsh all the details and even build him a panda with the issue in the farm and he'll sort the problem
21:26:10 <dmarlin> pbrobinson: maybe we can get him access to one (or more) of the affected systems?
21:26:11 <pwhalen> I dont recall seeing it on the TS, but will check again
21:26:25 <pbrobinson> dmarlin: absolutely
21:26:47 <pbrobinson> he is Mr SELinux, if he can't fix it no one can!
21:26:48 <masta> it seems like a weird race condition
21:27:00 <masta> simply restarting the NM serivce solves
21:27:23 <masta> dwalsh will be emailed
21:27:55 <bconoboy> who is sending the mail?
21:28:27 <pbrobinson> I would like to see the relabelling issue investigated as well with the anaconda install so not just the NM issue
21:29:12 <dmarlin> pbrobinson: I think that when we start using f18 tools, the relabelling issue will go away.
21:29:26 * masta will send dwalsh email
21:29:31 <pwhalen> #info - issues to be resolved for Beta 1) Highbank PXE Install 2) SE Linux issues - with image creation, boot in enforcing mode with later kernels
21:29:32 <dmarlin> pbrobinson: we didn't see it on my recent f18 anaconda install tests
21:29:56 <pwhalen> ok, masta, I posted some output for omap on the kernel testing page
21:29:59 <pbrobinson> dmarlin: which kernel?
21:30:28 <dmarlin> 3.6.3-3.fc18.armv7hl.highbank
21:31:31 <pwhalen> #link https://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/Kernel_Testing#kernel-3.6.4-1.fc18
21:31:59 <pwhalen> #info includes output of boot issue on omap with SE Linux in enforcing
21:32:02 <bconoboy> #action masta will email dan walsh about selinux issue
21:32:46 <pbrobinson> pwhalen: that's what we need to get to dwalsh
21:33:00 <pwhalen> right, just did before the meeting with intention to email him
21:33:22 <masta> does Dan have a panda?
21:33:33 <ctyler> Don't think so.
21:33:34 <pwhalen> and that was our next topic, so changing now
21:33:41 <pwhalen> #topic 3) selinux - boot issue with kernel-3.6.4-1+ when in enforcing
21:34:10 <jonmasters> pwhalen: where's the selinux boot text?
21:34:40 <pwhalen> jonmasters, http://fpaste.org/n7xX/
21:35:15 <jonmasters> ok (tangent - that sound symbol stuff needs fixing)
21:36:22 <jonmasters> so it's the mmap_zero AVC denials that need poking, ok
21:37:28 * jonmasters checks out selinux-policy
21:37:42 <pwhalen> jonmasters, is that something you'd be able to look at, or should we talk with dwalsh?
21:38:23 <pbrobinson> we should go both routes.
21:38:38 <pbrobinson> jonmasters has things he needs to be complete for me first
21:39:15 <jonmasters> ping Dan
21:39:24 <jonmasters> I'm just helping triage here in this meeting
21:39:51 <pwhalen> ok, masta is on that one I believe. Please let me know if you need more output or anything from me
21:40:14 <pwhalen> #topic 4) FUDCon Lawrence - who's attending, planning ARM activities
21:40:35 <pbrobinson> masta: copy the list then all can see and answer if they have the info or know the answer
21:40:35 <bconoboy> I'm going
21:40:39 * pbrobinson is not
21:40:45 <bconoboy> it'd be great if everybody else on the ARM team did too
21:40:56 <bconoboy> #link http://fedoraproject.org/wiki/FUDCon:Lawrence_2013
21:41:21 <bconoboy> Word has it the best donuts in the country are available in Lawrence, so you all should totally come.
21:41:36 * pwhalen hopes to be there
21:41:37 * jonmasters is going. I was in Lawrence a few weeks back, it's very nice
21:41:43 <fossjon> hmm
21:41:45 <fossjon> donuts
21:41:54 <fossjon> why do they waste the middle part tho
21:42:09 <pwhalen> timbits
21:42:11 <ctyler> I'll be there
21:42:12 <jonmasters> It also has a nice campus, some nice coffee shops, and great homemade ice cream! (if you like that in winter)
21:42:14 * ahs3 thinks voodoo donuts in portland, or, is better...maple bacon bar....mmmmm...
21:42:27 * ahs3 will plan on being ther
21:42:32 <ahs3> there, even
21:42:44 * masta is going to fudcon lawrence
21:43:02 <pwhalen> I think what we were talking about is some hack sessions on different hardware, what else would we like to plan?
21:43:11 <bconoboy> would anybody be interested in a remix hackathon?  try to get fedora remixes for as many systems as possible put together
21:43:25 <bconoboy> (arm remixes, that is)
21:43:44 <ctyler> bconoboy: that would be interesting, with a bit of pre-work to get some pieces into good shape
21:43:47 * pbrobinson would like to be going as it would have to be warmer than scotland in mid January
21:44:07 <ahs3> i would be interested in the hackathon -- i've got 3 boxen i'd like to have remixs for
21:44:09 <pbrobinson> we might even have a 3.8 kernel with more unified devices supported by then
21:44:10 <masta> bconoboy: sounds fun
21:44:20 <pbrobinson> ahs3: which 3?
21:44:31 <bconoboy> #info bconoboy, pwhalen, jonmasters, ctyler, ahs3, masta to attend
21:44:49 <ahs3> d2plug, CuBox and a shiny new NVIDIA Tegra3 board
21:45:25 <jonmasters> on a tangent I don't see recent mmap_zero fixes directly, must be some kind of misslabeling. Hey, pwhalen have you tried forcing a relabel on that panda?
21:45:34 <bconoboy> #info consider remix hackathon for arm devices
21:45:46 <jonmasters> pwhalen: I mean TS I guess, sorry
21:45:54 <pbrobinson> ahs3: the CuBox should eventually be supportable with unified
21:46:11 <pwhalen> jonmasters, I haven't, but will do now
21:46:16 <bconoboy> would be gerat to have trimslice with console, exynos, google chromebook, etc support
21:46:21 <pwhalen> it was a panda :)
21:46:24 <ahs3> pbrobinson: exactly -- and the d2plug is also an Armada 510
21:46:43 * ctyler forgets what the CuBox SOC is
21:46:50 <jonmasters> try that, see if it can relabel. Off hand, it looks like the right contexts, but maybe they changed something about systemd-launched stuff in F18
21:46:51 <pwhalen> jonmasters, the same issue is also on the TS
21:47:11 <pwhalen> jonmasters, we do a relabel on first boot with the alpha image
21:47:17 <ahs3> ctyler: also Armada 510, afaik
21:47:26 * masta notes he tried the relabel, did nto help
21:47:40 <pwhalen> jonmasters, ^
21:48:18 <jonmasters> ok, ping Dan with that output, he'll know what's wrong - it's got to be the wrong context is set on those services
21:48:38 <jonmasters> rmk got a CuBox and really likes it
21:48:55 <jonmasters> I was watching when he opened it and was trying to get it to talk to a TV
21:49:04 <masta> got to go now, bye all
21:49:07 * masta &
21:49:17 * jonmasters will try to get a couple of Chromebooks for FUDCon
21:49:34 <jonmasters> I might be able to get one to give away
21:50:03 <pbrobinson> jonmasters: and send one to me please!
21:50:20 * ctyler schemes to smuggle on into Canada
21:50:22 <jonmasters> pbrobinson: I've a friend at a certain company that might be able to assist there
21:50:34 <jonmasters> pbrobinson: will email
21:50:47 * ahs3 debates whether it's easier to beat up jon for a chromebook or just give in and order one :)...
21:50:59 <pwhalen> #topic 5) Your topic here
21:51:12 <pwhalen> we've got nine minutes, anything else to discuss today?
21:51:14 <pbrobinson> jonmasters: thanks
21:51:43 <pbrobinson> ahs3: the former is more fun as it's a challenge ;-)
21:52:01 * ahs3 ^5s pbrobinson
21:52:03 <jonmasters> :)
21:52:21 <bconoboy> pwhalen: looks like we're all set
21:52:22 <jonmasters> sure, I mean, there are so many options for beating the poor guy up
21:52:41 <pwhalen> #endmeeting