f18_alpha_gono-go_meeting
MINUTES

#fedora-meeting-1: F18 Alpha Go/No-Go meeting

Meeting started by jreznik at 19:00:49 UTC (full logs).

Meeting summary

  1. roll call (jreznik, 19:01:38)
    1. jreznik nirik jlk rbergeron kparal tflink adamw present (jreznik, 19:05:54)

  2. Purpose of this meeting (jreznik, 19:06:44)
    1. Purpose of this meeting is to see whether or not F18 Alpha is ready for shipment, according to the release criteria. (jreznik, 19:07:00)
    2. This is determined in a few ways: (jreznik, 19:07:07)
    3. No remaining blocker bugs ;-) (jreznik, 19:07:43)
    4. Test matrices for Alpha are fully completed (jreznik, 19:07:49)
    5. http://qa.fedoraproject.org/blockerbugs/current (jreznik, 19:07:58)
    6. http://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (jreznik, 19:08:06)
    7. https://fedoraproject.org/wiki/Test_Results:Current_Base_Test (jreznik, 19:08:12)
    8. http://fedoraproject.org/wiki/Test_Results:Current_Installation_Test (jreznik, 19:08:19)
    9. http://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test (jreznik, 19:08:26)

  3. agenda (jreznik, 19:09:05)
    1. 3 Proposed Blockers (tflink, 19:12:34)
    2. 3 non-VERIFIED Accepted Blockers (tflink, 19:12:56)

  4. (855849) could not UEFI boot F18 Alpha (TC6 through RC3) DVD or netinst written to optical disc or dd'ed to USB: /dev/root does not exist (tflink, 19:13:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=855849 (tflink, 19:13:52)
    2. Proposed Blockers, NEW (tflink, 19:13:54)
    3. AGREED: it is agreed in principle that the relevant release criterion should be weakened so it only requires any one of the 'normal' UEFI boot paths to work, not several (adamw, 19:36:07)
    4. AGREED: 855849 - RejectedBlocker - With the above modification to the F18 alpha release requirements, this bug is not considered a blocker as USB media created with livecd-iso-to-disk is still able to boot on (u)EFI machines (tflink, 19:38:14)

  5. (848305) When kernel modsetting is enabled, laptop screen remians off until Xorg starts (ironlake) (tflink, 19:38:46)
    1. ACTION: adamw to propose criterion modification on test list (adamw, 19:38:47)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=848305 (tflink, 19:38:49)
    3. Proposed Blockers, ASSIGNED (tflink, 19:38:52)
    4. AGREED: 848305 is rejected as a blocker on the basis that it only affects certain systems (so a conditional violation, so a judgment call) and appears to have a relatively simple and documentable workaround (adamw, 19:57:39)

  6. (856938) Native UEFI install from F18 Alpha RC3 DVD written to USB with livecd-iso-to-disk fails to boot (tflink, 19:58:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=856938 (tflink, 19:58:35)
    2. Proposed Blockers, NEW (tflink, 19:58:38)
    3. AGREED: 856938 - RejectedBlocker - While this is a conditional violation of the F18 alpha release criteria, it was decided that the current success rates are enough for F18 alpha (tflink, 20:11:24)

  7. (856399) RC2 DVD is missing grub2-efi and shim packages (tflink, 20:13:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=856399 (tflink, 20:13:06)
    2. Accepted Blockers, MODIFIED (tflink, 20:13:06)
    3. This has been fixed in RC3 and will be moved to VERIFIED shortly (tflink, 20:13:46)

  8. (856096) repoclosure failure on 18 Alpha RC2 DVDs (mongodb) (tflink, 20:13:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=856096 (tflink, 20:13:56)
    2. Accepted Blockers, ON_QA (tflink, 20:13:56)
    3. this bug has been fixed, needs to be moved to VERIFIED. after enough karma, the update will be pushed to stable and this bug will be closed (tflink, 20:15:57)

  9. (856836) /etc/fstab is not written correctly after live install (F18 Alpha RC2+) (tflink, 20:16:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=856836 (tflink, 20:16:11)
    2. Accepted Blockers, ON_QA (tflink, 20:16:13)
    3. this is reported to be verified with RC3, move to VERIFIED once that is confirmed in bz (tflink, 20:17:28)
    4. this has just been verified with RC3 -> move to VERIFIED (tflink, 20:18:35)

  10. the test matrices results (jreznik, 20:20:21)
    1. Base is 100% (adamw, 20:20:27)
    2. Desktop has Alpha tests covered for GNOME and KDE (release blocking desktops). fallback isn't really considered critical since F17 (adamw, 20:20:48)
    3. http://tflink.fedorapeople.org/updates/f18_traceback.img (tflink, 20:26:35)
    4. AGREED: the 'local disk' requirement of criterion " The installer must be able to report failures to Bugzilla and local disk, with appropriate information included" is waived for F18 Alpha as the failure reporting tool does not currently have code for local disk reporting, and we do not think an Alpha release strictly requires this function (adamw, 20:34:32)
    5. missing Install tests are install_to_SCSI which has been waived for several releases, traceback_to_disk which was waived above, and non-EFI liveusb-creator which is OK as we only need *one* working USB method for alpha, and we have more than one already (adamw, 20:38:09)
    6. per above, Install matrix is functionally complete (adamw, 20:38:21)

  11. go/no-go decision (jreznik, 20:38:53)
    1. rel-eng votes Go (dgilmore) (adamw, 20:39:37)
    2. devel votes Go (jlk) (adamw, 20:39:44)
    3. QA votes Go (tflink, viking, adam) (adamw, 20:39:52)
    4. infra is go (dgilmore) (jreznik, 20:40:12)
    5. FPL votes go (rbergeron) (adamw, 20:40:26)
    6. program manager votes go (jreznik) (adamw, 20:40:39)
    7. ACTION: jreznik to announce go/no-go result (jreznik, 20:46:55)


Meeting ended at 20:47:38 UTC (full logs).

Action items

  1. adamw to propose criterion modification on test list
  2. jreznik to announce go/no-go result


Action items, by person

  1. adamw
    1. adamw to propose criterion modification on test list
  2. jreznik
    1. jreznik to announce go/no-go result


People present (lines said)

  1. adamw (200)
  2. jreznik (93)
  3. tflink (84)
  4. jlk (52)
  5. rbergeron (27)
  6. dgilmore (23)
  7. nirik (21)
  8. pjones (17)
  9. Viking-Ice (15)
  10. zodbot (8)
  11. kparal (8)
  12. rdieter (3)


Generated by MeetBot 0.1.4.