fedora-meeting-1
LOGS
19:59:52 <pwhalen> #startmeeting
19:59:52 <zodbot> Meeting started Wed Aug 29 19:59:52 2012 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:01 <pwhalen> .fas pwhalen
20:00:01 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:00:09 <dsd> hi
20:00:17 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin
20:00:17 <zodbot> Current chairs: bconoboy ctyler dgilmore dmarlin jonmasters pbrobinson pwhalen
20:00:32 <ctyler> .fas ctyler
20:00:33 <zodbot> ctyler: ctyler 'Chris Tyler' <chris@tylers.info> - ctyler2621 'Christopher Tyler' <chris@mowisp.com>
20:01:17 <jcapik> .fas jcapik
20:01:17 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:01:20 <pwhalen> anyone else? looks like a small group today, and some key people missing for some of our topics
20:01:59 <pwhalen> #topic 1) Build status update - packages needing attention
20:02:00 * masta is here
20:02:13 <masta> .fas parasense
20:02:14 <zodbot> masta: parasense 'Jon Disnard' <jdisnard@gmail.com>
20:02:28 <dsd> i've been trying to do F18 builds for OLPC
20:02:49 <dsd> current breakage is that new network-manager-applet builds have not been mirrored (and the latest built on arm has broken requires)
20:03:12 <dsd> and also  spherical-cow-backgrounds is built on ARM but not on the mirrors?
20:03:41 <pwhalen> jonmasters mentioned he has made progress on llvm, with one remaining issue he'll be looking at
20:04:32 <pwhalen> dsd, likely ks will try again shortly
20:05:10 <pwhalen> anyone else aware of packages that seem to be broken on arm?
20:05:23 <dsd> for the nm-applet issue? it has yet to try a first time
20:05:43 <dmarlin> pwhalen: is the kernel included in that list (broken on arm) ?
20:05:43 <pwhalen> how long ago was it built in PA?
20:05:58 <dmarlin> dsd: and now is it tagged?
20:06:06 <dmarlin> s/now/how/
20:06:12 <dsd> it was built on 14th august
20:06:18 <dsd> tagged f18-updates-pending f18-updates-testing
20:06:41 <pwhalen> the kernel has built, but an attempt to boot on omap failed to find the rootfs
20:06:55 <dsd> http://koji.fedoraproject.org/koji/buildinfo?buildID=348207
20:07:41 <pwhalen> # link http://fpaste.org/9Dv3/ <-- omap boot failure on 3.6.0-0.rc3.git2.1.fc18
20:07:54 <pwhalen> #link http://fpaste.org/9Dv3/ <-- omap boot failure on 3.6.0-0.rc3.git2.1.fc18
20:07:54 <dmarlin> dsd: http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=85176
20:08:12 <dsd> dmarlin: different package
20:08:25 <dmarlin> dsd: quite right
20:08:59 <dsd> Peter already mentioned that during alpha freeze some packages may fall behind. just wanted to point it out as being one of the critical ones
20:09:22 <ctyler> so the mirrors aren't updating, or things are tagged into testing/pending and not being pushed to the right repos?
20:09:48 <dsd> the nm-applet issue is simply a build that hasnt been mirrored (yet)
20:10:04 <dsd> the spherical-cow-backgrounds thing is a package that has been built but doesnt appear on the mirrors
20:10:13 <pwhalen> I was looking at kernels in comparison to our builds and we seems to be a few weeks back
20:10:28 <dsd> the tags look correct. http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=90351
20:10:57 <pwhalen> we'd really need to look over our ks logs to find out the current package issues
20:11:27 <pwhalen> Peter did mention they were public, but not sure where. Does anyone know?
20:12:15 * ctyler notes that ks there means koji-shadow not kickstart
20:12:29 <pwhalen> right, thanks
20:12:56 <pwhalen> ok, perhaps we can ask Peter to send out their location
20:13:37 <pwhalen> #topic 2) iwmmxt optimizations - https://bugzilla.redhat.com/show_bug.cgi?id=837964
20:14:39 <pwhalen> I followed this a little on the mailing list, dsd, was there something you wanted to talk about here?
20:14:43 <dsd> for this bug i was wondering if this functionality is of particular interest to anyone else (i.e. should we pressure Jakub)
20:15:04 <dsd> otherwise, olpc can just fork the fixman package for a cycle or so, until gcc-4.9 gets included in fedora
20:16:02 <masta> so not gcc 4.8 ?
20:16:12 <dsd> 4.8 correct. that was a typo
20:16:32 <masta> whew - 4.9 would be a long wait
20:17:31 <pwhalen> dsd, not sure the appropriate people are here currently, but we can make note of it now
20:17:44 <pwhalen> revisit next week
20:17:46 <dsd> ok, sure
20:18:14 <pwhalen> #topic 3) Raspberry Pi status update
20:18:26 <pwhalen> rc1! awesome, getting closer
20:19:12 <ctyler> We have what appears to be a successful armv6 build of glibc
20:19:20 <maxam> yay!
20:19:24 <pwhalen> whoa, even better
20:19:35 <ctyler> So we should be able to do a preliminary test compose Real Soon Now.
20:19:54 <pwhalen> ctyler, is there anything we can do to help? beyond testing and providing feedback?
20:20:07 <ctyler> I was away last week, so I'm a bit out of the loop. fossjon et al?
20:20:33 <fossjon> i think we got a lot of it down so far
20:20:56 <jcapik> cool
20:21:01 <pwhalen> whats left before you do a test compose?
20:21:37 <ctyler> Need to sanity-check this glibc and then I think we're good for a compose. Also need an armv6 soft glibc.
20:22:08 <ctyler> Watch for v6 composes to be out before next meeting, and please bang on them hard once they're out.
20:22:24 <pwhalen> please let us all know if we can do anything
20:22:30 <pwhalen> looking forward to it :)
20:22:49 <pwhalen> #topic 4) Feedback on F18 ARM Release Criteria - http://fedoraproject.org/wiki/Architectures/ARM/Fedora_18_Alpha_Release_Criteria
20:23:17 <pwhalen> so, we discussed this briefly in another meeting, has anyone else had a chance to review?
20:23:34 <pwhalen> any suggestions, feedback?
20:23:56 * ctyler thinks it looks good
20:24:07 <ctyler> What's our arm alpha target?
20:24:18 <ctyler> (date, I mean)
20:24:46 <ctyler> Can we hit PA+1w ?
20:25:07 <pwhalen> #link http://fedoraproject.org/wiki/Releases/18/Schedule
20:25:43 <pwhalen> thats the PA release schedule, their aiming for Sept 4th, adding a week to that sounds reasonable for a goal
20:25:52 <masta> that release criteria page looks good
20:26:04 <masta> I think we can hit those targets
20:26:42 <ctyler> So we need a go/no-go this time next week.
20:26:43 <pwhalen> ok, I understand its a lot to read right now if you hadn't had a chance, please do so and forward feedback to the list, primarily for alpha
20:27:17 <masta> ppc release fairly quick after PA last time....
20:27:21 <ctyler> vfad next Wed?
20:27:26 <pwhalen> or at least a status update for next week
20:27:41 <pwhalen> ctyler, I agree
20:27:53 <pwhalen> then in the meeting we will know where we stand
20:28:11 <ctyler> With the long weekend there's really only three workdays between now and then.
20:28:49 <pwhalen> good point. We are pretty close to PA now
20:29:22 <pwhalen> F18 Missing: 330
20:30:05 <ctyler> So, question: how many of those 330 do we care about? I think we only critically care about ones that are in the default image, at the Alpha point.
20:30:29 <ctyler> i.e., I don't think we should block on a package that isn't installed by default for Alpha (for final, maybe)
20:30:44 <pwhalen> as long as they hit their release date, we'll have that list
20:30:46 <pwhalen> agreed
20:31:16 <ctyler> s/the default image/our default images/
20:32:33 <ctyler> One note on the Alpha blocker bugs: it says we'll do go/no-go in our meeting, but it also says 20:00 ETC on Wednesday is the cut off time, which is after our standard meeting
20:32:54 <ctyler> (actually, not sure what ETC is?)
20:33:24 <pwhalen> #idea ARM VFAD Wed Sept 5th at 12pm edt to test alpha images, with followup in our meeting to decide on alpha release readiness
20:33:36 <pwhalen> ctyler, thought I removed them all, will change that, thanks
20:33:37 <ctyler> +1
20:34:20 <pwhalen> well, we agree :)
20:34:21 <pwhalen> anyone?
20:34:46 <masta> +1
20:35:22 <pwhalen> #agreed ARM VFAD Wed Sept 5th at 12pm edt to test alpha images, with followup in our 4PM edt meeting to decide on alpha release readiness
20:35:50 <jcapik> +1
20:35:56 <pwhalen> so, if anyone else find something that looks wrong, please let me know, or feedback etc
20:36:09 <pwhalen> (with the release criteria)
20:36:36 <pwhalen> #topic 5) Your topic here
20:36:53 <pwhalen> anything else folks would like to discuss?
20:37:10 <ctyler> Going back to the mirror issues that dsd mentioned, I did a quick look at dl.fedoraproject.org and it doesn't make sense
20:37:17 <ctyler> that those packages aren't there.
20:38:15 <ctyler> I think the mashing and mirroring is being done my dgilmore, maybe he can check into this and identify what's going on?
20:38:21 <ctyler> s/my/by/
20:39:26 <pwhalen> ctyler, what package is missing?
20:39:40 <pwhalen> spherical-cow-backgrounds?
20:40:14 <ctyler> and probably others
20:41:52 <masta> did anybody get a chance to test hdmi on pandaboard, or wifi?
20:42:31 <pwhalen> I'll make note of the repo and ping Dennis when he's around
20:43:23 <ctyler> #action pwhalen will talk to dgilmore about packages possibly not appearing in the mirrors
20:43:23 <pwhalen> anything else?
20:43:28 <pwhalen> ctyler, thanks
20:44:08 <dsd> thanks for following up
20:44:24 <pwhalen> #endmeeting