fpc
LOGS
16:00:17 <spot> #startmeeting Fedora Packaging Committee
16:00:17 <zodbot> Meeting started Wed May 30 16:00:17 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:23 <spot> #meetingname fpc
16:00:23 <zodbot> The meeting name has been set to 'fpc'
16:00:28 * abadger1999 here
16:00:35 <spot> #topic Roll Call
16:00:56 <tibbs> Howdy.
16:01:18 <Rathann> here
16:02:34 <spot> rdieter_work, SmootherFrOgZ: ping?
16:03:35 <rdieter> yo
16:03:52 <spot> okay, with rdieter we barely hit quorum. :)
16:03:58 <spot> so much for my early lunch. ;)
16:04:18 <spot> #topic ~ in version - https://fedorahosted.org/fpc/ticket/178
16:04:36 <spot> there is no draft here, just a very odd batmanchu. :)
16:04:54 <spot> it would be nice if someone would volunteer to draft something, could probably lift big chunks of it from debian
16:06:20 <rdieter> I'd be tempted to simply continue to say "don't do it" in fedora packaging
16:06:23 <tibbs> Actually, what I intended was simply that we ban the thing in Fedora.
16:06:35 <spot> then draft that up.
16:06:46 <spot> i think suse is the only consumer of it currently
16:07:00 <spot> we'll revisit this when a draft appears
16:07:09 <tibbs> Well, I wanted to get a general sentiment first.
16:07:10 <rdieter> I think our current Naming guidelines already cover this (or in particular, doesn't allow for this sort of thing)
16:07:31 <spot> rdieter: agreed, but i think it is worth clarifying explicitly
16:07:39 <zodbot> abadger1999: Error: The command "whois" is available in the Internet and Network plugins.  Please specify the plugin whose command you wish to call by using its name as a command before "whois".
16:07:55 <spot> wow, thats some bot lag.
16:07:57 <tibbs> We would have loads of compatibility problems if we allowed it now, certainly.
16:08:20 <tibbs> How many more years of EL6 will probably never get the capability?
16:08:29 <spot> so, draft up a little subsection explaining that it is not okay, and the reasoning
16:08:58 <tibbs> Sure.
16:09:02 <spot> #topic libresample bundling library for pjproject - https://fedorahosted.org/fpc/ticket/179
16:09:16 <tibbs> I didn't see nearly enough info to make a decision.
16:09:28 <spot> so pjproject is using an older "libresample" that is not at all the same as the current "libresample" which is in Fedora
16:09:39 <tibbs> So package up the older one?
16:09:45 <spot> they share a loose history, but its sortof "dinosaurs" and "birds"
16:10:18 <spot> okay. i'll give that a shot, should be doable.
16:10:32 <rdieter> bundling is probably ok here, I doubt anyone else would be consumers of something packaged separately
16:10:42 <spot> rdieter: yeah, that is also my thought
16:10:52 * spot doesn't mind packaging it to avoid the paperwork though
16:10:53 <tibbs> I don't really know, but "package it up separately" is one of our usual answers in this situation.
16:12:22 <abadger1999> <nod>
16:12:29 * abadger1999 agrees with tibbs
16:12:39 <spot> okay, thats easy enough.
16:12:47 <spot> #action spot will make a package to resolve this need
16:12:52 <spot> #topic Open Floor
16:13:16 <spot> there are some writeups that need doing
16:13:26 <tibbs> Occasionally I wonder about the rpm collections thing and when we can start thinking about looking into whether we want to adopt it.
16:13:38 <spot> they're on my todo list, but at a low priority, which means it gets bumped
16:14:08 <spot> tibbs: i really don't think we want to encourage pseudo-silo packaging
16:14:21 <Rathann> tibbs: what are rpm collections?
16:14:36 <Rathann> google is not very helpful :(
16:14:43 <tibbs> It's a feature added to rpm 4.9 that basically lets us get rid of a lot of scriptlets.
16:14:55 <tibbs> At least according to the very limited info I was able to find.
16:15:01 <spot> oh? i think we're thinking of something different
16:15:17 <tibbs> Basically you declare that your package installs a shared lib and rpm runs the ldconfig stuff automatically.
16:15:36 * rdieter likes that idea
16:15:46 <tibbs> Or you declare that it installs gconf schemas and it takes care of that.
16:16:20 * SmootherFrOgZ here
16:16:28 <abadger1999> That would be nice to use.
16:16:39 <SmootherFrOgZ> craps, loos like I'm too late.
16:16:43 <SmootherFrOgZ> looks*
16:16:45 <tibbs> 4.9 is in every supported Fedora release by this point.
16:16:57 <Rathann> EXPERIMENTAL support for package "collections" which are sort of like named triggers that only run once within a transaction. This can be used for example to avoid redundant calls for cache updates etc. (XXX add link to documentation once it exists)
16:17:02 <Rathann> hm
16:17:10 <spot> tibbs: i don't think its turned on yet.
16:17:28 <spot> because iirc, it would make the rpm format incompatible with older versions
16:17:29 <Rathann> nothing else since 4.9.0 in the release notes
16:17:29 <tibbs> I don't know; I saw something from Panu talking about it.
16:17:52 <spot> but yes, we should make an effort to implement it when it is ready
16:18:07 <tibbs> It sounds like something we really should pursue but I was hoping that something further would happen with it.
16:18:21 <tibbs> I guess I should jump on the rpm-maint list and ask.
16:18:27 <spot> they are working on all sorts of things, some progress was made on my %license ticket
16:18:52 <spot> so in the future, it should be possible to use "%license FOO" in the same sort of way as %doc, but not counted as a doc
16:19:07 <tibbs> That would be nice as well.
16:19:28 <spot> we're talking about having rpm do auto-hardlinking across licenses to minimize duplicates
16:19:44 <tibbs> Always nice to save a few K.
16:20:00 <spot> i'm not sure it would be even that much, but on things like the XO, i know it matters
16:20:08 <tibbs> With the collections thing, I just want to get the often-screwed-up scriptlets out of the spec files.
16:20:15 <spot> tibbs: indeed.
16:20:40 <spot> well, if there is nothing else, it looks like i get an early lunch after all
16:20:46 * spot will give it, oh, 2 minutes
16:21:00 <zodbot> Announcement from my owner (mdomsch): Fedora Town Hall at 1700 UTC (1pm US-Eastern) with the FESCo candidates. Visit https://fedoraproject.org/wiki/Elections#IRC_Town_Halls for information on how to participate and pose questions to the candidates.
16:21:28 <tibbs> Nothing else from me.  Still working on the sponsorship thing.
16:24:16 <spot> thanks everyone
16:24:19 <spot> #endmeeting