fedora-meeting-1
LOGS
20:00:16 <pwhalen> #startmeeting
20:00:16 <zodbot> Meeting started Wed May 23 20:00:16 2012 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:17 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson
20:00:17 <zodbot> Current chairs: bconoboy ctyler jonmasters pbrobinson pwhalen
20:00:26 <pwhalen> who's here?
20:00:32 * bconoboy is here
20:00:38 <jcapik> .fas
20:00:38 <zodbot> jcapik: (fas <query>) -- Search the Fedora Account System usernames, full names, and email addresses for a match.
20:00:45 <jcapik> .fas jcapik
20:00:45 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:00:47 * djdelorie is here
20:00:50 <bconoboy> .fas blc
20:00:50 <zodbot> bconoboy: blckspder 'Antoni Sousa' <blckspder@gmail.com> - blc '' <blc@redhat.com>
20:00:51 * agreene is here
20:01:05 <bconoboy> .fas blc@redhat.com
20:01:06 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:01:30 * maxam is here
20:01:47 <pwhalen> #topic 1) F17 build status - branching, updates, updates-testing - remaining problem packages
20:03:27 <pwhalen> so how are we doing with F17? are there any remaining problem packages specific to ARM?
20:03:34 * Frojoe is here
20:03:58 <dgilmore> hola
20:05:16 <jcapik> pwhalen: we still have a wiki table for that, right?
20:05:39 * fossjon is here
20:05:46 <fossjon> after watching youtube
20:05:54 <bconoboy> IT appears http://fedoraproject.org/wiki/Architectures/ARM/Fedora17_rawhide has a list of packages that still need attention
20:06:13 <fossjon> https://fedoraproject.org/wiki/Architectures/ARM/Fedora17_rawhide
20:06:17 <jcapik> yup ... that's the link
20:07:09 <jcapik> does anybody need to make a specific package from that list working?
20:08:19 <bconoboy> For primary we want them all working.  I'm not aware of any package blocking use of Fedora ARM in general though
20:08:44 <djdelorie> ntp and ntpdate *are* in the image, yes?
20:08:53 <bconoboy> y
20:08:53 <jcapik> bconoboy: ok goood ... I had to lend my panda to jskarvad, who was collecting some power consumption stats
20:08:56 <fossjon> ya we should have those
20:09:04 <fossjon> since some of our machines cant remember the time
20:09:10 <djdelorie> is there a wiki of what's in the image, with versions?  We talked about that previously
20:09:11 <fossjon> no rtc clock or something
20:09:12 <jcapik> bconoboy: but now it's back and I'd like to start solving these issues
20:09:21 <pwhalen> the output of shadow should help tell us whats causing the most grief right now
20:09:44 <pbrobinson> fossjon: it's called ntp it works quite well ;-)
20:09:50 <fossjon> ya thats what i mean
20:09:54 <bconoboy> pbrobinson:Topic is remaining problems in F17
20:09:55 <fossjon> we should include ntp pkgs for our images
20:10:02 <bconoboy> we already are
20:10:07 <fossjon> oh ok good :)
20:10:12 <fossjon> was just agreeing with djdelorie
20:10:15 <bconoboy> 1) F17 build status - branching, updates, updates-testing - remaining problem packages
20:10:24 <pbrobinson> OK that sounds like me
20:10:31 <bconoboy> :-)
20:11:58 <pbrobinson> as can be seen from fossjon's script we're pretty close. I've spent some time over the weekend to clean up quite a few things and we're looking pretty good. A lot of stuff is fixed in updates-testing so we're planning on locking down f17 and tagging like mainline so that builds get pushed to f17-candidate and get retagged as appropriate.
20:12:21 <pbrobinson> the wiki has all the current outstanding issues but i'm not sure anyone other than me is working on them
20:12:41 <fossjon> i was going to try at a few but some of them are C errors which are over my head right now
20:12:52 <jcapik> pbrobinson: I'll try to help here
20:12:58 <fossjon> i would really like to dig deeper but that takes a lot of time teaching yourself C/ASM ...
20:13:29 <pbrobinson> fossjon: if you have cycles there's likely others as well. I'm not sure of skillsets and time etc
20:14:02 <pbrobinson> in some cases the fixes can be patched pulled from debian/suse/ubuntu and just tested and make sure they apply cleanly etc
20:14:03 <fossjon> if I see any errors which are higher up on the language stack I can try to help out
20:14:12 <fossjon> thats true too pbrobinson
20:14:17 <jcapik> it is also possible to ask upstream for help :]
20:14:32 <jcapik> and work together
20:15:06 <pbrobinson> yep and if it's broken in mainline it could be enough to file bugs and get maintainers to fix and upstream there's all sorts of breakages... I'm sure in the 300+ broken packages there's fixes too :)
20:15:29 <pbrobinson> python / ruby / php etc
20:15:46 <dgilmore> fossjon: the issue is no battery backup of the rtc, chrony or ntp are needed
20:15:57 <pbrobinson> but anyway f-17 is looking about as good as we can expect to get it
20:16:12 <pbrobinson> and from there updates get submitted as normal
20:16:27 <pbrobinson> koji-shadow is pretty quick now at getting builds done
20:16:47 <djdelorie> are we, in general, "keeping up with primary" ?
20:17:01 <dgilmore> djdelorie: we are doing pretty well at at
20:17:05 <pbrobinson> as once they hit mainline there's now few blockages to stop it building without assistance on arm
20:17:06 <dgilmore> not perfect
20:17:17 <djdelorie> that was a concern for the SA->PA step
20:17:37 <pbrobinson> it's not perfect but if you look at some of the recent reports on arm they look pretty close to mainline for d17
20:17:39 <pbrobinson> f17
20:18:11 <pwhalen> okay.. on to F18?
20:18:16 <pbrobinson> we're catching up on rawhide and you would have noticed the rawhide report each day over the last week is generally in the 100s
20:18:19 <bconoboy> Er, when are we 'done' with f17?
20:18:20 <pwhalen> #topic 2) Rawhide status update - how do we look for F18? problem packages?
20:18:53 <pbrobinson> bconoboy: we're not done with f17 as it moves from "f17" to f17-updates etc. so we're never really done
20:19:15 <bconoboy> pbrobinson: By done I mean F17ARM GA
20:19:21 <djdelorie> we're done with F17 when F19 is released :-)
20:19:29 <pbrobinson> but ultimately most of updates-testing works and builds and if we have failures on ARM I'm on the maintainer pretty quickly :)
20:19:30 <dgilmore> djdelorie: a month after
20:19:36 <djdelorie> that too
20:19:40 <bconoboy> Right now we're just about to push the beta out. What is GA?
20:20:00 <dgilmore> bconoboy: for GA id like to get the delta of older packages to 0
20:20:04 <pbrobinson> I'm talking here purely on package building and not the overall experience
20:20:21 <dgilmore> right now i think its less than 100
20:21:04 <pbrobinson> yes, and we're closing in on those quickly, I'm review the diffs daily and fixing as necessary.
20:21:20 <dgilmore> the missing im not as worried about
20:21:40 <dgilmore> id like those we can have but waiting on f18 for those i think is probably ok
20:21:46 <pbrobinson> yes, the missing tend to be arch dependent or broken on mainline too
20:21:53 <dgilmore> but we shouldnt ship anything older
20:22:02 <dgilmore> pbrobinson: right
20:22:26 <bconoboy> Okay, so we get that count to 0, meet F17 final release criteria, and that's gA?
20:22:31 <pbrobinson> now I have koji back I was planning on checking again this evening
20:22:45 <dgilmore> bconoboy: yep
20:22:58 <bconoboy> cool. we can talk release criteria later.  F18?
20:23:08 <bconoboy> (sorry pwhalen:-)
20:23:36 <pbrobinson> I'd like to see stable 3.3 kernels on our main omap/tegra too
20:23:58 <pbrobinson> versatile seems to be good now, correct?
20:24:50 <jcapik> pbrobinson: +1
20:25:41 <pwhalen> vexpress is working well, tested yesterday.. pbrobinson, anything else you would like to discuss for f18?
20:25:50 <bconoboy> versatile is good now.
20:26:40 <pwhalen> ....someone mentioned koji, which leads us into our next topic :)
20:27:04 <pwhalen> #topic 3) ARM Koji status update - Update on latest downtime, how did it go?
20:27:33 <Frojoe> Well, after some stumbling blocks, we're back up and running
20:28:12 <Frojoe> One thing I am concerned about though is the overall health of our SSD's, especially the ones we're using for scratch space
20:29:07 <pwhalen> Frojoe, anything specific you noticed?
20:29:08 <bconoboy> the ssd's used for scratch space are rated for 20GB of writes per day for 5 years.  You can check write stats on a live system to see how we're doing there and extrpolate the long term.
20:29:31 <jcapik> do we have SMART outputs?
20:29:52 <Frojoe> Yeah, I've been doing some reading up on how to properly calculate the current wear on them
20:30:00 <jcapik> any S.M.A.R.T. stats from the drives?
20:30:04 <Frojoe> I can generate them
20:30:08 <pbrobinson> sorry lost connection
20:30:27 <bconoboy> in other words, each disk should be good for 36.5TB of write duty
20:31:37 <Frojoe> Mhmm
20:31:46 <pbrobinson> I don't think the SSD's are really going to become as major problem
20:31:57 <jcapik> once the drives start getting reallocations, then we should immediately replace them
20:32:25 <bconoboy> do ssds get reallocations?
20:32:40 <jcapik> bconoboy: according to the smart output at least some of them YES
20:32:46 <maxam> Frojoe: smart related packages are installed and some of those were configured to gather stats automatically
20:33:17 <jcapik> bconoboy: the question is if the controlled fills the fields correctly
20:33:29 <Frojoe> I can write something to keep an eye on the write stats for the drives.
20:33:39 <fossjon> this is something our team can research more and monitor
20:33:40 <pbrobinson> bconoboy: from before I got disconnected I made the point:  the release criteria for f18 should be the same as for mainline with anaconda producable images and standard QA procedures :)
20:35:22 <fossjon> ya anaconda based images are probably important
20:36:19 <pwhalen> pbrobinson, our release criteria differs slightly then PA. The working document showed all changes made, it will be adjusted once we're able to produce said images. But it is largely the same
20:36:40 <bconoboy> are we still on Koji Donwtime or have we moved on?
20:36:43 <Frojoe> Other than the few stumbling blocks we ran into, I think we have the process for doing the SSD upgrades down when we need to do that again.
20:37:02 <pwhalen> I think we can move on...
20:37:05 <Frojoe> So yeah, we can  move on
20:37:06 <pwhalen> #topic 4) Nightly image creation - how can this be improved?
20:37:23 <fossjon> we can script it?
20:37:28 <bconoboy> it is scripted
20:37:41 <maxam> it is scripted
20:37:41 <bconoboy> We can use media creator instead of bconoboy scripts
20:37:54 <pwhalen> : )
20:38:59 <maxam> possible.... we need to test it.... make kickstarts and so on
20:39:26 <jcapik> bconoboy belittles his own work :
20:39:31 <jcapik> :]
20:39:56 <bconoboy> the alternative is my scripts become the standard for all fedora image creation... and we probably don't want that ;-)
20:40:02 <dgilmore> long term we need something that takes a kickstart and makes the image from scratch
20:40:36 <bconoboy> I'd like to suggest that we move to media-creator as soon as it's feasible to do so.
20:40:54 <dgilmore> bconoboy: right, thats my suggestion also
20:40:59 <bconoboy> It will help with the PA criteria and work better with QA
20:41:00 <fossjon> didnt dmarlin do some good work with lorax image creator?
20:41:12 <fossjon> can we combine dmarlin and bconoboy's work?
20:41:12 <dgilmore> fossjon: still a lot to be done
20:41:15 <bconoboy> yaneti, dmarlin already has it working for the trimslice
20:41:27 <dmarlin> fossjon: I posted a link to the wiki page... feedback is appreciated
20:41:28 <bconoboy> it's just not quite in upstream-shape yet
20:41:40 <bconoboy> dmarlin: can you post it here as well?
20:41:48 <fossjon> yes
20:42:14 <dmarlin> http://fedoraproject.org/wiki/Architectures/ARM/Installer
20:42:19 <bconoboy> if somebody at seneca wants to work on it that'd be super
20:42:38 <fossjon> if its something im capable of sure thing
20:42:44 <fossjon> id like to help out in anyway
20:43:21 <dmarlin> the email should be in the archives: Using livemedia-creator on ARM, 05/14/2012
20:43:22 <fossjon> does this page state what the problem is or what still needs to be done?
20:43:26 <bconoboy> There was one other point on this topic...
20:43:39 <bconoboy> ... which needs a vote
20:44:07 <bconoboy> Right now the nightly image creator is using an FC15 kernel for pandas since the F17 kernel doesn't work on pandas.
20:44:15 <bconoboy> For this reason we aren't including the Panda image in the Beta release
20:44:38 <jcapik> :'(
20:44:39 <bconoboy> ... but how do people feel about using a non-F17 kernel in an F17 image?
20:45:01 <bconoboy> (Panda is not in the beta, but it's still in the nightly)
20:45:07 <jcapik> I can live with that :]
20:45:18 <bconoboy> I think it's better to have something that works, even if it's not pure F17 since these are snapshot images and unofficial.
20:45:28 <maxam> as long as it provides a fedora experience
20:45:31 <dmarlin> I think the kernel need to be fixed.  F17 kernels in F17 images only for 'release' images...
20:45:36 <bconoboy> dgilmore thinks differently, I believe
20:45:41 <dmarlin> for nightlies, it matters less
20:46:11 <bconoboy> The thing is, if these nightlies are looked upon as being official, it becomes an increasing problem, so I see why it might not be a good idea.
20:46:26 <bconoboy> Likewise, the F17 raspberry pi image uses the F14 kernel that seneca built.
20:46:40 <bconoboy> So... what sort of boundaries should we set?
20:46:51 <dgilmore> bconoboy: right we cant ship anything with an older kernel
20:47:08 <dgilmore> first thing when people update they will get a new kernel reboot and bam
20:47:16 <dmarlin> dgilmore: define "ship"
20:47:33 <dgilmore> bconoboy: afaik we really cant ship raspberry pi images as official
20:47:33 <jcapik> last time jonmasters told us, that the issue disappears with different configuration .... maybe we could create our own (but temporary) kernel that way
20:47:57 <dgilmore> dmarlin: post it on a server where someone could reasonanly assume its from fedora
20:48:02 <bconoboy> dgilmore: Y, I don't believe we can include the rpi images in the beta either for this reason.  But I think ctyler etc have a different F17 rpi image they're working on.
20:48:15 <dgilmore> dmarlin: so seneca, mirrors  or anywhere in fedoraproject,org
20:48:21 <bconoboy> jcapik: Well, it disappears if we enable debugging...
20:48:28 <dmarlin> dgilmore: got it
20:48:34 <jcapik> bconoboy: so .... let's enable debugging :]
20:48:48 <dmarlin> jcapik: +1   :)
20:49:01 <dmarlin> (it is just beta)
20:49:04 <dgilmore> bconoboy: people will look on the nightlies as official
20:49:24 <jcapik> dgilmore: can the debugging affect their experience negatively?
20:49:31 <dmarlin> dgilmore: then they should be tested, no?
20:49:36 <bconoboy> dgilmore: I can segregate them on the web page... put the non-f17-pure images in a different table
20:49:55 <dgilmore> jcapik: maybe maybe not
20:50:10 <bconoboy> debugging may slow the kernel down some
20:50:11 <dgilmore> bconoboy: probably should be a different page all together
20:50:29 <yaneti> vault/target  split would greatly help my feeble brain
20:50:49 <bconoboy> ?
20:51:03 <jcapik> dgilmore: but users need something to play with ... they want to have GUI ..... and if fedora can't give them what they want, then they will install ubuntu
20:51:14 <yaneti> vault/{panda,beagle,etc..}/
20:51:31 <fossjon> yes users dont like command line anymore
20:51:36 <bconoboy> yaneti: Oh, don't look at the vault if you can help it... look at the main page one directory up. Much prettier.
20:51:56 <yaneti> bconoboy: "latest" type of setups bug me to no end
20:51:57 <jcapik> dgilmore: so ... we should have at least unofficial way how to help them
20:52:00 <dgilmore> jcapik: and we should have that. it should all be working.  we need to fix some kernel bugs
20:52:15 <bconoboy> yaneti: Ah. Okay.. I'll take it under advisement.
20:52:22 * pbrobinson thinks he's back, sorry net connection issues
20:52:53 <dgilmore> jcapik: the f15 kernel for instance doesnt have omapdrm. so the bits we intend to have in f17 cant work
20:52:53 <bconoboy> If I'm understanding the feedback correctly people are saying "We would like more unofficial images with a wider range of kernels that enable GUIs on our boards"
20:52:59 <yaneti> bconoboy: makes it harder for me to track which is which
20:53:21 <jcapik> dgilmore: sure sure ... we need to fix them .... but till it gets fixed, we can make the kernel available for download
20:53:24 <djdelorie> +1 for HDMI out of the box, if "unofficial" is acceptable
20:53:42 <dgilmore> jcapik: its poi9ntless to do so because its so different from what it needs to be
20:53:51 <jcapik> we can also make a note about the issue
20:54:33 <dgilmore> jcapik: older kernels only have omapfb  not omapdrm the setup and way they work is like day and night
20:55:35 <jcapik> dgilmore: now i don't understand where you see a problem
20:55:36 <bconoboy> Are we talking about mixing an F18 kernel with F17? Or some non-fedora kernel?
20:56:00 <dgilmore> bconoboy: no, we need to fix the f17 kernel
20:56:23 <bconoboy> dgilmore: fix what? panda?
20:57:04 <pbrobinson> we should get 3.3 kernels for tegra / omap just like we have for vexpress.
20:57:05 <bconoboy> Other than booting F17 on panda with an f17 kernel, even to console, is there anything else that needs doing there?  We can start making F18 images if that kernel is going to give us more of our GUI desires.
20:57:18 <jcapik> dgilmore: but why don't we simply use the f17 kernel (even with debugging enabled) ? it has no sense to release f17 with f15 kernel
20:57:31 <jcapik> dgilmore: nobody would use it
20:57:32 <bconoboy> pbrobinson: I'd like that, but does it need to be F17?
20:57:42 <pbrobinson> why not
20:58:12 <bconoboy> pbrobinson: Because we need to put our energy into F18 soon
20:58:46 <pbrobinson> bconoboy: I've been putting energy into f18 for weeks :)
20:58:47 <dgilmore> jcapik: if debugging enabled masks the issue then for beta its ok
20:58:49 <bconoboy> I believe jcapik is proposing that we simply enable debugging in the F17 omap kernel.  I think that's a great idea.  It's broken on panda and we need to track it down.
20:58:52 <dgilmore> but needs fixed for GA
20:59:17 <fossjon> the pandas seem like  a machine that should be supported
20:59:21 <bconoboy> dgilmore: Okay, will you do that?
20:59:22 <fossjon> they're still fast and current
20:59:27 <fossjon> armv7
20:59:35 <fossjon> :)
20:59:37 <jcapik> panda is great as a workstation
21:00:12 <dgilmore> bconoboy: ill look into i t
21:00:21 <jcapik> and I'm still using the ubuntu kernel .... just because we don't have our own .....
21:00:30 <jcapik> btw. the ubuntu kernel has also some issues
21:00:35 <pbrobinson> I think we're going around in circles here. We need mainline 3.3.x kernels for GA.... end of story
21:00:49 <jcapik> like changing keyboard repetition delay/rate
21:00:54 <bconoboy> #agreed dgilmore will look into turning on omap debugging in f17 kernel tree
21:01:06 <pwhalen> #topic 4) Your topic here
21:01:17 <fossjon> can we not use the ubuntu configs for how they built it and compile it ourselves the same way?
21:01:30 <fossjon> im probably missing something huge assuming that
21:01:36 <bconoboy> #agreed bconoboy will segregrate pure f17 images from hybrid-f17 images
21:02:09 <bconoboy> Topic 4: Beta release!
21:02:16 <bconoboy> are we there yet?
21:02:31 <yaneti> mx51 higtly , what would you need to vet it ?
21:02:35 <yaneti> nightly
21:02:49 <bconoboy> I believe we're ready to ship trimslice, beagle, vexpress images
21:03:01 <pwhalen> #topic 5 - Beta release - today?
21:03:21 <bconoboy> yaneti: need somebody to try booting it
21:03:28 <djdelorie> +1 already ;-)
21:03:39 <jcapik> fossjon: the ubuntu config can differ from our a lot .... and we want to have the same set of features as primary archs
21:03:48 <yaneti> bconoboy: is it expected to have a working fb ?
21:03:54 <dgilmore> it should work on a smarttop
21:03:55 <bconoboy> yaneti: No.
21:03:59 <dgilmore> yaneti: no working fb
21:04:23 <dgilmore> it should work on a smartbook also but no working fb makes it not so useful
21:04:25 <yaneti> might put a console=/dev/ttymxc0 in there..
21:04:31 <bconoboy> dgilmore/pwhalen: Beta release is your thing.  I'm done making images so the latests that are there now are good to go IMHO.
21:05:19 <pwhalen> bconoboy, all ready to go, images have been put up, just need to send an announcement
21:05:33 <dmarlin> bconoboy: just to confirm, all the latest have been tested?
21:05:51 <pwhalen> dmarlin, yes
21:06:13 <dmarlin> pwhalen: have they been tagged?
21:06:22 <dmarlin> (in koji)
21:07:13 <dmarlin> I assume "beta" is our snapshot in time
21:07:32 <pwhalen> I believe the tag was created last week, but we're using the latest from this week
21:08:06 <dmarlin> pwhalen: right, so should the tag be changed to match the release?
21:08:36 <dmarlin> dgilmore: ?  ^^^
21:08:51 <pwhalen> dmarlin, we'll update it
21:09:04 <dmarlin> pwhalen: thank you.
21:10:21 <pwhalen> any other thoughts on the Beta?
21:10:42 <pwhalen> #topic 6) Your topic here
21:10:46 <pbrobinson> I think we call it done and move on
21:10:55 <pwhalen> anything else?
21:10:55 <dmarlin> +1
21:11:19 * pbrobinson is hungry but I don't think anyone here can fix that
21:11:37 <bconoboy> we could order you delivery
21:11:52 <pwhalen> from here... will take a while
21:12:01 <maxam> somw beefy miracle!
21:12:08 <jcapik> pbrobinson: I can give you a hint .... eat something :]
21:12:08 <pwhalen> last call...
21:12:15 <maxam> some*
21:12:21 <jcapik> pbrobinson: the hint is for free
21:12:24 <pbrobinson> it's marinating at the moment
21:12:31 <maxam> lol
21:12:36 <fossjon> get out the bbq
21:12:43 <pwhalen> #endmeeting