f17_final_go_no_go_meeting
MINUTES

#fedora-meeting-1: F17 Final Go No Go Meeting

Meeting started by rbergeron at 17:03:17 UTC (full logs).

Meeting summary

  1. Gathering the Peeps (rbergeron, 17:03:43)
  2. Purpose of this meeting (rbergeron, 17:04:50)
    1. Purpose of this meeting is to see whether or not F17 Final is ready for shipment, according to the release criteria. (rbergeron, 17:05:21)
    2. This is determined in a few ways: (rbergeron, 17:05:37)
    3. No remaining blocker bugs (rbergeron, 17:05:46)
    4. Test matrices are fully completed (rbergeron, 17:06:01)
    5. https://fedoraproject.org/wiki/Current_Release_Blockers (rbergeron, 17:06:26)
    6. https://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria (rbergeron, 17:07:01)
    7. https://fedoraproject.org/wiki/Category:Fedora_17_Final_RC_Test_Results (rbergeron, 17:08:28)

  3. Blocker Bugs (rbergeron, 17:09:31)
    1. 5 proposed blockers (tflink, 17:09:45)
    2. 2 accepted blockers (tflink, 17:09:45)

  4. (821077) Firstboot window does not fit the screen after install from F17 TC4 Final KDE Live (tflink, 17:10:47)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=821077 (tflink, 17:10:50)
    2. Accepted Blocker, NEW (tflink, 17:10:53)
    3. https://bugzilla.redhat.com/attachment.cgi?id=585074 (spot, 17:14:32)
    4. packaging the C code outside of firstboot seems like the best solution for now (tflink, 17:21:19)
    5. ACTION: spot to get patch packaged, get ajax to sanity check patch (rbergeron, 17:23:02)
    6. ACTION: tflink to coordinate with mgracik re: firstboot changes (rbergeron, 17:27:40)

  5. (822123) Graphical grub is unusable slow (tflink, 17:28:11)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=822123 (tflink, 17:28:11)
    2. Accepted Blocker, MODIFIED (tflink, 17:28:11)
    3. workedaround, just need to wait for RC2 (rbergeron, 17:31:00)
    4. anaconda-17.28-1 should workaround this to the point where it's no longer a blocker (tflink, 17:31:01)

  6. (794927) PackageKit cannot import GPG keys - Fatal error: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code14: Invalid input passed to daemon: char '<' in text! (tflink, 17:31:54)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=794927 (tflink, 17:31:58)
    2. Proposed Blocker, MODIFIED (tflink, 17:32:01)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=998 (nirik, 17:36:26)
    4. AGREED: - 794927 - AcceptedBlocker - Violates the Fedora 17 alpha release criterion "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops" (tflink, 17:42:27)

  7. (748320) automatically import default GPG keys (tflink, 17:42:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=748320 (tflink, 17:42:37)
    2. Proposed Blocker, NEW (tflink, 17:42:39)
    3. AGREED: - 748320 - RejectedBlocker, AcceptedNTH - This doesn't directly hit any of the Fedora 17 release criteria and we've been shipping like this for a while now - rejected as blocker. However, this would improve the user experience and a tested fix would be considered for inclusion past code freeze (tflink, 17:47:12)

  8. (822430) PK is stuck after installing a single update (tflink, 17:47:20)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=822430 (tflink, 17:47:20)
    2. Proposed Blocker, NEW (tflink, 17:47:20)
    3. no kittens will be harmed during the triage and fix for this bug ... if all goes according to plan (tflink, 18:03:59)
    4. AGREED: - 822430 - RejectedBlocker, AcceptedNTH - This doesn't completely hit any of the Fedora 17 release criteria and has a simple workaround - install all of the updates. Thus it can be fixed by an update and does not need to block release. However, it does cause problems with certain update use cases and would be considered for freeze break. Separate patches and/or builds for the different PK issues are requested so that they can be evaluated in (tflink, 18:04:12)

  9. (820478) [ta_IN] Without autohinting tamil strings rendering is badly broken. (tflink, 18:04:28)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=820478 (tflink, 18:04:31)
    2. Proposed Blocker, MODIFIED (tflink, 18:04:34)
    3. AGREED: - 820478 - RejectedBlocker, AcceptedNTH - This doesn't directly hit any of the Fedora 17 release criteria but it does impact readability and user experience for installations in Tamil. The fix is built and tested, will accept if more composes are done. (tflink, 18:09:16)

  10. (815473) Preugprade from F16 to F17 Beta doesn't successfully set the boot menu default (tflink, 18:09:32)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=815473 (tflink, 18:09:35)
    2. Proposed Blocker, NEW (tflink, 18:09:37)

  11. (815473) Preugprade from F16 to F17 Beta doesn't successfully set the boot menu default (tflink, 18:17:06)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=815473 (tflink, 18:17:09)
    2. Proposed Blocker, NEW (tflink, 18:17:11)
    3. AGREED: - 815473 - RejectedBlocker - This doesn't affect the ability of preupgrade to actually work and thus, doesn't violate the Fedora 17 release criteria. The workaround is relatively painless but a new preupgrade build is very much desired as the issue has been fixed in git (tflink, 18:21:02)

  12. (822495) Fedora 17 DVD build does not contain device-mapper-multipath (tflink, 18:22:48)
    1. http://bugzilla.redhat.com/show_bug.cgi?id=822495 (tflink, 18:22:51)
    2. Proposed Blocker, NEW (tflink, 18:22:53)
    3. AGREED: - 822495 - AcceptedBlocker - Violates the Fedora 17 final release criterion "The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel)" and multipath is very much the norm for higer end networked storage (tflink, 18:26:20)

  13. Go or No Go? (rbergeron, 18:32:23)
    1. Test matrices are pretty much covered, except SCSI, which we are always missing. (rbergeron, 18:32:51)
    2. 4 blockers - 2 previously accepted, 2 new (rbergeron, 18:36:12)
    3. some desktop tests, including KDE, are missing, we need an RC2 spin. (rbergeron, 18:36:52)
    4. AGREED: F17 Final (from RC1) is a no-go; we slip one week, for a GA of May 29. (rbergeron, 18:38:10)
    5. Release readiness meeting in this channel in 20 minutes (rbergeron, 18:39:38)
    6. ACTION: rbergeron to send out slip mail with a sad, unbeefy face (rbergeron, 18:40:02)
    7. Next Go/No-Go will be 2012-05-24, same bat time, same bat channel (17:00 UTC, 13:00 eastern, 10:00 pacific) (rbergeron, 18:45:40)


Meeting ended at 18:48:34 UTC (full logs).

Action items

  1. spot to get patch packaged, get ajax to sanity check patch
  2. tflink to coordinate with mgracik re: firstboot changes
  3. rbergeron to send out slip mail with a sad, unbeefy face


Action items, by person

  1. rbergeron
    1. rbergeron to send out slip mail with a sad, unbeefy face
  2. spot
    1. spot to get patch packaged, get ajax to sanity check patch
  3. tflink
    1. tflink to coordinate with mgracik re: firstboot changes


People present (lines said)

  1. tflink (152)
  2. rbergeron (136)
  3. adamw (83)
  4. nirik (52)
  5. spot (19)
  6. sgallagh (13)
  7. drago01 (10)
  8. bcl (6)
  9. zodbot (6)
  10. mclasen (4)
  11. dgilmore (0)


Generated by MeetBot 0.1.4.