fpc
LOGS
16:09:27 <spot> #startmeeting Fedora Packaging Committee
16:09:28 <zodbot> Meeting started Wed Apr 11 16:09:27 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:09:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:09:31 <spot> #meetingname fpc
16:09:31 <zodbot> The meeting name has been set to 'fpc'
16:09:32 <limburgher> Yup.
16:09:45 * spot is just now recovering from some sort of flu virus
16:10:27 * abadger1999 remebers belatedly that tibbs|h said he couldn't make this time this week
16:10:38 <spot> #topic Roll Call
16:10:42 * limburgher here
16:10:52 * geppetto is here
16:11:18 * abadger1999 here
16:11:27 * spot is mostly here
16:12:58 * limburgher casts +3 smelling salts at spot
16:14:09 <abadger1999> Looking like we lack quorum :-(
16:14:15 <geppetto> yeh
16:14:25 <abadger1999> geppetto: Did my analysis of https://fedorahosted.org/fpc/ticket/161  look correct to you?
16:14:30 <geppetto> On the upside … early lunch
16:14:51 <geppetto> abadger1999: Why you asking me?
16:15:09 <abadger1999> I figure you're the rpm expert :-)
16:15:18 <geppetto> Ahh … yeh, the rpm macros side looked fine.
16:15:35 <geppetto> But I figured you wouldn't need to ask me about that :)
16:15:39 * spot senses no quorum. :/
16:15:43 <spot> lets try next week.
16:15:49 <spot> hopefully i'll be a bit more alive then.
16:16:02 <limburgher> OK.  I'd say give it a few minutes, but it's 15 already.  Go to bed.
16:16:07 <spot> and of course, as soon as i say that... :)
16:16:16 <rdieter> hiya
16:16:20 <limburgher> <giggle>
16:16:32 <geppetto> rdieter: Hey, you are quorum maker :)
16:16:35 <abadger1999> heh
16:17:06 <spot> okay, gimme a second to toss an agenda together
16:17:48 <spot> #topic Bundling exception request for Passenger - https://fedorahosted.org/fpc/ticket/160
16:18:07 <spot> this bug has been around almost forever.
16:18:28 <limburgher> It's BZ number is double that of most Merge Reviews. :)
16:18:41 <spot> limburgher: yes, and thus "almost"
16:19:24 <spot> i think the key point here is that we've had a long window of time to observe the Passenger upstream behavior with regards to their boost fork
16:19:50 <spot> they have been aggressively keeping the base boost in sync
16:20:16 <spot> and there is a dedicated Red Hat employee who has been working for the last several months to minimize the amount of Passenger specific changes
16:20:23 <limburgher> It looks like one of the sane exceptions, even though the upstreaming process is slow.
16:20:26 <spot> (also the ticket filer, fyi)
16:20:29 <limburgher> s/sane/saner/
16:20:49 <spot> so, I'm +1 on this exception.
16:21:16 * rdieter too, +1
16:21:19 <limburgher> +1 I agree.
16:21:27 <geppetto> Ok … so I didn't know about the history much … but my first thought was … "fork" the bits you can't integrate into upstream boost, and then integrate everything else.
16:21:50 <geppetto> It just feels like shipping their own copy of boost is a big hammer.
16:21:59 <spot> geppetto: the changes that can't integrate right now are very low level within boost
16:22:15 <limburgher> geppetto, ideally, yes, but I'm not sure that that wouldn't necessarily help the upstreaming situation.
16:22:21 <spot> so its not trivial to separate it out (which is one of the big reasons it sat like this for so long)
16:22:41 <geppetto> But AIUI boost is a collection of different things, right? … so if they need say matrix stuff … they can just "fork" their own copy of the matrix stuff
16:22:59 * spot is not a boost expert, but the ticket filer is
16:23:15 <spot> so i tend to trust him when he says an exception is merited
16:23:25 <geppetto> Ok, then … +1
16:24:10 <spot> vote stands at +4. abadger1999?
16:24:27 * abadger1999 considering
16:26:06 <abadger1999> Well.... I'm a hesitant +1
16:26:21 <abadger1999> I don't think a lot of the issues with bundling of boost have gone away
16:26:55 <abadger1999> But wakko666 does take the place of upstream (passenger) trying to work with the boost upstream.
16:27:09 <abadger1999> Is wakk0666 going to be the passenger maintainer?
16:28:03 <abadger1999> I recall that kanarip didn't know C++/boost very well so it didn't seem like a good idea to allow bundling where a security fix might need to go out and the package maintainer didn't know how to code/backport/merge in said fix.
16:28:55 <abadger1999> If wako666 is the passenger maintainer then that point of contention goes away.
16:29:40 <spot> abadger1999: i think we can make the exception contingent on him being the maintainer
16:29:47 <spot> i know he was willing when i spoke to him previously
16:30:00 <abadger1999> +1
16:30:04 <abadger1999> Sounds good to me.
16:30:28 <spot> #action Exception granted, as long as wakko666 is the maintainer. (+1:5, 0:0, -1:0)
16:31:29 <spot> #topic Update Eclipse Guidelines - https://fedorahosted.org/fpc/ticket/161
16:31:40 <spot> Diff: https://fedoraproject.org/w/index.php?title=EclipsePluginsPackaging_change&action=historysubmit&diff=283864&oldid=283859
16:31:44 <spot> it came with a diff!
16:31:45 * spot faints
16:31:55 * limburgher fans spot
16:32:59 <spot> i think the key concern here is what abadger1999 points out in the ticket
16:33:40 <abadger1999> pdebuild portion +1... that seems fairly simple.  Not sure about the %_libdir => %_eclipse_base portion
16:34:06 <spot> yeah, so i think we can go ahead and consider the pdebuild changes
16:34:17 <geppetto> Yeh, I'm +1 on everything apart from the eclipq_base crack.
16:34:24 <limburgher> Yeah, I'm not sure why thy couldn't just use lidbir.
16:34:33 <limburgher> gepetto: Me too.
16:34:40 <geppetto> limburgher: I think they are confused about what they want
16:34:42 <spot> well, they can't use libdir because it will eval wrong
16:34:51 <spot> but so will their proposed solution
16:34:58 <geppetto> Yeh
16:35:04 <spot> because they dont seem to understand that the macro is evaluated at build time, not install time
16:35:16 <geppetto> They want something that magically points to /lib and /lib64 depending on arch it's installed on … but is noarch.
16:35:32 <limburgher> Which is an odd thing to need, really.
16:35:34 <spot> yeah. i think the choices are roughly this:
16:35:47 <spot> A) fix eclipse to have a true "noarch" directory for these files
16:35:56 <spot> B) Set these packages to be arch specific
16:36:08 <spot> C) Patch noarch eclipse plugin build scripts to properly find the dependent plugins whether they're in /usr/lib or /usr/lib64
16:36:44 <geppetto> Yeh, not sure if C is good though … but A or B for sure.
16:37:04 <abadger1999> I think A won't work since the dependent plugins in question are arch-specific.
16:37:12 <limburgher> I prefer B, less obvious deviation from upstream.
16:37:44 <geppetto> limburgher: yeh, just sucks to have duplicate packages
16:37:58 * geppetto adds quotes to "duplicate".
16:38:08 <spot> abadger1999: if there was an understanding that dependent plugins can depend on arch-independent packages, it should be okay to teach eclipse to search in an additional dir (e.g. /usr/share/eclipse/plugins)
16:39:00 * spot re-reads what he just typed and gives himself a worse headache, but it should make some sense
16:39:02 <limburgher> geppetto: That's life for multiarch, though.
16:39:07 <abadger1999> I think I may have used "dependent" but meant the opposite. The noarch plugin depends on an arch-specific plugin
16:39:36 <spot> abadger1999: okay, ew.
16:40:11 <limburgher> Ew indeed, which is why I prefer B.
16:40:23 <spot> i can't think of a good way to really do A in that case.
16:40:27 <geppetto> B is certainly much easier fix.
16:40:34 <spot> C might be able to be macroized
16:40:44 <spot> %find_eclipse_arch_plugin foo
16:40:54 <geppetto> spot: But how would that work?
16:40:57 <spot> but that would be... nasty.
16:41:05 <limburgher> B would also prevent having to have a new macro, no?
16:41:12 <geppetto> spot: In the case where package built on x86_64 and installed on i686?
16:41:21 <geppetto> limburgher: yeh
16:41:38 <spot> geppetto: never mind
16:41:40 <spot> you're riht
16:41:44 <spot> it won't work either.
16:41:58 <spot> there is no good way to specify the Requires properly.
16:42:31 <spot> even if C is done, the package will still not be valid for x86_64 and i686
16:42:43 * geppetto nods
16:42:45 <abadger1999> they might still be able to have a search path in their code/build scripts... I don't know what those actually look like.
16:43:12 <abadger1999> but.. not enough information to figure that out.
16:43:14 <limburgher> abadger1999: With B, we don't have to care.
16:43:17 <spot> the only other hack i can think of is really nasty
16:43:24 <abadger1999> <nod>
16:43:26 <spot> and i hesitate to put it on the record.
16:43:43 <geppetto> :)
16:43:52 <spot> (hint: it involves %ghost and %post)
16:44:06 <limburgher> Dude, seriously shut up and go back to bed.
16:44:14 * spot laughs
16:44:15 <limburgher> For your own good.
16:44:21 <spot> it would work. :)
16:44:28 <limburgher> I need a shower.
16:44:48 <spot> lets vote on the pdebuild changes
16:44:49 <spot> +1
16:44:55 <geppetto> +1
16:44:56 <limburgher> +1
16:45:57 <abadger1999> +1
16:47:53 <geppetto> rdieter: ?
16:48:45 <spot> i may have infected him with the "easter virus"
16:49:16 <limburgher> Maybe he started thinking about your idea and his heart gave out.
16:50:33 <spot> hehehe
16:50:37 <spot> its possible
16:51:06 <spot> well, that was the last item on the agenda for today
16:51:21 <spot> so we'll just open the floor and hopefully rdieter will revive long enough to vote on the pdebuild changes
16:51:24 <spot> #topic Open Floor
16:51:28 <rdieter> +1 (got pulled away)
16:51:30 <spot> aha!
16:51:47 <rdieter> pesky users and their questions
16:51:48 <limburgher> Oh thank $_DEITY, I'd feel like such a tool if something had actually happened. :)
16:51:54 <spot> #action Eclipse pdebuild changes (only) approved (+1:5, 0:0, -1:0)
16:54:18 <limburgher> Is that count right?
16:54:29 <spot> umm
16:54:30 <limburgher> Oh.  It is.
16:54:37 <limburgher> I'm. . .just. . .yeah.
16:54:38 <spot> spot, geppetto, limburgher, abadger1999, rdieter
16:54:44 <spot> oh no, i broke your brain
16:54:48 <limburgher> I misread
16:54:58 <spot> think happy thoughts. google announces that they have unbundled everything from chromium.
16:55:05 <spot> photoshop is released under the GPL
16:55:09 <limburgher> Guru Meditation #3256q34626
16:55:12 <abadger1999> woo hoo!
16:55:33 <abadger1999> ;-)
16:55:46 <spot> okay, so i'm not hearing any topics for open floor
16:56:02 <spot> aside from "spot needs to get more rest"
16:56:18 <spot> so, thanks everyone
16:56:20 <spot> #endmeeting