insight
LOGS
19:01:44 <stickster> #startmeeting Insight
19:01:44 <zodbot> Meeting started Mon Apr 25 19:01:44 2011 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:47 <stickster> #meetingname Insight
19:01:47 <zodbot> The meeting name has been set to 'insight'
19:01:59 <asrob> hi
19:02:00 <stickster> #topic Roll call!
19:02:02 * stickster 
19:02:04 * rbergeron waves
19:02:09 * asrob too
19:02:12 <stickster> Hi asrob, rbergeron
19:02:36 * stickster is going to plunge right in because there's a lot going on today :-)
19:02:47 <stickster> #link https://fedoraproject.org/wiki/Fedora_Insight#Meeting_agenda <-- Agenda
19:03:04 * nirik is lurking.
19:03:04 <stickster> #topic Action items from last week
19:03:36 <stickster> #info This weekend review was finished for backup_migrate, so...
19:03:47 <stickster> #action stickster still needs to make puppet changes to include backup_migrate on hosts
19:04:02 <stickster> #info 4, 5, 7 done
19:04:22 <stickster> By the way...
19:04:28 <stickster> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2011-04-18/insight.2011-04-18-19.00.html <-- last week's action items
19:04:34 <stickster> That's the list I'm working from! :-)
19:04:48 <stickster> asrob, How's #2 going?
19:05:08 * stickster needs to get asrob access, which means asrob needs to apply for sysadmin-insight
19:05:17 <stickster> #action asrob apply for sysadmin-insight group at FAS
19:05:31 <asrob> stickster: I am working on it, I think, date and calendar modules are packaged
19:05:53 <stickster> asrob, Remember, we need to flesh out our project plan before we start adding modules to the host.
19:05:59 <stickster> Define the problem first, then work on the solution :-)
19:06:25 <stickster> #action stickster fix the key ordering problem in https://fedorahosted.org/fedora-infrastructure/ticket/2726 once backup_migrate is available
19:06:39 <asrob> our calendar is working on my devel instance, tomorrow I am going to test it on Insight dev server
19:06:50 <stickster> asrob, See above ^^
19:07:04 <asrob> stickster: yep, I'll fill a ticket ;)
19:07:05 <stickster> We'll discuss after we finish this topic I guess :-)
19:07:14 * stickster doesn't see pcalarco around
19:07:28 <stickster> #action stickster email pcalarco + tatica about ticket 2691
19:07:49 <stickster> #action stickster email list about format for change instances
19:07:49 <asrob> stickster: btw "The webpage at https://insight.dev.fedoraproject.org/ might be temporarily down or it may have moved permanently to a new web address."
19:08:06 <stickster> asrob, Yeah, we need averi here because I haven't been able to access this host at all.
19:08:13 <asrob> ah, okay
19:08:15 <stickster> nirik, Maybe you know something about it?
19:08:33 <stickster> #topic Is dev host available?
19:08:35 <nirik> hum...
19:08:45 <nirik> I don't know about that, but can investigate.
19:08:47 <stickster> I can't seem to ssh there either
19:09:05 <nirik> the machine is up.
19:09:06 <stickster> nirik, I wasn't involved in setting it up so I'm not sure what was left to do -- averi or smooge might know?
19:09:15 <nirik> I basically just setup the instance.
19:09:19 <nirik> I didn't install anything on it.
19:09:47 <nirik> it looks like httpd is not running, so likely stuff needs to get moved over from the publictest box still.
19:10:16 <stickster> Aha
19:10:17 <stickster> OK
19:10:23 <stickster> nirik, Is sshd running?
19:10:38 <nirik> yeah.
19:10:46 <nirik> I am in...
19:10:53 <stickster> nirik, Is it through the bastion?
19:11:07 <nirik> it should be world accessable.
19:11:09 * nirik looks.
19:11:19 * stickster tried ssh insight.dev.fp.o to no avail
19:11:24 <nirik> hangs?
19:11:34 <nirik> .members sysadm-insight
19:11:36 <zodbot> nirik: Members of sysadm-insight:
19:11:40 <nirik> .members sysadmin-insight
19:11:41 <zodbot> nirik: Members of sysadmin-insight: @averi +pfrields
19:11:44 <stickster> nirik, No name resolution
19:11:56 <nirik> huh.
19:12:05 <nirik> yeah, you should be able to get to it via bastion then.
19:12:38 <stickster> No name resolution there either -- nirik, is it "insight.dev.fedoraproject.org" ?
19:13:28 <nirik> oh no.
19:13:34 <nirik> it's insight01.dev.fedoraproject.org
19:13:47 <stickster> aha
19:13:58 <stickster> whoopee
19:14:15 <asrob> hm, I cannot reach it
19:14:20 <stickster> Works everywhere now. Thanks nirik.
19:14:47 <stickster> #info SOLVED! hostname is insight01.dev.fedoraproject.org :-)
19:14:54 <nirik> I can change it if need be.
19:14:58 <nirik> Sorry for the mixup
19:15:04 <stickster> nirik, No need afaict
19:15:06 <stickster> Thanks!
19:15:17 <stickster> asrob, Does 'ssh insight01.dev.fedoraproject.org' not work for you?
19:15:33 <stickster> asrob, You're not part of the group yet, see above -- apply for sysadmin-insight and I can approve you there.
19:16:35 <stickster> #topic New meeting time
19:16:36 <asrob> stickster: ouch, my mistake, ssh is working, I tried to reach it through www
19:16:40 <stickster> :-)
19:17:16 <stickster> #link http://whenisgood.net/insight-spr11/results/2nxjdx <-- meeting matrix results
19:17:50 <stickster> We had 4 people respond. The best time looks to be either this same time, or 1 hour earlier, and lose averi, or Tuesday at 4:00pm EDT and lose rbergeron.
19:18:13 <stickster> rbergeron, How do you feel about that?
19:18:54 <rbergeron> stickster: i can pop in as needed.
19:19:15 <stickster> rbergeron, So would you agree that we should try to catch averi by shifting to Tuesday at 4pm EDT?
19:19:19 <rbergeron> i'm okay with it - I think it's more important to have the people doing the implementing, and quite frankly, i can't help there. :)
19:19:46 <stickster> rbergeron, OK, makes sense -- wanted to make sure you didn't feel stiffed if we move the time :-)
19:20:00 <rbergeron> :)
19:21:05 <stickster> OK, one last consideration -- next Tuesday I won't be around online; I'll be working at the Red Hat Summit. So I would move that...
19:21:27 <stickster> #idea we meet next Monday, May 2 as the last Monday meeting, and then the next meeting following that will be Tuesday, May 10 at 4:00pm EDT (2000 UTC).
19:21:36 <stickster> +/-1?
19:22:22 <asrob> it looks good to me
19:22:29 * rbergeron thinks that sounds good as well
19:22:59 <stickster> #agreed Schedule as above -- Mon May 2 at 1900 UTC is last Monday meeting, next meeting following is Tue May 10 at 4:00pm EDT (2000 UTC).
19:23:17 <stickster> #topic Features plan
19:23:45 <stickster> asrob, So you discovered this cool module, tell us a little more about it. http://drupal.org/project/features
19:24:21 <asrob> stickster: http://developmentseed.org/blog/2009/may/29/making-and-using-features-drupal
19:24:54 <asrob> stickster: we can develop our features with this modules easily
19:25:21 <asrob> we can export/import our features into a module like a contrib module
19:26:02 <stickster> So we could git-manage that set of modules as with any other code
19:26:32 <asrob> yep, we can maintain our features in a git repository
19:27:13 <asrob> and if we have to use a "cool gallery", just git clone into drupal dir and enable on features page
19:28:24 <asrob> but I do not suggest that we write into files(.inc, .module etc.) directly
19:29:03 <stickster> Yeah, if we're using regular contrib modules, those should really be packaged so the entire community can use them
19:29:42 <stickster> asrob, But I had some additional questions on the list waiting for answers... such as (1) does Features capture permission changes for roles that relate to new modules?
19:30:43 <asrob> stickster: you can capture permissions, but I could not test it with our FAS module, I could test it contrib modules
19:31:16 <stickster> asrob, Do you mean there is something wrong with authfas module? Or just that you didn't have a chance to try it?
19:31:31 <stickster> If there's a bug, I'd be happy to take a look at it and fix it :-)
19:31:33 <asrob> stickster: I have not any chance
19:31:45 <stickster> asrob, OK, no problem -- just wanted to make sure I didn't write something terribly wrong :-)
19:32:06 <asrob> if I could test it our dev server, it will be good ;)
19:32:14 <stickster> asrob, So I had some other questions outstanding on the list, if you could answer there it would be very helpful
19:32:30 <asrob> I am looking for that email, wait a sec ;)
19:32:57 <stickster> asrob, You can take your time and answer it after meeting, no worries
19:33:07 <stickster> In the meantime...
19:33:16 <stickster> #action stickster finish review in .bug 698590
19:33:44 <asrob> 2., 3., is these related to FAS module, am I right?
19:34:14 <stickster> What 2. and 3. are you referring to?
19:34:26 <stickster> Oh, my questinos!
19:34:29 <stickster> *questions, even.
19:34:33 <asrob> " (2) the group
19:34:34 <asrob> membership to map to "authenticated users", and (3) the FAS group
19:34:36 <asrob> <--> Drupal RID mappings.  Will it capture these?"
19:34:57 <stickster> Yes
19:35:00 <stickster> Both related to authfas
19:35:26 <asrob> okay, I need to test it
19:35:36 <stickster> authfas uses the .install to add a table to the database with FAS group <--> Drupal rid mappings.
19:36:01 <stickster> In the best case scenario, we could add those using Features as well
19:36:25 <stickster> asrob, So if you see where I'm going with this -- we could turn our entire pages of customization directions into Features commits through git.
19:36:51 <asrob> okay
19:36:57 <stickster> asrob, The ultimate purpose is to make recreating the system as automated as possible
19:37:10 <stickster> I still don't think we can automate moving the content :-)
19:37:36 <stickster> But at the very least, we could have a better capture of what we do in git than simply emailing or IRC'ing
19:37:39 <asrob> I'll figure it out how to do this :)
19:37:59 <stickster> #action asrob continue working on way to use Features to manage our development deployment
19:38:27 <stickster> OK, that brings us to the last agenda item which is...
19:38:32 <stickster> #topic Start phase 2 discussions
19:39:01 <stickster> #info Overall, the purpose of having a project plan is to set out which problems we want to solve, so we can move on to gathering requirements for solving each.
19:41:17 <asrob> stickster: I think, built-in calendar system is almost done
19:41:40 <stickster> asrob, I want to be careful that we understand what problems we're solving with the calendar system, and with other modules, before we deploy them
19:41:57 * nirik looks up at the mention of calendar
19:41:59 <stickster> asrob, Because we don't want to get in a situation where people are coming to us, one small change at a time, over and over
19:42:16 <asrob> stickster: hmm, you are right
19:42:17 <nirik> does this help us with ticket 1197 ?
19:42:20 <stickster> asrob, We should do a proper job of gathering all the requirements first, and then implement the calendar to handle all those requirements.
19:42:25 <nirik> .ticket 1197
19:42:28 <zodbot> nirik: #1197 (Lets find a calendar server.) - Fedora Infrastructure - Trac - https://fedorahosted.org/fedora-infrastructure/ticket/1197
19:43:09 <stickster> nirik, Possibly, but again, we'd need to know all the requirements to be certain.
19:43:38 <stickster> The Drupal Calendar module doesn't automatically do things like LDAP integration, sync, etc.
19:43:48 <stickster> That ticket's pretty long to try and digest what people are really looking for.
19:44:00 <nirik> indeed.
19:44:13 <nirik> so perhaps we should at some time brainstorm a real list of requirements.
19:44:21 <stickster> If people want a groupware/appointment system, that's different than e.g. a submittable, shareable group calendar
19:45:08 <nirik> I personally was wanting more a shareable group calendar.
19:45:45 <asrob> yeah, I am just excited due to phase2 and Features :)
19:46:02 <stickster> nirik, I like that idea. Set up a wiki page and open it for input? We should ask people to list each requirement along with what they feel is its overall importance. In other words, Feature X might be great to have, but it's not a deal-breaker.
19:46:26 <nirik> yeah. I thought there might be one, but if not I can create one.
19:46:59 <stickster> nirik, That would be awesome if you could do so -- maybe blog it so people see where they can put in their hit list items?
19:47:19 * stickster is going to be very tight on time for the next two weeks due to hectic travel schedule
19:47:31 <nirik> http://fedoraproject.org/wiki/User:Herlo/Fedora_Calendar_Project_Desired_Features_(Draft)
19:47:38 <stickster> \o/
19:48:07 <nirik> will ping herlo about that.
19:48:51 <stickster> nirik, You should definitely let them know we'd be using Drupal for this. It's well known, and supplants the "Zikula" suggestion given in the text (which pre-dates our moving to Drupal)
19:49:04 <nirik> yeah.
19:52:04 <asrob> stickster: could we talk about a ticket(#2695) later?
19:53:39 <stickster> asrob, Certainly
19:53:45 <stickster> Sorry, was in another conversation.
19:54:04 <asrob> and sysadmin-insight membership
19:54:06 <asrob> okay
19:54:09 <stickster> #action nirik talk to herlo about draft calendar project wiki, and update of requirements to see if we could meet that need.
19:54:56 <stickster> #idea I would like to see whatever major additions we want to make to Insight, added to our project plan page here in the next 2 weeks or so: https://fedoraproject.org/wiki/Insight_project_plan
19:57:04 <asrob> okay
19:59:53 <stickster> asrob, That's about it for me
20:00:06 <stickster> Anything else before we close?
20:00:17 * stickster has to get on phone for a $DAYJOB meeting
20:00:48 <asrob> talk about a ticket and membership, or later?
20:01:10 <stickster> asrob, we can do that in #fedora-mktg
20:01:22 <asrob> okay then you can cloe
20:01:27 <asrob> close
20:01:34 <stickster> #endmeeting