fedora-cloud
LOGS
19:08:56 <roshi> #startmeeting CloudWG
19:08:56 <zodbot> Meeting started Wed Feb 11 19:08:56 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:08:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:09:20 <kushal> let us do it here, but we will loose the logs iirc
19:09:36 <roshi> oh, we will?
19:09:38 <kushal> #topic Roll Call
19:09:56 <kushal> roshi, I thought so, but let us just do it here.
19:10:07 <dustymabe> .hellomynameis
19:10:08 <zodbot> dustymabe: (hellomynameis <username>) -- Return brief information about a Fedora Account System username. Useful for things like meeting roll call and calling attention to yourself.
19:10:12 <roshi> http://meetbot.fedoraproject.org/meetbot/fedora-cloud/2015-02-11/
19:10:15 <oddshocks> .hellomynameis oddshocks
19:10:15 <roshi> :D
19:10:16 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:10:17 <dustymabe> .hellomynameis dustymabe
19:10:19 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:10:22 <kushal> .hellomynameis kushal
19:10:23 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:10:23 <roshi> .hello roshi
19:10:29 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:10:34 <kushal> roshi, feel free to run the meeting tonight :)
19:10:55 <roshi> ok
19:11:08 <roshi> #topic Previous meeting followup
19:11:25 <roshi> #chair dustymabe oddshocks kushal
19:11:25 <zodbot> Current chairs: dustymabe kushal oddshocks roshi
19:11:43 <kushal> News: I am back
19:11:46 <kushal> almost :p
19:11:59 <roshi> * dustymabe to update the ticket with his dockerfile plans
19:12:00 <roshi> * oddshocks to get with releng about updated images
19:12:04 <rtnpro> .fas rtnpro
19:12:04 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
19:12:12 <roshi> glad to hear it kushal :)
19:12:19 <roshi> not the same with you sick and not around
19:12:22 <lsm5> .hellomynameis lsm5
19:12:23 <zodbot> lsm5: lsm5 'Lokesh Mandvekar' <lsm5@redhat.com>
19:12:44 <dustymabe> roshi: I went on vacation at the end of last week and that killed my weekend plans
19:12:49 <dustymabe> planning to get back on this this weekend
19:13:15 <roshi> who approved his vacation?
19:13:18 <roshi> :p
19:13:29 <oddshocks> Talked to Dennis and updated the ticket https://fedorahosted.org/cloud/ticket/94
19:13:33 <roshi> no worries dustymabe
19:13:39 <roshi> sweet, thanks oddshocks
19:13:41 <oddshocks> Basically they're still working on coming up with a process AIUI
19:14:30 <roshi> as I'm finding out, it's no trivial thing to get this stuff to work
19:15:30 <roshi> alright onto to tickets
19:16:06 <roshi> #topic HVM support
19:16:11 <roshi> #link https://fedorahosted.org/cloud/ticket/68
19:16:21 <roshi> do we have ami's up yet?
19:16:24 * roshi hasn't checked
19:17:07 <oddshocks> yeah
19:17:10 <oddshocks> they're on the site too
19:17:17 <roshi> sweet, we can close this out
19:17:21 <oddshocks> https://getfedora.org/en/cloud/download/
19:17:23 <oddshocks> sure can
19:17:25 <roshi> oddshocks: you want to close it?
19:17:28 <oddshocks> sure will
19:17:47 <roshi> #topic dockerfiles
19:17:51 <roshi> #link https://fedorahosted.org/cloud/ticket/84
19:17:58 <kushal> got disconnected
19:18:03 <roshi> np :)
19:18:23 <roshi> this is ongoing and dustymabe will update it soon
19:18:30 <roshi> want another action item dustymabe ?
19:18:39 <dustymabe> roshi: haha I think I have enough
19:18:47 <roshi> I figured :p
19:18:49 <dustymabe> btw I think jzb gave an update for this on the list
19:18:58 <roshi> just didn't know if you liked to collect them or something :p
19:19:21 <roshi> yeah
19:19:24 <kushal> dustymabe, he did.
19:19:32 <roshi> jzb said he was going to work on this next week
19:19:34 <kushal> He will work on the same on coming Monday or Tuesday iirc.
19:19:44 <roshi> not sure there's much more for us to go over for it
19:20:08 <roshi> this touches on what jsmith brought up regarding our documentation
19:20:21 <roshi> we can talk about that when we get to open floor though
19:20:22 <dustymabe> roshi: whats the story with test days? I know they aren't too far off.
19:20:29 <kushal> roshi, yeah
19:20:34 <roshi> got one tomorrow for DNF/Anaconda
19:20:39 <roshi> a couple others scheduled
19:20:40 <dustymabe> oops.. thought we were to open floor
19:20:43 <dustymabe> sorry
19:20:52 <roshi> np - we can finish up tickets now
19:21:03 <kushal> roshi, go ahead
19:21:14 <roshi> #topic CHecksums
19:21:18 <roshi> #link https://fedorahosted.org/cloud/ticket/93
19:21:27 <roshi> kushal, is that link what you were looking for?
19:21:42 <roshi> https://getfedora.org/en/static/checksums/Fedora-Cloud-Images-x86_64-21-CHECKSUM
19:21:51 <kushal> roshi, so basically systemd folks want the checksum and signature in two different files, in a format they like
19:22:12 <kushal> There is already a ticket from virt folks related to similar things.
19:22:27 <roshi> so what do we need to do with this?
19:22:47 <roshi> write them a parser to break these standard checksum files into something they like?
19:22:48 <kushal> roshi, I will update this ticket with the virt folks ticket (I will have to find that ticket first).
19:22:58 <roshi> iirc, this is how *all* our checksums are generated for all our images
19:23:00 <kushal> roshi, hehe
19:23:06 <dustymabe> kushal: weird.. what is the benefit of having them separated?
19:23:13 <kushal> roshi, correct
19:23:28 <roshi> it seems to me they need to take this to releng, not us
19:23:29 <kushal> dustymabe, a standard name to find them easily sha1sum and sha1sum.gpg
19:23:37 <roshi> since we have nothing to do with that generation
19:23:50 <kushal> dustymabe, I guess they already wrote some parser and do not want any more work.
19:24:11 <dustymabe> weird.. all they have to do is parse it out
19:24:12 <roshi> what are they trying to accomplish?
19:24:18 <kushal> roshi, yes, but the call has to go through us and we are also part of the discussion.
19:24:24 <dustymabe> get rid of what is between -----BEGIN PGP SIGNED MESSAGE-----
19:24:25 <kushal> roshi, search and download cloud images
19:24:31 <kushal> something like
19:24:40 <roshi> they can use fedfind for that
19:24:42 <kushal> machinectl search fedora
19:24:55 <roshi> what does that do and where is it used?
19:25:14 * roshi has never used systemd to search for something on the internet
19:25:25 <kushal> roshi, they are having they new systemd-nspwan and friends, which will allow them to run containers from the cloud images and container images
19:25:49 <kushal> roshi, they want to way to find the details of all available images too
19:26:01 <kushal> roshi, I guess oddshocks was doing something in that area.l
19:26:01 <roshi> fedfind should do that
19:26:15 <roshi> available on our infra, or on all infra?
19:26:16 <kushal> roshi, fedfind is not systemd for them :)
19:26:33 <kushal> roshi, our infra, some sort of json file or something.
19:27:00 <roshi> so they need a change to releng processes, and we have to just take this to releng then?
19:27:01 <kushal> Ubuntu has some spec written for the same I guess, I am yet to look at those.
19:27:10 <dustymabe> seems like it would be easeier for them to verify if the sig stays in the file
19:27:20 * roshi wonders what things use the current format - and if we need to produce both or just one
19:27:23 <kushal> roshi, we did, and they do not like the idea.
19:27:41 <kushal> roshi, now I have to make sure that systemd team talks directly with rel-eng and virt folks
19:27:46 <dustymabe> kushal: who is "they"?
19:27:54 <dustymabe> releng?
19:27:57 <kushal> I missed too many discussions by missing devconf :(
19:28:07 <kushal> dustymabe, Yes.
19:28:08 <roshi> if releng doesn't like it, then I don't know what we even *can* do about it
19:28:37 <roshi> unless I'm not understanding some facet of this ticket
19:28:40 <kushal> roshi, Tell systemd nicely that talk to rel-eng and other teams if they want.
19:28:58 <roshi> that's about all we can do, I think
19:29:15 <kushal> roshi, I will update the ticket.
19:29:38 <roshi> I don't have strong feelings either way, but parsing the standard fedora checksum file should probably be their fallback incase releng won't change things to make systemd folks lives easier
19:29:39 <kushal> #action Kushal will update the checksum ticket #93
19:29:44 <roshi> sgtm
19:29:47 <kushal> roshi, Yup.
19:30:22 <roshi> anyone have anything else to add?
19:30:52 * roshi moves on
19:30:54 <roshi> #topic OpenShift Commons
19:30:58 <roshi> #link https://fedorahosted.org/cloud/ticket/83
19:31:59 <kushal> no updates, we are waiting on board.
19:32:00 <roshi> has anyone had time to get info from pythondj on this one?
19:32:04 <roshi> ah
19:32:08 <kushal> We can move on.
19:32:13 <roshi> can you update the ticket with what we're waiting on?
19:32:40 <kushal> roshi, I guess right now mattdm has more info on that.
19:32:44 <kushal> roshi, Okay.
19:33:00 <roshi> #topic TeachMeHowtoDockerfile
19:33:04 <roshi> #link https://fedorahosted.org/cloud/ticket/87
19:33:15 <roshi> I think we can close this out as a dupe from the earlier ticket
19:33:25 <dustymabe> roshi: one sec
19:33:33 <roshi> update the other ticket to include the desire for a howto on the magazine and the wiki
19:33:37 <roshi> kk
19:33:55 <dustymabe> i think this one is more about using Dockerfiles from scratch
19:34:10 <dustymabe> or is this more about our dockerfiles and how to use them?
19:34:17 <kushal> roshi, jzb created this one separately iirc
19:34:50 <roshi> yeah
19:34:51 <dustymabe> I think it is about encouraging people to use them and then submit PRs when they see something that needs to be fixed.
19:35:22 <roshi> I just didn't know if we needed another since the ongoing publicize dockerfiles effort encompasses it
19:35:31 <roshi> but if it's useful for tracking things, then we can keep it
19:35:43 <dustymabe> roshi: yeah. I would wait and let jzb make the decision on that
19:35:53 <roshi> I'd remove the meeting keyword though, and link to it from the other ticket
19:36:22 <roshi> thoughts on that?
19:36:40 <kushal> roshi, keeping the meeting keyword till the next meeting
19:37:02 <roshi> fair enough, give jzb time to respond
19:37:19 * roshi moves onto the last ticket
19:37:29 <roshi> #topic Updated images
19:37:31 <roshi> #link https://fedorahosted.org/cloud/ticket/94
19:38:11 <roshi> oddshocks: anything you need from us to chase this bit down?
19:38:30 <kushal> #link  https://fedorahosted.org/rel-eng/ticket/6098
19:38:45 <kushal> lsm5, was also trying for the same.
19:39:03 <roshi> well, it's being worked on - so that's a good thing :)
19:39:37 <kushal> But we all know rel-eng is already overloaded.
19:39:43 <roshi> that's for sure
19:39:48 <roshi> those dudes are tireless
19:40:12 <kushal> I am ready to help, but getting the initial info is too difficult :(
19:40:17 <lsm5> kushal: roshi btw, could we have someone from releng directly interface with docker re: fedora 21 image, right now i'm sort of the middleman
19:40:20 <roshi> I can imagine
19:40:41 <kushal> lsm5, we will when koji will add those features.
19:40:54 <lsm5> kushal: ok, sounds good
19:41:08 <kushal> lsm5, I remember dgilmore was talking with the docker team for the same, and he mentioned their (docker) tooling is also broken.
19:41:20 <roshi> thanks for being the middleman in the mean time though, lsm5 :)
19:41:29 * oddshocks clicks
19:41:32 <lsm5> kushal: yup
19:41:36 <lsm5> roshi: sure thing :)
19:41:46 <oddshocks> roshi: Oh, no, I think we're just waiting on more info from releng
19:42:17 <roshi> ok, cool
19:42:18 <kushal> oddshocks, thanks for the initiative.
19:42:45 <roshi> ready for openfloor?
19:43:01 <oddshocks> sure thing
19:43:04 <roshi> #topic Open Floor
19:43:26 <roshi> I had one thing kinda related to the getting better documentation for cloud stuff
19:43:32 <roshi> anyone else have stuff?
19:43:33 <kushal> Good to see nightly builds started again.
19:43:48 <roshi> failed today though...
19:44:12 <kushal> Oh, let me check
19:44:40 <kushal> roshi, the koji build is yet to start, may be they will have some magic :)
19:45:47 <roshi> hopefully
19:46:14 <roshi> well, you've all heard me fighting to get a cloud image to build locally
19:46:33 <kushal> yeah
19:46:40 <roshi> which all started because I'm working on a patch to add dnf support to cloud-init, but need to roll a custom image to test it
19:46:41 <kushal> roshi, I will do that tomorrow
19:46:54 <rtnpro> Hi all
19:47:00 <roshi> hey rtnpro
19:47:15 <rtnpro> roshi, Hi
19:47:15 <kushal> roshi, first try with the standard cloud-init, if it works, then go for custom one :)
19:47:25 <kushal> rtnpro, the meeting is still on.
19:47:41 <rtnpro> I thought it's open floor
19:47:45 <roshi> and when I have my normal QA hat on, it's common to spin a live image locally with an updated package to test
19:48:07 <roshi> each of these tasks require some manual work to get things built
19:48:32 <dustymabe> rtnpro: it is open floor
19:48:35 <dustymabe> whats up
19:48:39 <roshi> so I was thinking about writing a tool where you basically say "build me an image with foo" and it handles all the building for you
19:48:44 <rtnpro> I wanted to find an entry point to start contributing to fedora-cloud and get my feet wet
19:48:45 <roshi> would this be useful to others?
19:49:10 <roshi> rtnpro: you can test the nightlies and report back results to the test matrices
19:49:13 <rtnpro> could some one direct me to some task that I can research/work on?
19:49:20 <roshi> that's a good start
19:49:29 <rtnpro> roshi, sounds good :)
19:49:34 <dustymabe> roshi: do you have link to some tests that can run
19:49:36 <roshi> or figuring out and writing up documentation for dockerfiles :)
19:49:40 <roshi> yeah
19:49:43 * roshi finds it
19:49:54 <dustymabe> rtnpro: do you know how to find the nightlies ?
19:50:01 <rtnpro> dustymabe, no
19:50:41 <kushal> Which reminds me that I will setup a tunir instance somewhere to run automated tests on nightlies.
19:50:47 <rtnpro> dustymabe, could you help me with link to the workflow process for testing the nightlies and where to find them?
19:50:57 <kushal> rtnpro, read my worknotes :)
19:51:03 <rtnpro> kushal, ok
19:51:08 <roshi> I'll help you out after the meeting rtnpro :)
19:51:20 <rtnpro> roshi, thanks, +1
19:51:22 <roshi> thoughts on the tool I suggested?
19:51:26 <roshi> anybody?
19:51:49 <roshi> I know gholms was wanting an easier way to roll custom cloud images for testing the packages he maintains
19:51:50 <kushal> rtnpro, also the tool you wanted, have you used imagefactory?
19:51:52 <dustymabe> roshi: is foo an rpm?
19:52:02 <roshi> yeah
19:52:06 <rtnpro> kushal, no
19:52:24 <kushal> roshi, then we can just install/update that rpm in an existing cloud image, correct?
19:52:30 <dustymabe> roshi: got it. I think it could be useful. I only wish I could work on it with you
19:52:41 <roshi> :D
19:52:43 <dustymabe> can't wait til I have more free time for all of these ideas
19:52:51 <roshi> and for that you get to do code reviews :p
19:53:03 <roshi> that would be the thought kushal
19:53:14 <roshi> so, let's say we find a bug in a nightly that blocks a release
19:53:30 <kushal> roshi, that is what I was doing with the help from your testcloud
19:53:36 <kushal> roshi, go ahead.
19:54:00 <roshi> with a tool like this, when the offending package gets updated, each of us (or one of us) can roll an updated image with the new package, verify the fix and get it into the next TC/RC request knowing the fix is there
19:54:19 <roshi> instead of waiting for the next days build to finish to know if the fix was actually a fix
19:55:01 <dustymabe> roshi: agreed.
19:55:13 <kushal> roshi, in case we want to roll a new image following the same path of the koji, then we will have to get that new rpm(s) into a repo (local or remote) and then build the image.
19:55:43 <roshi> yeah
19:55:56 <roshi> that's what I do currently with testing packages in a custom Live image
19:56:09 <kushal> roshi, correct.
19:56:15 <roshi> I have a local repo that I put the updated packages in, and build from a custom kickstart
19:56:29 <kushal> roshi, sounds just like me :)
19:56:38 <roshi> but I can't even get the cloud image to *build* for me right now
19:56:54 <roshi> and the only docs I've really found have been your worknotes :)
19:57:12 <kushal> roshi, I started writing it only for this reason.
19:57:27 <roshi> kushal: my thought is, testCloud makes it easy to boot images, now we need something that makes it easy to build images
19:57:40 <kushal> roshi,  I will fire a build tomorrow morning after I wake, do not want to stress out tonight.
19:57:54 <roshi> no need to stress out tonight :)
19:58:08 <kushal> roshi, imagefactory is that easy, only problem is that our repos change regularly
19:58:11 <roshi> I was just looking to get feedback if my approach and reasoning were sound to other people :)
19:58:43 <kushal> also the repo url(s) change based on the date/time we are in the release cycle
19:59:25 <roshi> yeah, there's a ton of moving parts
20:00:00 <kushal> roshi, this is only why I found it difficult to do as a simple command.
20:00:06 <kushal> too many variables.
20:00:13 <roshi> yeah
20:00:31 <roshi> I just want something to handle all those variables for me
20:01:06 <kushal> roshi, the only way I can find those, is by reading koji build results manually
20:01:16 <roshi> and writing docs for all this would be great for us as well as for upstream
20:01:27 <kushal> but that is also from the last build, not for the things coming.
20:01:40 <roshi> yeah
20:01:51 <roshi> there's a lot of exploration I need to do in order to fully grok it
20:02:06 <kushal> roshi, rel-eng is where we should put our head in.
20:02:16 <kushal> roshi, I am hoping to do it in the coming cycle.
20:02:28 <roshi> sounds good to me
20:02:32 <roshi> that's all I had :)
20:02:54 <kushal> roshi, i guess we can end the meeting now :)
20:02:58 <roshi> anybody have anything else?
20:03:05 <roshi> my thoughts exactly
20:03:09 * roshi sets the fuse
20:03:11 <roshi> 3...
20:03:28 <roshi> 2...
20:04:03 <roshi> 1...
20:04:10 <roshi> thanks for coming folks!
20:04:13 <roshi> #endmeeting