f18final-blocker-review-5
MINUTES

#fedora-bugzappers: f18final-blocker-review-5

Meeting started by tflink at 16:40:43 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 16:40:44)
  2. Introduction (tflink, 16:46:53)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 16:46:58)
    2. We'll be following the process outlined at: (tflink, 16:47:04)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 16:47:05)
    4. The bugs up for review today are available at: (tflink, 16:47:10)
    5. http://qa.fedoraproject.org/blockerbugs/current (tflink, 16:47:10)
    6. The criteria for release blocking bugs can be found at: (tflink, 16:47:17)
    7. https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (tflink, 16:47:17)
    8. https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria (tflink, 16:47:17)
    9. https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria (tflink, 16:47:17)
    10. 22 Proposed Blockers (tflink, 16:47:58)
    11. 12 Accepted Blockers (tflink, 16:47:58)
    12. 38 Proposed NTH (tflink, 16:47:58)
    13. 9 Accepted NTH (tflink, 16:47:58)
    14. 13 Proposed Blockers marked Ready for Discussion (tflink, 16:47:59)

  3. (883075) fedup upgrading is too quiet (tflink, 16:49:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=883075 (tflink, 16:49:38)
    2. Proposed Blocker, fedup-dracut, ASSIGNED (tflink, 16:49:38)
    3. AGREED: 883075 - AcceptedBlocker - Violates the following F18 final release criteria in spirit due to lack of user-facing progress information: "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using all officially recommended upgrade mechanisms..." (tflink, 16:54:00)

  4. (887236) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 3: ordinal not in range(128) (tflink, 16:54:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=887236 (tflink, 16:54:09)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:54:12)
    3. AGREED: 887236 - AcceptedBlocker - Violates the following F18 final release criterion for several well-used non-english languages: "The installer must be able to complete an installation using all supported interfaces" (tflink, 16:57:58)

  5. (886502) create grub.cfg even when not installing bootloader (tflink, 16:58:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886502 (tflink, 16:58:04)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:58:07)
    3. AGREED: 886502 - RejectedBlocker AcceptedNTH - This doesn't clearly violate any F18 release criteria but it would help multibooters if we generate the config during install w/o bootloader and this can't be fixed with a post-release update. A tested fix would be considered past freeze. (tflink, 17:03:02)

  6. (869841) attempts to resize ufs partitions (tflink, 17:03:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869841 (tflink, 17:03:08)
    2. Proposed Blocker, anaconda, POST (tflink, 17:03:08)
    3. http://www.fpaste.org/tRNH/raw/ (fenrus02, 17:07:47)
    4. AGREED: 869841 - RejectedBlocker AcceptedNTH - While this is a technical violation of the release criteria, it seems to be a bit too much of a corner case to justify blocking release for. However, it can't be fixed with an update post-release and a tested fix would be considered past freeze (tflink, 17:30:39)

  7. (875944) Shrink function in 'Reclaim space' dialog does not allow user to specify target size, automatically picks smallest possible size (tflink, 17:30:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=875944 (tflink, 17:30:55)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:36:28)
    3. AGREED: 875944 - AcceptedBlocker - Violates the following F18 final release criteria by making other installed OSs so small, they are practically unusable after a relatively short time: "The installer must be able to install into free space alongside an existing clean single-partition Windows installation and either install a bootloader which can boot into the Windows installation, or leave the Windows bootloader untouched and working" (tflink, 17:37:49)

  8. (885385) Strange race in livecd creation (tflink, 17:40:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885385 (tflink, 17:40:28)
    2. Proposed Blocker, livecd-tools, ON_QA (tflink, 17:40:28)
    3. AGREED: 885385 - RejectedBlocker AcceptedNTH - This doesn't cause compose failures every time and thus isn't enough to block release. However, getting reliable composes is important and a tested fix would be considered past freeze. (tflink, 17:46:58)

  9. (886647) Anaconda throws exception trying to setup network (tflink, 17:47:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886647 (tflink, 17:47:04)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:47:06)
    3. AGREED: 886647 - While potentially serious, there is not currently enough information to make a decision on blocker status. Will revisit when more information is available. (tflink, 17:52:23)

  10. (886061) core fedora repository error must be fatal, otherwise the upgraded system might be broken heavily (tflink, 17:52:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886061 (tflink, 17:52:35)
    2. Proposed Blocker, fedup, NEW (tflink, 17:52:37)

  11. (886705) live cd should include qemu-guest-agent package (tflink, 18:13:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886705 (tflink, 18:13:20)
    2. Proposed Blocker, spin-kickstarts, NEW (tflink, 18:13:20)
    3. AGREED: 886705 - RejectedBlocker AcceptedNTH - This doesn't clearly violate any of the F18 release criteria and thus is rejected as a blocker. However, the livecd cannot be updated post-release so a tested fix would be considered past freeze. (tflink, 18:26:46)

  12. (887363) cloud-init 0.7.1 change prevents creation of ec2-user (tflink, 18:27:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=887363 (tflink, 18:27:16)
    2. Proposed Blocker, cloud-init, ON_QA (tflink, 18:27:16)
    3. http://lists.fedoraproject.org/pipermail/cloud/2012-December/002038.html (nirik, 18:30:15)
    4. AGREED: 887363 - AcceptedBlocker - Violation of the following F18 final release criterion for EC2 images: "The release must boot successfully as Xen DomU with releases providing a functional, supported Xen Dom0 and widely used cloud providers utilizing Xen. This does not include any issues limited to the release functioning as Xen Dom0" (tflink, 18:36:17)

  13. (887539) FormatDestroyError: error wiping old signatures from /dev/sdb2: 1 (tflink, 18:36:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=887539 (tflink, 18:36:27)
    2. Proposed Blocker, anaconda, NEW (tflink, 18:36:30)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=876789 is the other bug (adamw, 18:38:59)
    4. AGREED: 887539 - We need more information on whether this is a dupe of #876789 before making a decision on blocker status. will re-visit later (tflink, 18:44:00)

  14. (885912) Resize of NTFS partition results in partition smaller than the filesystem, broken Windows install (tflink, 18:44:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885912 (tflink, 18:44:14)
    2. Proposed Blocker, anaconda, NEW (tflink, 18:44:16)
    3. AGREED: 885912 - AcceptedBlocker - Violation of the following F18 release criterion: "All known bugs that can cause corruption of user data must be fixed or documented at Common F18 bugs" (tflink, 18:52:18)

  15. (887357) workaround for for appliance creation in koji (tflink, 18:52:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=887357 (tflink, 18:52:28)
    2. Proposed Blocker, device-mapper-multipath, ASSIGNED (tflink, 18:52:28)
    3. AGREED: 887357 - AcceptedBlocker - Violates the following F18 final release criterion by blocking the creation of cloud images: "The release must boot successfully as Xen DomU with releases providing a functional, supported Xen Dom0 and widely used cloud providers utilizing Xen. This does not include any issues limited to the release functioning as Xen Dom0" (tflink, 18:55:46)
    4. https://admin.fedoraproject.org/updates/FEDORA-2012-20266/marble-4.9.4-2.fc18 (nirik, 19:00:25)

  16. (886329) fedmsg-0.6.3 is a broken dependency. (tflink, 19:01:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886329 (tflink, 19:01:50)
    2. Proposed NTH, fedmsg, MODIFIED (tflink, 19:01:50)
    3. AGREED: 886329 - AcceptedNTH - There is a desire to release a final frozen repo without dep issues, even if they don't affect the F18 media. A tested fix would be considered past freeze. (tflink, 19:09:01)

  17. (887990) 1:python-marble-4.9.4-1.fc18.x86_64 requires sip-api(8) >= 0:8.1 (tflink, 19:10:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=887990 (tflink, 19:10:34)
    2. Proposed NTH, marble, MODIFIED (tflink, 19:10:37)
    3. AGREED: 887990 - AcceptedNTH - There is a desire to release a final frozen repo without dep issues, even if they don't affect the F18 media. A tested fix would be considered past freeze. (tflink, 19:11:07)

  18. (874378) firewalld caused minimal install to grow substantially between Alpha and Beta TC7: firewalld deps are pretty heavy (tflink, 19:15:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=874378 (tflink, 19:15:20)
    2. Proposed NTH, firewalld, ON_QA (tflink, 19:15:22)
    3. AGREED: 874378 - AcceptedNTH - This reduces the dependencies on a minimal install so that cairo and X aren't pulled in for firewalld as requested by FESCo (tflink, 19:22:58)

  19. (885541) Renew-Subscription spam in /var/log/cups/access_log (tflink, 19:23:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885541 (tflink, 19:23:11)
    2. Proposed NTH, kde-print-manager, ON_QA (tflink, 19:23:11)
    3. AGREED: 885541 - AcceptedNTH - This is spamming logs on the KDE live image which could cause problems with overlays or ramdisks. A tested fix would be considered past freeze. (tflink, 19:26:34)

  20. (886734) Obsolete subpackage system-config-printer-kde in the F18 repository (tflink, 19:26:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886734 (tflink, 19:26:47)
    2. Proposed NTH, kdeadmin, ON_QA (tflink, 19:26:49)

  21. (872468) Thai font missing from installer environment (tflink, 19:30:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=872468 (tflink, 19:30:13)
    2. Proposed NTH, lorax, ON_QA (tflink, 19:30:13)
    3. AGREED: 872468 - AcceptedNTH - It's not good form to break a language in the installer. A tested fix would be considered past freeze. (tflink, 19:31:58)

  22. (886733) live images built with livecd-creator 18.13 have major SELinux problems (SELinux is preventing /usr/libexec/colord from 'write' accesses on the directory colord.) (tflink, 19:32:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886733 (tflink, 19:32:10)
    2. Proposed NTH, selinux-policy, MODIFIED (tflink, 19:32:12)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=886187 is also proposed as NTH (adamw, 19:37:26)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=873355 relates to xen (adamw, 19:39:23)
    5. AGREED: 886733 - AcceptedNTH - while not absolutely critical, it would make a positive difference in the livecds and is not entirely fixable post-release. A tested fix would be considered past freeze. (tflink, 19:39:39)

  23. Oversize issues for secondary DE spins (tflink, 19:40:34)
    1. Covers 887120 , 887991 , 853590 (tflink, 19:40:54)
    2. AGREED: In principle, we agree that oversize issues for secondary DE spins are accepted as NTH without explicit discussion for F18 (tflink, 19:42:58)

  24. (887996) liveinst fails in f18 Soas TC3 Could not open x display - no protocol specified (tflink, 19:44:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=887996 (tflink, 19:44:19)
    2. Proposed NTH, anaconda, NEW (tflink, 19:44:21)
    3. AGREED: 887996 - AcceptedNTH - This breaks install of SoaS which, as a secondary DE, is a NTH issue for F18 final. (tflink, 19:46:42)

  25. (877128) Ocaml tries to allocate a ridiculous amount of memory (tflink, 19:51:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=877128 (tflink, 19:51:56)
    2. ProposedNTH, ocaml, ON_QA (tflink, 19:51:56)
    3. AGREED: 877128 - We're not quite sure why this has to be fixed before release, will re-visit when there is more justification available (tflink, 20:04:34)

  26. Open Floor (tflink, 20:04:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886963 (adamw, 20:05:54)

  27. (886963) Update eucalyptus to 3.2 (tflink, 20:10:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=886963 (tflink, 20:10:14)
    2. Proposed NTH, eucalyptus, ON_QA (tflink, 20:10:14)
    3. AGREED: 886963 - RejectedNTH - While the packaging bug mentioned here would be enough for NTH, it would need to be separated out by itself instead of as part of a version upgrade for multiple components. Would re-consider for a separated out fix (tflink, 20:15:52)

  28. Open Floor (tflink, 20:15:59)
    1. Next blocker/NTH review meeting will be tomorrow, 2012-12-18 at 17:00 UTC (tflink, 20:17:18)


Meeting ended at 20:18:45 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. tflink (368)
  2. adamw (260)
  3. nirik (99)
  4. cmurf (79)
  5. kparal (71)
  6. jreznik (60)
  7. bugbot_ (33)
  8. fenrus02 (23)
  9. agrimm (14)
  10. jsmith (11)
  11. mkrizek (10)
  12. zodbot (9)
  13. nanonyme (5)
  14. pschindl (3)
  15. rdieter (1)
  16. satellit (1)
  17. satellit_e (1)


Generated by MeetBot 0.1.4.