f18final-blocker-review-3
MINUTES

#fedora-bugzappers: f18final-blocker-review-3

Meeting started by tflink at 17:13:22 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 17:13:22)
  2. Introduction (tflink, 17:16:12)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 17:16:18)
    2. We'll be following the process outlined at: (tflink, 17:16:23)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 17:16:23)
    4. The bugs up for review today are available at: (tflink, 17:16:29)
    5. http://qa.fedoraproject.org/blockerbugs/current (tflink, 17:16:29)
    6. note that due to the number of currently proposed blockers, the list is currently being filtered for bugs which are ready for discussion (tflink, 17:16:57)
    7. http://tflink.fedorapeople.org/blockerbugs/sorted/sortedBlockers.html (tflink, 17:17:23)
    8. The criteria for release blocking bugs can be found at: (tflink, 17:17:35)
    9. https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (tflink, 17:17:35)
    10. https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria (tflink, 17:17:35)
    11. https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria (tflink, 17:17:35)
    12. the current full list of blocker/nth bugs is at: (tflink, 17:18:04)
    13. 28 Proposed Blockers (tflink, 17:18:10)
    14. 14 Accepted Blockers (tflink, 17:18:10)
    15. 26 Proposed NTH (tflink, 17:18:10)
    16. 3 Accepted NTH (tflink, 17:18:10)
    17. the list of bugs ready for discussion is at: (tflink, 17:18:23)
    18. 16 Proposed Blockers deemed ready for discussion (tflink, 17:18:36)

  3. (885378) AttributeError: 'NoneType' object has no attribute 'name' (tflink, 17:19:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885378 (tflink, 17:19:26)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:19:28)
    3. AGREED: 885378 - AcceptedBlocker - Violates the following F18 final release criterion for reuse of encrypted LVM layouts: "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (tflink, 17:28:50)

  4. (885124) Notifications stays after clicking on 'x' button (tflink, 17:29:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885124 (tflink, 17:29:02)
    2. Proposed Blocker, gnome-shell, NEW (tflink, 17:29:02)
    3. AGREED: 885124 - RejectedBlocker AcceptedNTH - While this is a polish issue with the default interface, there are workarounds and it does not seem to be enough to block release over. Accepted as NTH for F18 final and a tested fix would be considered past freeze. (tflink, 17:40:11)

  5. (866887) the default keyboard layout isn't comfortable with the selected language (tflink, 17:40:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866887 (tflink, 17:40:24)
    2. Proposed Blocker, anaconda, POST (tflink, 17:40:26)
    3. it sounds like we are missing some info on this bug, will re-visit when more information is available (tflink, 17:45:07)

  6. (885641) partitioning: Continue says I don't have enough space, Done says I do (tflink, 17:45:44)
    1. ACTION: kparal to ask Vratislav about 866887 and present a summary on wednesday. also ping jreznik (kparal, 17:45:47)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=885641 (tflink, 17:45:47)
    3. Proposed Blocker, anaconda, NEW (tflink, 17:45:50)
    4. http://wiki.sugarlabs.org/go/File:Error_Msg-Disk_too_small.png also (satellit_, 18:08:15)
    5. AGREED: 885641 - AcceptedNTH - While this is a bad way for the installer to fail, it's not clear whether or not it's actually a blocker. Accepted as NTH, blocker status will be revisited when more info is available. A tested fix would be considered past freeze. (tflink, 18:10:55)

  7. (885090) Inconsistent locations of font files on UEFI systems (tflink, 18:11:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885090 (tflink, 18:11:06)
    2. Proposed Blocker, grub2, NEW (tflink, 18:11:06)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=859632 is one of them (tflink, 18:12:19)
    4. AGREED: 885090 - RejectedBlocker AcceptedNTH - This isn't serious enough by itself to warrent blocker status for F18 final but it would be nice to have correct fonts for release. A tested fix would be considered after freeze. (tflink, 18:29:28)

  8. (859632) gfxterm hangs when editing boot entries with large font (tflink, 18:29:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=859632 (tflink, 18:29:37)
    2. Proposed Blocker, grub2, ASSIGNED (tflink, 18:29:40)
    3. AGREED: 859632 - RejectedBlocker, AcceptedNTH - Even though this is an actual hang in grub, it is too much of a corner case to block release for. However, a tested fix would be considered after freeze. (tflink, 18:56:58)

  9. (880271) Wrong keyboard layout in initramdisk (tflink, 18:57:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=880271 (tflink, 18:57:15)
    2. Proposed Blocker, dracut, ASSIGNED (tflink, 18:57:16)
    3. AGREED: 880271 - AcceptedBlocker - Conditional violation of the following F18 final release criterion for non-US keymaps: "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using all officially recommended upgrade mechanisms. The upgraded system must meet all release criteria" (tflink, 19:03:33)

  10. (869584) ibus menu in kde panel does not work, disappears immediately (tflink, 19:03:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869584 (tflink, 19:03:42)
    2. Proposed Blocker, ibus, MODIFIED (tflink, 19:03:45)
    3. AGREED: 869584 - AcceptedBlocker - Conditional violation of the following F18 final release criterion for asian language users of KDE: "ll elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use" (tflink, 19:13:36)

  11. (885133) no notification when unmounting external HDDs and data are still not synced (tflink, 19:13:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885133 (tflink, 19:13:50)
    2. Proposed Blocker, gvfs, NEW (tflink, 19:13:52)
    3. AGREED: 885133 - AcceptedBlocker - Accepted due to conditional violation of the following F18 final release criteria for external hard drives: "All known bugs that can cause corruption of user data must be fixed or documented at Common F18 bugs" (tflink, 19:21:13)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=885147 (tflink, 19:21:35)
    5. Proposed Blocker, system-config-users, NEW (tflink, 19:21:38)
    6. AGREED: 885133 - RejectedBlocker AcceptedNTH - While this is a technical violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use", it could be fixed with an update, isn't likely to affect livecds and can be worked around by editing the user instead of the group. (tflink, 19:29:18)

  12. (885279) AttributeError: 'NoneType' object has no attribute 'startswith' (tflink, 19:29:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885279 (tflink, 19:29:31)
    2. Proposed Blocker, anaconda, NEW (tflink, 19:29:34)
    3. AGREED: 885279 - AcceptedBlocker - Violates the following F18 final release criterion for adding a swap partition in custom partitioning: "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (tflink, 19:32:52)

  13. (884896) DiskException: no partition specified (tflink, 19:32:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=884896 (tflink, 19:33:00)
    2. Proposed Blocker, anaconda, ON_QA (tflink, 19:33:02)
    3. AGREED: 884896 - We need more information on exactly what the trigger for this bug is before deciding on blocker status, will re-visit when there is more info (tflink, 19:38:31)

  14. (882722) 'KeyError: None' while trying to install F18 beta (tflink, 19:38:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=882722 (tflink, 19:38:47)
    2. Proposed Blocker, anaconda, ON_QA (tflink, 19:38:47)
    3. AGREED: 882722 - AcceptedBlocker - Conditional violation of the following F18 final release criterion for reuse of encrypted VGs: "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (tflink, 19:46:18)

  15. (884660) Anaconda fails to load on machines with multiple NICs (tflink, 19:46:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=884660 (tflink, 19:46:25)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 19:46:25)
    3. AGREED: 884660 - AcceptedBlocker - Conditional violation of the following F18 alpha release criterion for systems with multiple connected nics: "The installer must boot and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick ..." (tflink, 19:51:16)

  16. (885240) GRUB is installed despite Do not install bootloader being selected (tflink, 19:51:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885240 (tflink, 19:51:46)
    2. Proposed Blocker, anaconda, ON_QA (tflink, 19:51:49)
    3. AGREED: 885240 - AcceptedBlocker - The original report violates the following F18 final release criterion : "The installer must be able to install into free space alongside an existing clean single-partition Windows installation and either install a bootloader which can boot into the Windows installation, or leave the Windows bootloader untouched and working". The other issues are not affected by this and should be separated into new bugs. (tflink, 19:59:36)

  17. Open Floor (tflink, 19:59:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=885853 (kparal, 20:00:38)
    2. The next blocker review meeting is scheduled for 2012-12-12 @ 17:00 UTC (tflink, 20:05:45)


Meeting ended at 20:06:11 UTC (full logs).

Action items

  1. kparal to ask Vratislav about 866887 and present a summary on wednesday. also ping jreznik


Action items, by person

  1. jreznik
    1. kparal to ask Vratislav about 866887 and present a summary on wednesday. also ping jreznik
  2. kparal
    1. kparal to ask Vratislav about 866887 and present a summary on wednesday. also ping jreznik


People present (lines said)

  1. tflink (278)
  2. adamw (217)
  3. kparal (139)
  4. jreznik (58)
  5. Viking-Ice (57)
  6. buggbot (18)
  7. jskladan (7)
  8. mkrizek (5)
  9. zodbot (4)
  10. satellit_ (3)
  11. satellit (1)
  12. rbergeron (1)


Generated by MeetBot 0.1.4.