f18-alpha-blocker-review-4
MINUTES

#fedora-bugzappers: f18-alpha-blocker-review-4

Meeting started by tflink at 16:01:56 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 16:02:03)
  2. Introduction (tflink, 16:09:07)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 16:09:18)
    2. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 16:09:29)
    3. http://qa.fedoraproject.org/blockerbugs/current (tflink, 16:09:30)
    4. https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (tflink, 16:09:45)

  3. (841451) polkitd doesn't start in rawhide (tflink, 16:14:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=841451 (tflink, 16:14:14)
    2. Proposed Blockers, NEW (tflink, 16:14:14)
    3. AGREED: 841451 - RejectedBlocker (Alpha) - This appears to be an upgrade issue which is not alpha blocker material. Change to a proposed beta blocker. (tflink, 16:23:21)

  4. (850550) TypeError: verifyLocalPkg() takes exactly 1 argument (2 given) (tflink, 16:23:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=850550 (tflink, 16:23:34)
    2. Proposed Blockers, ON_QA (tflink, 16:23:36)
    3. AGREED: 850550 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following F18 alpha release criterion: "The installer must be able to complete package installation with the default package set for each supported installation method" (tflink, 16:30:06)

  5. (849998) KDE artwork in Spherical Cow still contains content from the previous release (tflink, 16:30:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849998 (tflink, 16:30:19)
    2. Proposed Blockers, ON_QA (tflink, 16:30:21)
    3. AGREED: 849998 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following F18 alpha release criterion: "The default Fedora artwork must either refer to the current Fedora release under development (Fedora 18), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development." (tflink, 16:32:50)

  6. (849982) The default Fedora 18 artwork refers to the previous release in F18 Alpha TC3 (tflink, 16:33:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849982 (tflink, 16:33:09)
    2. Proposed Blockers, NEW (tflink, 16:33:11)
    3. AGREED: 849982 - This is not a clear alpha blocker since it doesn't look exactly like the F17 theming. If the gnome theme is still F17, it will be accepted as a blocker. Will re-evaluate at the next blocker review meeting. (tflink, 16:44:02)

  7. (849967) firstboot fails to run partly due to /etc/sysconfig/i18n not being written by anaconda (tflink, 16:46:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849967 (tflink, 16:46:23)
    2. Proposed Blockers, POST (tflink, 16:46:26)
    3. http://linuxgrrl.com/fedora-ux/Projects/Anaconda/Prototypes/Screens/03-progress_hub2.svg (elad_laptop, 16:50:53)
    4. AGREED: 849967 - AcceptedBlocker - Accepted as a F18 alpha blocker due to violation of the F18 alpha release criterion: "In most cases, a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. The firstboot utility must be able to create a working user account" (tflink, 16:57:02)

  8. (850775) display managers aren't enabled after installation (tflink, 16:57:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=850775 (tflink, 16:57:17)
    2. Proposed Blockers, NEW (tflink, 16:57:17)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=850465 (nirik, 16:58:46)
    4. AGREED: 850775 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the release criterion: "After firstboot is completed and on subsequent boots, a system installed according to any of the above criteria must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied" (tflink, 17:04:55)

  9. (849395) UnicodeDecodeError: 'utf8' codec can't decode byte 0xb8 in position 0: invalid start byte (tflink, 17:08:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849395 (tflink, 17:08:24)
    2. Proposed Blockers, MODIFIED (tflink, 17:08:26)
    3. AGREED: 849395 - AcceptedBlocker - Accepted as F18 alpha blocker due to violation of the following release criterion for systems using ipv6: "The installer must be able to use at least one of the HTTP or FTP remote package source options" (tflink, 17:14:23)

  10. (849990) Apper: Authentization failed when trying to install updates (tflink, 17:14:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849990 (tflink, 17:14:36)
    2. Proposed Blockers, ASSIGNED (tflink, 17:14:38)
    3. AGREED: 849990 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following criteria for KDE systems: "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops" (tflink, 17:17:12)

  11. (847548) kernel BUG at include/linux/scatterlist.h:67 (vp_set / virtscsi_init / virtscsi_complete_free) kernel panics when virtio-scsi module is loaded (tflink, 17:19:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=847548 (tflink, 17:19:25)
    2. Proposed NTH, MODIFIED (tflink, 17:19:27)
    3. https://admin.fedoraproject.org/updates/kernel-3.6.0-0.rc2.git2.1.fc18,grub2-2.00-5.fc18,pesign-0.10-4.fc18 is the update (adamw, 17:27:02)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=850003 ? (adamw, 17:32:38)
    5. http://www.fpaste.org/ZUtO/ (jwb, 17:40:33)
    6. AGREED: 847548 - RejectedNTH - This bug requires a non-default VM setup in order to manifest and thus not qualified as alpha NTH. (tflink, 17:42:49)

  12. (850003) One machine is crashing when running kernel-PAE-3.6.0-0.rc2.git0.1.fc18.i686 but not kernel-PAE-3.6.0-0.rc1.git0.2.fc18.i686 (tflink, 17:43:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=850003 (tflink, 17:43:03)
    2. Proposed NTH, MODIFIED (tflink, 17:43:06)
    3. AGREED: 850003 - AcceptedNTH - Bare metal crashes on boot are bad and would be nice to avoid. Hardware isn't obscure, many people could be affected. (tflink, 17:58:44)

  13. (847693) repoclosure failure on 18 Alpha TC2 DVDs (pion-net) (tflink, 17:59:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=847693 (tflink, 17:59:59)
    2. Accepted Blockers, ON_QA (tflink, 17:59:59)
    3. an update is available that should fix this bug, it needs karma and to be pulled in to tc4 (tflink, 18:01:04)

  14. (847694) repoclosure failure on 18 Alpha TC2 DVDs (shotwell) (tflink, 18:01:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=847694 (tflink, 18:01:53)
    2. Accepted Blockers, NEW (tflink, 18:01:53)
    3. https://admin.fedoraproject.org/updates/FEDORA-2012-12406/shotwell-0.12.3-5.fc18 (adamw, 18:03:46)
    4. This bug doesn't tell us anything that #844510 doesn't already say and there is an update available to fix that bug. Closing as dupe of #844510 (tflink, 18:05:52)

  15. (847683) repoclosure failure on 18 Alpha TC3 DVDs (fatrat) (tflink, 18:06:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=847683 (tflink, 18:06:34)
    2. Accepted Blockers, ON_QA (tflink, 18:06:34)
    3. update was submitted to fix this bug but didn't actually fix it. Update has been unpushed, still waiting for fix. (tflink, 18:08:52)

  16. (848641) Fedora 18 Alpha TC2 fails to boot from USB stick (written by livecd-iso-to-disk) (tflink, 18:09:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=848641 (tflink, 18:09:08)
    2. Accepted Blockers, NEW (tflink, 18:09:11)
    3. Some progress has been made, anaconda-dracut is currently suspected as being the problem. Waiting for more analysis and hopefully a fix since none of the supported USB media creation methods are currently working. (tflink, 18:10:28)

  17. (848803) Root password is not set due to missing authconfig (tflink, 18:14:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=848803 (tflink, 18:14:50)
    2. Accepted Blockers, MODIFIED (tflink, 18:14:50)
    3. This should be fixed, kickstart install needs verification that root password is set correctly before closing (tflink, 18:16:30)

  18. (844510) FTBFS in Rawhide with gphoto 2.5.0 (tflink, 18:17:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=844510 (tflink, 18:17:12)
    2. Accepted Blockers, ON_QA (tflink, 18:17:12)
    3. FTBFS issue has been fixed and an update is available. Needs karma before it's pulled in to TC4 (tflink, 18:17:47)

  19. (849118) firstboot doesn't show up in LXDE (tflink, 18:18:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849118 (tflink, 18:18:07)
    2. Accepted Blockers, POST (tflink, 18:18:07)
    3. patch for anaconda has been posted, waiting for review. (tflink, 18:19:42)

  20. (840179) Latest grub2 update broke "system" theme (tflink, 18:19:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=840179 (tflink, 18:19:57)
    2. Accepted Blockers, ON_QA (tflink, 18:19:58)
    3. Fix is available, update needs karma before being pulled in to TC4 (tflink, 18:20:35)

  21. (849012) IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-p2p1' (tflink, 18:20:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849012 (tflink, 18:20:49)
    2. Accepted Blockers, MODIFIED (tflink, 18:20:51)
    3. It's unclear whether or not this issue will be fully fixed with anaconda-18.7-1, will need testing when new build is available or clarification from anaconda devs (tflink, 18:24:57)

  22. (849152) anaconda doesn't use DVD repo (tflink, 18:25:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849152 (tflink, 18:25:10)
    2. Accepted Blockers, MODIFIED (tflink, 18:25:10)
    3. should be fixed with anaconda-18.7-1. Will need testing and karma once a new build is available (tflink, 18:25:40)

  23. (849250) Not setting up a root password makes non-desktop installs impossible to access (tflink, 18:26:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849250 (tflink, 18:26:13)
    2. Accepted Blockers, NEW (tflink, 18:26:16)
    3. ACTION: adamw to poke anaconda team about 849250 (adamw, 18:27:25)
    4. There hasn't been much movement on this yet, anaconda devs may still be discussing potential solutions, will ask for update (tflink, 18:27:52)

  24. (849667) Bugreporting from anaconda doesn't work as expected (tflink, 18:28:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849667 (tflink, 18:28:07)
    2. Accepted Blockers, ON_QA (tflink, 18:28:07)
    3. an update to python-meh should fix this, needs testing and karma so that it can be pushed to stable (tflink, 18:29:35)

  25. (849070) Anaconda's bug reporter doesn't work (tflink, 18:29:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=849070 (tflink, 18:29:51)
    2. Accepted Blockers, MODIFIED (tflink, 18:29:51)
    3. patch has been submitted to fix this issue, waiting for it to be pulled into anaconda before it can be re-tested and karma-ed (tflink, 18:30:35)

  26. Open Floor (tflink, 18:31:02)
    1. f18 alpha blocker review meeting #5 will be on 2012-08-29 @ 16:00 UTC if alpha slips (tflink, 18:46:44)


Meeting ended at 18:47:06 UTC (full logs).

Action items

  1. adamw to poke anaconda team about 849250


Action items, by person

  1. adamw
    1. adamw to poke anaconda team about 849250


People present (lines said)

  1. tflink (299)
  2. adamw (137)
  3. jreznik (67)
  4. elad_laptop (55)
  5. nirik (50)
  6. jwb (21)
  7. mkrizek (20)
  8. bugb0t (14)
  9. buggbot (10)
  10. kparal (10)
  11. zodbot (9)
  12. rbergeron (9)
  13. maxamillion (6)
  14. aspratyush (1)


Generated by MeetBot 0.1.4.