f17-alpha-blocker-review-2
LOGS
17:01:24 <tflink> #startmeeting F17-Alpha-Blocker-Review-2
17:01:24 <zodbot> Meeting started Fri Feb  3 17:01:24 2012 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:25 * adamw sends in the adamw-bot
17:01:37 <tflink> #meetingname F17-Alpha-Blocker-Review-2
17:01:37 <zodbot> The meeting name has been set to 'f17-alpha-blocker-review-2'
17:01:37 * nirik is lurking if he can assist with anything.
17:01:43 <tflink> #topic roll call
17:01:58 <tflink> so we have a mechanized adamw?
17:03:55 <adamw> i-would-like-some-tea-please
17:04:13 <tflink> no tea for you!
17:04:53 * cpuobsessed is his first meeting w00t!
17:04:56 <adamw> exterminate
17:05:14 <adamw> cpuobsessed: don't worry, your excitement will soon turn to mind-numbing boredom.
17:05:30 <tflink> adamw: you're not supposed to scare off new people!
17:05:47 <cpuobsessed> huh what?
17:05:59 <adamw> don't worry, we're just kidding
17:06:39 <tflink> pschindl: you here for some blocker bug review?
17:06:52 * pschindl is here
17:07:07 * cpuobsessed should have reviewed the blockers
17:07:13 <tflink> cool, lets get started then
17:07:17 <pschindl> tflink: I just want to help :)
17:07:30 <tflink> #topic Introduction
17:07:47 <tflink> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:07:59 <tflink> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:08:10 <tflink> #link https://fedoraproject.org/wiki/Current_Release_Blockers
17:08:20 <tflink> #info 3 Proposed Blockers
17:08:20 <tflink> #info 1 Proposed NTH
17:08:20 <tflink> #info 1 Accepted Blocker
17:08:34 <tflink> unless there are objections, let's dive into the proposed blockers
17:09:23 <tflink> #topic (772878) RuntimeError: maximum recursion depth exceeded
17:09:23 <tflink> #link http://bugzilla.redhat.com/show_bug.cgi?id=772878
17:09:23 <tflink> #info Proposed Blocker, ASSIGNED
17:09:24 <buggbot> Bug 772878: urgent, unspecified, ---, dlehman, ASSIGNED, RuntimeError: maximum recursion depth exceeded
17:09:34 <bcl> oh, here we go
17:09:47 <tflink> sounds like this is fixed in anaconda-17.5?
17:10:11 <adamw> yes, it should be
17:10:19 <tflink> sounds like a pretty clear blocker, though
17:10:20 <adamw> i'll have to reconfirm with the tc1 images
17:10:31 <tflink> The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media
17:10:53 <tflink> proposed #agreed - 772878 - AcceptedBlocker - The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media
17:10:58 <adamw> yeah, it feels like one - dead crash early in install
17:11:00 <adamw> ack
17:11:01 <tflink> ack/nak/patch?
17:11:17 <tflink> cpuobsessed: if you have any questions about the process, feel free to ask
17:11:47 <pschindl> ack
17:11:56 * satellit_ http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#Fedora-17-Nightly-20120202.09-i686-Live-soas has anaconda-17.5-1.fc17.i686  and it installs fine now
17:11:57 <cpuobsessed> ack
17:12:11 <tflink> #agreed - 772878 - AcceptedBlocker - The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media
17:12:21 <tflink> #topic (787234) memtest86+ boot menu option doesn't work
17:12:21 <tflink> #link http://bugzilla.redhat.com/show_bug.cgi?id=787234
17:12:21 <tflink> #info Proposed Blocker, NEW
17:12:21 <cpuobsessed> i probably have the oldest system (FX-60, nforce4)
17:12:22 <buggbot> Bug 787234: unspecified, unspecified, ---, mgracik, NEW, memtest86+ boot menu option doesn't work
17:12:45 <cpuobsessed> i haven't seen memtest appear in any boot menu
17:12:59 <adamw> cpuobsessed: it's there when you install
17:13:03 <adamw> not after install
17:13:10 <tflink> oh, I forgot to ask if anyone would be willing to play secretary
17:13:14 <adamw> i'll do it
17:13:43 <tflink> adamw: thanks
17:13:54 <robatino> i know this test (memtest) will probably change to final level but it's alpha at the moment
17:14:06 <tflink> does this hit any criteria?
17:14:08 <pschindl> there is only testcase for this, but no criterion.
17:14:23 <pschindl> there is proposal for final criterion
17:14:40 * tflink needs to catch up on test@ mail
17:14:51 * jskladan is here!
17:14:53 <tflink> I think that I'm -1 blocker on this, then
17:14:55 <jskladan> sorry for teh delay
17:14:58 <adamw> right, we have a proposed final criterion for this one
17:15:08 <adamw> so i'm -1 alpha blocker, we could re-propose it as a final blocker
17:15:11 <tflink> jskladan: now the group is complete and we can get started!
17:15:15 <adamw> hi jskladan
17:15:22 <adamw> tflink: hehe
17:15:29 <pschindl> -1 alpha blocker +1 final blocker
17:15:31 <cpuobsessed> i've seen it on special distros, but not any of the main distros (slack, ubuntu, etc.)
17:15:40 * tflink is wondering about nth
17:15:50 <tflink> nvm
17:16:08 <adamw> hum, i'd probably want to see the fix
17:16:16 <adamw> but it doesn't smell like a great nth to me
17:16:26 <adamw> too fragile to poke the boot menu during affreeze
17:16:28 <tflink> proposed #agreed - 787234 - RejectedBlocker - memtest is a proposed criterion for final, not alpha. Re-propose as final blocker if that criterion is accepted
17:16:35 <adamw> ack
17:16:38 <pschindl> ack
17:16:45 <tflink> adamw: yeah, it took me a minute to think it through fully
17:16:59 <robatino> the test matrix should be updated to show it as final level
17:17:21 <cpuobsessed> ack
17:17:22 <tflink> robatino: would you mind taking care of that?
17:17:30 <tflink> #agreed - 787234 - RejectedBlocker - memtest is a proposed criterion for final, not alpha. Re-propose as final blocker if that criterion is accepted
17:17:31 <robatino> tflink: ok, easy change
17:17:59 <tflink> #action robatino to update test matrix to show memtest as applying to final
17:17:59 <adamw> robatino: tflink: pschindl is working on that
17:18:02 <tflink> robatino: thanks
17:18:13 <tflink> oh
17:18:16 <tflink> #undo
17:18:16 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1fff0ad0>
17:18:17 <adamw> no biggie
17:18:31 <tflink> #action pschindl to update test matrix to show memtest as applying to final
17:18:44 <tflink> #topic (785808) dracut Warning: "/dev/disk/by-label/Fedora\x2017-Alpha\x20i386" does not exist
17:18:47 <tflink> #link http://bugzilla.redhat.com/show_bug.cgi?id=785808
17:18:48 <buggbot> Bug 785808: unspecified, unspecified, ---, dgilmore, NEW, dracut Warning: "/dev/disk/by-label/Fedora\x2017-Alpha\x20i386" does not exist
17:18:50 <tflink> #info Proposed Blocker, NEW
17:19:13 <tflink> oddly enough, I don't see this in the usrmove boot isos I've been building
17:19:57 <adamw> has anyone tried tc1 DVD yet?
17:20:03 <adamw> as described it's clearly a blocker, though
17:20:07 <tflink> but it seems to hit The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media
17:20:15 <adamw> yup
17:20:28 <tflink> proposed #agreed - 785808 - AcceptedBlocker - The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media
17:20:52 * tflink just downloaded TC1, hasn't done anything with it yet
17:21:16 <tflink> ack/nak/patch?
17:21:29 <pschindl> ack
17:21:42 <adamw> ack
17:21:47 <adamw> with a note that we need to test tc
17:21:48 <adamw> 1
17:21:56 <jskladan> +1 & ack
17:22:05 <tflink> proposed #agreed - 785808 - AcceptedBlocker - The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media - needs retesting with F17 Alpha TC1
17:22:18 <tflink> #agreed - 785808 - AcceptedBlocker - The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media - needs retesting with F17 Alpha TC1
17:22:35 <robatino> i don't see it with the TC1 DVDs
17:22:39 <cpuobsessed> i'll be trying tc1 this weekend
17:22:40 <tflink> ok, that's all of the proposed blockers, on to the proposed NTH
17:22:45 <tflink> #topic (785815) dracut Warning: dracut: FATAL: No or empty root= argument
17:22:48 <tflink> #link http://bugzilla.redhat.com/show_bug.cgi?id=785815
17:22:49 <buggbot> Bug 785815: unspecified, unspecified, ---, crobinso, NEW, dracut Warning: dracut: FATAL: No or empty root= argument
17:22:51 <tflink> #info Proposed NTH, NEW
17:23:48 * tflink is wondering if this is beta
17:24:44 <adamw> looking through the comments, it doesn't seem like a great fit for nth or blocker
17:25:02 <cpuobsessed> edge case?
17:25:09 <tflink> is this only a problem with virt-install?
17:25:15 <adamw> it's really kind of a virt-install enhancement request, and virt-install isn't something that's 'nth-sensitive' like anaconda
17:25:24 <jskladan> tflink: imho yes
17:25:39 <tflink> the only other factor is rats_sanity and other like tools that rely on firt-install
17:25:46 <tflink> virt-install
17:25:52 <cpuobsessed> has virt-install been updated since 0127?
17:26:02 <tflink> but I'm not sure that's enough to make it blocker or nth
17:26:14 <adamw> brb, package delivery
17:26:17 <cpuobsessed> push back to beta?
17:26:29 <tflink> I'm thinking more about reject
17:26:37 <bcl> I'm fairly sure this was normal for pre-F16
17:26:54 <bcl> F16 'worked' because the 2 stages were in one big file.
17:27:19 <tflink> c10 makes it sound like the situation might change with wwoods' rewrite of the anaconda arg handling, though
17:27:56 <tflink> -1 nth
17:28:02 <cpuobsessed> since #785808 is accepted, all platforms would include vm?
17:28:41 <tflink> cpuobsessed: not sure I'm following your argument
17:29:00 <bcl> tflink: I don't think were not going to require root=
17:29:11 <cpuobsessed> the install must boot and run on all primary arch, isn't a vm an arch?
17:29:21 <cpuobsessed> or is vm not considered a primary arch?
17:29:35 <tflink> cpuobsessed: vms are more beta material
17:29:41 <cpuobsessed> is this bug preventing installing on a vm
17:29:43 <bcl> cpuobsessed: it does, if you use the iso. this is a specific problem when using vmlinuz+initrd, you need the root fs too.
17:29:59 <bcl> I'm -1
17:29:59 <tflink> and it doesn't prevent install on VMs, just messes with virt-install
17:30:11 <cpuobsessed> aight, -1
17:30:21 <pschindl> -1 NTH for m
17:30:25 <pschindl> me
17:30:27 <jskladan> cpuobsessed: IMHO difference is, that (IIUIC) the 785815 is triggered just by using virt-install
17:30:34 * jskladan is with the crowd
17:30:45 <adamw> ack
17:30:53 <tflink> proposed #agreed - 785815 - RejectedNTH - This is a feature request for virt-install and is a bit too much of a corner case for NTH
17:30:56 <cpuobsessed> thanks for the clarification
17:31:08 <cpuobsessed> ack
17:31:09 <pschindl> ack
17:31:10 <jskladan> ack
17:31:17 <tflink> #agreed - 785815 - RejectedNTH - This is a feature request for virt-install and is a bit too much of a corner case for NTH
17:31:17 <adamw> yeah, the key point is it's only special tools, not regular installs.
17:31:34 <tflink> wow, already through all of the proposed bugs
17:31:40 <tflink> and 1 accepted blocker
17:31:47 <tflink> #topic (754850) Some systems won't boot off GPT disks if the protective MBR entry isn't flagged bootable
17:31:50 <tflink> #link http://bugzilla.redhat.com/show_bug.cgi?id=754850
17:31:51 <buggbot> Bug 754850: unspecified, unspecified, ---, anaconda-maint-list, NEW, Some systems won't boot off GPT disks if the protective MBR entry isn't flagged bootable
17:31:53 <tflink> #info Accepted Blocker, NEW
17:32:12 <tflink> looks like there hasn't been any movement on this since last week
17:32:23 <adamw> yeah. bcl, is this getting implemented?
17:32:41 <tflink> was there any conclusion on how to fix this (if we're going to)?
17:32:58 <adamw> well, it's not really a 'how' question
17:33:01 <bcl> adamw: yep. built new parted and pyparted yesterday.
17:33:22 <adamw> it's just...something the anaconda team has to change, there's no 'design' required
17:33:24 <tflink> cool, sounds like it'll be ready for testing ~ TC2, then
17:33:29 <bcl> the only question now is do we always set boot on GPT or do a whitelist like we do for switching back to msdos.
17:33:42 <adamw> alright, not much to worry about i guess
17:33:47 <bcl> tflink: I still need to fix anaconda.
17:34:11 <bcl> 'm leaning towards always setting boot on GPT unless that becomes a problem.
17:34:11 <tflink> #info fix process has been started, still waiting for changes in anaconda
17:35:45 <tflink> bcl: anything need to be done on our end for a fix? It sounds like there isn't anything
17:36:07 <bcl> no
17:36:25 <tflink> alrighty then, that's all the bugs we have to review
17:36:36 * tflink thinks that this might be the shortest blocker review meeting ever
17:36:42 <tflink> #topic open floor
17:36:46 <adamw> i'm scared
17:36:47 <bcl> groovy.
17:36:49 <tflink> anything that I missed?
17:36:54 <adamw> there must be!
17:36:59 <adamw> it's only 9:36!
17:37:02 <cpuobsessed> guess i started on a good meeting?
17:37:02 <adamw> something is terribly wrong!
17:37:04 <tflink> adamw: yeah, I didn't say anything earlier for fear of jinx
17:37:04 <adamw> :P
17:37:06 <adamw> cpuobsessed: yeah
17:37:15 <robatino> need several bugs for repoclosure and file conflicts problems in TC1 - see https://lists.fedoraproject.org/pipermail/test/2012-February/105381.html
17:37:34 <cpuobsessed> why is the iso only 2.4Gb?
17:37:35 <robatino> i'm not sure what components to file under so someone else please do it
17:37:37 <adamw> robatino: yeah, we'll look into that
17:37:43 <adamw> cpuobsessed: we're not sure why the size is smaller
17:38:06 <robatino> cpuobsessed: i found that the libreoffice-langpack* packages were gone and that seems to account for about half of the shrinkage
17:38:09 <tflink> cpuobsessed: I think it has something to do with libreoffice langpacks but I could be remembering wrong
17:38:21 <tflink> and robatino beat me to it :)
17:38:42 <tflink> any volunteers to file the repoclosure bugs?
17:39:17 <adamw> i'll look into those
17:39:37 <tflink> adamw: thanks
17:40:01 <tflink> if there are no other issues, I'll set the fuse for ~ 5 min
17:40:25 <cpuobsessed> time to clear the DVD-RW and reburn
17:40:47 <tflink> #info Fedora 17 Alpha Blocker Bug Review #3 - 2012-02-10 @ 17:00 UTC
17:43:26 <adamw> oh hey
17:43:30 <adamw> i'm just gonna file a new blocker
17:43:33 <adamw> gimme 2 mins and we can review it
17:43:42 <jskladan> :)
17:43:48 <tflink> adamw: you just made it before the fuse
17:45:44 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=787261
17:45:45 <buggbot> Bug 787261: unspecified, unspecified, ---, tcallawa, NEW, Fedora 17 Alpha TC1 still has all F16 artwork
17:46:25 <tflink> #topic (787261) Fedora 17 Alpha TC1 still has all F16 artwor
17:46:25 <tflink> #link http://bugzilla.redhat.com/show_bug.cgi?id=787261
17:46:25 <tflink> #info Proposed Blocker, NEW
17:46:26 <buggbot> Bug 787261: unspecified, unspecified, ---, tcallawa, NEW, Fedora 17 Alpha TC1 still has all F16 artwork
17:46:29 <cpuobsessed> can't wait to see what a "Beefy Miracle" artwork will be
17:46:37 <adamw> heh
17:46:42 <tflink> seems like a clear blocker to me
17:46:43 <adamw> not sure if that's the right component, but the bug's clear enough
17:46:48 <bcl> aren't we supposed to wait until the last second to update artwork ;)
17:46:56 <adamw> bcl: oh yes, that's right ;)
17:47:25 <tflink> I thought that's why we added the criteria - so that wouldn't happen
17:47:25 <cpuobsessed> push to beta
17:47:26 <pschindl> there is final criterion for this, isn't it?
17:47:33 <tflink> pschindl: alpha criteria
17:47:34 <jskladan> pschindl: alpha
17:47:39 <tflink> The default Fedora artwork must either refer to the current Fedora release under development (Fedora 17), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development. This includes artwork used in the installer, graphical bootloader menu, firstboot, graphical boot, graphical login and desktop background.
17:47:40 <jskladan> #19
17:47:49 <adamw> at alpha, there's required to be at least placeholder artwork, to avoid confusion
17:47:52 <pschindl> jskladan: thx
17:47:57 <adamw> at final, the actual final artwork should be in
17:47:59 <tflink> proposed #agreed - 787261 - AcceptedBlocker - The default Fedora artwork must either refer to the current Fedora release under development (Fedora 17), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development. This includes artwork used in the installer, graphical bootloader menu, firstboot, graphical boot, graphical login and desktop background.
17:48:00 <bcl> I like that.
17:48:08 <pschindl> ack :)
17:48:10 <jskladan> ack
17:48:12 <adamw> otherwise we get people saying 'i downloaded f17 alpha but it says it's f16!'
17:48:17 <adamw> ack
17:48:20 <tflink> #agreed - 787261 - AcceptedBlocker - The default Fedora artwork must either refer to the current Fedora release under development (Fedora 17), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development. This includes artwork used in the installer, graphical bootloader menu, firstboot, graphical boot, graphical login and desktop background.
17:48:45 <tflink> any other new blockers?
17:49:15 <pschindl> If Kamil was here, he would find some :)
17:49:31 <tflink> but those can wait for next week :)
17:49:36 <tflink> #topic open floor
17:49:48 * tflink re-sets the fuse to ~ 5 minutes
17:50:40 <jskladan> tflink: http://matroid.org/flux/no_jokes_please.jpg
17:51:27 <adamw> i like the 'no kidnapping' icon
17:51:29 <tflink> jskladan: crap, am I in trouble for lighting the fuse?
17:51:33 <adamw> er, 'no hijacking'
17:51:57 <adamw> it's like, 'man, I was all set to hijack this plane, i have my guns and my bombs all ready, but they have a 'no hijacking' sign! Curses!'
17:52:10 <jskladan> hehe
17:52:39 <tflink> because telling people something isn't allowed ALWAYS works
17:52:59 * tflink is keeping with the "no jokes please!" mentality
17:53:03 <tflink> :-D
17:53:32 <tflink> eh, close enough to 5 minutes
17:53:40 * tflink will send out minutes shortly
17:53:47 <tflink> thanks for coming, everyone!
17:53:49 <tflink> #endmeeting