f-15-beta-blocker-review
LOGS
17:00:17 <jlaska> #startmeeting Fedora 15 Beta blocker review
17:00:17 <zodbot> Meeting started Fri Apr  8 17:00:17 2011 UTC.  The chair is jlaska. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:24 <jlaska> #meetingname f-15-beta-blocker-review
17:00:24 <zodbot> The meeting name has been set to 'f-15-beta-blocker-review'
17:00:29 <jlaska> #topic Roll Call
17:00:41 <jlaska> who is ready to walk the bug list of dooooom?
17:01:03 * tflink is scared
17:01:07 * brunowolff is here
17:01:08 <jlaska> heh
17:01:11 * nirik is lurking. Ping if needed.
17:01:15 <jlaska> nirik: okay
17:02:17 <jlaska> clumens is out today, and I suspect bcl is knee deep working one of the issues w/ adamw
17:02:59 <jlaska> let's see ... anyone else?  dgilmore, rbergeron?
17:03:04 <adamw> yo
17:03:07 * dgilmore is here
17:03:15 <adamw> i'm still trying to clarify a couple of things here
17:03:26 * bcl waves
17:03:29 <jlaska> Hey gang
17:03:51 <jlaska> adamw: understood
17:04:11 <jlaska> okay, let's get started ... this shouldn't be too long </famous_last_words>
17:04:32 <jlaska> #topic Why are here?
17:04:33 <adamw> er, it may be. :)
17:04:38 <jlaska> true
17:04:44 <jlaska> one never knows with these
17:04:51 <jlaska> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:04:55 <adamw> no, i mean, we have some thorny issues.
17:04:58 <adamw> anyway, we'll see.
17:05:11 <jlaska> yup
17:05:31 <jlaska> #link https://fedoraproject.org/wiki/Current_Release_Blockers
17:06:00 <jlaska> #info We are here to evaluate whether proposed blockers meet the Beta release criteria, and to review accepted blocker bugs for progress/issues
17:06:12 <jlaska> Any preference on order today?
17:06:17 <jlaska> proposed blockers first?
17:06:31 <adamw> sure.
17:07:06 <jlaska> #topic https://bugzilla.redhat.com/693588
17:07:20 <jlaska> #info NetworkManager applet cannot scroll the list of wireless networks
17:07:39 <adamw> note, we already took a fix for this into beta rc1
17:07:39 <jlaska> I think this is a moot point, since the MODIFIED version is now in the beta RC1
17:07:43 * jlaska confirms
17:08:12 <jlaska> indeed ... so I gather we can mark this whiteboard:AcceptedNTH at this time
17:08:17 <adamw> but if we want to confirm the decision...this makes it tough to get connected if you have a lot of wireless networks visible, and yours isn't in the first page of results.
17:08:25 <adamw> er. AcceptedBlocker?
17:08:37 <jlaska> err, yes sorry
17:08:42 <brunowolff> I think NTH. Most people won't have that many visible networks.
17:09:00 <adamw> brunowolff: try living in an apartment block.
17:09:01 <bcl> How many?
17:09:05 <seifried> you ever go to a coffee shop or any other wifi crowded area like an apartment?
17:09:06 <adamw> bcl: varies with screen resolution.
17:09:16 <adamw> also, try using a system with a small screen.  =)
17:09:22 <bcl> I live in the woods and I've got 5 (only 2 are mine)
17:10:02 <jlaska> did this prevent connecting to a wireless network using NM?
17:10:08 <jlaska> or did it make it annoying?
17:10:17 <adamw> jlaska: i couldn't find a GUI workaround
17:10:30 <adamw> jlaska: you can use the workaround provided for hidden networks and manually type the SSID
17:10:40 <rbergeron> sorry folks :)
17:10:43 <adamw> hey robyn
17:10:54 <jlaska> hi rbergeron
17:10:57 <adamw> anyway, let's not argue about it TOO long, since the fix is in already and it's kinda academic
17:11:00 <jlaska> yup
17:11:01 * rbergeron was on the phone with hotels in vegas about a you-know-what-con, sorry :)
17:11:02 <adamw> if you just want to go with NTH to keep it short, whatever
17:11:14 <jlaska> "The installed system must be able to download and install updates with yum and PackageKit "
17:11:25 <jlaska> adamw: ... is the Alpha criteria you are suggesting for this?
17:11:36 <adamw> jlaska: yeah, the usual implied network criteria.
17:11:39 <jlaska> right
17:11:51 <adamw> though maybe we should add an explicit network criterion just to make it clear...
17:12:01 <jlaska> I'm +0 on Blocker ... but like we said, it's not a big issue since the fix is already
17:12:04 <jlaska> included ... so ...
17:12:26 <adamw> rbergeron: i've told you before, organize your furrycons in your own PRIVATE time!
17:12:50 <adamw> everyone seems to be happy with nth so let's just do that.
17:12:55 <jlaska> proposed #agreed 693588 - AcceptedBlocker for Beta.  Issue already fixed in RC1, made it difficult to connect to wireless network in certain situations
17:12:59 <jlaska> ack/nak/patch
17:13:09 <tflink> ack
17:13:15 <rbergeron> adamw: sorry, sorry :)
17:13:23 <brunowolff> +0
17:13:34 <jlaska> #idea Add explicit requirement to release criteria for network enablement
17:13:38 <rbergeron> ack
17:13:42 <adamw> ack
17:13:56 <jlaska> #agreed 693588 - AcceptedBlocker for Beta.  Issue already fixed in RC1, made it difficult to connect to wireless network in certain situations
17:14:01 <jlaska> #topic https://bugzilla.redhat.com/692573
17:14:13 <jlaska> #info SELINUX=disabled in /etc/selinux/config causes failure to boot; libselinux lies to systemd about SELinux state
17:14:54 <jlaska> "Based on developments in bug #692436, it was determined that the failure to
17:14:55 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=692436 urgent, unspecified, ---, mgrepl, CLOSED ERRATA, Incorrect SELinux labelling of new /run directory prevents system boot
17:14:57 <jlaska> boot in this bug is in fact separate from the failure to boot in the other bug. Thus, this bug should be a beta blocker after all."
17:15:00 <jlaska> from our good friend adamw
17:15:17 <adamw> let's not the 'CLOSED ERRATA' here
17:15:22 <adamw> s/not/note/
17:15:32 <jlaska> right
17:16:08 <jlaska> proposed #agreed 692573 - AcceptedBlocker for beta.  Issue fixed in latest libselinux already included in RC1
17:16:12 <jlaska> ack/nak/patch
17:16:23 <rbergeron> ack
17:16:26 <brunowolff> +1
17:16:32 <tflink> ack
17:16:44 <jlaska> thanks ... good enough
17:16:46 <jlaska> #agreed 692573 - AcceptedBlocker for beta.  Issue fixed in latest libselinux already included in RC1
17:17:03 <jlaska> #topic https://bugzilla.redhat.com/694079
17:17:18 <jlaska> similar issue here ... is fixed in current systemd already included in RC1
17:17:51 <jlaska> I believe this did qualify as a beta blocker given it would either 1) prevent creating a new user account in firstboot, or 2) continue to run firstboot on every boot
17:18:08 <jlaska> which we have Alpha criteria for
17:18:39 <adamw> "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a worki
17:18:39 <adamw> ng user account "
17:18:42 <adamw> +1 blocker
17:18:51 <brunowolff> +1 blocker
17:18:55 <rbergeron> +1 blocker
17:19:08 <jlaska> #agreed 694079 - AcceptedBlocker for Beta.  Impacted Alpha criteria by preventing user creation in firstboot or running firstboot on every boot.
17:19:18 <jlaska> #topic https://bugzilla.redhat.com/694239
17:19:32 <jlaska> #info Live image built with latest systemd/selinux-policy etc fails to boot with selinux enabled
17:19:56 <jlaska> adamw: is this the _other_ selinux bug mentioned by an earlier comment from you
17:20:14 <adamw> this is the one which broke everything.
17:20:20 <adamw> selinux-policy -13 fixes it, all is good.
17:20:24 <jlaska> this one seems pretty clear ... prevented booting a default installation
17:20:26 <adamw> yeah.
17:20:28 <jlaska> already fixed and verified
17:20:30 <adamw> +1 blocker on that basis.
17:20:37 * jlaska starts the #agreed ...
17:20:38 * rbergeron notes thanks to everyone who helped work on these yesterday.
17:20:41 <rbergeron> +1 blocker
17:20:44 <brunowolff> +1 blocker
17:21:10 <jlaska> #agreed 694239 - AcceptedBlocker.  Prevented system boot after installation.  Verified and fixed in RC1
17:21:26 <jlaska> last proposed ...
17:21:27 <jlaska> #topic https://bugzilla.redhat.com/693247
17:21:45 <jlaska> #info SELinux is preventing /usr/bin/pulseaudio from 'read' accesses on the file +sound:card29
17:21:52 <adamw> okay, this is the tricky one.
17:22:15 <adamw> we pulled in a last-minute fix for this yesterday.
17:22:15 <jlaska> seems so (udev) ... what's the latest here?
17:22:30 <adamw> however, the last-minute fix is breaking the hell out of anaconda; it's the cause of the 'anaconda won't run on live images' bug.
17:22:49 <adamw> we can fix that bug, and the fix actually is a sensible improvement in anaconda, however...you then run into bugs at partitioning stage.
17:22:52 <jlaska> adamw: -3 pulls in more than just this change?
17:23:05 <adamw> it seems pretty clear the udev patch is changing behaviour in bad ways.
17:23:05 <adamw> no.
17:23:12 <adamw> the only change in -3 is this patch. i know because i built it =)
17:23:22 <jlaska> okay
17:23:35 <jlaska> #link http://git.kernel.org/?p=linux/hotplug/udev.git;a=commit;h=51f43b53293c4cc64c2a55598491c6cbf27b6bd5;2
17:23:45 <adamw> i summarized the situation and the options in comment #31
17:24:18 <jlaska> any luck getting hold of haraldh?
17:24:33 <adamw> an interesting factor here is the blockeriness of this bug is not actually clear-cut; we were working under the assumption it broke sound for the reporter, but it actually doesn't. afaik no-one has identified a definite criteria-breaking problem that's due to this issue yet.
17:24:35 <adamw> nope.
17:24:59 <jlaska> which makes me lean towards the revert option
17:25:17 <adamw> i just tried another round of pings.
17:25:29 <adamw> yeah, 1 and 2 are the simplest options, i think.
17:25:30 <jlaska> while we further explore that issue for possible post-beta fix or more targetted blocker issue
17:25:50 <adamw> the only thing that worries me about 'just revert' is the potential to open ourselves up to another issue we find in testing, but...it's not a horrible choice.
17:26:11 * jlaska would prefer leaving this call to the udev experts
17:26:11 <jlaska> agreed
17:26:18 <brunowolff> It looks like it might be a final blocker under "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login"
17:26:25 <adamw> jlaska: yeah, if we could FIND one.
17:26:39 <jlaska> adamw: understood
17:26:45 <adamw> brunowolff: yeah, probably.
17:27:00 <jlaska> adamw: you were worried though whether this impacted sound on all systems originally?
17:27:14 <jlaska> was that a possible Beta criteria issue
17:27:24 <adamw> jlaska: well that was when i was assuming it actually affected sound on the reporter's system - i tested that it didn't on mine and wondered if the impact was hardware-dependent
17:27:34 <jlaska> okay
17:27:36 <adamw> but since it doesn't actually affect sound on the reporter's machine...
17:27:53 <jlaska> well ... that does seem to lower the importance
17:28:00 <jlaska> is the only criteria affected what brunowolff highlighted?
17:28:10 <adamw> the only one we know about for sure at present, yes.
17:28:18 <jlaska> yes, well phrased
17:29:52 <jlaska> unless we have someone from udev, I don't think we should make the decision to do the "safe" fix
17:29:57 <adamw> so...are we leaning towards option 1) ?
17:30:00 <jlaska> yup
17:30:08 <jlaska> just my opinion of course
17:30:15 <adamw> revert the patch, spin rc2, test, try and poke upstream
17:30:23 <adamw> i can go with that
17:30:45 <jlaska> yeah, let's set a time for RC2 to start with dgilmore ... and continue trying to get feedback from hh (or others) on option#2
17:31:16 <adamw> or #3
17:31:23 <jlaska> shall we accept this as a Final blocker for the criteria brunowolff mentioned ... and leave the udev rollback to the installer bug?
17:31:36 <jlaska> yeah, #1 or #3 would be my choices
17:31:42 <adamw> sure. rolling back udev doesn't fix this bug, it un-fixes it :)
17:31:42 <jlaska> other opinions?
17:31:56 * rbergeron defers to more expertise
17:32:00 <brunowolff> I like #1
17:32:16 <jlaska> adamw: right ... you said we discovered that sound playback wasn't actually impacted by this bug? or did I get that wrong
17:32:20 <tflink> #1 or #3, I think. depends on when we might be able to get a patch from upstream
17:33:17 * bcl has lost track of the options. But installer working it more important than sound for a Beta.
17:33:21 <adamw> jlaska: yes. again, we have no known criterion-infringing issues. you get avcs from sound-related stuff, but sound works.
17:33:24 <bcl> s/it/is/
17:33:31 <jlaska> adamw: okay
17:33:35 <adamw> bcl: options are in the bug, comment #31.
17:33:48 <bcl> handy!
17:33:49 <jlaska> so let's accept this bug for Final, and we'll deal with the udev issue when it comes to the accepted anaconda/udev blocker ?
17:33:52 <adamw> bcl: none of the options involves having the installer not working, don't worry =)
17:34:11 <adamw> jlaska: er, okay?
17:34:25 <jlaska> adamw: try to keep issues separate, but I think that's confusing things ... apologies
17:34:35 <adamw> yeah, they're not really separate =)
17:34:47 <adamw> anything we do about one of them also affects the other.
17:35:43 <jlaska> right
17:36:00 <jlaska> so ... that packages fixed may overlap ... but this bug is *only* about the AVC while playing sound right?
17:36:14 <adamw> ...man, we're going down rabbit holes here.
17:36:21 <jlaska> I know ... I blame IRC
17:36:37 <jlaska> adamw: if you've got a proposed queued up ... and can better articulate ... go for it!
17:36:42 <adamw> THIS bug is for the fact that the /run/udev/tags and /run/udev/watch subdirectories have the wrong selinux labels if udev is not fixed.
17:37:04 <adamw> the only consequence of that error that we currently KNOW about is that various sound-related processes will throw avcs, but apparently don't stop working: no-one is claiming they don't have sound.
17:37:26 <adamw> we applied a fix for the bug, which causes various bugs in anaconda, so we are discussing the consequences of reverting that fix and hence leaving this bug open for beta.
17:37:27 * jlaska nods
17:37:58 <adamw> so...
17:38:45 <adamw> propose #agreed known consequences of 693247 not serious enough to be a Beta blocker: is a Final blocker per the SELinux avcs criterion. If further testing shows any more serious consequences of this bug, we can revisit it being a blocker.
17:38:55 <brunowolff> +1
17:38:58 <adamw> that would allow us to revert it.
17:39:11 * jlaska was trying to keep the fix and the reported bugs separate ... but see how that was confusing
17:39:23 <jlaska> +1 to adamw's proposed
17:39:28 <rbergeron> +1
17:39:31 <tflink> +1
17:39:34 <jlaska> #chair adamw
17:39:35 <zodbot> Current chairs: adamw jlaska
17:40:24 <jlaska> #agreed known consequences of 693247 not serious enough to be a Beta blocker: is a Final blocker per the SELinux avcs criterion. If further testing shows any more serious consequences of this bug, we can revisit it being a blocker.
17:40:45 <jlaska> leave the other aspects of this for the live image issue ... and move on?
17:40:49 <adamw> okay.
17:41:02 <jlaska> we are ready for AcceptedBlockers now
17:41:08 <jlaska> I'm going to skip VERIFIED bugs
17:41:16 <jlaska> bug walk through all others
17:41:33 <jlaska> adamw: thanks clearing my proposed cobwebs :)
17:41:37 <jlaska> #topic https://bugzilla.redhat.com/678553
17:41:48 <jlaska> #info NetworkManager doesn't start successfully on bootup after upgrade from F14 -> F15
17:42:18 <adamw> fix is in, works, move on!
17:42:26 <jlaska> I just queued up 2 F-14 installs so I can verify this ... but good, one less thing to test
17:42:38 <jlaska> adamw: where is the confirmation, in bodhi?
17:42:43 * jlaska would like to move this to VERIFIED
17:43:11 <adamw> oh, sorry, i thought someone had tested it in the bug report...
17:43:12 <jlaska> #link https://admin.fedoraproject.org/updates/NetworkManager-0.8.998-1.fc15
17:43:29 <adamw> oh, nope, got confused.
17:43:34 <adamw> so yeah, still needs confirmation, sorry.
17:43:42 <jlaska> okay ... well, I'll confirm this after meeting
17:43:47 <jlaska> I've got installs/upgrades going now
17:44:02 <jlaska> #action jlaska - verify 678553 and post into bug report
17:44:06 <jlaska> anything else here?
17:44:57 <jlaska> I'll take that as a no ... moving on ...
17:45:07 <jlaska> I'll raise alerts if I'm not able to VERIFY this issue
17:45:12 <adamw> oh, ffs.
17:45:20 <jlaska> ?
17:45:54 <jlaska> oh, I see #anaconda ?
17:45:57 <jlaska> okay moving on
17:45:59 <jlaska> #topic https://bugzilla.redhat.com/691139
17:46:11 <jlaska> #info NetworkManager 0.8.997 doesn't connect to hidden wireless network
17:46:29 <jlaska> #link https://admin.fedoraproject.org/updates/control-center-3.0.0.1-2.fc15
17:46:41 <jlaska> Anyone have a hidden wireless network nearby and can test this?
17:46:50 <rbergeron> not me :(
17:46:55 <tflink> I can make my wireless hidden
17:46:59 <adamw> the update is -3 now, note.
17:47:01 <jlaska> I see support exists to connect to "Other..." networks now ... but I haven't tested it
17:47:14 <jlaska> #link
17:47:16 <jlaska> #link https://admin.fedoraproject.org/updates/control-center-3.0.0.1-3.fc15
17:47:28 <jlaska> tflink: if that's not too much trouble, thank you
17:47:35 * tflink will test after the meeting
17:47:40 <jlaska> caillon also reported success for connecting to hidden networks
17:48:01 <jlaska> I'd definitely feel happy with multiple testers on this issue
17:48:32 <jlaska> #info 691139 confirmed fixed by caillon in bodhi, tflink will also test post-meeting
17:48:59 <jlaska> okay, moving on to adamw and bcl's issue
17:49:00 <jlaska> #topic https://bugzilla.redhat.com/694712
17:49:26 <jlaska> #info Anaconda crashes on launch in F15 Beta RC1 live images
17:49:32 <jlaska> sounds like we may be back to square one on this?
17:49:44 <dgilmore> :(
17:49:54 <jlaska> looks like investigating still inprogress
17:49:56 <adamw> yeah
17:50:00 <adamw> i thought i had it...
17:50:13 <jlaska> anything else to report here, and help needed?
17:50:14 <adamw> so, my diagnosis is bad...because i respan my custom live image with the 'broken' udev, and it worked.
17:50:21 <adamw> so now we're down to some other difference between my live and rc1.
17:50:25 <adamw> here's the package list diff:
17:50:30 <adamw> http://fpaste.org/YsJw/
17:50:41 <adamw> the next most obvious candidate is, i guess, dracut.
17:51:02 <jlaska> yeah ... looking at dracut changelog
17:51:18 <adamw> respinning without the updated dracut.
17:51:34 <jlaska> okay
17:51:40 <jlaska> well ... I don't think there's anything else we can add here
17:52:02 <jlaska> adamw: bcl: feel free to shout for backup if desired
17:52:13 <jlaska> #info investigating continues on root cause
17:52:28 * jlaska moving on in a moment
17:52:42 <adamw> well
17:52:49 <adamw> we need to agree it's a blocker, yes?
17:52:52 <adamw> oh, or did we do that already?
17:52:59 <jlaska> yeah, we did that _e_ lectronically
17:53:01 <adamw> okay.
17:53:06 <jlaska> heh ... through bz acks
17:53:07 <adamw> so, yeah, we're stuffed.
17:53:26 <jlaska> #topic https://bugzilla.redhat.com/694716
17:53:37 <jlaska> #info 15 Beta RC1 DVDs fail repoclosure
17:53:43 <jlaska> brunowolff gets the thanks for this one
17:54:11 <jlaska> I created a DVD.iso with the patch brunowolff commited and reran repoclosure against the created DVD ... the problem appears to be resolved
17:54:12 <brunowolff> Note at this point in the release process we work off of spin-kickstarts trunk, so there may not be a package update for this for a while yet.
17:54:38 <jlaska> brunowolff: oh ... so we could include this fix without doing a package build?
17:55:08 <brunowolff> I believe the scripts just use the trunk version. I am not the one that does that though.
17:55:14 <jlaska> wait no ... wouldn't we need an updated spin-kickstarts to pull this in
17:55:26 <jlaska> (that may just be due to my mock-based pungi test)
17:55:30 <brunowolff> Even for final, we do something similar but in a release branch.
17:55:45 * jlaska defers to dgilmore for that
17:55:57 <jlaska> not sure what setup is used for official composes
17:57:13 <jlaska> #info New spin-kickstarts package may not be needed, depending how rel-eng creates official ISO media (from git master or from spin-kickstarts rpm)
17:57:29 <jlaska> I guess we can follow-up after meeting, I think dgilmore may be afk at the moment
17:57:53 <dgilmore> sorry im here
17:57:55 <brunowolff> If you want I can make a new package build this afternoon. You wouldn't have to pull it in.
17:58:14 <jlaska> brunowolff: no preference for me ... whatever dgilmore needs to do the ISO's
17:58:20 <dgilmore> jlaska: i always do composes from git
17:58:30 <dgilmore> jlaska: i have to edit things to compose
17:58:39 <jlaska> dgilmore: okay, thanks!
17:58:44 <dgilmore> since we can not access mirrormanager where we run the composes
17:58:51 <jlaska> aah, I see
17:58:56 <jlaska> cool, one less thing for brunowolff to do :)
17:59:14 <dgilmore> and we add the packages for blockers to a side repo
17:59:22 <dgilmore> rather than waiting hours on a mash
17:59:34 <jlaska> this concludes the proposed and accepted blockers
17:59:57 <gholms> (And now for something completely different.)
17:59:59 <jlaska> :)
18:00:12 <jlaska> #topic Open Discussion
18:00:28 <jlaska> We can call out specific bugs from the proposed + accepted NTH lists if folks prfer
18:00:30 <brunowolff> Do we need to look at proposed NTH's or is that moot?
18:00:31 <jlaska> prefer
18:00:32 <jlaska> I don't think we need to walk each bug
18:00:45 <jlaska> I'd like to call out ...
18:00:46 <jlaska> #topic https://bugzilla.redhat.com/692135
18:00:53 <adamw> well, we should walk each proposed nth.
18:00:58 <adamw> otherwise they don't get evaluated.
18:01:09 <jlaska> adamw: duh ... right ... I'll walk those next
18:01:12 <jlaska> :)
18:01:40 <jlaska> looks like we have an updated isomd5sum build ... I've not been able to verify the fix, but I'm not entirely sure my test reproducer is valid
18:01:49 <jlaska> #info Image failed media check
18:02:08 <jlaska> This is an approved NTH issue ... I'm debating whether we want to pull it into RC2 or not
18:02:10 <maxamillion> I'm not having good luck with the beta install media ... going back to test the alpha image on this box for sanity sake
18:02:38 <maxamillion> err... wrong channel, but I suppose it applies here as well
18:02:50 <jlaska> maxamillion: yeah, we can work though any specific issues you've reported here
18:02:58 <jlaska> or get 'em filed in #fedora-qa first :)
18:02:58 <bcl> sorry, doing 4 different things.
18:03:04 <jlaska> bcl: understoon
18:03:13 <jlaska> heh ... same here apparently
18:03:16 <jlaska> understood
18:03:25 <maxamillion> jlaska: already voiced the bits in #fedora-qa ... one is a kernel panic, the other I think is just my work proxy being stupid
18:03:42 <jlaska> maxamillion: okay, let's continue to work those issues into bugs
18:03:50 <maxamillion> sounds good :)
18:04:06 <jlaska> for #topic ... unless anyone else has ideas ... I'll add this to the rel-eng TRAC ticket for consideration
18:04:17 <jlaska> now for proposed NTH ...
18:04:22 <jlaska> #topic https://bugzilla.redhat.com/689291
18:04:31 <jlaska> #info <error> activation_source_schedule(): activation stage already scheduled
18:04:53 <adamw> this was the problem with a specific ipv6 router setting.
18:04:58 <adamw> it got pulled in with a blocker fix.
18:05:05 <adamw> i'm happy with +1 nth for it
18:05:34 <rbergeron> +1 nth as well here.
18:05:45 <rbergeron> i think it was a *very* specific ipv6 router setting
18:05:57 <jlaska> given the specific nature, I'd be fine with post-beta if it wasn't already fixe
18:06:00 <jlaska> d
18:06:03 <jlaska> but seems like things are already on track
18:06:24 <jlaska> proposed #agreed 689291 - AcceptedNTH for Beta.  Proposed fix already included in RC1
18:06:44 <tflink> ack
18:06:56 <jlaska> I count 3 acks ...
18:07:01 <jlaska> #agreed 689291 - AcceptedNTH for Beta.  Proposed fix already included in RC1
18:07:11 <jlaska> #topic https://bugzilla.redhat.com/678236
18:07:35 <jlaska> we have several +1's for NTH already in the bug report
18:07:41 <jlaska> #info User list sometimes not visible on greeter
18:07:48 <jlaska> "So, I proposed this as a blocker as it's a fail on a Beta-level validation
18:07:52 <jlaska> test, but it doesn't hit any criteria and I think that's probably right: this
18:07:55 <jlaska> seems NTH not blocker to me, there are easy workarounds (reboot if you really
18:07:58 <jlaska> *need* the user list, or just type a user name) and it can be fixed with an
18:08:01 <jlaska> update. propose drop to NTH. votes?"
18:08:05 <brunowolff> It's really pretty minor. I see this from time to time, and entering a userid isn't hard.
18:08:14 * tflink is +1 on nth, its a little bit of an annoyance but not too bad
18:08:15 <jlaska> same here
18:08:31 <brunowolff> +0
18:08:41 <jlaska> +0 for NTH?
18:08:45 <brunowolff> Yes
18:08:52 <jlaska> okay
18:09:08 <jlaska> I think we have enough to approve this for NTH given votes already in the bz
18:09:17 <jlaska> unless there are any -1's ... I'll #agreed
18:09:19 <jlaska> So, I proposed this as a blocker as it's a fail on a Beta-level validation
18:09:22 <jlaska> test, but it doesn't hit any criteria and I think that's probably right: this
18:09:25 <jlaska> seems NTH not blocker to me, there are easy workarounds (reboot if you really
18:09:28 <jlaska> *need* the user list, or just type a user name) and it can be fixed with an
18:09:31 <jlaska> ergh, paste buffer, I curse you!
18:10:07 <jlaska> #agreed 678236 - AcceptedNTH for Beta.  If a tested fix is available in time, will include in Beta
18:10:19 <jlaska> #topic https://bugzilla.redhat.com/693899
18:10:30 <jlaska> #info samba downgrade to 3.5.8
18:10:59 <jlaska> I revert my previous stance in bz on this issue
18:11:09 <jlaska> I don't think this qualifies for the NTH criteria
18:11:40 * rbergeron reads
18:11:46 <jlaska> this seems like something one would expect to pull down as a post-beta update ... and this issue doesn't prevent users from locating those updates
18:11:50 <adamw> well, we only have nth principles; there's wiggle room.
18:12:10 <adamw> yeah, i couldn't think off the top of my head if samba can affect install or not.
18:12:28 <tflink> how unstable is samba 3.6?
18:12:28 <jlaska> has anyone heard from Guenther?
18:12:42 <adamw> i think we took the change into rc1, though
18:12:49 <brunowolff> The bug also wasn't very specific about what stability problems there were.
18:12:50 * jlaska checks
18:12:51 <adamw> so now, changing it back for rc2 would arguably be the more controversial change
18:13:02 <jlaska> samba-3.5.8-68.fc15.1.i686.rpm
18:13:09 * adamw put the 'new' samba in his trac list without checking if the bug was acceptednth, sorry
18:13:20 <jlaska> so looks like this is already fixed according to their wishes
18:14:04 <jlaska> proposed #agreed 693899 - Already fixed in RC1, accepted NTH.  Move to VERIFIED -> CLOSED
18:14:07 <jlaska> ack/nak/patch?
18:14:36 <tflink> so the older samba is already in Rc1?
18:14:44 <jlaska> tflink: appears so
18:14:55 <adamw> well, we don't close until it's pushed stable
18:15:02 <adamw> i don't think dgilmore has pushed the rc1 packages to stable yet
18:15:05 <tflink> ack
18:15:09 <brunowolff> +1
18:15:23 <jlaska> adamw: yes, good point
18:15:46 <jlaska> the assumption though is if they are in RC1, they should be stable packages already?
18:16:03 <jlaska> well, I guess we've not always followed this
18:16:13 <jlaska> #agreed 693899 - Already fixed in RC1, accepted NTH.  Move to VERIFIED
18:16:14 <adamw> no, we often build rcs from a side repo.
18:16:18 <adamw> they should get pushed soon after, though.
18:16:21 <adamw> ack
18:16:21 <jlaska> okay
18:16:25 <jlaska> #topic https://bugzilla.redhat.com/692048
18:16:31 <jlaska> #info Fail to connect to the specified address with VNC client vinagre when using vnc method in anaconda 15.25
18:16:44 <adamw> quick note, i have a new theory on 694712, if we want to go back to it in a bit.
18:17:11 <jlaska> adamw: this is the last bug ... we can go back to that after
18:17:13 <jlaska> #link https://admin.fedoraproject.org/updates/tigervnc-1.0.90-2.fc15
18:17:22 <jlaska> I'm all for taking this in the Beta as a NTH
18:17:26 <adamw> it's an installer bug but the fix isn't in anaconda so can't screw up anything else - yay. +1 nth.
18:17:44 <jlaska> vncviewer already works fine, this issue deals with only using vinagre to connect
18:19:08 <jlaska> proposed #agreed 692048 - AcceptedNTH for Beta, updated tigervnc package attempts to correct vinagre client connection issues
18:19:43 <rbergeron> +1
18:19:50 <rbergeron> +1 nth that is
18:19:59 <jlaska> I'm leaning towards -1 on taking this ... since this is a tigervnc (server) rebuild, which could impact anaconda connecting to any VNC sessions
18:20:27 <jlaska> it's not just updating vinagre to handle different VNC connection specs
18:20:29 <tflink> has it been tested with anaconda?
18:20:35 <jlaska> no
18:20:47 <adamw> <jlaska> I'm all for taking this in the Beta as a NTH
18:20:48 <jlaska> not tested, and I don't know if we need an anaconda rebuild or just a compose to test it
18:20:53 <jlaska> adamw: revised
18:20:56 <adamw> ah
18:21:01 <adamw> that first one was Cranes? :)
18:21:10 <jlaska> heh, I'll let you decide :)
18:21:28 <jlaska> proposed #agreed 692048 - AcceptedNTH for Beta, will take into RC2 if a VERIFIED fix is available
18:21:31 <jlaska> how's that instead?
18:21:49 <jlaska> so as long as this is tested and VERIFIED (which I'll try to do after meeting) ... we can take it NTH
18:22:08 <tflink> as long as it doesn't mess with anaconda, I'm fine with that
18:22:16 * rbergeron nods
18:22:19 <adamw> okay.
18:22:26 <brunowolff> +1 to proposal
18:22:41 <jlaska> thanks all
18:22:47 <jlaska> #agreed 692048 - AcceptedNTH for Beta, will take into RC2 if a VERIFIED fix is available
18:23:01 <jlaska> adamw: want to take it away with #topic ... I'm done with the lists
18:23:29 <adamw> sure
18:23:37 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=694712
18:23:38 <buggbot> Bug 694712: urgent, unspecified, ---, harald, NEW, Anaconda crashes on launch in F15 Beta RC1 live images
18:23:40 <adamw> soo...new theory on this one
18:23:49 <adamw> happily, a substantially less complicated one!
18:23:55 <adamw> seems like dracut is the actual culprit
18:24:22 <jlaska> \o/
18:24:27 <adamw> i had been testing with a private compose which is almost the same as rc1, but with different udevs...but then i tried the same compose with the *same* udev as rc1, and it still didn't hit the bug
18:24:40 <adamw> so obviously udev isn't the problem, and there was another diff between rc1 and my compose that i missed
18:24:50 <adamw> looks like it's dracut: when i did my compose with the older dracut that's in rc1, i hit the bug
18:25:09 <adamw> so, dracut 009-5 is fixed vs. dracut 008-7
18:25:35 <adamw> looks like we just need harald or another dracut maintainer to confirm what change is needed and submit an appropriate build as an update
18:25:48 <adamw> i'm seeing if dracut 009-3 (which has something vaguely relevant in its changelog) is enough to fox it
18:25:49 <adamw> fix it
18:26:08 <jlaska> nice job isolating the changes
18:27:05 <adamw> eventually...
18:27:17 <jlaska> if we're not able to get in touch w/ haraldh or $other ?
18:28:16 <adamw> then we should probably isolate the earliest dracut that fixes the bug and get it submitted as an update
18:28:17 <jlaska> attempt to find the specific dracut patch that fixes it ... and submit a build?
18:28:23 <jlaska> okay
18:28:24 <adamw> or even a specific patch, yeah
18:28:32 <adamw> though it may be hard since there's a version bump in there
18:28:53 * jlaska looks at pkgdb for dracut
18:29:04 <adamw> changelog is all harald
18:29:07 <jlaska> agk + jcm
18:29:09 <jlaska> yeah it is
18:29:16 <jlaska> rats
18:29:48 <jlaska> well, I can't think of anything other than to keep doing what you're already doing ... and we'll hope that harald pokes his head in this evening (his time)
18:29:55 <jlaska> and we'll make a decision once we know more
18:30:03 <jlaska> dgilmore: when is RC2 scheduled?
18:30:36 <adamw> i'll provide as much info as i can on the bug and ping whoever i can think of
18:31:00 * jlaska will try a few angles as well
18:31:08 <jlaska> thanks for the update on this one
18:31:09 <dgilmore> jlaska: wehn we have blockers fixed
18:31:23 <jlaska> dgilmore: okay ... didn't know if you were aiming for a specific time today
18:31:26 <adamw> 009-3 works
18:31:34 <dgilmore> jlaska: just when things are fixed
18:33:06 <jlaska> alright
18:33:08 <jlaska> adamw: sweet!
18:33:25 <jlaska> anything else to cover here ... or shall we get down to the details outside of the meeting?
18:33:31 <adamw> well, need to test -1 and -2
18:34:04 <jlaska> adamw: in the meeting?
18:34:08 <adamw> no
18:34:10 <jlaska> okay
18:34:11 <adamw> outside meeting is fine
18:34:32 <jlaska> #info Adamw confirmed dracut-009-3 works, and is looking to test older dracut versions
18:34:38 <jlaska> #topic Open Discussion
18:34:51 <jlaska> okay, anything not already discussed that we need to review in this meeting?
18:35:40 <gholms> [A tumbleweed blows by]
18:35:44 <brunowolff> I tried out the update for isomd5sum and it seems to be working for me now.
18:36:13 <brunowolff> I left +1 karma.
18:36:28 <jlaska> brunowolff: cool, I couldn't confirm the fix when I testd ... but glad someone did
18:36:42 <jlaska> alright ... last call for topics  (timer set to 1min)
18:36:53 <brunowolff> I didn't do it with anaconda though. Just command line for a live image I build today.
18:37:33 <jlaska> brunowolff: ah!
18:37:58 <jlaska> okay ... thanks all, let's #endmeeting and get back to testing!
18:38:03 <jlaska> I'll follow-up with minutes to the list
18:38:05 <jlaska> #endmeeting