fedora-board
MINUTES

#fedora-board-meeting: Fedora Board Meeting --- https://fedoraproject.org/wiki/Meeting:Board_meeting_2011-01-24

Meeting started by jreznik at 19:01:22 UTC (full logs).

Meeting summary

  1. roll call (jreznik, 19:02:28)
    1. jds2001 ke4qqq mizmo jreznik smooge nirik kylem notting spot rdieter cwickert mmaslano abadger1999 present (jreznik, 19:04:30)

  2. Fedora strategic goals discussion with FESCo --- https://fedoraproject.org/wiki/Meeting:Board_meeting_2010-12-13#Suggested_Goals_in_more_detail (jreznik, 19:07:58)
    1. the goals FESCo agreed on can be found in FESCo trac --- https://fedorahosted.org/fesco/ticket/539 (jreznik, 19:09:07)

  3. GOAL #1: Improve and simplify collaboration in the Fedora Community (jreznik, 19:13:08)
    1. IDEA: look at our unresponsive maintainer policies again... we should really encourage co-maintainers more so packages don't sit with no one watching them. (mizmo, 19:22:59)
    2. IDEA: how to possibly improve our morass of mailing lists (mizmo, 19:23:12)
    3. IDEA: how to possibly reduce the number of irc channels/lists/etc to make it easier for people to join/follow (mizmo, 19:23:17)
    4. IDEA: encourage direct communication between different groups. recently things seem to go up all the way to the board and then down again. this is ineffective collaboration. we need to have workflows for $contributor from group A requesting something from group B. ether there are not workflows or they are all different (mizmo, 19:23:22)
    5. IDEA: As mentioned on the board wiki, calendaring and scheduling could really be improved. (mizmo, 19:23:27)
    6. IDEA: it would be great to know when/where things are happing all the time. (mizmo, 19:23:34)
    7. IDEA: I wonder if we couldn't designate or create some area in all the communications channels for pointing people at just where to go for something. some kind of directory service... so you could look up who you ask about helping out with $foo instead of just wandering around trying to find out. (mizmo, 19:23:44)
    8. IDEA: say all groups have a trac instance to bring something up to their attention, just like the board opened it's trac recently. doesn't need to be trac, but a common protocol for everybody (mizmo, 19:31:17)
    9. so, 1 - 7 votes, 3 - 7 votes, 4 - 3 votes, 5 - 1 vote, 7 - 1 vote, 9 - 1 vote, 12 - 3 votes, 13 - 1 vote, 14 - 3 votes, 15 - 4 votes. (mizmo, 19:32:57)
    10. 1, 3, 15, 12 14 4, 5, 7 9 (mizmo, 19:33:01)
    11. http://meetbot.fedoraproject.org/fedora-meeting/2011-01-19/fesco.2011-01-19-17.35.log.html (mizmo, 19:33:05)

  4. GOAL #3: Improve and encourage high-quality communication in the Fedora Community (jreznik, 19:34:01)
    1. some overlap here with the first ones ideas... (mizmo, 19:35:14)
    2. IDEA: Teaching folks how to run meetings, and how to communicate better on lists would be lovely. (mizmo, 19:36:40)
    3. IDEA: We could possibly use some framework like moodle to setup classes for these things so people could learn more easily. (mizmo, 19:36:45)
    4. IDEA: Possibly we could ask mailing list owners to try and get people to avoid long threads or off topic discussion, but there's no easy fix. (nirik, 19:38:52)
    5. Nirik cites mailing lists as being the biggest communication breakdown place. Some people just use lists and not other channels. Issues getting IRC discussions synched back to list. Issues with noise on the lists. (mizmo, 19:39:00)
    6. notting seconds nirik's mailing list comments (mizmo, 19:40:10)
    7. mmaslano thinks it's like hall monitor - people who are OT usually don't participate classes to become better ones (jreznik, 19:43:49)
    8. spot says there are some crazy ideas on how to accomplish things to improve signal to noise ratio on mailing lists without acting like hall monitors (jreznik, 19:44:30)
    9. Anything that is described as 'teaching people how to communicate better on mailing lists' sounds like it would trigger a backlash, however well intentioned. "who are you to tell me i can't communicate?", etc. alas. it sounds like hall monitor. You can teach people better communication, but I'm not sure that those who go OT will be in this class. (mizmo, 19:44:38)
    10. IDEA: empower mailing list owners to do more management when needed. Possibly the Community Working group could propose some ideas on how they could better do so, but I think it might be better seen when coming from people who are part of whatever area that is and are managers of that resource. (mizmo, 19:44:56)

  5. GOAL #15: Improve developer experience (jreznik, 19:46:55)
    1. IDEA: gather feedback from developers at fudcon on areas to look at improving. (mizmo, 19:48:37)
    2. IDEA: get more people doing buildroot overrides or some way to automate them. (mizmo, 19:48:41)
    3. IDEA: See if we can reduce the maintainer sponsorship queue down. (so people wanting to help are there to help all of us) (mizmo, 19:48:51)
    4. IDEA: make co-maintainers more common/expected. Possibly by auto acking requests to be a comaintainer if the maintainer doesn't respond or the like. (mizmo, 19:49:14)
    5. IDEA: help improve repos.fedorapeople.org or kopers or whatever so they are easier for our maintainers to use. (mizmo, 19:49:41)
    6. IDEA: support of groups of maintainers in SIG or on group of packages. (mizmo, 19:51:11)
    7. IDEA: fesco could look at doing would be some better way to get provenpackagers helping others... some bat signal to call for help on a serious/difficult bug they can't solve. (mizmo, 19:55:00)
    8. IDEA: better communication with bugzappers would be nice. I think they could help more packages, but it seems sometimes packagers don't know to ask for them to help. (mizmo, 19:55:05)
    9. we don't necessarily have project-wide roadmaps for the tools we use (mizmo, 20:03:04)
    10. there's little we can do to enact new initiatives other than 'set policies' (mizmo, 20:03:23)
    11. we cant force people to do things, but one thing that might improve some of those bottlenecks is having multiple people who do each thing/can do tasks for some team... that way there's no single point if someone is busy or the like (jreznik, 20:07:56)
    12. ACTION: ke4qqq to get with releng and document instructions how to join the team and put a wiki page up (jreznik, 20:20:06)


Meeting ended at 20:29:20 UTC (full logs).

Action items

  1. ke4qqq to get with releng and document instructions how to join the team and put a wiki page up


Action items, by person

  1. ke4qqq
    1. ke4qqq to get with releng and document instructions how to join the team and put a wiki page up


People present (lines said)

  1. jreznik (87)
  2. nirik (62)
  3. mizmo (60)
  4. notting (39)
  5. cwickert (29)
  6. spot (28)
  7. jds2001 (17)
  8. ke4qqq (16)
  9. mmaslano (12)
  10. zodbot (5)
  11. cwickert1 (2)
  12. rdieter (1)
  13. abadger1999 (1)
  14. smooge (1)
  15. SMParrish (1)
  16. kylem (1)


Generated by MeetBot 0.1.4.