fedora-blocker-review
LOGS
17:00:30 <roshi> #startmeeting F22 Blocker Review
17:00:30 <zodbot> Meeting started Mon Feb  9 17:00:30 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:38 <roshi> #topic Roll Call
17:00:50 * roshi is here
17:01:02 <adamw> ahoy
17:01:20 <roshi> o/
17:01:22 <danofsatx> land ho!
17:01:35 <adamw> arrrrrrrrrr, splice me timbers and shiver the mainbrace
17:02:11 <danofsatx> wrong holiday, adamw
17:02:13 <roshi> lol
17:02:30 <danofsatx> we're supposed to be speaking Latin this month, not Pirate.
17:02:41 <adamw> i don't think my high school latin stretches to pirate vocab
17:02:50 <roshi> me either
17:03:03 <roshi> #chair adamw danofsatx
17:03:03 <zodbot> Current chairs: adamw danofsatx roshi
17:03:05 <danofsatx> I grew up in the stix....we dint have no latin thingy
17:03:11 <adamw> mind, i suppose the pirates probably wouldn't have spoken latin.
17:03:32 <danofsatx> Roman pirates would have.
17:04:37 <roshi> well, should we start with the 3 of us?
17:04:48 <danofsatx> what's quorum?
17:04:51 <adamw> no, see, that's what i'm saying, i don't think there *were* any roman pirates. romans tended to be the pirated.
17:04:55 <danofsatx> or do we have such a thing
17:04:57 <roshi> 3
17:05:11 <danofsatx> k
17:05:22 <roshi> #topic Introduction
17:05:22 <roshi> Why are we here?
17:05:22 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:05:26 <roshi> #info We'll be following the process outlined at:
17:05:28 <danofsatx> short list. short meeting. I have a frozen hard drive to test
17:05:29 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:05:31 <roshi> #info The bugs up for review today are available at:
17:05:34 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
17:05:36 <roshi> #info The criteria for release blocking bugs can be found at:
17:05:39 <roshi> #link https://fedoraproject.org/wiki/Fedora_22_Alpha_Release_Criteria
17:05:42 <roshi> #link https://fedoraproject.org/wiki/Fedora_22_Beta_Release_Criteria
17:05:45 <roshi> #link https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria
17:05:48 <roshi> we have 2/1/4 proposed
17:06:03 <roshi> to Alpha!
17:06:04 <roshi> #topic (1190243) g++ internal compiler error on arm
17:06:04 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1190243
17:06:05 <roshi> #info Proposed Blocker, gcc, NEW
17:06:37 <danofsatx> adamw: since it's a holiday in the great white north, you want me to secretarialize?
17:06:46 <danofsatx> or however you spell it
17:06:55 <adamw> danofsatx: sure, if you'd be so kind
17:07:03 <adamw> and that's exactly how to spell it, many bonus points to you, good sir
17:07:08 <danofsatx> roger, will do
17:07:20 <pwhalen> roshi, ive provisioned a machine for debugging this. no updates yet (info sent to Jakub)
17:07:25 * danofsatx passed phonix with flying colours
17:07:37 <adamw> were you hukd?
17:07:46 <roshi> thanks pwhalen
17:07:55 <roshi> which criteria is this supposed to violate?
17:08:14 <adamw> yeah, " Feature/Toolchain issues" doesn't quite cut it, for me
17:08:27 <danofsatx> yeah, I had trouble finding a criteria to fit it in.
17:08:35 <adamw> pwhalen: do you have any details on what exactly the implications are here? nothing builds? lots of things don't build? or is it only this package that's affected?
17:08:43 <roshi> does it cause the image to not boot?
17:08:44 <adamw> this package per se doesn't seem to be super important
17:08:55 <roshi> cause broken packages to not install?
17:09:14 <pwhalen> seeing if Peter is around
17:09:39 <roshi> kk
17:10:00 <adamw> roshi: the case where i can see a compiler error being a release blocker is where it stops us building the fix for a release blocker, or the case where it stops us building *lots* of packages, in which case we can say it's likely to prevent us being able to fix other blockers
17:10:23 <roshi> yeah, same here - but that's not in the bug
17:10:26 <adamw> of course this will cause the packages not to be updated for *any* primary arch because they can't go out of syc
17:10:31 <danofsatx> that was the only thing I could come up with, too
17:11:19 <adamw> i love that i can auto-complete peter's nick with pbr:
17:11:38 <roshi> lol
17:11:48 <danofsatx> pabst blue ribbon? yuck
17:12:01 <pwhalen> he might be afk, releng meeting just finished
17:12:22 <roshi> well, I'm leaning hard -1 for this since there isn't a violated criterion
17:12:58 <roshi> and no indication of the reach of this error
17:13:42 <danofsatx> agreed.
17:14:01 <adamw> for now -1 or punt
17:14:12 <adamw> if we -1 we can ask for more data and re-propose
17:14:25 <pwhalen> id say maybe punt for now, Peter may be back shortly (during this meeting)
17:14:27 <danofsatx> -1. need. more. data.
17:14:34 <adamw> ok, let's punt to the end of the meeting then...
17:14:40 <pwhalen> thanks
17:14:40 <roshi> kk
17:14:44 <danofsatx> rgr, on standby.
17:15:06 <roshi> #topic (1190610) imsettings NVR is lower in rawhide/F22
17:15:07 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1190610
17:15:07 <roshi> #info Proposed Blocker, imsettings, NEW
17:15:28 <danofsatx> this one is pretty cut and dry. +1
17:16:13 <danofsatx> but isn't upgrade path beta, not alpha?
17:16:36 <roshi> The installed system must be able to download and install updates with the default console package manager
17:16:38 * pbrobinson is here
17:16:46 <roshi> the Updates criterion
17:17:00 <roshi> hey pbrobinson :)
17:17:09 <pbrobinson> roshi: hey!
17:17:14 <danofsatx> ahh, I guess that is alpha then.
17:17:16 <roshi> let us wrap this one up, then we can get back to yours, if you have time
17:17:30 <adamw> roshi: this doesn't violate that.
17:17:35 <roshi> yeah
17:17:40 * kparal has no background info, but thinks this would violate the fedup upgrade criterion, possibly
17:17:42 <adamw> that criterion is about the package manager being broken, not about issues with packages.
17:17:45 <roshi> but that's the updates criterion danofsatx was looking for
17:17:57 <adamw> upgradepath being broken is not a blocker per se
17:17:58 <roshi> I don't see an alpha criterion this violates
17:18:06 <danofsatx> oh, got it.
17:18:13 <adamw> only if it actually results in the upgrade failing or the upgraded system not working
17:18:25 * kparal agrees
17:18:35 <danofsatx> so, what's imsettings do?
17:18:42 <adamw> there are multiple packages with upgradepath issues in f21->f22 atm, i saw like a dozen when i tested a Workstation upgrade
17:18:43 <roshi> hey kparal :)
17:18:56 <roshi> surprised you had time with the conference and all :)
17:19:04 * kparal lurks
17:19:21 <adamw> danofsatx: i think it's old input switching stuff
17:19:37 <pbrobinson> adamw: I saw it today and would have fixed it but it wasn't clear whether the revert was needed for f22
17:19:43 <danofsatx> "This package contains the core DBus services and some utilities."
17:19:53 <roshi> -1 for this unless more information comes along saying it breaks as adam said
17:20:32 <adamw> certainly -1 alpha as upgrade stuff isn't in effect till beta anyway, and it seems pointless to worry about individual upgradepath issues at this point, so just -1 in general.
17:20:50 <adamw> (i do wish wwoods would review my hack to make fedup do distro-sync...)
17:21:26 * kparal could have kicked him into shin during devconf
17:21:27 <roshi> proposed #agreed - 1190610 - RejectedBlocker - This bug doesn't violate any Alpha criterion.
17:22:05 <roshi> could add a bit about re-propose if more information surfaces and it does violate something
17:22:07 <danofsatx> ack.
17:22:13 <kparal> ack
17:22:29 <roshi> #agreed - 1190610 - RejectedBlocker - This bug doesn't violate any Alpha criterion.
17:22:41 <roshi> #topic (1190243) g++ internal compiler error on arm
17:22:41 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1190243
17:22:42 <roshi> #info Proposed Blocker, gcc, NEW
17:22:55 <roshi> ok, pbrobinson - this is the bug you were summoned for :)
17:23:40 <pbrobinson> not sure how wide spread the issue is as there's no mass rebuild
17:24:00 <pbrobinson> the maintainer knows of the issue and it might already be building as a fix
17:24:21 <roshi> ok
17:24:21 <pbrobinson> awaiting -10 for testing
17:24:49 <roshi> I'm still -1 on this with the caveat that if it affects more than we know, repropose it
17:25:13 <adamw> yeah, it obviously has the *potential* to be blockery but it's not sufficiently demonstrated yet
17:25:41 <pbrobinson> yes, the main reason for proposal was to ensure it was on people's radar
17:26:03 <pbrobinson> I'm some what nervous about gcc5
17:26:55 <roshi> proposed #agreed - 1190243 - RejectedBlocker - This bug doesn't violate any of the Alpha criteria, but has the potential to affect more. If it turns out this bug manifests itself in a larger way to affect upgrades or building a TC/RC, please repropose.
17:27:00 <adamw> ack
17:28:02 <roshi> acks? nacks?
17:28:16 <danofsatx> ack
17:28:28 <roshi> #agreed - 1190243 - RejectedBlocker - This bug doesn't violate any of the Alpha criteria, but has the potential to affect more. If it turns out this bug manifests itself in a larger way to affect upgrades or building a TC/RC, please repropose.
17:28:33 <roshi> thanks pbrobinson !
17:28:55 <roshi> #topic (1190415) fedup from updated 21 Workstation to Rawhide 2015-02-07 fails after upgrade-prep.sh
17:28:59 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1190415
17:29:01 <roshi> #info Proposed Blocker, fedup, NEW
17:30:06 <danofsatx> I was going to attempt to replicate this before the meeting, but shtuph happens.
17:30:11 <roshi> if fedup supposed to work with upgrading to rawhide?
17:30:12 <adamw> so here's why i couldn't tell if the upgradepath issues were critical :P
17:30:21 * roshi thought it on;y did releases
17:30:41 <adamw> roshi: it managed to pick the right package source and download all the packages, i don't know of any reason rawhide vs. branched should affect the 'install-the-updates' phase
17:31:13 <roshi> and the criteria doesn't specify branched or not
17:31:40 <roshi> looks like a +1 to me
17:31:43 <danofsatx> fedup is one of the "approved" methods to go from current release to rawhide, at least according to the wiki page
17:32:05 <adamw> and as we all know wikis never lie :P
17:32:17 <danofsatx> uh uh, they shur don't.
17:32:24 <roshi> guess I'd only really considered the FN -> FN+1 use case
17:32:45 <roshi> votes?
17:33:17 <danofsatx> +1
17:33:28 <adamw> +1
17:33:37 <kparal> +1
17:33:39 <roshi> proposed #agreed - 1190415 - AcceptedBlocker - This bug is a clear violation of the Beta upgrade requirements criterion: "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed. The user must be made to specify which Product (or none) they wish to have running when upgrade is complete."
17:33:52 <danofsatx> ack
17:34:22 <adamw> ack
17:34:22 <kparal> ack
17:34:28 <roshi> #agreed - 1190415 - AcceptedBlocker - This bug is a clear violation of the Beta upgrade requirements criterion: "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed. The user must be made to specify which Product (or none) they wish to have running when upgrade is complete."
17:34:38 <roshi> onto the Final SELinux bugs...
17:34:40 <roshi> #topic (1182640) SELinux is preventing /usr/lib/systemd/systemd-journald from 'getattr' accesses on the netlink_audit_socket netlink_audit_socket.
17:34:42 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1182640
17:34:45 <roshi> #info Proposed Blocker, selinux-policy, NEW
17:35:10 <roshi> I think with almost all of these, an updated selinux-policy fixed the issues
17:35:28 <danofsatx> first three, yeah. that last one is a doozy.
17:36:35 <roshi> on friday I spun up an updated workstation live, and the installation went through fine
17:36:43 <roshi> and no AVCs on boot from the install
17:37:09 <adamw> i hit several after first boot
17:37:18 <roshi> hrm, what did you do?
17:37:30 <roshi> I checked panel, browser, terminal...
17:37:34 <roshi> and got nil
17:37:35 <adamw> let's just close this one
17:37:48 <roshi> ok
17:38:00 <roshi> I mean, we can still vote on blockeriness
17:38:01 <danofsatx> +1 close.
17:38:08 <roshi> since it's easily a blocker :p
17:38:32 <roshi> proposed #agreed - 1182640 - CloseFixed
17:38:36 <danofsatx> Agreed - this *would* have been a blocker had it not been resolve.
17:38:54 <adamw> roshi: the one i still hit with 110 is https://bugzilla.redhat.com/show_bug.cgi?id=1190377
17:38:55 <roshi> yeah, but if adamw is still seeing it
17:39:37 <roshi> ah
17:39:53 <roshi> #agreed - 1182640 - CloseFixed
17:39:53 <adamw> roshi: i don't see thjis one any more. i already closed it. :P
17:40:00 <roshi> ok
17:40:10 <roshi> #topic (1188888) SELinux is preventing chronyd from 'read' accesses on the file resolv.conf.
17:40:13 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1188888
17:40:15 <roshi> #info Proposed Blocker, selinux-policy, MODIFIED
17:40:30 <adamw> yeah, this one was fixed too.
17:40:56 <adamw> closed it.
17:41:50 <roshi> moving on then
17:41:56 <roshi> #topic (1188889) SELinux is preventing geoclue from 'getattr' accesses on the file /run/NetworkManager/resolv.conf.
17:41:59 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1188889
17:41:59 * adamw is the Bug Unmaker
17:42:02 <roshi> #info Proposed Blocker, selinux-policy, MODIFIED
17:42:02 <adamw> aaand this one too.
17:42:13 <roshi> #topic (1190377) SELinux is preventing polkitd from 'read' accesses on the lnk_file localtime.
17:42:16 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1190377
17:42:19 <roshi> #info Proposed Blocker, selinux-policy, NEW
17:42:26 <roshi> go go adamw !
17:42:32 <roshi> is this one closed yet?
17:42:34 <roshi> :p
17:42:37 <adamw> no :P
17:42:44 <adamw> this is the one i see with -110
17:42:47 <adamw> odd that you didn't, though
17:42:58 <adamw> what nightly did you test with exactly?
17:43:01 <roshi> I'll check it again
17:43:10 <roshi> not a nightly, custom
17:43:12 <adamw> ah
17:43:16 <adamw> maybe you got a build in the middle?
17:43:28 <adamw> check with a nightly at least 0207
17:43:31 <roshi> I just wanted to test selinux-policy would let anaconda launch
17:43:38 <roshi> ok, can do after the meeting
17:43:42 <roshi> +1 for this
17:44:00 <danofsatx> +1
17:44:33 <adamw> it'd be good to get someone else to confirm it, but i won't object :)
17:45:22 <roshi> proposed #agreed - 1190377 - AcceptedBlocker - This is a clear violation of the Final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
17:45:27 <adamw> ack
17:45:41 <danofsatx> ackity ack
17:45:48 <roshi> #agreed - 1190377 - AcceptedBlocker - This is a clear violation of the Final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
17:45:55 <roshi> #topic Open Floor
17:45:59 <roshi> I had one thing
17:46:16 <roshi> can someone change the default channel topic in here to reflect the right time, since we moved the meeting?
17:46:17 <adamw> fire awaaaaaay
17:46:31 <roshi> and I don't know how to change it myself :)
17:46:41 <adamw> did you try just changing it and get not enough privs or something?
17:46:49 <adamw> the fedora-qa one i think is set so anyone can change it
17:47:10 <roshi> I haven't even looked up how to do it, in order to try
17:47:16 <roshi> just noticed when I started the meeting
17:47:26 <roshi> and thought "oooh, that should change."
17:48:29 <roshi> anybody have anything else?
17:48:45 * roshi sets the ACME old-timey fast fuse...
17:49:20 <adamw> ok, i'll try it after the meeting
17:49:22 <roshi> 3...
17:49:27 <adamw> don't think so...we've got tc1 coming this week
17:49:27 <roshi> thanks
17:49:29 <adamw> funtimes
17:49:33 <roshi> whee!
17:49:38 <roshi> 2...
17:49:48 <roshi> thanks for coming!
17:49:58 <roshi> adamw: go enjoy your holiday :)
17:50:01 <roshi> 1...
17:50:10 <roshi> #endmeeting