f21-blocker-review
LOGS
17:01:29 <roshi> #startmeeting F21-blocker-review
17:01:29 <zodbot> Meeting started Mon Nov 24 17:01:29 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:29 <roshi> #meetingname F21-blocker-review
17:01:29 <zodbot> The meeting name has been set to 'f21-blocker-review'
17:01:30 <roshi> #topic Roll Call
17:01:34 <roshi> who's around?
17:01:40 * jreznik_2nd is here, again
17:01:43 * kparal spins around
17:02:21 <roshi> see what adamw did there? He suggested a time that gave him just enough time to escape somewhere...
17:02:25 <roshi> :p
17:02:39 <roshi> #chair jreznik_2nd kparal adamw
17:02:39 <zodbot> Current chairs: adamw jreznik_2nd kparal roshi
17:02:50 * nirik is here.
17:03:07 <roshi> #chair nirik
17:03:07 <zodbot> Current chairs: adamw jreznik_2nd kparal nirik roshi
17:03:24 <roshi> #topic Introduction
17:03:24 <roshi> Why are we here?
17:03:24 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:03:28 <roshi> #info We'll be following the process outlined at:
17:03:30 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:03:33 <roshi> #info The bugs up for review today are available at:
17:03:35 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
17:03:38 <roshi> #info The criteria for release blocking bugs can be found at:
17:03:40 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
17:03:43 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
17:03:46 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
17:03:53 * smccann is here
17:03:55 <roshi> alright, first up
17:04:01 <roshi> welcome smccann ;)
17:04:04 <roshi> #topic (1158533) selecting one disk from VG spanning over multiple disks causes troubles
17:04:07 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1158533
17:04:10 <roshi> #info Proposed Blocker, anaconda, NEW
17:05:02 * kparal asked dlehman to join us
17:05:05 * pschindl is here too
17:05:14 <roshi> #chair pschindl
17:05:15 <zodbot> Current chairs: adamw jreznik_2nd kparal nirik pschindl roshi
17:05:47 <jreznik_2nd> kparal: btw. vpodzimek told me, he knows what's the issue and promised fix for it to me (unless dlehman will be faster ;-)
17:06:04 <kparal> jreznik_2nd: this bug?
17:06:15 <adamw> remember it was split in two
17:06:17 <jreznik_2nd> kparal: he told me he was looking on both
17:06:45 <jreznik_2nd> but you're right I asked specificaly for the second one, already accepted
17:06:58 <adamw> i believe there was some discussion on IRC to the effect that they kind of consider this 'user error' and the only 'fix' would be to error out better
17:07:03 <kparal> they are different, mcsontos claims
17:07:09 <adamw> that was from i think dlehman though, not a brno folk
17:08:00 <nirik> disk spanning vg's seems like a really bad idea, but I guess there's some use cases.
17:08:42 <adamw> nirik: doesn't seem that odd to me, it's what you get with a multiple disk guided installation.
17:09:05 <adamw> i guess this strictly counts as a blocker under 'reject invalid operations gracefully' or whatever that criterion is, but i'm kinda starting to think that one was a mistake
17:09:29 <nirik> well, the sysadmin in me would never have a single disk break your entire machine... ;) but thats just my background.
17:10:01 <kparal> this crashes during installation, right?
17:10:39 <adamw> from the traceback i think so.
17:10:43 <nirik> yeah.
17:11:06 <kparal> I don't see a simple reproducer
17:11:10 <kparal> can somebody tell me?
17:11:31 <kparal> I think I have installed to multiple disks and then just to a single disk in the past, and it always worked
17:11:42 <kparal> using default layout, thus lvm
17:12:36 <nirik> 2 disks connected, but not clear what was on them before I guess?
17:13:05 <kparal> bcl: do you know something about this? just read the stuff from satellit, the rest was split into a different bug
17:14:07 <adamw> kparal: did you have the disks that made up a VG all connected, but only select one of them as an install target?
17:14:13 <nirik> sdb seems to be a msdos...
17:14:15 <adamw> that seems to me to be the case ehre
17:14:16 <nirik> format = existing None
17:14:24 <kparal> adamw: yes. but I'd need to verify
17:15:57 <bcl> kparal: I think this is one of the 'too broken to handle' category that dlehman was planning on catching.
17:15:58 <nirik> oh, right, thats gpt/msdos...
17:16:15 <bcl> But you'd have to ask him to be sure.
17:16:44 <nirik> bcl: is he in this week?
17:16:44 <kparal> I think we need to reproduce it first in order to vote on it. at the moment I'm very unclear what exactly is going on, and what uses cases are exactly affected
17:16:45 <bcl> I think so.
17:17:26 <bcl> There's a number of these kinds of things that hit QA somewhat consistently because they're good a breaking things but that normal users will rarely see.
17:17:32 <adamw> yeah, the case that got split out seems clearly defined, but i'm not sure we have the data on exactly how to reproduce satellit's
17:17:41 <nirik> so, punt for now and try and clarify?
17:18:00 <adamw> yeah, i'd go for that
17:18:20 <adamw> first thing to try i guess is do a guided multi-disk install of f20 or f21 then run installer again and pick only one of the disks as an install target, see if that reproduces it
17:18:29 <adamw> if not, it's gotta be something more complicated than that
17:18:45 <roshi> proposed #agreed - 1158533 - Punt - Work is still ongoing to get a solid set or reproduction steps for this. Will revisit next meeting.
17:19:02 <roshi> proposed #agreed - 1158533 - Punt - Work is still ongoing to get a solid set of reproduction steps for this. Will revisit next meeting.
17:19:08 <roshi> s/or/of/
17:19:15 <nirik> +1
17:19:18 <kparal> adamw: I'm trying that now
17:19:20 <jreznik_2nd> +1
17:19:26 <kparal> ack
17:19:27 <adamw> +1
17:19:34 <jreznik_2nd> or ack, is better :)
17:19:37 <roshi> #agreed - 1158533 - Punt - Work is still ongoing to get a solid set of reproduction steps for this. Will revisit next meeting.
17:20:10 <roshi> #topic (1165781) minimum-sized workstation installation results in a broken system (0% free space, GNOME not working)
17:20:13 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1165781
17:20:16 <roshi> #info Proposed Blocker, anaconda, NEW
17:20:57 <adamw> as commented in the bug i'm inclined to -1 on this.
17:21:29 <bcl> As am I/
17:21:31 <bcl> .
17:21:48 <roshi> -1, seems like
17:21:51 <jreznik_2nd> would be nice to have some heurestics but it's not blocker for me, -1
17:21:53 <kparal> I don't oppose that, but I don't think that trying to create fedora installation as small as possible is that edge-case use case
17:21:58 <bcl> No matter what we do it's going to be wrong for someone.
17:22:12 <nirik> yeah, and if there's a hard coding people will be mad they can't override it. ;)
17:22:17 <roshi> rather, seems like "when I try to break it - it breaks"
17:22:19 <kparal> bcl: the point is to boot into gnome, not to be right for everyone
17:22:37 <jreznik_2nd> kparal: if you want to do something like that, you can just experiment
17:23:08 <nirik> so I guess there was enough space to have rpm ok with installing, but not enough after that to be usable?
17:23:08 <bcl> kparal: then resize larger :) For gnome 100M won't matter. For a virt it could be very annoying.
17:23:15 <kparal> nirik: yes
17:23:30 <kparal> bcl: if anaconda tells user, I'd be more than happy
17:23:39 <adamw> is this anything new since f20?
17:23:47 <bcl> no
17:23:48 <kparal> it doesn't have to forbid it, just help the user avoid the mistake he doesn't even know about
17:23:51 <nirik> but if we make that so it's 99% full and you can login, but can't save a document...
17:24:03 <nirik> ie, how much space is 'enough'
17:24:11 <bcl> right. we can't know.
17:24:15 <jreznik_2nd> yep
17:24:22 <kparal> nirik: that's why I proposed some small hardcoded number like 500 MB
17:24:27 <bcl> And any padding attempts will be wrong for other use cases.
17:24:52 <kparal> if the system boots, then the user can actually learn that the disk space is too small and can install again
17:25:00 <kparal> if the system doesn't boot...
17:25:33 * nirik thinks this is a perfectly fine thing to look at for f22. ;) but is -1 to blocking f21 on it.
17:25:55 <kparal> I think you're confusing the bug report with "can't please everyone" approach, which is not what this is about
17:26:35 <kparal> make it work badly, but make it work
17:26:38 <kparal> that's what this is about
17:26:58 <nirik> this just seems like a very corner case to be messing with right now.
17:26:58 <roshi> proposed #agreed - 1165781 - RejectedBlocker - The installer currently does the best it can to handle this without hardcoded values. As it's more of an edge-case, it's not considered blocking for release.
17:26:59 <kparal> sure, can be a target for f22
17:27:09 <kparal> probably was broken in the past for a long time
17:27:26 <nirik> roshi: +1
17:27:35 <roshi> who's secretarializing?
17:27:42 <jreznik_2nd> ack
17:27:49 <adamw> not sure about the wording, i think anaconda could *possibly* do more here but it's not a blocker, but eh
17:27:58 <adamw> ack
17:28:05 <adamw> i can secretarialize if no-one else is
17:28:22 <roshi> I wasn't sure the best way to word it, that was one of several iterations
17:28:59 <roshi> #agreed - 1165781 - RejectedBlocker - The installer currently does the best it can to handle this without hardcoded values. As it's more of an edge-case, it's not considered blocking for release.
17:29:07 <roshi> #topic (1166730) the existence of an unaligned partition precludes anaconda installation without any obvious error
17:29:10 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1166730
17:29:13 <roshi> #info Proposed Blocker, anaconda, NEW
17:30:32 <nirik> do we know any cases of things that make unaligned partitions like this?
17:30:46 <kparal> I hoped dlehman would be able to look at it
17:30:50 <roshi> windows has done it to me before (in the past)
17:30:54 * jreznik_2nd is watching video
17:30:57 <adamw> well we clearly know there's at least *one*
17:31:02 <kparal> nirik: I created it just to verify a different bug
17:31:06 <adamw> parted :P
17:31:20 <nirik> well, I meant something like another os... yeah.
17:31:37 <nirik> so windows users could hit this in theory...
17:31:49 <kparal> I guess so, especially when using some third-party tools
17:32:26 <nirik> ERR anaconda: vda may not have enough space for grub2 to embed core.img when using the ext4 file system on partition
17:32:34 <kparal> I can begin installation > I can't begin installation
17:32:36 <nirik> so this unaligned was /dev/vda1 ?
17:32:41 <kparal> why oh why I can't edit bugzilla comments
17:32:41 <bcl> 512B is likely the problem here. You're not going to have room for grub.
17:32:49 * nirik nods.
17:33:18 <bcl> I'd be more worried if it was starting > 1M and still failing.
17:33:23 <kparal> bcl: that didn't occur to me. I can try again with the partition moved
17:33:27 <bcl> granted, a better error would be nice.
17:33:35 <kparal> 'any error' :-)
17:33:44 <kparal> explanation
17:33:59 <bcl> actually, I thought we did have one about starting too low.
17:35:55 <adamw> that's what that error message says, to me. maybe it's a bit jargony, but "not enough space for grub2 to embed core.img'...
17:36:16 <kparal> ouch, my mistake then. so the problem is a bit different
17:36:52 <bcl> oh, right, nirik found it.
17:37:52 * kparal quickly trying again
17:37:52 <bcl> kparal: so did the error show up in the storage spoke error bar?
17:37:54 <nirik> well, that was in the anaconda.log...
17:38:04 * nirik didn't look at the video
17:38:18 <bcl> If not, then that's the only problem, but shouldn't be a blocker.
17:38:52 <kparal> ok, if I create the partition with 1 MB space from the disk start, anaconda works as expected
17:39:05 <nirik> bcl: yeah, no error on the spoke.
17:39:11 <bcl> darn.
17:39:18 <nirik> (from the video)
17:39:35 <adamw> yeah, it seems like the error doesn't show up in the GUI
17:39:50 <bcl> My FF doesn't like the video. offers to open with rythembox
17:39:55 <nirik> so, -1 blocker, +1 FE if the error is easy to fix?
17:40:01 <adamw> still, i'm -1 if the problem is the partition alignment, that's no new error case
17:40:06 <nirik> totem played it fine here.
17:40:25 <adamw> i could +1 FE an improvement to displaying partitioning errors if it's safe and lands soon
17:40:37 <bcl> at this point I'd leave it alone.
17:40:59 <roshi> yeah
17:41:00 <nirik> alright.
17:41:04 <roshi> -1/+1
17:41:29 <jreznik_2nd> ok, so -1/+1
17:41:35 <nirik> dunno how common it would be, but might warrent a common bugs (if you try and install and get an error, but it doesn't show what error, check anaconda.log?)
17:42:14 * kparal needs to go away for a bit
17:43:36 <bcl> nirik: seems reasonable in any case. always read the logs :)
17:43:36 <roshi> proposed #agreed - 1166730 - RejectedBlocker AcceptedFreezeException - This bug isn't severe enough to block on, but we would consider a fix to displaying errors better if it's simple and lands soon.
17:43:50 <nirik> bcl: true enough.
17:43:50 <adamw> ack
17:43:53 <nirik> ack
17:43:54 <pschindl> ack
17:43:56 <jreznik_2nd> ack
17:44:10 <roshi> #agreed - 1166730 - RejectedBlocker AcceptedFreezeException - This bug isn't severe enough to block on, but we would consider a fix to displaying errors better if it's simple and lands soon.
17:44:18 <roshi> #topic (1167014) Manual partitioning using single partition: unable to escape from Partitioning page except with workaround
17:44:21 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1167014
17:44:23 <adamw> so everyone's OK with me editing the bug quite a lot to explain what the real issue is?
17:44:23 <roshi> #info Proposed Blocker, anaconda, NEW
17:44:30 * roshi is
17:46:25 <nirik> adamw: editing? you mean adding ? ;)
17:47:44 * nirik waits for adamw's comment, gets more coffee.
17:48:59 <adamw> nirik: well, changing the topic too
17:49:01 <adamw> i did it now
17:49:13 <adamw> (1166730)
17:49:40 * bcl checks to see if he can reproduce.
17:49:43 <nirik> oh, that one, I thought you meant this one... ( 1167014 )
17:49:47 <adamw> ah, sorry
17:51:27 <adamw> hi dlehman
17:51:33 <dlehman> hi
17:51:34 <nirik> more reproducers here would be good... looks like kparal couldn't reproduce it.
17:51:50 <roshi> yeah
17:51:58 <roshi> doesn't look like it's easy to hit
17:52:47 <adamw> sounds like kparal is having trouble reproducing, yeah
17:52:49 <bcl> yeah, works for me. can't make it not escape, even when there's a real error.
17:53:09 <adamw> even if there's a real bug here i think i'd be OK documenting the workaround
17:53:51 <nirik> the logs seem like they are from a successfull install...
17:54:16 <roshi> proposed #agreed - 1167014 - RejectedBlocker - This bug isn't easy to reproduce but has an easy workaround when you do run into it. Document on Common Bugs.
17:54:39 <pschindl> ack
17:54:56 <jreznik_2nd> ack
17:55:13 <adamw> do we want to consider FE?
17:55:20 <adamw> well, maybe only with a clear reproducer
17:55:26 <nirik> yeah. ack.
17:55:38 <roshi> I wouldn't want to do an FE for this until more people hit it
17:55:38 <adamw> i'll add a note that it's OK to repropose for FE if a clear reproducer can be found
17:55:45 <roshi> sounds good
17:55:53 <roshi> #agreed - 1167014 - RejectedBlocker - This bug isn't easy to reproduce but has an easy workaround when you do run into it. Document on Common Bugs.
17:56:05 <roshi> #topic (1165856) CVE-2014-7850 freeipa: XSS flaw can be used to escalate privileges [fedora-all]
17:56:08 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1165856
17:56:11 <roshi> #info Proposed Blocker, freeipa, ON_QA
17:57:41 <nirik> this is a "moderate" level cve...
17:58:08 <adamw> the criterion states "The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update (e.g. issues during installation). "
17:58:10 <nirik> did we have a security critera? anyhow, I am +1 to pulling it in, either as a blocker or fe
17:58:11 <adamw> https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Security_bugs
17:58:14 <adamw> so, going by the book, -1/+1
17:58:26 <nirik> sure. -1/+1
17:58:41 <roshi> -1/+1
17:59:03 * jreznik_2nd is blind but does not see clasification in the bug
17:59:28 <nirik> it's in the CVE bug that one is linked to
17:59:46 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1165280
17:59:54 <jreznik_2nd> yea, it's there moderate - -1/+1
18:00:53 <roshi> proposed #agreed - 1165856 - RejectedBlocker AcceptedFreezeException - The CVE isn't classified high enough to block release, but we would accept a fix before release.
18:00:58 <nirik> ack
18:01:01 <jreznik_2nd> ack
18:02:01 <adamw> ack
18:02:08 <roshi> #agreed - 1165856 - RejectedBlocker AcceptedFreezeException - The CVE isn't classified high enough to block release, but we would accept a fix before release.
18:02:23 <roshi> #topic (1163698) Webcam not working in kamoso
18:02:24 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1163698
18:02:24 <roshi> #info Proposed Blocker, kamoso, VERIFIED
18:03:36 <pschindl> kamoso isn't installed in default is it?
18:03:48 <jreznik_2nd> I think it is
18:04:00 <jreznik_2nd> rdieter told me so
18:04:29 <pschindl> ah, it is default in KDE, I see. Ok. Then if it is installed in default, then this should be blocker
18:04:57 <jreznik_2nd> yep, +1 blocker
18:04:57 <adamw> i can +1 as per #c20, but in my black little excuse for a heart i suspect that if we didn't have a fix for this and this was go/no-go, we'd find a way to fudge it...
18:04:58 <nirik> we have a fix in hand it seems too...
18:05:03 <nirik> +1 blocker
18:05:05 <nirik> adamw: me too.
18:05:20 <pschindl> +1
18:05:29 <roshi> +1 if it's default
18:05:51 <kparal> +1
18:05:58 * kparal is back
18:06:23 <roshi> proposed #agreed - 1163698 - AcceptedBlocker - This bug is a clear violation of the criterion: All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.
18:06:30 <adamw> ack
18:06:47 <kparal> ack
18:07:05 <jreznik_2nd> ack
18:07:06 <roshi> #agreed - 1163698 - AcceptedBlocker - This bug is a clear violation of the criterion: All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.
18:07:31 <roshi> #topic (1164609) CVE-2014-8600 kwebkitpart, kde-runtime: Insufficient Input Validation By IO Slaves and Webkit Part [fedora-all]
18:07:34 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1164609
18:07:37 <roshi> #info Proposed Blocker, kde-runtime, ON_QA
18:08:11 <jreznik_2nd> low impact, -1/+1
18:08:25 <adamw> yeah
18:08:54 <roshi> -1/+1
18:09:03 <nirik> -1/+1
18:09:54 <roshi> proposed #agreed - 1164609 - RejectedBlocker AcceptedFreezeException - This CVE isn't a high enough classification to block release. However, we would accept a fix before release.
18:09:58 <adamw> ack
18:10:00 <jreznik_2nd> ack
18:10:03 <kparal> ack
18:10:10 <roshi> #agreed - 1164609 - RejectedBlocker AcceptedFreezeException - This CVE isn't a high enough classification to block release. However, we would accept a fix before release.
18:10:17 <roshi> #topic (1164607) CVE-2014-8600 kwebkitpart: kwebkitpart, kde-runtime: Insufficient Input Validation By IO Slaves and Webkit Part [fedora-all]
18:10:20 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1164607
18:10:23 <roshi> #info Proposed Blocker, kwebkitpart, MODIFIED
18:10:43 <nirik> thats the same one?
18:10:52 <adamw> sure looks like it
18:10:59 <roshi> yeah, it does
18:11:04 <nirik> got proposed twice... the cve bug and the child bug
18:11:05 <adamw> two packages, but that doesn't need two bugs, you wouldn't think...
18:11:12 <adamw> ah, darn security procedures
18:11:14 <roshi> same CVE too
18:11:46 <roshi> proposed #agreed - 1164607 - RejectedBlocker AcceptedFreezeException - This CVE isn't a high enough classification to block release. However, we would accept a fix before release.
18:11:50 <jreznik_2nd> ack
18:11:55 <pschindl> ack
18:12:06 <adamw> -1
18:12:07 <adamw> nack
18:12:08 <adamw> whatever
18:12:15 <adamw> this doesn't seem like even cve bug and child bug
18:12:24 <adamw> they just seem like dupes
18:12:43 <adamw> so i'd say we should close one
18:12:44 <nirik> yeah, whatever to undupe them and have only one of them
18:12:47 <roshi> then we can just unpropose it and link it to the one we just voted on
18:12:48 * nirik nods
18:13:36 <jreznik_2nd> one is in kde-runtime, one in kdewebkitpart
18:14:02 <jreznik_2nd> (to grab both packages)
18:14:03 <adamw> yeah
18:14:06 <adamw> i was right the first time
18:14:21 <adamw> i guess i'd expect one bug report and one update with both packages, but hey. +1
18:15:17 <nirik> ok, then ack this one too and move on. ;)
18:16:25 <roshi> we don't need an agreed for this
18:16:31 <roshi> we're done with proposed blockers
18:16:36 <roshi> now to FEs
18:16:57 * jreznik_2nd has to move home now as he has another meeting 9 pm, will be available on passport
18:17:00 <roshi> any other blockers that people have?
18:17:11 <roshi> thanks jreznik_2nd
18:17:55 <nirik> lets hit the fe's. ;)
18:17:58 <adamw> don't think so
18:18:12 <roshi> cool, onto FEs
18:18:18 <roshi> #topic (1167016) ark-4.14.3-1 :  crash on exit
18:18:18 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1167016
18:18:18 <roshi> #info Proposed Freeze Exceptions, ark, MODIFIED
18:19:46 <nirik> sure. +1 FE.
18:20:22 <adamw> yup
18:20:34 <roshi> yeah
18:21:16 <roshi> proposed #agreed - 1167016 - AcceptedFreezeException - A fix will be considered for this despite freeze.
18:21:49 <adamw> ack
18:22:01 <nirik> ack
18:22:09 <roshi> #agreed - 1167016 - AcceptedFreezeException - A fix will be considered for this despite freeze.
18:22:16 <roshi> #topic (1166189) gearbox requires ice
18:22:17 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1166189
18:22:17 <roshi> #info Proposed Freeze Exceptions, gearbox, NEW
18:22:58 <kparal> +1 fe
18:22:59 <roshi> +1
18:23:00 <nirik> +1 FE
18:23:05 <roshi> already has votes in bug
18:23:17 * pschindl has to leave. Good night.
18:23:19 * nirik is double voting. ;)
18:23:28 <roshi> proposed #agreed - 1166189 - AcceptedFreezeException - A fix will be considered for this despite freeze.
18:23:33 <kparal> ack
18:23:34 <pschindl> ack
18:23:36 <roshi> night pschindl
18:23:39 <roshi> thanks for coming
18:23:47 <roshi> I saw what you did there nirik - sneaky
18:24:19 <adamw> ack
18:24:21 <roshi> #agreed - 1166189 - AcceptedFreezeException - A fix will be considered for this despite freeze.
18:24:23 <nirik> ack
18:25:01 <roshi> #topic (1163698) Webcam not working in kamoso
18:25:02 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1163698
18:25:02 <roshi> #info Proposed Freeze Exceptions, kamoso, VERIFIED
18:25:14 <roshi> we can skip this one, already accepted it as a blocker
18:25:17 <adamw> yup
18:25:41 <roshi> and two more are those CVE dupes
18:25:44 <roshi> I'll skip those
18:25:45 <roshi> #topic (1158848) Unable to write to /dev/console and /dev/ttyS0 on s390x
18:25:48 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1158848
18:25:51 <roshi> #info Proposed Freeze Exceptions, kernel, MODIFIED
18:26:54 <adamw> this is secondary arch stuff, right
18:27:04 <nirik> yep
18:27:07 <nirik> +1 FE
18:27:15 <roshi> +1
18:27:27 <roshi> having no console
18:27:32 <roshi> not fun
18:27:35 <adamw> yeah, iirc we allow secondary arch showstoppers to be FE so they're not stuck while we're in freeze for primary
18:27:36 <adamw> +1
18:28:06 <roshi> proposed #agreed - 1158848 - AcceptedFreezeException - A fix would be considered before release.
18:29:02 <adamw> ack
18:29:29 <nirik> ack
18:29:40 <roshi> #agreed - 1158848 - AcceptedFreezeException - A fix would be considered before release.
18:29:52 <roshi> #topic (1166193) Octomap requires ice
18:29:52 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1166193
18:29:52 <roshi> #info Proposed Freeze Exceptions, octomap, NEW
18:29:59 * oddshocks pops in
18:30:32 <nirik> +1 FE
18:30:43 <adamw> same as the last one?
18:30:57 <roshi> yeah, same as last one - different package though
18:31:03 <roshi> +1
18:31:03 <adamw> "I'd like to get it into the repositories before final so that the srpm in the "fedora" is buildable"
18:31:04 <adamw> ehhh
18:31:08 <adamw> well, I guess.
18:31:15 <adamw> +1, sure, whatever, i'm feeling charitable
18:31:34 <nirik> hum
18:31:41 <nirik> I don't actually see it as a broken dep...
18:31:49 <roshi> it could be fixed with updates anyways, right?
18:31:55 * roshi isn't familiar with octomap
18:32:50 <nirik> yeah, looks like the one in base repo is installable fine.
18:32:56 * nirik digs some more
18:33:33 <adamw> it's a broken *build* dep. aiui.
18:33:48 <adamw> see the bit i quoted.
18:34:05 <nirik> ah... I see. yeah.
18:34:06 <roshi> yeah
18:34:12 <roshi> I dunno that this needs an FE
18:34:36 <nirik> well, the one in the base repo will not be buildable...
18:34:43 <nirik> but not sure how many people would care.
18:35:00 * nirik is fine with +1 since it's a corner package...
18:35:56 <roshi> yeah, it's not going to affect much aiui
18:36:00 <adamw> yeah, it's kinda 'on the one hand who cares, on the other hand it can't break anything important' thing
18:36:09 <roshi> yup
18:37:09 <sgallagh> /me reappears
18:37:35 * kparal has some new info about 1158533
18:37:38 <adamw> eh, let's just pick something and go with it
18:38:02 <roshi> +1
18:38:27 <roshi> proposed #agreed - 1166193 - AcceptedFreezeException - We'll consider a fix for this before release.
18:38:32 <nirik> ack
18:38:40 <roshi> then we can get to kparal's info
18:39:05 <kparal> ack
18:39:18 <roshi> #agreed - 1166193 - AcceptedFreezeException - We'll consider a fix for this before release.
18:39:22 <adamw> ack
18:39:31 <roshi> that's it for FEs
18:39:36 <roshi> whatcha got kparal ?
18:39:50 <kparal> last two comments at https://bugzilla.redhat.com/show_bug.cgi?id=1158533
18:40:05 <roshi> #topic (1158533) selecting one disk from VG spanning over multiple disks causes troubles
18:40:08 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1158533
18:40:43 <kparal> if that helps, we can decide on it right away. or we can do some more testing. but atm I'm out of ideas what to test more
18:40:55 <roshi> seems like it's not reproducible at all
18:41:01 <kparal> for me
18:42:15 <adamw> try it with only one disk *connected* instead of all connected but only one selected?
18:42:36 <kparal> ah
18:42:56 <adamw> roshi: https://bugzilla.redhat.com/show_bug.cgi?id=1167047 just appeared as a proposed FE
18:43:06 <kparal> it will take a minute
18:44:05 <roshi> +1 on that FE
18:44:06 <kparal> guided part worked
18:44:34 <nirik> +1 on that FE as well.
18:44:36 <kparal> and I can't easily retest other avenues, since I deleted my snapshot
18:44:46 <kparal> so, tomorrow if needed
18:45:01 <adamw> i think it'd be worth giving it a few more tries tomorrow
18:45:08 <adamw> we aren't in any hurry to decide, we have wednesday's meeting
18:45:34 <kparal> alright
18:45:39 <roshi> proposed #agreed - 1167047 - AcceptedFreezeException - We would consider a fix for this before release.
18:45:50 <roshi> yeah, I can test it here as well and see if I can reproduce it
18:45:54 <kparal> roshi: might be a good idea to change #topic?
18:46:12 <roshi> yeah, writing it up now
18:46:28 <roshi> #topic (1167047) Kickstart line selinux --disabled has no effect
18:46:28 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1167047
18:46:28 <roshi> #info Proposed Freeze Exceptions, anaconda, POST
18:46:32 * kparal needs to go, see you
18:46:37 <roshi> have a good night
18:46:37 <adamw> cya kparal
18:46:42 <adamw> thanks
18:46:49 <nirik> night kparal
18:46:52 <kparal> +1 and ack here
18:47:05 <adamw> might even be blocker? /me checks criteria
18:47:27 <kparal> that's the famous one missing I believe
18:47:35 <kparal> still on my #action list somewhere
18:47:40 <adamw> oh, no, criteria only say it has to be enabled by default
18:47:44 <adamw> not that disabling it has to work
18:47:45 <adamw> so, +1 fe
18:49:07 <nirik> +1 fe as noted before
18:49:26 <roshi> so acks?
18:49:34 <roshi> proposed #agreed - 1167047 - AcceptedFreezeException - We would consider a fix for this before release.
18:49:40 <nirik> ack
18:50:13 <adamw> ack
18:50:34 <roshi> #agreed - 1167047 - AcceptedFreezeException - We would consider a fix for this before release.
18:50:38 <roshi> and that's it
18:50:43 <roshi> anybody have anything else?
18:50:50 <roshi> #topic Open Floor
18:51:45 * roshi sets the fuse
18:51:48 <roshi> 3...
18:51:55 <nirik> kaboom!
18:52:04 <roshi> 2...
18:52:27 <roshi> 1...
18:52:30 <adamw> nirik: i think you need to check the warranty on your fuses.
18:52:33 <roshi> thanks for coming folks!
18:52:42 <roshi> yeah, their QA team seems to be slacking...
18:52:52 <nirik> adamw: it's evil super villan checklist. Always make bombs go off on 3. ;)
18:53:14 <adamw> that would be a *competent* evil super villain, then, so not one who ever shows up in movies?
18:53:32 <adamw> fedora fuses always go off at 2.73, but we have the workaround documented.
18:53:34 <roshi> one that doesn't get caught monologing?
18:54:05 <roshi> #endmeeting