f21-blocker-review
LOGS
15:59:26 <roshi> #startmeeting F21-blocker-review
15:59:26 <zodbot> Meeting started Wed Jul 16 15:59:26 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:27 <roshi> #meetingname F21-blocker-review
15:59:27 <zodbot> The meeting name has been set to 'f21-blocker-review'
15:59:29 <roshi> #topic Roll Call
15:59:37 <jsmith> .hellomynameis jsmith
15:59:38 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
15:59:47 * jsmith will be in and out
15:59:51 * nirik is lurking around.
15:59:55 * ignatenkobrain here
16:00:12 * kalev joins the lurkers club.
16:00:53 <adamw> ahoyhoy
16:01:25 <roshi> o/
16:01:31 <roshi> #topic Introduction
16:01:31 <roshi> Why are we here?
16:01:31 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:01:35 <roshi> #info We'll be following the process outlined at:
16:01:37 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:01:40 <roshi> #info The bugs up for review today are available at:
16:01:42 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:01:45 <roshi> #info The criteria for release blocking bugs can be found at:
16:01:47 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:01:48 * jreznik is here, just blocked on other meeting
16:01:50 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:01:53 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
16:02:03 <roshi> sounds good jreznik
16:02:12 * pwhalen is here
16:02:28 <roshi> onto the proposed blockers :)
16:02:29 <roshi> #topic (1117965) Fedora needs per-Product Configuration files
16:02:29 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1117965
16:02:31 <roshi> #info Proposed Blocker, distribution, NEW
16:03:54 <roshi> I'm +1 for this, it makes sense to get this ironed out before a release
16:04:14 <ignatenkobrain> +1
16:04:56 <roshi> The firewall criteria works for me, but I feel like there should be a process criteria of some sort
16:05:02 <adamw> workstation has https://fedoraproject.org/wiki/Workstation/Technical_Specification#Firewall in its criteria
16:05:25 <adamw> i can kinda see the point here, but it seems rather indirect to me. it'd be clearer if the bug was 'the Server firewall configuration is not as it should be'.
16:05:41 <roshi> yeah
16:05:42 <adamw> this is kind of a background issue that prevents that bug being fixed, there's a level of indirection
16:06:32 <roshi> that's true
16:06:36 * dgilmore is not really here
16:06:57 * adamw waves a hand right through dgilmore
16:07:08 <roshi> though, the bug is aimed at a more general fix for other things as well
16:07:32 <roshi> if it was just a firewall bug, they could end up fixing *just* the firewall example and nothing else
16:07:44 <roshi> aiui anyway
16:08:24 <kalev> makes sense to sort this out before alpha, but maybe reclassify as a freeze exception, not a blocker?
16:08:49 <roshi> I would see the firewall not being right in server as a blocker, and this as a FE
16:09:01 <roshi> but we'd need a new bug created
16:09:08 <roshi> oh
16:09:17 <roshi> any volunteers for secretary duty today?
16:10:38 * jsmith can't
16:11:00 * adamw can
16:11:13 <roshi> thanks adamw :)
16:11:24 <adamw> i'd see the firewall bug being a blocker and depending on this bug
16:11:31 <roshi> so, thoughts on reclassifying this as a FE?
16:11:35 <adamw> (our blocker tools handle that as you'd expect)
16:12:39 <roshi> so how do we want to handle this, +1 on this being a blocker and file another bug depending on this one?
16:15:13 * tflink needs to put the blocker review meetings on his calendar
16:15:22 <roshi> er, the other way around - firewall bug created, as a blocker and depending on this bug
16:15:52 <roshi> I should make sure they're in fedocal as well
16:17:05 <roshi> +1/0/-1?
16:19:05 <tflink> are there other configuration things which are different? it sounds like firewalld was just an example
16:19:29 <adamw> the layout would work in general
16:19:32 <roshi> yeah - that was the impression I got as well
16:19:38 <adamw> have all actual blocker bugs that require variant configuration depend on this bug
16:19:38 <pwhalen> he eludes to that, but only one given
16:20:00 <adamw> if we vote +1 blocker on a theoretical bug for server firewall config, I'll create it as part of secretary duty
16:20:47 <roshi> +1 on theoretical bug blocker
16:21:04 <roshi> it makes sense at a high level that each product needs a conf for this kind of stuff
16:21:11 <tflink> +1 on not-yet-created firewall config bug
16:21:29 <roshi> but we don't really have a "The process we use needs fixed" criteria for this specific bug to be a blocker, per se
16:21:56 <roshi> which could potentially be a good idea to have with the .next stuff going on
16:22:51 <mattdm> right now, I think firewall is the only practical example, but we definitely want it for more things in the future
16:24:09 <roshi> so I'm seeing 3 +1 on theoretical blocker bug
16:24:15 <roshi> any more?
16:24:23 <adamw> roshi: i don't think so, i think bug deps handle it fine.
16:24:37 <pwhalen> +1 on theoretical blocker bug
16:24:48 <mattdm> httpd might be one concrete (but not-actually-yet-really) example -- gnome-user-share pulls it in to use for local-network file sharing, and the configuration for that is obviously different from a web server httpd config
16:25:08 <mattdm> (just for example. carry on with actual non-sidetracked meeting....)
16:25:17 <adamw> mattdm: sure, so if httpd functions are release blocking, that bug could be a blocker and depend on the config bug too.
16:25:19 <adamw> it all works. ;)
16:25:42 <mattdm> adamw: hmm okay :)
16:26:55 <roshi> adamw: got a proposed #agreed for this? Not sure how to word it for this usecase...
16:27:27 <roshi> #chair adamw pwhalen tflink
16:27:27 <zodbot> Current chairs: adamw pwhalen roshi tflink
16:27:41 <adamw> propose #agreed 1117965 is not a blocker in itself, but needs to be fixed for an actual as-yet-unreported blocker bug (server firewall configuration) to be resolved. we will report the server firewall bug, accept it as a blocker, and have it depend on this bug.
16:28:01 <roshi> ack
16:28:11 <ignatenkobrain> ack
16:28:13 <pwhalen> ack
16:28:26 <tflink> ack
16:28:32 <kalev> ack
16:28:34 <adamw> do i have a chair?
16:28:38 <roshi> yup
16:28:42 <adamw> #agreed 1117965 is not a blocker in itself, but needs to be fixed for an actual as-yet-unreported blocker bug (server firewall configuration) to be resolved. we will report the server firewall bug, accept it as a blocker, and have it depend on this bug.
16:28:46 <roshi> thanks :)
16:28:52 <roshi> ok, next bug
16:28:55 <roshi> #topic (1088933) update grubby to support device tree options for arm
16:28:58 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1088933
16:29:01 <roshi> #info Proposed Blocker, grubby, POST
16:30:59 <pwhalen> dgilmore, looks like your patch needs to be reworked, have you had a chance to look at it ?
16:33:15 <pwhalen> this is a pretty big requirement for arm systems - with out the fdtdir the system wont boot.
16:33:24 <pwhalen> +1
16:33:25 <dgilmore> pwhalen: i already know yes
16:33:29 <dgilmore> need time to do so
16:33:31 <roshi> it's a clear blocker imo
16:33:32 <roshi> +1
16:34:00 <ignatenkobrain> +1
16:34:02 <tflink> +1
16:35:11 <roshi> proposed #agreed - 1088933 - AcceptedBlocker - This clearly violates the Alpha criteria: "All release-blocking images must boot in their supported configurations."
16:35:29 <jreznik> ack
16:35:30 <pwhalen> ack
16:35:43 <ignatenkobrain> фсл
16:35:44 <ignatenkobrain> ack
16:35:58 <tflink> ack
16:35:59 <roshi> #agreed - 1088933 - AcceptedBlocker - This clearly violates the Alpha criteria: "All release-blocking images must boot in their supported configurations."
16:36:11 <roshi> #topic (1119380) AttributeError: 'Flags' object has no attribute 'targetarch'
16:36:14 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1119380
16:36:16 <roshi> #info Proposed Blocker, kexec-tools, NEW
16:36:59 <ignatenkobrain> +1 from me
16:37:22 <tflink> not sure I understand what's going on
16:37:45 <ignatenkobrain> tflink: crash when using anaconda I think
16:37:45 <tflink> is this a crash on startup or a metacrash?
16:37:49 <roshi> anaconda is crashing on a depreciated flag?
16:38:17 <ignatenkobrain> on backtrace seems after start
16:38:18 <roshi> pwhalen?
16:39:10 <pwhalen> this happens right after choosing text install
16:39:19 <ignatenkobrain> yes. I'm right
16:40:06 <adamw> pwhalen: on ARM?
16:40:12 <roshi> so, violates "Installation interfaces" or installer must run?
16:40:22 <adamw> i'd say installation interfaces, since it only affects text
16:40:22 * roshi didn't see it in the bug
16:40:23 <ignatenkobrain> installer must run
16:40:34 <pwhalen> on arm - but i think i saw someone else mention it
16:40:45 <ignatenkobrain> https://github.com/daveyoung/kdump-anaconda-addon/pull/2/files
16:40:54 <ignatenkobrain> seems only ppc64
16:40:58 <tflink> the crash was on a wandboard, so I assume it's arm
16:41:38 <adamw> affects an x86_64 VM too
16:41:42 <adamw> i guess it's all arches, on a text install
16:41:45 <adamw> +1 blocker
16:41:48 <pwhalen> +1
16:41:48 <ignatenkobrain> adamw: I think we will get this error with gui installation
16:41:50 <mattdm> yeah was going to say -- this isn't just arm
16:41:51 <tflink> +1
16:41:53 <adamw> ignatenkobrain: no, only text.
16:41:55 <roshi> +1 -violates several criteria
16:41:58 <mattdm> it prevents the cloud images from getting made
16:42:06 <adamw> (i think)
16:42:08 <pwhalen> right, only on text. vnc install is working
16:42:22 <ignatenkobrain> adamw: ok.
16:42:27 <kalev> if it prevents could images from getting made, then it's a clear blocker -- +1 from me
16:42:32 <jreznik> +1
16:43:29 <mattdm> i guess we could make the cloud images build with the gui instead of in text mode; I didn't expect it would ever have a negative impact!
16:43:34 <adamw> :P
16:43:39 * adamw pokes roshi
16:43:42 * randomuser notices he was pinged, starts paying attention
16:43:44 <roshi> proposed #agreed - 1119380 - AcceptedBlocker - This bug violates several Alpha criteria, most notably "Installation interfaces," which interferes with installation and cloud image creation.
16:43:59 <roshi> I was typing :p
16:44:03 <ignatenkobrain> ack
16:44:07 <pwhalen> ack
16:44:09 <kalev> ack
16:44:19 <adamw> ack
16:44:20 <jreznik> roshi: you should type faster!
16:44:21 <jreznik> ack
16:44:22 <roshi> #agreed - 1119380 - AcceptedBlocker - This bug violates several Alpha criteria, most notably "Installation interfaces," which interferes with installation and cloud image creation.
16:44:31 <adamw> someone from brno hand me that whip
16:44:56 <roshi> do we want to go over the accepted blockers, or move to the FE?
16:45:08 <tflink> delayed ack
16:45:09 <ignatenkobrain> I think we can move to FEs
16:45:25 <tflink> it's early enough that we don't really need to do the FEs
16:45:31 <jreznik> yep
16:45:54 <adamw> accepted blockers probably more significant
16:45:56 <roshi> that's kinda what I was thinking - but didn't know if people didn't feel fulfilled with a blocker meeting that was *only* an hour
16:46:19 <roshi> onto accepted blockers then :)
16:46:42 <roshi> #topic (1111417) anaconda should depend on NetworkManager-wifi
16:46:42 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1111417
16:46:42 <roshi> #info Accepted Blocker, anaconda, MODIFIED
16:47:05 <ignatenkobrain> oh.
16:47:31 <kalev> I don't see why anaconda should depend on a wifi support package
16:47:35 <roshi> looks like it's on track
16:47:44 <kalev> it should probably just be added to relevant products / spins in comps?
16:48:41 <ignatenkobrain> but when I want to install server from wifi? :P
16:49:05 <ignatenkobrain> cloud yes. but that's only for gui package, so I think it's correct fix
16:50:17 <roshi> in the GUI subpackage seems like the right place
16:50:34 <adamw> kalev: no, anaconda dep is the correct thing here.
16:50:47 <adamw> kalev: it's to ensure you can use a wifi connection during installation.
16:50:47 <randomuser> ignatenkobrain, you gest, but I've had to do some interesting things...
16:51:02 <roshi> as have I :)
16:51:12 <adamw> and yeah, this is on track (at last)
16:51:20 <roshi> for in home local stuff? wireless is more and more common for servers I would guess
16:51:35 <roshi> for those people who have servers in their house doing things :P
16:51:51 <roshi> well, things are on track - nothing to do for this one
16:51:55 <jreznik> like my r-pi on wifi
16:51:58 <roshi> moving onto the next!
16:52:02 <ignatenkobrain> go go go !
16:52:12 <roshi> #topic (1109603) dracut unable to boot 3.16 most of the time
16:52:12 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1109603
16:52:13 <roshi> #info Accepted Blocker, cloud-initramfs-tools, NEW
16:52:35 <adamw> this one seems to be sitting around a bit
16:53:12 <roshi> yeah
16:53:14 <jsmith> Yeah
16:53:25 <jsmith> A bit ol' +1 from me
16:53:28 <pwhalen> it does, we're going to test images that do not use 'dracut-modules-growroot' to make sure that is the cause
16:53:58 <roshi> so it is being worked on pwhalen?
16:54:50 <pwhalen> we're trying to narrow it down, i'llping pbrobinson to see if he had time to push the change to the ks
16:55:01 <roshi> sgtm
16:55:11 <roshi> anyone got anything else on this one?
16:55:56 * roshi moves on then
16:55:59 <roshi> #topic (1116478) [abrt] gnome-initial-setup: gdk_window_hide(): gnome-initial-setup killed by SIGSEGV
16:56:02 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1116478
16:56:05 <roshi> #info Accepted Blocker, gnome-initial-setup, NEW
16:56:23 <adamw> i'll give the desktop team a poke on this one
16:56:48 <roshi> that works
16:57:53 <roshi> next bug then - unless someone else has something
16:58:17 <roshi> #topic (1115120) cryptsetup-1.6.5-1.fc21 breaks booting when using luks partitions
16:58:20 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1115120
16:58:22 <roshi> #info Accepted Blocker, kernel, ASSIGNED
16:58:58 <roshi> looks like things are moving along
16:59:02 <roshi> should be fixed soon
16:59:49 <roshi> anyone have any comments here?
17:00:01 <ignatenkobrain> interesting bug, but go next
17:00:04 <roshi> two more accepted to look at
17:00:08 <roshi> #topic (1116450) Can't login to fresh rawhide installation (2014-07-04) if SELinux is enforcing
17:00:11 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1116450
17:00:14 <roshi> #info Accepted Blocker, lorax, MODIFIED
17:01:07 <ignatenkobrain> will fixed soonish
17:01:11 <roshi> things are moving along
17:01:12 <roshi> yeah
17:01:22 <ignatenkobrain> next ?
17:01:32 <roshi> that's what I'm thinking
17:01:40 <roshi> #topic (1044778) wandboard uboot missing serial line speed in console environment variable
17:01:43 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1044778
17:01:45 <roshi> #info Accepted Blocker, uboot-tools, NEW
17:02:32 <ignatenkobrain> seems easyfix, but not fixed
17:02:51 <ignatenkobrain> I think we want ping maintainer
17:02:54 <roshi> pwhalen: any movement on this one?
17:03:06 <ignatenkobrain> ah. Dennis
17:03:31 <pwhalen> in the works and expected soon
17:03:49 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1116450 should be fixed already, btw
17:04:06 <adamw> if anyone's seeing it in images dated, oh, 07-14 or later, that might be a problem (the fixed lorax landed 07-12)
17:04:39 <roshi> good to know
17:05:10 <roshi> well, that's it for accepted blockers
17:05:26 <roshi> since this one is in the works
17:06:36 <roshi> #topic Open Floor
17:06:47 <roshi> anyone have anything for open floor?
17:07:05 <adamw> PANIC
17:07:13 <ignatenkobrain> adamw: KERNEL ?
17:07:20 <ignatenkobrain> ;)
17:07:21 <adamw> COLONEL
17:07:52 <ignatenkobrain> adamw: COLONEL KERNEL PANIC... okay.
17:09:08 <roshi> well, if no one has anything I suppose I'll light the fuse...
17:09:12 <ignatenkobrain> roshi: when we will move to FEs ?
17:09:21 <adamw> ignatenkobrain: bit closer to freeze time
17:09:25 <roshi> too soon for FE's really
17:09:35 <ignatenkobrain> adamw: roshi: ah. ok.
17:09:44 <roshi> I would imagine this gets fixed before we ever get to it anyway
17:10:55 * roshi sets the Olde Timey powder fuse
17:12:22 <adamw> booooo
17:12:27 <adamw> quantum fuses are where it's at, man.
17:12:33 <adamw> i finished this meeting before it even *started*.
17:13:04 <roshi> we just have a bunch of them laying around, they never get used
17:13:54 <roshi> the thing with the quantum fuse is you never know if it really ended or just ended up in a super position of ended as well as not ended
17:14:21 <randomuser> physicists call that 'open floor phase'
17:14:31 <roshi> ah
17:15:07 <roshi> well, thanks for coming folks!
17:15:13 <roshi> #endmeeting