f20-blocker-review-#4
MINUTES

#fedora-blocker-review: F20-blocker-review

Meeting started by roshi at 17:02:22 UTC (full logs).

Meeting summary

  1. Roll Call (roshi, 17:03:17)
  2. Introduction (roshi, 17:04:05)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (roshi, 17:04:06)
    2. We'll be following the process outlined at: (roshi, 17:04:06)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (roshi, 17:04:06)
    4. The bugs up for review today are available at: (roshi, 17:04:06)
    5. http://qa.fedoraproject.org/blockerbugs/current (roshi, 17:04:06)
    6. The criteria for release blocking bugs can be found at: (roshi, 17:04:07)
    7. https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria (roshi, 17:04:07)
    8. https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria (roshi, 17:04:08)
    9. https://fedoraproject.org/wiki/Fedora_20_Final_Release_Criteria (roshi, 17:04:08)

  3. (1008137) BootLoaderError: bootloader install failed (roshi, 17:05:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1008137 (roshi, 17:05:47)
    2. Proposed Blocker, anaconda, NEW (roshi, 17:05:47)
    3. AGREED: - 1008137 - RejectedBlocker - Without solid reproduction steps, this isn't considered a blocker. (roshi, 17:17:38)

  4. (1008732) LUKSError: luks device not configured (roshi, 17:17:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1008732 (roshi, 17:17:50)
    2. Proposed Blocker, anaconda, NEW (roshi, 17:17:50)
    3. AGREED: - 1008732 - RejectedBlocker - There are no recent reproducers or crash reports associated with this bug and is thusly not considered a blocker. (roshi, 17:20:48)

  5. (1026834) method= combined with kickstart uses invalid repository (roshi, 17:21:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1026834 (roshi, 17:21:04)
    2. Proposed Blocker, anaconda, NEW (roshi, 17:21:04)
    3. AGREED: - 1026834 - Punt - Putting off a decision until this is reproduced with TC4. Please vote on blocker status in ticket. (roshi, 17:30:01)

  6. (1035799) f20 tc3, adding a new mount point, desired capacity empty, crash (roshi, 17:30:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035799 (roshi, 17:30:20)
    2. Proposed Blocker, anaconda, POST (roshi, 17:30:20)
    3. AGREED: - 1035799 - AcceptedBlocker - This bug violates the Final criteria: "The installer must be able to create and install to any workable partition layout... " (roshi, 17:38:06)

  7. (1036705) BootLoaderError: bootloader install failed when /boot on LV (roshi, 17:38:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1036705 (roshi, 17:38:30)
    2. Proposed Blocker, anaconda, NEW (roshi, 17:38:30)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1008137#c18 (Viking-Ice, 17:42:55)
    4. AGREED: - 1036705 - AcceptedBlocker - This bug violates the Final criteria: "The installer must be able to create and install to any workable partition layout... " (roshi, 17:47:52)

  8. (1035533) Fedora 20 final fedora-release and generic-release packages required for GA (roshi, 17:48:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035533 (roshi, 17:48:03)
    2. Proposed Blocker, fedora-release, ON_QA (roshi, 17:48:03)
    3. AGREED: - 1035533 - AcceptedBlocker - This violates the final criteria: "A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images ..." (roshi, 17:50:26)

  9. (1035531) Fedora 20 final release notes required for GA (roshi, 17:50:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035531 (roshi, 17:50:41)
    2. Proposed Blocker, fedora-release-notes, NEW (roshi, 17:50:41)
    3. AGREED: - 1035531 - AcceptedBlocker - This violates the final criteria: "The final branded release notes must be present on release-blocking images and the appropriately versioned generic release notes must be available in the release repository..." (roshi, 17:52:21)

  10. (1024223) fedup 19->20 failed with DVD iso upgrade (roshi, 17:53:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1024223 (roshi, 17:53:03)
    2. Proposed Blocker, fedup, NEW (roshi, 17:53:03)
    3. https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Upgrade_requirements (adamw, 17:55:10)
    4. https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Upgrade_requirements (mkrizek, 18:07:39)
    5. AGREED: - 1024223 - AcceptedBlocker - This bug conditionally violates the beta criteria: "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora..." (roshi, 18:11:25)

  11. (1035408) [abrt] gnome-shell-3.10.2.1-2.fc20: js_malloc: Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV) (roshi, 18:11:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035408 (roshi, 18:11:43)
    2. Proposed Blocker, gnome-shell, NEW (roshi, 18:11:43)
    3. AGREED: - 1035408 - RejectedBlocker - Without valid reproduction steps this is not considered a blocker. (roshi, 18:19:18)

  12. (1018317) Network Manager can't connect to OpenVPN network in F20 (roshi, 18:19:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1018317 (roshi, 18:19:37)
    2. Proposed Blocker, NetworkManager-openvpn, NEW (roshi, 18:19:37)
    3. AGREED: - 1018317 - RejectedBlocker AcceptedFreezeException - This bug doesn't directly violate any criteria and can be fixed with an update. A stable fix will be considered past freeze. (roshi, 18:25:29)

  13. (1035536) Final spin-kickstarts build required for Fedora 20 GA (roshi, 18:26:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035536 (roshi, 18:26:25)
    2. Proposed Blocker, spin-kickstarts, NEW (roshi, 18:26:25)
    3. AGREED: - 1035536 - AcceptedBlocker - This violates the final criteria: "A spin-kickstarts package which contains the exact kickstart files used to build the release must be present in the release repository." (roshi, 18:28:37)
    4. ACTION: adamw to ping mclasen regarding desktop size bug (roshi, 18:29:28)
    5. ACTION: brunowolff to reproduce bug 1036247 on TC4 (roshi, 18:34:40)

  14. (1023960) erlang-R16B-02.2.fc20 fails to build on secondary arches (roshi, 18:37:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1023960 (roshi, 18:37:26)
    2. Proposed Freeze Exceptions, erlang, ON_QA (roshi, 18:37:26)
    3. AGREED: - 1023960 - AcceptedFreezeException - A fix will be considered past freeze. (roshi, 18:42:05)

  15. (1033156) qt5-qtdeclarative ppc bootstrap build does not build on power. (roshi, 18:42:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1033156 (roshi, 18:42:28)
    2. Proposed Freeze Exceptions, qt5-qtdeclarative, ON_QA (roshi, 18:42:29)
    3. http://bugzilla.redhat.com/show_bug.cgi?id=103 "rpm-2.5.3-5.1 dumps core when I try to upgrade certain packages" (adamw, 18:44:27)
    4. AGREED: - 1033156 - AcceptedFreezeException - A fix will be considered past freeze. (roshi, 18:45:11)

  16. (1034940) qt5-qtwebkit 5.2.0-beta1 FTBFS on secondary arches (roshi, 18:45:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1034940 (roshi, 18:45:59)
    2. Proposed Freeze Exceptions, qt5-qtwebkit, ON_QA (roshi, 18:45:59)
    3. AGREED: - 1034940 - AcceptedFreezeException - A fix will be considered past freeze. (roshi, 18:47:02)

  17. (1027507) [abrt] gnome-initial-setup-3.10.1.1-2.fc20: magazine_chain_pop_head: Process /usr/libexec/gnome-initial-setup was killed by signal 11 (SIGSEGV) (roshi, 18:47:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027507 (roshi, 18:47:38)
    2. Proposed Freeze Exceptions, gnome-initial-setup, ON_QA (roshi, 18:47:38)
    3. AGREED: - 1027507 - AcceptedFreezeException - A fix will be considered past freeze. (roshi, 18:53:06)

  18. (1034790) Unable to start mariadb. (roshi, 18:53:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1034790 (roshi, 18:53:15)
    2. Proposed Freeze Exceptions, mariadb, MODIFIED (roshi, 18:53:15)
    3. AGREED: - 1034790 - RejectedFreezeException - The listed build never got pushed to stable, so there's nothing to push past freeze. (roshi, 18:56:11)

  19. (1031696) libvirt: machines get killed when scopes are destroyed (roshi, 18:56:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1031696 (roshi, 18:56:24)
    2. Proposed Freeze Exceptions, systemd, NEW (roshi, 18:56:24)
    3. AGREED: - 1031696 - RejectedFreezeException - There is no tested fix for this and one won't be considered past freeze. (roshi, 19:00:31)

  20. (1035764) Crashes with certain Google Drive documents (roshi, 19:00:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035764 (roshi, 19:00:47)
    2. Proposed Freeze Exceptions, webkitgtk3, MODIFIED (roshi, 19:00:47)
    3. AGREED: - 1035764 - AcceptedFreezeException - A fix will be considered past freeze. (roshi, 19:02:30)

  21. (1020974) incorrectly treats a disk with partially corrupt GPT as having no partition at all (roshi, 19:21:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1020974 (roshi, 19:21:31)
    2. Accepted Blocker, anaconda, ASSIGNED (roshi, 19:21:31)

  22. (1027947) Cannot change a partition's size, then return it to the original size (roshi, 19:26:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027947 (roshi, 19:26:15)
    2. Accepted Blocker, anaconda, ASSIGNED (roshi, 19:26:15)

  23. (864198) grubby fatal error updating grub.cfg when /boot is btrfs (roshi, 19:30:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864198 (roshi, 19:30:07)
    2. Accepted Blocker, grubby, ASSIGNED (roshi, 19:30:07)

  24. (1035462) initial-setup-text only displays timezone spoke (roshi, 19:37:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1035462 (roshi, 19:37:07)
    2. Accepted Blocker, initial-setup, VERIFIED (roshi, 19:37:07)

  25. (969524) qml-based systray plasma widgets unclickable on arm (roshi, 19:38:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=969524 (roshi, 19:38:59)
    2. Accepted Blocker, kdelibs, NEW (roshi, 19:38:59)
    3. http://koji.fedoraproject.org/koji/taskinfo?taskID=6247897 (pwhalen, 19:39:48)
    4. ACTION: jreznik to check with KDE guys regarding 1035462 (roshi, 19:41:45)

  26. (1004621) plasma-nm doesn't attempt to connect to any listed networks on Fedora KDE live (roshi, 19:42:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1004621 (roshi, 19:42:17)
    2. Accepted Blocker, kde-plasma-nm, ON_QA (roshi, 19:42:17)

  27. (1032921) KDE f20 TC2 x86_64 fails to shutdown from menu bar (roshi, 19:44:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1032921 (roshi, 19:44:22)
    2. Accepted Blocker, kde-workspace, MODIFIED (roshi, 19:44:22)

  28. (1000893) Desktop Live is oversized (larger than 1 GB) (roshi, 19:49:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1000893 (roshi, 19:49:45)
    2. Accepted Blocker, LiveCD, NEW (roshi, 19:49:45)

  29. (790339) [abrt] system-config-services-0.101.7-2.fc17: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "list_services" with signature "" on interface "org.fedoraproject.Config.Services.ServiceHerder" doesn't exist (roshi, 19:52:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=790339 (roshi, 19:52:22)
    2. Accepted Blocker, system-config-services, VERIFIED (roshi, 19:52:22)

  30. (1006386) Journal flushing often slow, can prevent system booting correctly (roshi, 19:54:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1006386 (roshi, 19:54:33)
    2. Accepted Blocker, systemd, NEW (roshi, 19:54:33)
    3. ACTION: jreznik to check with mschmidt regarding bug 1006386 (roshi, 19:57:02)

  31. (1026860) Instantiated service is not run, it stays in inactive state (and systemd debug log does not state why) (roshi, 19:57:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1026860 (roshi, 19:57:32)
    2. Accepted Blocker, systemd, NEW (roshi, 19:57:32)

  32. Open Floor (roshi, 19:58:23)


Meeting ended at 20:05:05 UTC (full logs).

Action items

  1. adamw to ping mclasen regarding desktop size bug
  2. brunowolff to reproduce bug 1036247 on TC4
  3. jreznik to check with KDE guys regarding 1035462
  4. jreznik to check with mschmidt regarding bug 1006386


Action items, by person

  1. adamw
    1. adamw to ping mclasen regarding desktop size bug
  2. brunowolff
    1. brunowolff to reproduce bug 1036247 on TC4
  3. jreznik
    1. jreznik to check with KDE guys regarding 1035462
    2. jreznik to check with mschmidt regarding bug 1006386


People present (lines said)

  1. roshi (292)
  2. adamw (188)
  3. Viking-Ice (61)
  4. cmurf (51)
  5. jreznik (48)
  6. pwhalen (44)
  7. nirik (25)
  8. pschindl (23)
  9. mkrizek (16)
  10. satellit (12)
  11. brunowolff (10)
  12. zodbot (8)
  13. danofsatx (4)
  14. sharkcz (4)
  15. satellit_f20 (1)
  16. tflink (0)


Generated by MeetBot 0.1.4.