cockpit
LOGS
14:05:51 <andreasn_> #startmeeting Cockpit
14:05:51 <zodbot> Meeting started Mon Jan 26 14:05:51 2015 UTC.  The chair is andreasn_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:05 <jscotka> stefw, I only want to inform about testing progress, using avocado. I've discussed it with andreasn_ ans mvollmer, nothing else
14:06:21 <andreasn_> #chair andreasn petervo jscotka FireDrunk
14:06:21 <zodbot> Current chairs: FireDrunk andreasn andreasn_ jscotka petervo
14:06:34 <andreasn_> anyone else?
14:07:18 <andreasn_> all right
14:07:20 <andreasn_> #topic Agenda
14:07:34 <andreasn_> * Testing progress
14:07:54 <andreasn_> * multi-select container
14:08:25 <andreasn_> anything else?
14:09:34 <FireDrunk> Has there been any progress regarding the Ubuntu Repo?
14:10:04 <andreasn_> no idea, we can take it on the Open Floor item
14:10:10 <FireDrunk> Haven't seen any updates on the mailing list, but i was a bit busy, so it might have slipped my inbox.
14:10:18 <andreasn_> #topic testing progress
14:10:27 <andreasn_> ok, jscotka, your topci
14:10:29 <andreasn_> topic
14:10:31 <jscotka> yes
14:10:53 <jscotka> So, I've done some progress.
14:11:14 <jscotka> avocado with some patch works as expected
14:11:27 <andreasn_> nice
14:11:41 <jscotka> output is linked in https://trello.com/c/3kNZ2Qw7/91-rework-integration-tests-for-ci-and-qe
14:11:51 <jscotka> there is tar.gz archive
14:12:22 <jscotka> inside ./html/results.html is nice what avocado did.
14:13:04 <jscotka> nowadays avocado have still no repaired all bugs, but are filled, and all  should be ready until devconf.
14:13:35 <andreasn_> cool
14:13:45 <andreasn_> great to hear!
14:13:45 <jscotka> and then I've created compilation test (as initial part of testing) So we can call it new test for cockpit. (It is written in bash)
14:14:58 <jscotka> andreasn_, stefw Could you please look at avocado reports and in case you would like to have some another info, you could directly file the issue to avocado, or to say me and I'll do that
14:15:08 <andreasn_> jscotka: sure
14:15:25 <andreasn_> I think stefw is a better fit for that than me
14:15:26 <jscotka> andreasn_, cool
14:15:40 <jscotka> more eyes more bugs :-)
14:16:07 <jscotka> It is everything from my side for testing update progress
14:16:16 <andreasn_> #action stefw needs to look at avocado reports
14:16:24 <andreasn_> thanks!
14:16:29 <jscotka> Do anyone have any quetiuons?
14:17:30 <andreasn_> seems not. Lets jump to the next item
14:17:32 <FireDrunk> Is there a description to setup a test environment?
14:17:43 <FireDrunk> (For these specific tests?)
14:18:20 <jscotka> FireDrunk, yes
14:18:31 <petervo> once it's ready to commit to master we'll need to rework this page
14:18:32 <petervo> https://github.com/cockpit-project/cockpit/blob/master/test/README
14:18:52 <jscotka> FireDrunk, here https://github.com/jscotka/cockpit/blob/new_test_structure/test/tests/setup.sh
14:19:19 <andreasn_> petervo: yeah, perhaps that should be part of the pull request
14:19:53 <FireDrunk> Looks good!
14:19:54 <jscotka> FireDrunk, But as I said, there are still some troubles in avocado what causes that it is not working well, need some patching of code of avocado, but hope that It will be ready in avocado until DevConf
14:21:20 <jscotka> petervo, Yes, sure. Now it is ready for playing
14:22:07 <petervo> ok, next topic?
14:22:16 <andreasn_> yep
14:22:20 <andreasn_> #topic multi-select container
14:22:21 <jscotka> petervo, and probably for some time there will be exist both ways, until all test will be rewritten
14:22:29 <jscotka> yep :-)
14:22:32 <andreasn_> https://github.com/cockpit-project/cockpit/issues/1517
14:23:02 <petervo> do you prefer disabled buttons to just doing both?
14:23:04 <andreasn_> so there exists a design for this, and I think petervo have some code ready
14:23:22 <andreasn_> petervo: disabled buttons for running containers?
14:23:27 <petervo> yes
14:23:51 <andreasn_> yeah, I think that's best. It would be consistent with the controls in the container page itself
14:24:02 <petervo> ok
14:24:22 <andreasn_> did you have a branch for your code that I can refer to in the issue tracker?
14:24:36 <andreasn_> (I saw it I think, but then lost it)
14:24:55 <petervo> https://github.com/cockpit-project/cockpit/pull/1724
14:25:12 <petervo> or
14:25:12 <petervo> https://github.com/petervo/cockpit/tree/docker-actions
14:25:29 <andreasn_> thanks!
14:25:46 <andreasn_> I linked to the merge request
14:26:33 <andreasn_> I can check it out and test it once you have the disabled buttons for running containers in
14:26:46 <andreasn_> thanks for hacking on this one!
14:27:10 <andreasn_> the docker container story will be much better after your and dominiks additions
14:27:51 <andreasn_> #info https://github.com/cockpit-project/cockpit/issues/1517
14:28:24 <andreasn_> #action andreasn to test the pull request once petervo's polish fixes are in
14:28:33 <andreasn_> all right, on to open floor?
14:28:42 <petervo> yep
14:28:58 <andreasn_> #topic Open Floor
14:29:09 <andreasn_> FireDrunk: you had a question about Ubuntu I think
14:29:24 <FireDrunk> Yeah, there were some rumors regarding an ubuntu repo.
14:30:00 <FireDrunk> I've been testing Fedora 21 with Cockpit, but moved to Ubuntu, because for some other software i needed Java 7, but F21 has Java 8 by default.
14:30:13 <FireDrunk> also, i'm using WebVirtManager, which is more likely to work on Ubuntu.
14:30:28 <andreasn_> I haven't heard of any ppa's myself
14:30:52 <andreasn_> but if there is one, we should add it to http://cockpit-project.org/running.html
14:30:57 <FireDrunk> I'm not that familiar with PPA
14:31:15 <FireDrunk> 's, but i can try to compile Cockpit on ubuntu, and see if that yields any good results.
14:31:27 <andreasn_> Personal Package Archive (I think), it's basically just a repo
14:31:43 <andreasn_> FireDrunk: that would be excellent
14:31:48 <FireDrunk> I know about PPA's, but not much about Compiling Cockpit from source.
14:32:02 <FireDrunk> i mean, i know how PPA' s work, but never tried hosting one :)
14:32:10 <andreasn_> #info FireDrunk to try and compile Cockpit on Ubuntu and see how that work
14:32:23 <jscotka> FireDrunk, I have one test what is doing compilation&installation of cockpit https://github.com/jscotka/cockpit/blob/new_test_structure/test/tests/inittest.sh
14:32:39 <FireDrunk> But itś YUM based :)
14:33:11 <andreasn_> FireDrunk: please send a mail to the cockpit-devel mailing list with any reports on success or failures
14:33:12 <jscotka> FireDrunk, It would be nice to add debian* like section, so add there some code for that
14:33:37 <FireDrunk> Isn't there a platform-agnostic test suite that would make this easier for us?
14:33:50 <FireDrunk> i think the guys from SUSE had some auto-packing toolkit?
14:34:27 <andreasn_> https://susestudio.com/ ?
14:34:29 <jscotka> FireDrunk, This in only one test what should be platform specific, I hope that nothing else should operate with felease specific commands
14:34:31 <FireDrunk> Jenkins?
14:35:28 <jscotka> FireDrunk, So this test could cover part for debianish and fedorish distros to solve dependency issues for variaous distros
14:36:15 <FireDrunk> Well, i don't know for sure, i've searched for a few of these applications (had a use-case which was work related), but never deeply investigated it.
14:36:33 <FireDrunk> i know there are a few open sourece auto build/compile solutions, but i don know if there is automatic dependancy testing
14:37:26 <jscotka> we discussed with stefw and andreasn_ about http://openbuildservice.org/ If that is solution for you.
14:37:29 <jscotka> FireDrunk, ^\
14:38:06 <FireDrunk> That' s the one i meant :)
14:38:18 <FireDrunk> I don't know if thats a solution, just a suggestion.
14:40:09 <jscotka> FireDrunk, Will see. It would be nice to test it, if it works well, I have no experiences with that. So in case you would like, it would be perfect to check this possibility
14:40:50 <FireDrunk> Sure, but i first need to get CockPit working on ubuntu. If that works decently, i can start trying to compile it from source.
14:41:12 <FireDrunk> if that turns out to be easy (especially regarding dependancies), then i can try to get some auto compilation working.
14:41:29 <FireDrunk> but that' s a lot of work, so don't expect results in a few days ;)
14:41:54 <andreasn_> hope it works out!
14:42:01 <jscotka> FireDrunk, propably most important part is to install dependencies, otherwise I thing that compilation should be without problem
14:42:40 <FireDrunk> I have plenty of resources (4 cluster nodes with 16GB of ram), and a main server with 32GB of ram, so if you want me to  do a specific setup with multiple test servers, it's manageable...
14:44:04 <andreasn_> anything else before we wrap it up?
14:44:29 <FireDrunk> 1
14:44:35 <petervo> Permission UI, is that ready to go andreasn?
14:44:52 <andreasn_> petervo: what was the issue for that now again?
14:44:53 <FireDrunk> Has there been any talk about libvirt or basic KVM support?
14:44:56 <petervo> or is there more design work needed?
14:45:05 <petervo> https://github.com/cockpit-project/cockpit/issues/1702
14:45:51 <andreasn_> from what I could see from the screenshot it looked good
14:46:00 <petervo> ok
14:46:15 <andreasn_> the only thing I would change would be to be more specific of what user it is that doesn't have the priviledges
14:46:17 <FireDrunk> Is it a good idea if you picked another color for a button thats disabled for authentication reasons?
14:46:18 <andreasn_> https://github.com/cockpit-project/cockpit/issues/1702#issuecomment-71017460
14:46:38 <FireDrunk> so Enabled / Disabled / Disabled ( For auth reasons)
14:47:15 <andreasn_> FireDrunk: I think just disabling them for now should be ok, but it might be worth filing a separate issue about making it more clear
14:47:50 <FireDrunk> Ok, seems fine to me :)
14:48:00 <andreasn_> and the hover state is fairly clear about why it's disabled
14:49:05 <jscotka> andreasn_, Just dumb question :-)  How it  finds that user does not have enought privilegies?
14:49:08 <andreasn_> petervo: do you have a branch up with this already, or only local?
14:49:16 <petervo> local only
14:49:31 <andreasn_> jscotka: it says in a popup https://cloud.githubusercontent.com/assets/795070/5854661/7b04048c-a230-11e4-99a0-04a23c136923.png
14:49:38 <petervo> the it's got polkit stuff i need to remove
14:49:58 <andreasn_> petervo: all right. Let me know as soon you have something I can play around with
14:50:46 <jscotka> andreasn_, No I think how it find that user have no privilegies? Via NetworkManager? or via some user policy (like user have to be in wheel? )
14:51:26 <andreasn_> via polkit I think, but petervo would know the more technical details
14:51:40 <petervo> the goal is polkit
14:51:49 <petervo> right now it's root or whell
14:51:52 <petervo> wheel*
14:52:02 <andreasn_> some more details here https://github.com/cockpit-project/cockpit/pull/1645
14:53:21 <jscotka> andreasn_, ah, I think that users could have rights to manage interface, it is somehow solved via USERS in ifcfg files, who can manage which interace, or comething like that.
14:53:57 <FireDrunk> So Cockpit itself, never does anything with custom rights?
14:54:07 <FireDrunk> it only uses 'external' sources?
14:54:56 <jscotka> it is not so important to be in wheel in case of network interfaces, propably it coudl somehow ask NM if it is possible to deal with Network Interface, I dont think if it is viable, but I hope so
14:56:29 <petervo> that's what polkit is for
14:56:41 <petervo> but we aren't there yet
14:56:49 <jscotka> ah, cool
14:57:16 <petervo> and yes cockpit relies rights the user already has
14:57:28 <petervo> it doesn't grant anything itself
14:58:31 <jscotka> petervo, nevermind. Thanks for answers, I didn't know how it works now.
15:00:16 <andreasn_> all right, we're almost at the one hour mark
15:00:24 <andreasn_> thanks everyone for attending!
15:00:28 <andreasn_> #endmeeting