cockpit
LOGS
15:02:53 <andreasn___> #startmeeting Cockpit public meeting 2014-10-20
15:02:53 <zodbot> Meeting started Mon Oct 20 15:02:53 2014 UTC.  The chair is andreasn___. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:04 <mvollmer> .hellomyname is mvo
15:03:07 <andreasn___> #meetingname Cockpit
15:03:07 <zodbot> The meeting name has been set to 'cockpit'
15:03:11 <andreasn___> #chair puiterwijk andreasn mvollmer stefw sgallagh
15:03:11 <zodbot> Current chairs: andreasn andreasn___ mvollmer puiterwijk sgallagh stefw
15:03:18 * mvollmer is too grammatical
15:03:22 <mvollmer> .hellomynameis mvo
15:03:23 <zodbot> mvollmer: mvo 'Marius Vollmer' <marius.vollmer@gmail.com>
15:03:24 <andreasn___> .hellomynameis andreasn
15:03:26 <zodbot> andreasn___: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
15:03:33 <andreasn> #topic Welcome
15:03:55 <mvollmer> andreasn, let's have a quick round on agenda.
15:03:57 <jscotka> #chair  puiterwijk andreasn mvollmer stefw sgallagh jscotka
15:04:07 <andreasn> thanks, sorry jscotka
15:04:09 <jscotka> :-)
15:04:32 <andreasn> ok, lets start with the agenda we already started with :)
15:04:35 <andreasn> #topic agenda
15:04:40 <andreasn> * next steps
15:04:45 <andreasn> * url schema
15:04:48 <andreasn> * general status
15:04:53 <andreasn> * roadmap
15:04:59 <andreasn> * freeipa terminal
15:05:04 <andreasn> ok, lets start
15:05:11 <mvollmer> general status first
15:05:18 <andreasn> #topic general status
15:05:47 <andreasn> so, the new navigation is moving forward well
15:05:48 <mvollmer> so "New Navigation" is almost there, some polish, some testing, looks good.
15:06:16 <mvollmer> some code cleanups have happened, but hopefully more with the upcoming URL scheme rethinkg
15:06:34 <andreasn> #info new navigation layout, issue #1369 is almost there, some polish and testing remaining before merge
15:06:37 <mvollmer> stefw?
15:07:29 <andreasn> is he even here? he's on PTO today I think
15:07:41 <mvollmer> ohh.
15:07:54 <mvollmer> ok, I try.
15:08:15 <jscotka> is there anything for testing,  should it be tested from usability side?
15:08:35 <mvollmer> I think he is busy now with the AMD, the asynchronous module loader.
15:08:54 <mvollmer> and dbus3.
15:09:19 <mvollmer> packages work well so far, maybe some more bugs to shake out.
15:09:20 <andreasn> jscotka: yes, the pull request for the new navigation is in #1369. It should be fairly straight forward, but extra eyes is always good
15:09:39 <mvollmer> jscotka, what's your status?
15:09:47 <jscotka> I'll look at it
15:10:04 <andreasn> thanks!
15:10:54 <jscotka> I've tested 0.27 version with patches about compilation and another base directories, and it seems very well.
15:11:33 <jscotka> It seems to be closer to be distro-independent.
15:11:51 <mvollmer> ok, sounds good.
15:11:57 <andreasn> cool, anything more for navigation? it needs review from stefw, right?
15:12:06 <mvollmer> yes
15:12:25 <andreasn> #info navigation branch needs code review from stefw
15:12:30 <jscotka> As I saw some discusson last week. It seems that more users expected that it will work everywhere. I think that also raspberry was mentioned
15:12:36 <andreasn> #action stefw to review
15:12:51 <mvollmer> andreasn, he knows. :-)
15:13:02 <andreasn> mvollmer: yes, mostly for completeness :)
15:13:10 <mvollmer> :-)
15:13:42 <andreasn> topic url schema next?
15:13:56 <mvollmer> yeah, will be short. :-)
15:14:03 <andreasn> #topic url schema
15:14:24 <andreasn> jscotka: lets take the raspberry point as part of open floor
15:14:32 <mvollmer> we want to rethink our UI URLs one more time
15:14:47 <andreasn> #info we need to rework the ui url scheme again
15:14:58 <andreasn> is there a open issue about it?
15:15:03 <mvollmer> so that they fit the new navigation better and are maybe nicer to read also.
15:15:16 <mvollmer> andreasn, not sure.
15:15:32 <andreasn> #info for easier readability and to fit better with the reworked navigation
15:15:54 <mvollmer> no issue for it.
15:16:44 <mvollmer> they will look somethink like https://f21.cockpit.lan:9090/#/blue/server/vg/test
15:16:52 <mvollmer> sorry.
15:16:57 <mvollmer> they will look somethink like https://f21.cockpit.lan:9090/#/blue/storage/vg/test
15:17:05 <mvollmer> blue is the host name.
15:17:40 <mvollmer> needs discussion with stef
15:17:46 <andreasn> all right
15:17:58 <andreasn> #info needs further discussion
15:18:03 <andreasn> anything else?
15:18:33 <mvollmer> at the same time, we will rethink how pages are handled in JavaScript, so that this all works beautifully with packages loaded into iframes.
15:19:31 <mvollmer> I think our next goal could be that the navigation bar is filled dynamically based on package manifests loaded from each host.
15:20:00 <andreasn> right
15:20:00 <andreasn> #info needs rethinking how we handle pages in javascript as well, so it all works well together
15:20:21 <mvollmer> I'll work on that and discuss with stef
15:21:01 <mvollmer> ok, next?
15:21:02 <andreasn> cool
15:21:04 <andreasn> yep
15:21:19 <andreasn> #topic roadmap
15:21:38 <mvollmer> freeipa terminal?
15:22:36 <andreasn> how do I undo the topic
15:22:38 <andreasn> #undo
15:22:39 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2e43ab90>
15:22:48 <andreasn> ok, lets do the terminal
15:22:56 <andreasn> #topic freeipa terminal
15:23:05 <mvollmer> that's our first customer for the embeddble terminal.
15:23:32 <mvollmer> stef has approached them, now might be the time to have them test it with 0.28.
15:24:03 <andreasn> #info stef have been talking to freeipa about using our terminal via embedding
15:24:24 <andreasn> #info cockpit's code is ready with the 0.28 release
15:25:35 <mvollmer> right, now roadmap?
15:25:42 <mvollmer> we are fast today...
15:25:47 <andreasn> yep
15:25:51 <andreasn> #topic roadmap
15:26:08 <andreasn> #info https://github.com/cockpit-project/cockpit/wiki/Roadmap
15:26:11 <mvollmer> we could expand on Navigation redesign abit.
15:26:32 <andreasn> how do you mean?
15:26:47 <mvollmer> Add the things that are missing.
15:26:56 <mvollmer> isn't really necessary...
15:27:07 <andreasn> yes, the sidebar with the other machines is a missing piece
15:27:11 <mvollmer> and already covered by "modular architecture" anyway, I guess.
15:27:13 <andreasn> instead of a separate page
15:27:17 <mvollmer> right, that one.
15:27:27 <andreasn> I'll add that to the roadmap
15:27:54 <mvollmer> ok.
15:28:04 <jscotka> Is there planned to use same graphics for some mobile devices or some similar smalled displays?
15:28:22 <andreasn> #aciton andreasn to add navigation subitems to the roadmap
15:28:40 <andreasn> #action andreasn to add navigation subitems to the roadmap
15:28:58 <mvollmer> has anything changed about the roadmap?  I guess not.
15:29:05 <andreasn> jscotka: you should be able to use it on a tablet or cell phone todauy
15:29:07 <andreasn> today
15:29:20 <andreasn> the navigation should be able to reflow well
15:29:38 <andreasn> but I'll make sure to test that a bit extra to make sure we didn't miss anything
15:29:58 <mvollmer> andreasn, should we try to tackle the patternfly update soon?
15:30:02 <andreasn> my vm-bridge is acting a bit weird right now, but I'll get it working again after the meeting
15:30:12 <andreasn> mvollmer: yes, I wonder if that's next maybe
15:30:21 <jscotka> andreasn, Sounds good, I have to test it. It is question focused on redesign to be still able navigate somewhere when I have small display
15:30:23 <andreasn> so should be moved to next four weeks
15:30:50 <andreasn> jscotka: yes you should, having it work on a tablet is a quite important case
15:31:03 <andreasn> if nothing else, for demos :)
15:31:10 <jscotka> :-)
15:31:22 <andreasn> #action andreasn to add patternfly update to the 4 week section
15:32:02 <andreasn> is anything under "4 weeks" done already?
15:32:32 <mvollmer> nope
15:32:57 <andreasn> all right
15:33:05 <andreasn> anything else for roadmap?
15:33:33 <andreasn> I would like to get started on mockups for the atomic features soon too
15:33:49 <mvollmer> andreasn, did someone ask you for them?
15:34:11 <andreasn> stefw said it might be good to start on them sometime last week
15:34:21 <mvollmer> andreasn, right.
15:34:29 <andreasn> most of it is to improve our container story in general
15:34:42 <andreasn> esp on the storage side
15:34:56 <andreasn> #action andreasn to start with mockups for the atomic/docker features
15:34:58 <mvollmer> true
15:35:09 <andreasn> all right, that's all I had for roadmap
15:35:28 <andreasn> open floor next?
15:35:43 <mvollmer> alright!
15:35:43 <andreasn> #topic open floor
15:36:25 <andreasn> jscotka: you mentioned Cockpit on Raspberries, could you expand on that?
15:37:42 <jscotka> andreasn, I saw discussion there on #cockpit channel, that some user I think with nick like: ilovelinux mentioned that he would like to use/install cocpit there
15:37:50 <andreasn> ah, I see
15:38:10 <andreasn> there is a bunch of different images for rpi, like the debian one, and the fedora based one
15:38:33 <andreasn> the fedora based one is not too far away from a regular fedora, something we run on already
15:38:43 <andreasn> but I think it might be missing some dependecies
15:38:55 <andreasn> not sure if there is a udisks in those repositories
15:39:00 <andreasn> etc
15:39:13 <jscotka> yep, there is imporatnt make cockpit the more universal the more possible
15:40:22 <jscotka> ideally in early phase of cockpit. Lots of users is searching for some universal administration tools over more linux distros. (Have more various servers)
15:41:20 <andreasn> apart from udisks, the pidora images does have systemd and stuff, so that's good
15:41:37 <andreasn> but it would need someone to do the job of building and packaging
15:42:45 <jscotka> andreasn, Would it be possible to do it for example via some modules, like, I have systemX with this app for communication with disk, I will be able to write some wrapper, or something like that which allows cockpit to communicate with system via defined interface. It is only idea, not plan :-)
15:43:30 <andreasn> that is above my level of knowledge, that's a question for a programmer :)
15:43:40 <mvollmer> jscotka, yes, the idea is that Cockpit has specific UI+code for specific management interfaces.
15:44:18 <mvollmer> so if the system has journald, Cockpit will load the "journald" module for it.
15:44:28 <mvollmer> if it has something else, it will load another module.
15:44:48 <mvollmer> that's the idea, reality will follow soonish.
15:44:51 <jscotka> mvollmer, like network management via NetworkManager or via for example OpenLMI?
15:45:40 <jscotka> this module loading sounds very good
15:47:10 <mvollmer> jscotka, yes, exactly.
15:47:51 <andreasn> cool, anything else for the open floor?
15:48:03 <mvollmer> another dimension is that people can contribute these modules via independent rpms/debs.
15:49:52 <jscotka> mvollmer, It will be nice. I still hope that OpneLMI devels wrote their modules, for cockpit and then cocpit will be able to communicate via LMI specification.
15:49:52 <mvollmer> andreasn, doesn't look like it.
15:50:19 <andreasn> all right, thank you everyone for attending this weeks meeting
15:50:23 <andreasn> #endmeeting