cockpit
LOGS
15:00:32 <puiterwijk> #startmeeting Cockpit public meeting 2014-10-13
15:00:32 <zodbot> Meeting started Mon Oct 13 15:00:32 2014 UTC.  The chair is puiterwijk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:33 <puiterwijk> #chair puiterwijk andreasn mvollmer stefw sgallagh
15:00:33 <zodbot> Current chairs: andreasn mvollmer puiterwijk sgallagh stefw
15:00:35 <puiterwijk> #topic Welcome
15:00:38 * stefw is here
15:00:52 * puiterwijk is here, finally, again
15:01:18 <jscotka> #chair jscotka :-)
15:01:23 <puiterwijk> ah, sorry
15:01:30 <jscotka> puiterwijk, np ;-)
15:01:31 <puiterwijk> #chair puiterwijk andreasn mvollmer stefw sgallagh jscotka
15:01:31 <zodbot> Current chairs: andreasn jscotka mvollmer puiterwijk sgallagh stefw
15:01:46 <puiterwijk> jscotka: thanks for the correction, will update my template
15:02:06 <andreasn> all right, lets get started
15:02:09 <puiterwijk> #topic F21, last words
15:02:15 <andreasn> ugh, broken scrolling :(
15:02:35 <andreasn> .hellomynameis andreasn
15:02:36 <zodbot> andreasn: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
15:02:38 <puiterwijk> #undo
15:02:38 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2e081110>
15:02:49 <puiterwijk> .hellomynameis puiterwijk
15:02:50 <zodbot> puiterwijk: puiterwijk 'Patrick Uiterwijk' <puiterwijk@redhat.com>
15:02:50 <jscotka> I have small question cockpit-0.27-1.fc21.x86_64 is final one?
15:03:08 <puiterwijk> #topic F21, last words
15:03:09 <mvollmer> .hellomynameis mvo
15:03:10 <zodbot> mvollmer: mvo 'Marius Vollmer' <marius.vollmer@gmail.com>
15:03:33 <mvollmer> jscotka, yes, hopefully.
15:03:52 <mvollmer> so, 0.27 is our release for F21 beta.
15:04:03 <puiterwijk> #info cockpit-0.27-1.fc21 is the Cockpit release for F21 beta
15:04:30 <mvollmer> master goes on for new features, we branch for F21 when necessary.
15:04:33 <andreasn> any lingering issues?
15:04:39 <jscotka> puiterwijk, I'm testing it now
15:04:45 <mvollmer> one blocker bug in the NM package.
15:05:30 <jscotka> mvollmer, I've now tried to login, and cockpit shows me message: Cockpit not available: shell not installed correctly
15:05:33 <mvollmer> https://bugzilla.redhat.com/show_bug.cgi?id=1145646
15:05:48 <mvollmer> jscotka, is that with current master or with 0.27?
15:06:01 <puiterwijk> #info Just one blocker bug in NM: https://bugzilla.redhat.com/show_bug.cgi?id=1145646
15:06:03 <mvollmer> anyway, it's not really a meeting topic, is it?
15:06:27 <jscotka> mvollmer, no
15:06:54 <mvollmer> right, let's check this afterwards.  but if it is with current master, systemctl restart cockpit should help.
15:07:33 <mvollmer> so, yeah, everyone please test F21 beta TC3.
15:07:45 * mvollmer digs out the links.
15:07:49 <sgallagh> mvollmer: Is 0.27 in TC3?
15:07:58 <mvollmer> heh, good point.
15:08:03 <sgallagh> #link http://dl.fedoraproject.org/pub/alt/stage/21_Beta_TC3/
15:08:08 <mvollmer> thanks.
15:08:18 <sgallagh> No, it's carrying 0.25 right now
15:08:23 <mvollmer> everyone please test TC3 with cockpit updates to 0.27.
15:08:39 <sgallagh> #info everyone please test TC3 with cockpit updates to 0.27
15:08:56 <sgallagh> #undo
15:08:56 <zodbot> Removing item from minutes: INFO by sgallagh at 15:08:39 : everyone please test TC3 with cockpit updates to 0.27
15:08:59 <sgallagh> #info everyone please test TC3 with cockpit updated to 0.27
15:09:05 <mvollmer> yep.
15:09:50 <mvollmer> jscotka, how do things look from your point re F21?
15:11:36 <mvollmer> either perfect or hopeless, I guess. :-)
15:11:37 <jscotka> mvollmer, it does not seem good. there is some problem, probably something with ssh?
15:11:56 <mvollmer> ouch, ok.
15:12:14 <mvollmer> jscotka, can you file bugs/issues?
15:13:07 <andreasn> cool, anything else for F21 or good to move on?
15:13:24 <jscotka> mvollmer, as I said, I've tested it now, and I've also tried recompilation, installation make check, everything went well, but now I'm unable to connect to the machine anyway. It can be caoused by latest F21 update,
15:13:33 <jscotka> mvollmer, I'll do that after inspection
15:13:40 <mvollmer> ok, thanks!
15:13:57 <mvollmer> let's move on, ok?
15:14:00 <puiterwijk> #topic Packages
15:14:39 <mvollmer> I am in the middle of merging stefs package pull requests.
15:15:03 * stefw is in the middle of making more :o
15:15:22 <mvollmer> looks very very good, hopefully all merged tomorrow or wednesday.
15:15:50 <stefw> it would be awesome if for 0.28 we can put the toys in people's hands for doing basic embedding.
15:15:59 <andreasn> wow, already?
15:16:03 <andreasn> great to hear!
15:16:08 <stefw> well not embedding stuff *into* cockpit
15:16:10 <stefw> but cockpit into other things
15:16:14 <andreasn> ah, right
15:16:21 <stefw> adding components to cockpit needs the navigation rework
15:16:27 <stefw> and several other things
15:16:34 <stefw> although we are using components already in these branches
15:16:36 <stefw> they're pretty hard coded
15:17:08 <mvollmer> would it be an idea to approach one external project about experimental embedding into cockpit?
15:17:16 <stefw> i have approached IPA
15:17:17 <mvollmer> say, FreeIPA?
15:17:20 <mvollmer> cool.
15:17:24 <stefw> and i'm targetting their use case first
15:17:28 <stefw> since they want to try it out
15:17:41 <stefw> web terminal in IPA web gui
15:17:45 <mvollmer> very nice.
15:17:54 <mvollmer> right, also journal.
15:18:11 <stefw> mvollmer, interesting, that's another not too hard case
15:18:14 <mvollmer> what about the other way around, freeipa inside cockpit?
15:18:17 <stefw> if we disable navigation
15:18:32 <stefw> mvollmer, building custom cockpit components needs the new task switcher
15:18:49 <stefw> and new URL logic, and several other things
15:18:52 <mvollmer> yes, but we can start talking about this already, no?
15:18:55 <stefw> yes
15:19:04 <stefw> API's are documented
15:19:13 <stefw> well the ones that are public so far
15:19:15 <mvollmer> cockpit would do auth for freeipa then, so BIG change.
15:19:23 <mvollmer> or not?
15:19:35 <stefw> the idea would be that kerberos SSO would make thist seamless
15:19:36 <puiterwijk> mvollmer: well, except if you have kerberos. IPA accepts kerberos tokens as signin
15:19:38 <stefw> so both do auth, it's just SSO
15:20:03 <mvollmer> right
15:21:12 <mvollmer> okay, let's concentrate on embedding cockpit components elsewhere first, then.
15:21:17 <jscotka> mvollmer, Is IPA important for Cocpit or it is only some small part. I'm not sure now, if it is main usage, to have freeIPA and servers administrated via cockpit, or should it be only small part of cocpit project?
15:21:32 <stefw> it's a small aspect in the overall picture
15:21:38 <stefw> but the developers are interested in working with us
15:21:42 <stefw> and trying out our new embedding code
15:21:52 <stefw> i'm sure there will bemore
15:21:52 <jscotka> ah, okay. perfect
15:23:07 <mvollmer> so, for the minutes, stef is working on enabling the embedding of cockpit components into other web pages.
15:23:20 <stefw> one aspect worth mentioning
15:23:28 <puiterwijk> #info Stef is working on enabling embedding cockpit components into web pages
15:23:30 <stefw> is that there is a mini-login page (exactly the same as main login pace, in all but look)
15:23:35 <jscotka> I have to leave meeting today. Bye
15:23:57 <stefw> so if someone accesses a cockpit component, without having being logged into cockpit, this mini-login page shows up in place of the component.
15:24:00 <puiterwijk> stefw: you mean if people don't have login tokens (SSO) and cockpit gets embedded?
15:24:03 <mvollmer> jscotka, okay, thanks for joining!  file those bugs! :-)
15:24:07 <stefw> puiterwijk, yes
15:24:17 <jscotka> mvollmer, I'll do my best :-)
15:24:34 <puiterwijk> #info If not logged in when accessing embedded component, mini-login form is shown
15:25:41 <puiterwijk> okay. was that all on embedding, or is there more at this moment that anyone wants to add?
15:26:01 <mvollmer> stefw, anything to look out for after the "packages" series is merged?
15:26:14 <stefw> it needs a pretty deep reinstall
15:26:27 <stefw> i would suggest "sudo rm -r /usr/share/cockpit"
15:26:35 <stefw> and then a 'make install'
15:26:43 <puiterwijk> #info Packages patch series needs a reinstall of cockpit
15:26:53 <stefw> and probably a 'restorecon -Rv /usr/share/cockpit'
15:27:03 <stefw> in addition if you have the modules linked into ~/.local/share/cockpit
15:27:07 <stefw> you'll need to remove that link and make it again
15:27:10 <puiterwijk> #info Suggested to rm -r /usr/share/cockpit and make install and restorecon -Rv /usr/share/cockpit
15:27:11 <stefw> the HACKING.md has been updated
15:27:31 <mvollmer> stefw, what about summarizing that on cockpit-devel?
15:27:36 <puiterwijk> #info In case of modules linked to #/.local/share/cockpit, that link needs to be unlinked and recreated
15:27:46 <stefw> yes, was hoping to get more merged before that?
15:27:54 <mvollmer> of course.
15:29:02 <mvollmer> so, what's our road map for packages?  terminal is first, then come other pages?
15:29:06 <puiterwijk> #info More info to come to cockpit-devel after more is merged
15:29:22 <stefw> terminal first
15:29:27 <stefw> then i need to make dbus.js public API
15:29:38 <mvollmer> or should we first divide into dashboard / single server and proceed from there?
15:29:39 <stefw> which i would like to rework in the process, as mvollmer and I have discussed several times
15:29:44 <stefw> to do with jQuery deferreds, and simplicity
15:29:51 <stefw> once dbus code is in the base module
15:29:54 <stefw> then we can migrate other things
15:30:00 <stefw> we can migrate other pages that do not navigate
15:30:01 <mvollmer> ok, that'll be nice.
15:30:07 <stefw> before we migrate pages that do navigate
15:30:10 <stefw> we have to fix our URL logic
15:30:19 <stefw> which likely means also implementing all or part of the new nav redesign
15:30:25 <andreasn> do navigate, as in have subpages, or do you mean something else?
15:30:30 <stefw> andreasn, yes
15:30:34 <andreasn> right
15:30:39 <stefw> so, terminal was the perfect component because it did not navigate, and did not use dbus
15:31:53 <stefw> it was also perfect because others were interested in using it first
15:32:06 <mvollmer> ok, we are entering the next topic, Navigation, no?
15:32:24 <stefw> one more thing, documentation is available for all of this as it progresses
15:32:35 <stefw> http://files.cockpit-project.org/guide/
15:32:42 <puiterwijk> #info Documentation for all of this becomes available as it progresses at http://files.cockpit-project.org/guide/
15:32:52 <puiterwijk> #topic Navigation
15:32:54 <mvollmer> stefw, about terminology
15:32:57 <mvollmer> #undo
15:32:57 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2f02eb90>
15:33:01 <mvollmer> sorry. :)
15:33:21 <puiterwijk> mvollmer: you wanted to undo the #info?
15:33:25 <mvollmer> so packages are about naming, loading, and caching files.
15:33:30 <mvollmer> puiterwijk, yes.
15:33:36 <mvollmer> no, the topic!
15:33:45 <puiterwijk> mvollmer: ah, okay. then, go on :)
15:33:48 <stefw> mvollmer, yes
15:34:05 <mvollmer> they are not automatically JavaScript namespaces, for example.
15:34:12 <mvollmer> or HTML iframes
15:34:19 <mvollmer> so no encapsulation.
15:34:21 <puiterwijk> mvollmer: this is Packages topic, right?
15:34:22 <stefw> mvollmer, right ... if we do use AMD we can use the package names as a top level javascript namespace id
15:34:29 <stefw> mvollmer, but yes, you're right
15:34:30 <stefw> components live in packages
15:34:41 <stefw> you can think of each iframe as a component
15:34:59 <stefw> in the future we may have other types of components, such as javascript that extends some other aspect of cockpit, like adds a graph somewhere in another page
15:34:59 <mvollmer> so the terminal does have an iframe for encapsulation, and the dbus package will have a namespace, I guess?
15:35:23 <stefw> if you look at cockpit.js, which will include the dbus component, you can see that it includes a cockpit namespace
15:35:29 <stefw> http://files.cockpit-project.org/guide/api-cockpit.html
15:36:08 <stefw> javascript encapsulation may be further helped out with things like AMD, but we haven't gotten there yet
15:36:13 <stefw> https://github.com/amdjs/amdjs-api/wiki/AMD
15:36:15 <mvollmer> right
15:36:17 <stefw> all of that layers on top of packages
15:36:21 <stefw> and does not really affect it that much
15:36:41 <stefw> however, the package names, and checksum representation have been chosen to be valid javascript identifiers
15:36:50 <stefw> so there is some influence there, but in general the two are orthogonal
15:36:54 <mvollmer> what I am getting at is that we shouldn't say "we are putting terminal into a package", when we are really encapsulating it into a iframe etc.  would you agree?
15:37:02 <mvollmer> we should have a new name for that.
15:37:05 <stefw> component
15:37:10 <stefw> i used component in the documentation
15:37:19 <mvollmer> right, very good.
15:37:41 <mvollmer> that's also why "package" is much better than "module", right?
15:37:49 <stefw> yes, module has so many meanings
15:37:53 <stefw> package is a collection of files
15:37:57 <stefw> which is exactly what cockpit packages are
15:38:00 <stefw> with a manifest
15:38:11 <mvollmer> yep
15:38:11 <stefw> this documentation refers to components: http://files.cockpit-project.org/guide/embedding.html
15:38:25 <stefw> and this is about packages: http://files.cockpit-project.org/guide/packages.html
15:38:51 <stefw> if anyone finds broken stuff in the docs, or unclear stuff, file a bug
15:39:05 <stefw> this is the documentation for an iframe component: http://files.cockpit-project.org/guide/api-terminal.html
15:39:52 <stefw> hmmm, action item
15:40:04 <stefw> i need to separate the online uploaded docs into 'stable' and 'devel'
15:40:09 <stefw> and keep the 'stable' at 0.27 for now
15:40:16 <mvollmer> yeah
15:40:44 <puiterwijk> #action stefw Seperate online docs for stable and devel
15:41:00 <mvollmer> #info we'll use "component" for parts of cockpit that can be loaded into a iframe.
15:41:24 <mvollmer> #info a component is made up of one or more packages
15:41:38 <stefw> well not really
15:41:42 <stefw> it can be
15:41:49 <stefw> but often a package will have one or more components
15:41:58 <mvollmer> aha.
15:42:09 <mvollmer> like "shell" has now?
15:42:13 <stefw> right
15:42:18 <stefw> most of shell would probably become a "server" package
15:42:24 <mvollmer> #info often a package contains one or more components
15:42:43 <stefw> and it would contain components for each of the major tasks: storage, networking etc..
15:43:17 <mvollmer> how many packages would we have, roughly, once we have reached a stable point?
15:43:23 <danofsatx> umm......my networking configuration has disappeared from cockpit. There are no interfaces listed for the server. What's my first step in troubleshooting?
15:43:45 <stefw> mvollmer, i imagine 'terminal' package will move back into 'server' and become an alias for 'server'
15:43:57 <stefw> mvollmer, i imagine about 5 or 6
15:44:03 <mvollmer> right
15:44:15 <mvollmer> and ten'ish components?
15:44:20 <stefw> 'dashboard', 'server', 'docker' ...
15:44:27 <danofsatx> oops, sorrt, didn't realize a meeting was happening. belay my request until later, please.
15:44:44 <mvollmer> danofsatx, np.  first step: reload the web page. :-)
15:44:44 <stefw> mvollmer, i guess so, could be more once we have applications or server roles each with their own component
15:44:55 <mvollmer> yeah
15:45:09 <mvollmer> heh, ok, let's move on.
15:45:16 <danofsatx> already did that, logged out and back in.
15:45:45 <mvollmer> danofsatx, next would be to try and restart NetworkManager
15:45:53 <mvollmer> you can do that with cockpit.
15:45:57 <puiterwijk> #topic Navigation
15:46:26 <danofsatx> just saw a big red OOPS! in the top right, saying 'Cockpit had an unexpected internal error.'
15:46:27 <andreasn> so I have this thing that is 2 weeks old now https://github.com/andreasn/cockpit/tree/navigation-v2
15:46:45 <mvollmer> right, so, after merging the packages series, I'll work with andreasn on bringing his navigation branch to life.
15:46:50 <andreasn> cool
15:47:07 <mvollmer> that will include figuring out the new URL scheme.
15:47:24 <andreasn> what is the needs for the url scheme?
15:47:28 <andreasn> to be able to bookmark?
15:47:31 <stefw> right
15:47:36 <stefw> and pass some basic options to frames
15:47:48 <stefw> i've been thinking of something like this:
15:47:50 <mvollmer> yes, the current one is clunky and not necessary with the new navigation.
15:48:02 <mvollmer> it isn't really necessary right now either, I would say.
15:48:09 <stefw> https://server.example.com:9090/#/path/to/page?option=a,option2=b
15:48:15 <stefw> so basically exactly like a normal url
15:48:24 <stefw> except that everything after the port is in the hash
15:48:29 <andreasn> what would the options be?
15:48:56 <stefw> some options would tell frames that they are loaded within cockpit, and to rely on the outer frame to establish WebSocket and do auth
15:49:07 <stefw> or telling frames which server to connect to
15:49:17 <mvollmer> and I guess others are for the content of the page, like what disk to show the details of.
15:49:25 <stefw> why?
15:49:29 <stefw> no those would be in the path part
15:49:34 <mvollmer> or is that part of the path
15:49:36 <stefw> before the ?
15:49:36 <mvollmer> right
15:49:41 <mvollmer> hmm.
15:49:49 <stefw> but i can imagine other options showing up
15:49:53 <stefw> we did have one #server option
15:50:06 <mvollmer> it positional versus keyword arguments
15:50:10 <stefw> which was used for embedding cockpit and not showing the dashboard
15:50:13 <mvollmer> "it is"
15:50:14 <stefw> mvollmer, yes, like a path
15:50:34 <stefw> but happy to brainstorm this further
15:50:35 <mvollmer> and keyword args are better for future compatability, no?
15:50:50 <stefw> i guess so, but the entire internet works off paths
15:50:58 <stefw> maybe the web is broken though
15:51:03 <stefw> so we can discuss this more :)
15:51:29 <mvollmer> yep.
15:53:17 <mvollmer> right, quick road map update?
15:53:18 <puiterwijk> anything more on navigation? or OK to move on to roadmap?
15:53:26 <puiterwijk> #topic Roadmap update
15:53:27 <andreasn> moving on is ok
15:54:01 <mvollmer> ok, so F21 item can be deleted, right?
15:54:06 <andreasn> guess so
15:54:32 <mvollmer> any other change?
15:54:35 <mvollmer> i guess not.
15:54:48 <puiterwijk> #info F21 item can be removed from roadmap
15:54:50 <andreasn> is Roles still on the four month path?
15:55:07 <andreasn> I know we have a lot of work ahead of us, so curious if that fits in
15:55:23 <mvollmer> *shrug*
15:55:35 <mvollmer> sgallagh, still here?
15:55:50 <andreasn> depends a bit on f22 too I guess
15:55:55 <mvollmer> yeah
15:56:11 <sgallagh> mvollmer: What's up?
15:56:18 <sgallagh> (Wasn't following)
15:56:22 <mvollmer> sgallagh, Fedora Server roles.
15:56:31 <sgallagh> OK, what about them?
15:56:43 <mvollmer> it's currently on our road map under "next four month"
15:56:48 <sgallagh> I'd very much like to have Domain Controller deployment in Cockpit
15:56:51 <mvollmer> how does that sound to you?
15:56:55 <sgallagh> We've got that role available in rolekit today
15:57:03 <mvollmer> cool.
15:57:04 <sgallagh> (Just discussing how to test it in #fedora-server, actually)
15:58:32 <mvollmer> ok, I switch it with "Atomic" on the list.  that is only symbolically, but still. :-)
15:58:33 <sgallagh> mvollmer: Yes, I would be very interested in seeing this in F22
15:58:45 <github> [cockpit] stefwalter pushed 1 new commit to master: http://git.io/O5wjjw
15:58:45 <github> cockpit/master 1b6bd72 Stef Walter: Bump version number
15:58:57 <andreasn> what is the timeline for f22?
15:59:33 <andreasn> April next year?
15:59:33 <sgallagh> andreasn: Unclear as of yet
15:59:38 <andreasn> all right
15:59:45 <sgallagh> There's talk of having it be a shorter cycle than usual, maybe 4-5 months
15:59:53 <sgallagh> To try to get back in line with a two-per-year release schedule
16:00:15 <andreasn> ok
16:00:35 <mvollmer> andreasn, you wanted to fill the "next two years" a bit, no?
16:00:45 <mvollmer> or do I remember wrong?
16:00:47 <andreasn> yes, I haven't spelled that out more
16:00:54 <andreasn> will do asap
16:00:55 <mvollmer> right, no hurry. :-=
16:00:58 <mvollmer> :-)
16:01:06 <mvollmer> you got at least four month
16:01:16 <andreasn> hehe
16:01:34 <mvollmer> AOB?
16:02:46 <andreasn> all right, anything else?
16:02:51 <andreasn> at the hour
16:02:55 <puiterwijk> #topic Open Floor
16:03:06 <puiterwijk> Anyone got anything else?
16:03:18 <mvollmer> puiterwijk, vm-create on RHEL 6. :-)
16:03:41 <puiterwijk> mvollmer: yup, I got a document on how to do that. Can send you that
16:03:59 <mvollmer> nice, please do.
16:04:10 <puiterwijk> I tried to reproduce what I had done, and then wrote that doc. so I hope it's clear enough.
16:04:20 <puiterwijk> #action puiterwijk Send vm-create docs to mvollmer
16:04:40 <mvollmer> thanks!
16:04:44 <puiterwijk> anything else? if not, I'm closing in a minute
16:04:56 <mvollmer> not from me.
16:04:59 <andreasn> not from me
16:05:09 <puiterwijk> okay. then let's call it an end.
16:05:11 <puiterwijk> thanks all for coming
16:05:21 <puiterwijk> #endmeeting