atomic
LOGS
14:39:36 <jzb> #startmeeting CentOS Atomic SIG
14:39:36 <zodbot> Meeting started Tue Sep 30 14:39:36 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:39:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:39:36 <centbot> Meeting started Tue Sep 30 14:39:36 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:39:36 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:40:00 <jzb> #chair jbrooks scollier quaid walters kbsingh bexelbie
14:40:00 <zodbot> Current chairs: bexelbie jbrooks jzb kbsingh quaid scollier walters
14:40:00 <centbot> Current chairs: bexelbie jbrooks jzb kbsingh quaid scollier walters
14:40:41 <jzb> OK
14:40:48 <jzb> so - going through last week's action items
14:40:51 <jzb> the SIG proposal is up
14:40:58 <jzb> We've appointed a chair
14:41:18 <jzb> Have SIG folks who don't have wiki access made the request?
14:41:24 <quaid> #info SIG proposal is posted on wiki page
14:41:27 <jzb> I don't think I have an easy way to check that?
14:41:32 <quaid> try to edit?
14:41:41 <quaid> I think we use ACLs in some cases, so maybe just the SIG page
14:41:48 <jzb> quaid: well, I meant to verify if all the members had asked
14:41:58 <jzb> *I* have access. :_)
14:42:24 <quaid> well, you can look to see if usernames are in the page source
14:42:35 <jzb> Hm. OK
14:42:41 <quaid> trick is as you recall one has to ask on centos-docs generally, and I didn't see any new ones that I recall this week
14:42:43 <jzb> I'll shoot a note to SIG members this week
14:42:51 <jzb> quaid: yeah, none are leaping to mind.
14:43:02 <jzb> #action jzb ping SIG members on wiki access.
14:43:14 <quaid> http://wiki.centos.org/Contribute#head-42b3d8e26400a106851a61aebe5c2cca54dd79e5
14:43:33 <jzb> I still need to do a discuss on how Atomic should be listed in bugs.centos.org
14:43:34 <quaid> #info SIG members should ask on centos-docs as per http://wiki.centos.org/Contribute#head-42b3d8e26400a106851a61aebe5c2cca54dd79e5
14:43:37 <jzb> will do that today
14:43:51 <jzb> #jzb open discussion on how Atomic should be listed in bugs.centos.org
14:43:54 <jzb> er,
14:44:03 <jzb> #action jzb open discussion on how Atomic should be listed in bugs.centos.org
14:44:15 <jzb> walters: did you post on Anaconda work on atomic-devel?
14:45:07 <walters> i haven't yet sorry, haven't had a chance to test it in a clean CentOS environment
14:45:14 <jzb> walters: ok
14:45:27 <walters> really i need a baremetal CentOS box, and I don't have one handy myself
14:45:43 <jzb> walters: we can get you a free copy of CentOS...
14:45:45 <walters> though we could do the installer ISO in a virt environment
14:46:16 <jzb> walters: are you short hardware?
14:46:46 <jbrooks> walters, I've made my images so far in vms
14:47:05 <walters> i'd like to figure out a path for how Atomic works inside CentOS infrastructure
14:47:47 <walters> there are many components to that, from where the packages git lives, to the tree compose, and also the installer/cloud image generation side
14:48:38 <quaid> walters: we can get you bare metal on *.centos.org I reckon
14:49:17 <walters> jbrooks, yeah...but i don't even want to contemplate trying imagefactory inside a VM, it's already painful enough =)
14:49:24 <quaid> walters: I think there is a component in bugs.centos.org for 'build system', I think that's the best workflow we have to not forget stuff, then we'll get arrfab or KB to provision something for you
14:50:23 <jbrooks> walters, ok -- I'll try it eventually -- is it documented somewhere, this imagefactory-based process?
14:51:16 <quaid> jbrooks: we can also pester Ian McLeod, I think
14:52:21 <jzb> OK
14:52:39 <jzb> walters: you need a bare metal host to work with, yeah?
14:52:57 <walters> jzb, that would help yes
14:53:06 <jzb> quaid: can you take that and get it provisioned?
14:53:24 <jzb> quaid: or is that something I should request officially, or...?
14:53:27 <walters> jbrooks, it's now merged in https://github.com/projectatomic/rpm-ostree-toolbox - not really documented yet, still working on that
14:53:49 <jzb> quaid: what's the process here for making the magic happen?
14:55:24 <jzb> OK, we'll circle back
14:55:31 <jzb> I'm going to give myself the action to pester quaid
14:55:51 <jzb> #action jzb to follow up with quaid on getting hardware for bare metal work under *centos.org
14:57:03 <jzb> OK
14:57:09 <jzb> (quiet today)
14:57:17 <jzb> bexelbie: IIRC you have some questions on docs
14:57:23 <jzb> bexelbie: you want to take that?
14:57:32 <bexelbie> sure
14:57:53 <quaid> sorry, was in another window
14:57:53 <bexelbie> I was looking at putting the Atomic doc up and was wondering if we could keep it in a git repo instead of the wiki
14:58:12 <quaid> I think the process is as above, file a work ticket in bugs.centos.org in the build system component and ask for a bare metal host for Atomic work
14:58:14 <bexelbie> I think for long term maintainability it is a better plan and it will create what I think is a better workflow for future docs
14:58:46 <quaid> bexelbie: which doc? best workflow somewhat depends on who will collaborate on it
14:59:57 <bexelbie> the first doc is the Atomic QSG/background info
15:00:18 <bexelbie> git would seem to open it up to good revision control for future contributions from my side and allow full community access
15:00:35 <jbrooks> +1 to git
15:00:39 <bexelbie> I realize wiki's do revision control ...
15:00:56 <jzb> +1 to git as well
15:00:56 <bexelbie> however, wiki docs tend toward chaos in my experience and it isn't clear we have a lot of wiki garderners around
15:01:09 <bexelbie> I am thinking longer term here, so in the short term this won't crop up at
15:01:26 <bexelbie> It will also make future contributions from my side mucho easier :)
15:01:27 <quaid> if the goal is for the SIG to work on it, then whatever the SIG prefers; keep in mind that is a barrier to others contributing, that's all
15:01:55 <bexelbie> I believe that git is a barrier that can be overcome - that said I also know of some tools in progress that may help us with that in the long run
15:02:01 <bexelbie> I look to the SIG for guidance :)
15:02:33 <quaid> jzb: yeah, open a ticket in bugs.centos.org, should be a build system component, and fill it with the details -- including how long the provision is for
15:02:34 <jbrooks> Personally, I feel much more comfortable sending a PR vs rewriting stuff
15:02:40 <jzb> quaid: OK, will do
15:02:50 <jzb> walters: how long do you expect to need it?
15:02:59 <jzb> walters: 1-2 months seem sufficient, or is this longer term?
15:04:03 <bexelbie> I like PRs as well as it allows a doc to have some editorial control and can illuminate things that need second reviewers more easily
15:04:11 <walters> jzb, as long as it takes for the process to be more integrated with the centos rel-eng; e.g. if we can use imagefactory-as-a-service instead of imagefactory locally, that helps avoid the need for a baremetal box
15:04:13 <bexelbie> wikis are generally alwasy a "commit = publish" system
15:05:37 <jzb> bexelbie: I think we are generally disposed towards git, can you send a note to centos-devel?
15:05:49 <jzb> bexelbie: or maybe centos-docs
15:06:02 <bexelbie> jzb, sure - do you want a proposal for this and ask for location?
15:06:25 <jzb> bexelbie: pretty much, put out the workflow as you see it working and see if there's any dissent / better ideas, etc.
15:06:44 <bexelbie> jzb, sounds like a winner - I'll put it on my todo for this week
15:06:49 <jzb> bexelbie: thanks!
15:06:51 <quaid> bexelbie: I'd recommend (from a doc perspective) to use the best tool for the team (FLOSS, of course) to get things done over the shorter term, and to simply put it on a list of things to review, "Are we now where it makes more sense to move to an easier-to-edit-by-the-masses solution?"
15:06:53 <jzb> walters: ack
15:07:20 <jzb> OK, that's the items that I have for today, other items?
15:07:31 <bexelbie> quaid, ack - I have a dream about how we define "Easier to edit by the masses" :) we can talk about that later
15:07:43 <jzb> #action bexelbie put out docs workflow to mailing list to see if there's any dissent/better ideads.
15:07:46 <jzb> er, ideas.
15:08:05 <jzb> #topic new business
15:08:08 <bexelbie> jzb, I'll start with centos-docs
15:08:12 <quaid> dumb question, but is walters outside expert or a SIG member?
15:08:46 <walters> quaid, i'm not a sig member at the moment, but i am obviously interested =)
15:08:53 <jzb> quaid: I think he's a pending SIG member. Needs to "officially" request
15:09:13 <jzb> walters: all you really need to do is send a request to centos-devel so we can approve SIG request
15:09:15 <quaid> in short, resources would be for SIG members, so maybe as part of this just complete that loop so the governance/access is all aligned
15:09:21 <quaid> +1
15:09:37 <jzb> walters: slightly more formal than Fedora, I suppose :-)
15:10:53 <jzb> any other topics or items for today?
15:11:06 <walters> looking
15:15:54 <jzb> I think walters is digging deep :-)
15:16:05 <jbrooks> :)
15:16:53 <walters> sorry back; sent the request
15:17:18 <jzb> walters: thanks!
15:18:03 <walters> to what degree are we thinking of the Fedora Atomic efforts as upstream?
15:18:36 <jzb> walters: that's a tricky question. ATM, I think concurrent
15:19:50 <walters> right.  There's a lot of overlap of course, main thing is to ensure we don't diverge unnecessarily on things like package set
15:20:02 <jzb> walters: so, I'm working on that :-)
15:20:15 <jzb> walters: by end of week I hope to put out a proposal with the package set
15:20:18 <jzb> walters: I think you've seen that.
15:20:21 <jzb> early draft
15:20:26 <walters> yep, cool
15:21:00 <jzb> #action jzb get Atomic definition out by end of week to Project Atomic (SIG will want to review)
15:21:06 <jzb> walters: thanks
15:21:10 <jzb> any other items this week?
15:22:54 <jzb> I'm going to take that as a no :-)
15:23:07 <jzb> thanks everybody, this isn't goodbye, it's just "until next week"
15:23:12 <jzb> see you on the mailing lists!
15:23:15 <walters> thanks all!
15:23:16 <jzb> #endmeeting